Difference: UpgradeSoftwareReviewFT (7 vs. 8)

Revision 82012-06-13 - PaulSzczypka

Line: 1 to 1
 
META TOPICPARENT name="UpgradeSoftwareReviews"

Principal Reviewer

Line: 12 to 12
 
FT/FTDigitisation Contains the digitisation algorithms. Eric Cogneras
FT/FTDAQ The raw bank encoder/decoder. Olivier Callot
Changed:
<
<

Comments

>
>

Review Comments

  • Adhere to LHCb conventions for class and variable names.
  • Containers should have names which are a plural of the contained objects, e.g. "FTStations" contain FTStation objects/pointers.
  • Using namespaces can make code difficult to read - suggested to use a namespace alias to make it clear where a method comes from.
  • Strip out obsolete code, example given was "less_Chan" (which also violates naming conventions).
  • Variable names should be representative, "aSomething" is sometimes not a good name, especially if dealing with multiple instances of similar objects.
  • Debug statements should be protected.
 
Deleted:
<
<
Add comments etc. here, structure this page as you see fit.
 
Deleted:
<
<
However, you may wish to follow the structure found in the old EventModelReview
  -- PaulSzczypka - 30-May-2012
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback