Notes for testing gLite 3.1 nodes on SL4

These notes describe the initial release of gLite node types to certification of gLite 3.1 for SL4. At this initial point, the node types concerned are
  • glite-CE
  • glite-MON
  • glite-LB
  • glite-SE_dpm_disk
  • glite-SE_dpm_mysql
  • glite-TORQUE_utils
  • glite-VOBOX
  • glite-WMS
  • lcg-CE

What's new?

  • The binaries have been natively built on SL4
  • The codebase is gLite 3.1, not gLite 3.0 (in practise the changes here are small)
  • There are updated dependencies, most notably
    • VDT1.6 which provides GT4
    • Java 1.5
  • There is updated configuration based on yaim 3.1
  • Many obsolete components have been removed

This release is targeted to 32 bit architecture. Nevertheless, feedback on attempts at 64 bit installation are welcomed.

Installation

There is a section 'Known Issues in Installation and Testing' at the end of this page.

Please use the following instructions. There will be more detailed instructions for each node type as installation experience is gained. In the initial phase, the following meta-packages are available:

  • cert-glite-CE
  • cert-glite-MON
  • cert-glite-LB
  • cert-glite-SE_dpm_disk
  • cert-glite-SE_dpm_mysql
  • cert-glite-TORQUE_utils
  • cert-glite-VOBOX
  • cert-glite-WMS
  • cert-lcg-CE

You will have to install an rpm for java 1.5 first. If needed, you can get java as described in GLite31JPackage.

Examples of YUM repository configuration

For example, in order to use yum to install glite-CE or glite-WMS, first create glite.repo in /etc/yum.repos.d with the following contents (please note that the baseurls of the repositories have changed since the original release of this documentation).

glite.repo for glite-CE

[cert-glite-ce]
name=gLite 3.1 CE (Testing and Certification)
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/cert/3.1/glite-CE/sl4/i386
enabled=1

glite.repo for glite-VOBOX

[cert-glite-vobox]
name=gLite 3.1 VOBOX (Testing and Certification)
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/cert/3.1/glite-VOBOX/sl4/i386
enabled=1

glite.repo for glite-WMS

[cert-glite-wms]
name=gLite 3.1 WMS (Testing and Certification)
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/cert/3.1/glite-WMS/sl4/i386
enabled=1

glite.repo for lcg-CE

[cert-lcg-ce]
name=gLite 3.1 lcgCE (Testing and Certification)
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/cert/3.1/lcg-CE/sl4/i386
enabled=1

Common items for all gLite Node Types

You will have to reference a jpackage repository as well (for example in jpackage.repo);

[main]
[jpackage17-generic]
name=JPackage 1.7, generic
baseurl=http://mirrors.dotsrc.org/jpackage/1.7/generic/free/
enabled=1
protect=1

[main]
[jpackage5-generic]
name=JPackage 5, generic
baseurl=http://mirrors.dotsrc.org/jpackage/5.0/generic/free/
enabled=1
protect=1

More information on java and jpackage with gLite 3.1 can be found here

Then you can do

to install glite-CE, type
  # yum install cert-glite-CE

to install glite-WMS, type
  # yum install cert-glite-WMS

Known Issues in Installation and Testing

glite-MON

Metapackage installation errors:

Error: Missing Dependency: egee-log4j >= 1.2.6 is needed by package glite-rgma-servicetool
Error: Missing Dependency: egee-log4j >= 1.2.6 is needed by package glite-rgma-gin
Error: Missing Dependency: egee-log4j >= 1.2.6 is needed by package glite-rgma-publish-site

glite-SE_dpm_disk, glite-SE_dpm_mysql and glite-SE_dpm_oracle

Issues when preparing the repository:

WARNING. perl-SOAP-Lite-0.69-1.el4.rf.noarch.rpm picked from the Integration Repository

A Perl package required in installation is not found under ETICS. Alternative location has been chosen and the file has been copied to the integration repository from there. The module is perl-SOAP-Lite-0.69-1.el4.rf.noarch.rpm and its original location:

http://linuxsoft.cern.ch/dag/redhat/el4/en/i386/RPMS.dag/perl-SOAP-Lite-0.69-1.el4.rf.noarch.rpm

glite-VOBOX

Prior to installation of the metapackage, the following packages need to be installed:

  • jdk-1_5_0_12-linux-i586.rpm from Sun
  • java-1.5.0-sun-compat-1.5.0.12-1jpp.i586.rpm from jpackage1.7

Issues when preparing the repository:

WARNING. lcg-proxy-renew-1.0.1-1.noarch.rpm picked from the Integration Repository

The lcg-proxy-renew package has been fetched from a temporary location (not ETICS) described in the patch #1244:

/afs/cern.ch/user/e/elisal/public/lcg-proxy-renew-1.0.1-1.noarch.rpm

glite-WMS

Issues when preparing the repository:

WARNING. glite-security-lcmaps-plugins-voms-1.3.7-1.slc4.i386.rpm picked from the Integration Repository

Metapackage installation errors:

Error: Missing Dependency: glite-security-voms >= 1.7.16-2 is needed by package glite-wms-helper

glite-FTM

This needs a version of perl-SOAP-Lite later than that supplied by the OS. Because 'protectbase' is normally used, this manoeuvre is required before the main install;

# yumdownloader perl-SOAP-Lite-0:0.69-1.el4.rf.noarch
# yum localinstall perl-SOAP-Lite-0.69-1.el4.rf.noarch.rpm

Configuration

Instructions will be added in the next future.

-- JuhaHerrala - 24 Aug 2007

Edit | Attach | Watch | Print version | History: r15 < r14 < r13 < r12 < r11 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r15 - 2007-09-12 - SteveTraylen
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EGEE All webs login

This site is powered by the TWiki collaboration platform Powered by Perl This site is powered by the TWiki collaboration platformCopyright & by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Ask a support question or Send feedback