Release notes for gLite 3.1

These notes describe the gLite 3.1 release.

Supported platforms

The present release is for SL4. It has been certified on SLC4 but should run on compatible variants. Currently the release is only for i386.

What's the difference between this and other releases for SL4?

A previous SL4 release (of the WN) has been made to PPS, composed of the gLite 3.0 / SL3 binaries.

The main differences are that in the new release...

  • The binaries have been natively built on SL4
  • The codebase is gLite 3.1, not gLite 3.0 (in practise the changes here are small)
  • There are updated dependencies, most notably
    • VDT1.6 which provides GT4
    • Java 1.5
  • There is updated configuration based on yaim 3.1
  • Many obsolete components have been removed

Upgrade from the 'SL3 binaries on SL4' has not been tested.

This release has been tested only on 32 bit. Nevertheless, feedback on attempts at 64 bit installation are welcomed.

Release Process

The process of continual updates established for gLite 3.0 will continue for gLite 3.1. This includes the introduction of the various node-types as they become available. Presently the following meta-packages are available

  • glite-UI
  • glite-WN
  • glite-TORQUE_client

Installation

Please consult the Install Guide for information on installation and configuration.

Upgrades

As this release is the first release for SL4, no upgrade path from earlier versions is supported.

Configuration

GLite 3.1 is configured with yaim 3.1. This yaim version doesn't differ from the 3.0.1 from the configuration point of view. All configuration files used with YAIM 3.0.1 should be compatible with the yaim 3.1. To find more information on yaim 3.1 configuration, please refer to the yaim 3.1 notes.

Please configure your WN as follows

 
/opt/glite/yaim/bin/yaim -c -s <site-info.def> -n glite-WN 

Or with the torque client

/opt/glite/yaim/bin/yaim -c -s <site-info.def> -n glite-WN -n TORQUE_client

Please configure your UI as follows

 
/opt/glite/yaim/bin/yaim -c -s <site-info.def> -n glite-UI 

Documentation

The glite.org site has been updated with further documentation about gLite3.1

Known issues

Each node type has a 'known issues' page. For example, glite-WN or glite-UI

Information system

Ensure that your subcluster is advertised as GLITE-3_1_0

GlueHostApplicationSoftwareRunTimeEnvironment: GLITE-3_1_0

You can use yaim's CE_RUNTIMEENV parameter for this.

Please also advertise your system architecture (currently unsupported in yaim).

-- JoachimFlammer - 26 Juli 2007

Edit | Attach | Watch | Print version | History: r10 < r9 < r8 < r7 < r6 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r10 - 2011-06-20 - AndresAeschlimann
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EGEE All webs login

This site is powered by the TWiki collaboration platform Powered by Perl This site is powered by the TWiki collaboration platformCopyright & by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Ask a support question or Send feedback