YAIM 4.0.0 Certification (third phase)

Developers testing

There is no testing done by the developers at this second stage.

Fresh install testing

rpm list

The list of rpms can be found in etics in /afs/cern.ch/project/gd/www/yaim:

  • glite-yaim-core-4.0.0-10.noarch.rpm
  • glite-yaim-core-4.0.0-11.noarch.rpm: The core rpm had to be regenerated because now yaim lfc contains 3.0 and 3.1 configuration and the configure_node command was only taking into account UI and WN.
  • glite-yaim-clients-4.0.0-3.noarch.rpm
  • glite-yaim-clients-4.0.0-4.noarch.rpm: The clients rpm has been regenerated to configure one single sgm account for vobox and to include the _30 functions in its function list (this has been detected in GGUS ticket 26303).
  • glite-yaim-clients-4.0.0-5.noarch.rpm: The clients rpm has been regenerated because by mistake we introduced part of a fix in yaim core and it needed some changes also in clients, so we've decided to include them. This modification affects only config_wn and it fixes bug #28082 and #27896.
  • glite-yaim-dcache-4.0.0-2.noarch.rpm
  • glite-yaim-dpm-4.0.0-2.noarch.rpm
  • glite-yaim-fts-4.0.0-5.noarch.rpm
  • glite-yaim-lfc-4.0.0-4.noarch.rpm
  • glite-yaim-myproxy-4.0.0-2.noarch.rpm

The main difference with the rpms from the second phase of certification is:

  • config_bdii: the detection of openldap version was removed, but it is still required, adding one line before line "version=openldap-2.1" as:
result=`ls -d /usr/share/doc/openldap-servers-* | cut -d"-" -f3`
  • Changes for LFC node-info.d since 3.1 configuration is now in the node.
  • Remove "+" from the line 5 of function config_seclassic
  • add line "mkdir -p /var/log/glite/rgma-server" before line "chown
 tomcat4:tomcat4 /var/log/glite/rgma-server/" in config_rgma_server
  • remove config_bdii_only from function list of CE
  • in config_globus put back "GLOBUS_MDS=yes" for lcg CE
  • clients contains a fix for TAR WN in gLite 3.0.

For a list of the bugs that this version of YAIM intends to fix, please see the following Savannah patches:

CERN testing report

General remark:

  • For all resources, we need to uninstall lcg-info-generic and install glite-info-generic-2.0.2-1, besides, BDII needs to be upgarded to 3.9.1-3.

3.0 UI

  • When calling config_globus, it gives some error info:
/opt/globus/sbin/globus-initialization.sh: line 61: ./setup-globus-mds-gris:
No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 62: ./setup-globus-gatekeeper:
No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 63:
./setup-globus-gram-job-manager: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 64:
./setup-globus-gram-reporter-fork: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 65:
./setup-globus-gram-reporter-pbs: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 66:
./setup-globus-gram-reporter-condor: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 67:
./setup-globus-gram-reporter-lsf: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 68:
./setup-globus-job-manager-fork: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 69:
./setup-globus-job-manager-pbs: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 70:
./setup-globus-job-manager-condor: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 71:
./setup-globus-job-manager-lsf: No such file or directory
it's harmless, but annoying.

  • when calling config_glite_ui_30,
setup-ssl-utils: Complete

..Done
WARNING: The following packages were not set up correctly:
        globus_trusted_ca_42864e48_setup-noflavor-pgm
Check the package documentation or run postinstall -verbose to see what
happened
this can be ignored although I list it here

3.0 WN

  • when calling config_globus,
/opt/globus/sbin/globus-initialization.sh: line 65: ./setup-globus-gram-reporter-pbs: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 66: ./setup-globus-gram-reporter-condor: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 67: ./setup-globus-gram-reporter-lsf: No such file or directory
loading cache ./config.cache
checking for mpirun... /usr/bin/mpirun
updating cache ./config.cache
creating ./config.status
creating fork.pm
/opt/globus/sbin/globus-initialization.sh: line 69: ./setup-globus-job-manager-pbs: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 70: ./setup-globus-job-manager-condor: No such file or directory
/opt/globus/sbin/globus-initialization.sh: line 71: ./setup-globus-job-manager-lsf: No such file or directory
but it can be ignored.

3.0 LCG CE

  • when calling config_fmon_client, it complaims:
   INFO: Executing function: config_fmon_client 
JM.conf file parsing: [FAILED]

Batch system log dir not defined in JM.conf!
JM.conf file parsing: [FAILED]

Batch system log dir not defined in JM.conf!

WMS+LB

The test is based on the current checkpoint release, 1251.

  • node-info should be updated to use config_gip not config_gip_services, config_gip should be updated for WMS port and add LB node type.

VOBOX

  • when calling config_vobox
ls: /opt/vobox/dteam/proxy_repository: Permission denied
 Starting ProxyRenewal Daemon: vobox-renewd                [  OK  ]
 Process  does not exist ...                               [FAILED]
ls: /opt/vobox/dteam/proxy_repository: Permission denied
 Starting ProxyRenewal Daemon: vobox-renewd                [  OK  ]
 Process  does not exist ...                               [FAILED]
ls: /opt/vobox/dteam/proxy_repository: Permission denied
 Starting ProxyRenewal Daemon: vobox-renewd                [  OK  ]
 Process  does not exist ...                               [FAILED]
ls: /opt/vobox/dteam/proxy_repository: Permission denied
 Starting ProxyRenewal Daemon: vobox-renewd                [  OK  ]
.......
and it tried to configue VOBOX for all sgm pool accounts. And also it keeps printing out above error message on console after configuring. Notice: in grid-mapfile all sgm DN are mapped to sgm01, so we don't need to have daemons or cron for all sgm pool accounts.

Upgrade testing

3.0 APT repository

In order to test the upgrade to the new YAIM 4.0.0 in gLite 3.0 node types, please, apply patch 1238 by editing your apt string in the following way:

rpm http://lxb2042.cern.ch/gLite/APT/R3.0-cert rhel30 externals Release3.0 updates updates.certified internal patch1238.uncertified

3.1 YUM repository

In order to test the upgrade to the new YAIM 4.0.0 in gLite 3.1 node types (only WN and UI), please, apply patch 1239 by editing your yum string in the following way:

[patch 1239]
name=gLite 3.1 patch 1239
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/integration/cert/3.1/patches/1239/sl4/i386/
enabled=1

External Sites testing reports

INFN testing report

TCD testing report

GRNET testing report

CESGA testing report

PIC testing report

UCY testing report

CERN testing report

-- MariaALANDESPRADILLO - 24 Aug 2007

Edit | Attach | Watch | Print version | History: r11 < r10 < r9 < r8 < r7 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r8 - 2007-09-03 - MariaALANDESPRADILLO
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EGEE All webs login

This site is powered by the TWiki collaboration platform Powered by Perl This site is powered by the TWiki collaboration platformCopyright & by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Ask a support question or Send feedback