nordugrid-arc 0.8.2.2

Main language is C++

Dependencies expressed in RPM BuildRequires:

BuildRequires: gsoap-devel >= 2.7.2
BuildRequires: libxml2-devel >= 2.4.0
BuildRequires: globus-common-devel
BuildRequires: globus-ftp-client-devel
BuildRequires: globus-ftp-control-devel
BuildRequires: globus-gass-transfer-devel
BuildRequires: globus-gsi-credential-devel
BuildRequires: globus-gsi-sysconfig-devel
BuildRequires: globus-gss-assist-devel
BuildRequires: globus-io-devel
BuildRequires: openldap-devel
BuildRequires: globus-rls-client-devel
BuildRequires: globus-rsl-devel
BuildRequires: gettext
BuildRequires: python-devel
BuildRequires: voms-devel
%if %{?fedora}%{!?fedora:0} >= 12 || %{?rhel}%{!?rhel:0} >= 6
BuildRequires: libuuid-devel
%else
BuildRequires: e2fsprogs-devel
%endif
BuildRequires: lfc-devel

Runtime requirements:

Dependencies are all taken from EPEL. For some platforms the NorduGrid repository supplies:

* Globus >= 5.0.0
* VOMS
* LFC

nordugrid-arc-nox 1.1.0

Main language is C++ and some Python

BuildRequires: cppunit-devel
BuildRequires: pkgconfig
%if %{?fedora}%{!?fedora:0} >= 12 || %{?rhel}%{!?rhel:0} >= 6
BuildRequires: libuuid-devel
%else
BuildRequires: e2fsprogs-devel
%endif
BuildRequires: gettext
BuildRequires: python-devel
BuildRequires: glibmm24-devel
BuildRequires: glib2-devel
BuildRequires: libxml2-devel
BuildRequires: openssl-devel
BuildRequires: xmlsec1-devel >= 1.2.4
BuildRequires: xmlsec1-openssl-devel >= 1.2.4
BuildRequires: gsoap-devel >= 2.7.2
%if %{_vendor} == "suse"
BuildRequires: openldap2-devel
BuildRequires: gettext-devel
%endif
%if %{_vendor} = "suse"
BuildRequires: openldap-devel
%endif
BuildRequires: globus-common-devel
BuildRequires: globus-ftp-client-devel
BuildRequires: globus-ftp-control-devel
BuildRequires: globus-rls-client-devel
%if %{with_lfc}
BuildRequires: lfc-devel
%endif
%if %{_vendor} == "redhat"
BuildRequires: db4-devel
%endif
%if %{_vendor} == "suse"
BuildRequires: db-devel
%endif
%if %{with_java}
BuildRequires: java-devel
BuildRequires: jpackage-utils
%if %{with_gcj}
%if %{?fedora}%{!?fedora:0} >= 4
BuildRequires: java-gcj-compat-devel
%else
BuildRequires: java-1.4.2-gcj-compat-devel
%endif
%endif
%endif
%if %{?fedora}%{!?fedora:0} >= 7
BuildRequires: perl-Test-Harness
BuildRequires: perl-Test-Simple
%endif
BuildRequires: mktemp

Runtime requirements:

Dependencies are all taken from the base distribution and in the case of RHEL also from EPEL. For some older platforms the NorduGrid repository supplies:

* Globus >= 5.0.0
* VOMS
* LFC

-- JonKerrNilsen - 10-Sep-2010

Edit | Attach | Watch | Print version | History: r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r1 - 2010-09-10 - JonKerrNilsen
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback