EMI 1 RC1 - ETICS project-configuration changes log

This page is used to track any change or modification done to the EMI 1 RC1 build configurations in ETICS. It is to be used by the EMI Release Management people to record and exchange information.

Configuration: emi_B_1_rc1

Project configuration changes.

What Who When
Deleted SubConfiguration: emi-hydra_B_1_0_0_1 Francesco 14/03/2011
Updated SubConfiguration: emi-lb_R_3_0_4_3 Francesco/Zdenek 12/03/2011
Updated SubConfigurations:
emi-lb_R_3_0_4_2
emi-px_R_1_0_6_1
Cris/Zdenek 11/03/2011
Updated SubConfiguration: emi-dcache_B_emi_1 Cris/Christian 11/03/2011
Added SubConfiguration: emi.saga_R_1_0_0_1 Cris 10/03/2011
Updated SubConfiguration: emi-fts_R_2_2_6_1 Cris/Michail 09/03/2011
Updated SubConfiguration:
emi-lcgdm_R_1_8_1_0
emi-lcgutil_R_1_11_18_0
Cris/Oliver 09/03/2011
Updated SubConfiguration: emi-lb_R_3_0_3_1 Cris/Zdenek 08/03/2011
Updated SubConfiguration: emi-bdii_R_1_3_1_1 Cris/Pedro 08/03/2011
Updated SubConfiguration:
emi-resource-discovery_R_2_2_0_0
emi-wms-ui_R_3_3_11_0
emi-wms_R_3_3_1_0
glite-build-common-cpp_R_3_2_12_0
Cris/Paolo 07/03/2011
Updated SubConfigurations:
emi-jobid_R_2_0_2_1
emi-lbjp-common_R_3_0_1_2
emi-lb_R_3_0_2_1
emi-gridsite_R_1_7_11_1
Cris/Zdenek 07/03/2011
Updated SubConfiguration: emi.unicore.R_6.4.0_rc1 Cris/Bernd 07/03/2011
Updated SubConfigurations:
emi-java-security_R_3_0_0_1
emi-delegation_R_2_0_0_1
Cris/Joni 04/03/2011
Updated SubConfiguration: emi-dgas_R_4_0_1 Cris/AndreaG 04/03/2011
Updated SubConfiguration: emi-argus_R_1_3_0_RC1 Cris/Valery 04/03/2011
Updated SubConfigurations:
emi-jdl_R_3_2_5_0
emi-cream-ui_R_1_13_1_0
emi-cream-ce_R_1_13_1_0
Cris/Paolo 04/03/2011
Dependencies on apr-dev and aprutil-dev, which do not exist in SL5/EPEL, must be replaced with dependencies on apr-devel and apr-util-devel Alberto 03/03/2011
Updated SubConfiguration: emi-apel_R_3_2_6_0 Cris/Cris 03/03/2011
Updated SubConfiguration: emi-sac_B_1_dev Cris/Mischa 02/03/2011
Updated SubConfigurations:
emi-lb_R_3_0_1_1
emi-lbjp-common_R_3_0_1_1
emi-jobid_R_2_0_1_1
Cris/Zdenek 01/03/2011
The single oracle-instantclient package has been replaced by two separate packages, oracle-instantclient-basic and oracle-instantclient-devel to be set as build or runtime deps as necessary. This are the official packages distributed by Oracle Alberto 24/02/2011
Added oracle-instantclient.location and oracle-instantclient.version needed by some some components Alberto 24/02/2011
Added global PKG_CONFIG_PATH=/usr/${libdir}/pkgconfig:${stageDir}/usr/${libdir}/pkgconfig. This is prepended to any PKG_CONFIG_PATH declared by individual configurations. The same entries can be removed from individual configurations Alberto 24/02/2011
updated SubConfiguration: emi-px_R_1_0_2_1 Cris 22/02/2011
updated SubConfiguration: emi-jobid_R_2_0_0_2 Cris 22/02/2011
updated SubConfiguration: emi-lbjp-common_R_3_0_0_2 Cris 22/02/2011
updated SubConfiguration: emi-gridsite_R_1_7_10_4 Cris 22/02/2011
Created SubConfiguration: emi-storm_1_7_0_1_RC1 Cris 22/02/2011
Created SubConfiguration: emi-lrms-utils_B_HEAD Cris 22/02/2011
updated SubConfiguration: emi-dgas_R_4_0_0 Cris 22/02/2011
updated SubConfiguration: emi-delegation_B_HEAD Cris 22/02/2011
updated SubConfiguration: emi-jobid_R_2_0_0_1 Cris 22/02/2011
updated SubConfiguration: emi-gridsite_R_1_7_10_1 Cris 22/02/2011
added Property: package.autoreqprov = yes Cris 21/02/2011
Removed globus flavour properties. Since we are not using globus flavours anymore, these properties should not be used anymore. By removing them we can see which components still rely on them and why Alberto 13/02/2011
The project config still contained the EGEE/gLite copyright and license statements. Changed to EMI (but it must be checked) Alberto 13/02/2011
Removed all project level DEFAULT properties. All RPMS not available in the OS or in EPEL are being produced and will be part of the EMI distribution until they can be taken from OS/EPEL Alberto 13/02/2011

External packages changes

Component name Configuration name Change or comments Who? Done? When?
jug - jug-1.1-1.el5.noarch.rpm added, requested by transfer-fts Cris Yes 09/03/2011
myproxy No config needed The RPMS added in EMI repofrom EPEL-testing to the EMI repo, waiting to become available from the EPEL5 repo Cris Yes 07/03/2011
SAGA.api-java-1.0.1-3.noarch.rpm No config needed RPMS needed by emi.saga (SAGA.vu-java.engine) components Cris Yes 07/03/2011
axis1.4 axis1.4 v. 1.4-1 configurations that need to use the newer axis must set a dependency on this one rather than axis. The axis.location points by default to this version, which is installed in /usr/local/axis1.4 Alberto/Cris Yes 06/03/2011
ant1.8 ant1.8 v. 1.8.1-1 configurations that need to use the newer ant must set a dependency on this one rather than ant. The ANT_HOME and PATH env vars must be set in each configuration commands to point to this version if they want to use it. It is installed in /usr/local/ant1.8.1-1.8.1 (export ANT_HOME=/usr/local/ant1.8-1.8.1; export PATH=$ANT_HOME/bin:$PATH) Alberto/Cris YEs 06/03/2011
apr-dev and aprutil-dev - must not be used, instead use apr-devel and apr-util-devel Alberto/Cris Yes 06/03/2011
openldap2.4 - is now available in addition to openldap. If configurations need the newer version they can set a dependency on it (and other related openldap2.4 packages) Alberto/Cris Yes 06/03/2011
activemq-cpp-library activemq-cpp-library v. 3.2.4 pm in the repo is linked statically against apr to avoid conflicts with the standard versions of apr in SL5. Components using activemq-cpp-library do not have to set dependencies on apr or apr-util unless they themselves requires it. If they require higher versions of apr than those provided by SL5, they should be linked statically or in some way that doesn’t require upgrading the standard apr Alberto/Cris Yes 06/03/2011
editline-2.9-1.sl5 No config needed RPM needed by emi.amga components Alberto, Cris Yes 03/03/2011
SAGA.vu-java.engine-1.0.1-3.noarch.rpm
SAGA.lsu-cpp.engine-1.3.3-2.sl5.x86_64.rpm
No config needed RPMS needed by emi.saga components Cris Yes 03/03/2011
myproxy-admin
myproxy-devel
myproxy-libs
No config needed The RPMS added in EMI repofrom EPEL-testing to the EMI repo, waiting to become available from the EPEL5 repo Cris Yes 02/03/2011
globus-gridmap-callout-error
globus-gridmap-callout-error-devel
No configuration needed to be able to add the dependency The RPMS added to the EMI repo, waiting to become available from the EPEL5 repo Cris Yes 01/03/2011
oracle-instantclient-basic/devel 10.2.03 The RPMs have been added to the EMI repo, the old oracle-instantclient package has been removed Alberto, Cristina Yes 24/02/2011
maven maven v. 2.2.1-1emi The RPM has been added to the EMI repo Alberto, Cristina Yes 23/02/2011
gwt-lib gwt-lib v. 1.7.1-1emi The RPM has been added to the EMI repo. Please note that the file structure is different from that of the tarball used until now. The jars are in /usr/share/java/gwt-lib Alberto, Cristina Yes 22/02/2011
activemq activemq 5.4.2-1 Added newest activemq maintenance release with both tarball (from Apache) and RPM (from James Casey) Alberto Yes 16/02/2011
jclassads jclassads v. 2.4.0-2 Created new configuration jclassads v. 2.4.0-2. This configuration has the original source code and can be built to produce a standard RPM installing classad.jar in /usr/share/java/jclassads as required by the linux java guidelines. The configuration having a dependency on this package must update the path to the jar file using the path /usr/share/java/jclassads Alberto Yes 13/02/2011
gsoap All versions Changed packageName from gSOAP to gsoap, since both EPEL and Debian use gsoap. Changed or created new soap packages with small letter name for compatibilty with old gLite builds Alberto Yes 04/02/2011

EMI Component configuration changes.

Component name Configuration nameSorted ascending Change or comments Who? Done? When?
emi-argus
emi.argus emi-argus_B_1_3 Removed local PKG_CONFIG_PATH (see Project configuration changes above) Alberto Yes 24/02/2011
emi.argus.gsi-pep-callout emi-argus-gsi-pep-callout_B_1_2_EMI Removed local PKG_CONFIG_PATH (see Project configuration changes above) Alberto Yes 24/02/2011
emi.argus.parent emi-argus-parent_B_1_3 Added build-time dependency on maven Valery Yes 24/02/2011
emi.dcache.srmclient emi-dcache-srmclient_R_HEAD updated from static to dynamic dependencies:
from ant v.1.8.1 to ant>1.6.5
from jdk v.1.6.0_22 to jdk >= 1.6.0
Cris Yes 04/03/2011
emi.misc.glite-info-templates emi-glite-info-templates_R_1_1_0_1 apply fix from action #19508 Cris Yes 13/03/2011
emi.lb.logger-msg emi-lb-logger-msg_R_1_0_1_1 Removed dependencies on apr-dev and aprutil-dev, they do not exist in SL5/EPEL and the equivalent apr-devel and apr-util-devel are dependencies of activemq-cpp-library Alberto Yes 03/03/2011
emi.lb.yaim emi-lb-yaim_R_4_3_1_1 Removed dependency on emi.misc.glite-info-generic, not to be used anymore Cris 07.03.2011
emi..dcache
emi.lb
emi.misc
emi.voms
emi.voms.voms-admin-client emi.voms-admin-client_B_EMI_1 Added dependencies on maven and java Alberto Yes 25/02/2011
emi.voms.voms-admin-server emi.voms-admin-server_B_EMI_1 Added dependencies oracle-instantclient-basic Alberto Yes 25/02/2011
emi.voms.voms-admin-server emi.voms-admin-server_B_EMI_1 Added dependencies on maven and java Alberto Yes 25/02/2011
org.glite.security.voms-api-cpp emi.voms-api-cpp_R_2_0_0 Removed package.prefix=/ (inherited from the project) Alberto Yes 24/02/2011
org.glite.security.voms-api-java emi.voms-api-java_R_2_0_0 The script adapt-vomsjapi.sh creates a symlink vomsjapi-2.0.0.jar --> vomjapi.jar with absolute paths pointing to the temporary buildroot used to generate the binary rpm from source rpm. rpmbuild flags this as an error and prevents the creation of the rpm. Replace with relative paths, maybe by using something like
cd $dir
ln -s vomsjapi-2.0.0.jar vomsjapi.jar
cd -
Vincenzo Yes 28/02/2001
org.glite.security.voms-api-java emi.voms-api-java_R_2_0_0 LICENCE and AUTHORS files are installed in /usr/share/packageName-version, it should probably be /usr/share/doc/packageName-version Vincenzo Yes 28/02/2001
emi.voms emi.voms-EMI1 Removed local DEFAULT properties for oracle-instantclient, pyxml and zsi. oracle-instantclient is v. 10.2.0.4 Alberto Yes 24/02/2011
org.glite.security.voms-oracle emi.voms-oracle.HEAD Added dependencies on oracle-instantclient-basic and oracle-instantclient-devel Alberto Yes 24/02/2011
org.glite.security.voms-oracle emi.voms-oracle.HEAD oracle-instantclient properties required by voms-oracle are in the project configuration Alberto Yes 24/02/2011
emi.voms.voms-MYSQL emi.voms.voms-MYSQL_B_EMI_1 Restructured metapackage according to EMI policies: change of name using all small letters, starts with emi-, removed all non-first level dependencies, change installation path to /usr/share/doc/${packageName}-${version}, removed all content. There are still a few first level dependencies that I cannot judge whether they should be attached to some other package and removed from here, also the voms-static info provider package is missing, should it be here as well? Alberto, Andrea Ceccanti Partially 25/02/2011
All maven-based voms components   The property mavenRepositoryDir must be set to a directory accessible within the mock chroot, but it was pointing to the ETICS Workspace, changed to /tmp/m2-repository Alberto Yes 27/02/2011
All affected voms components   Added build time deps on autoconf, automake and libtool Alberto Yes 26/02/2011
All affected voms components   Moved packageName from configuration to module to maintain it in a single place Alberto Yes 25/02/2011


This topic: EMI > EMI-1 > EMI1RC1Log
Topic revision: r44 - 2011-03-18 - AlbertoDiMeglio
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright &© 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
or Ideas, requests, problems regarding TWiki? use Discourse or Send feedback