EMI 1 RC2 - ETICS project-configuration changes log

This page is used to track any change or modification done to the EMI 1 RC2 build configurations in ETICS. It is to be used by the EMI Release Management people to record and exchange information.

Configuration: emi_B_1_rc2

Project configuration changes.

What Who When
Updated SubConfiguration: emi-storm_B_1_7_0_3_RC2 Cris/Riccardo 28.03.2011
Updated SubConfiguration: emi-lb_R_3_0_5_1 Cris/Zdenek 28.03.2011
Updated SubConfiguration: emi-lrms-utils_R_1_0_0_1 Cris/Massimo 28.03.2011
Updated SubConfiguration:
emi-cream-ce_R_1_13_1_1
emi-wms_R_3_3_1_1
Cris/Paolo 28.03.2011
Updated SubConfiguration: emi-cluster_R_1_0_0_1 Cris/Massimo 25.03.2011
Updated Components SubConfigurations:
emi-build-common-cpp_R_3_2_12_1
emi-classad-utils_R_3_2_2_1
emi-jobman-exception_R_3_2_2_1
Cris/Paolo 25.03.2011
Updated SubConfigurations:
emi-resource-discovery_R_2_2_0_1
emi-jdl_R_3_2_5_1
emi-cream-ui_R_1_13_1_1
emi-wms-ui_R_3_3_11_1
Cris/Paolo 25.03.2011
Added SubConfiguration: emi-hydra_B_1_0_0_1 Cris/John 23.03.2011
Added SubConfiguration: emi.lcg-info_R_1_0_0, Cris/Laurence 23.03.2011
Updated SubConfiguration: emi-gridsite_R_1_7_12_1 Cris/Zdenek 23.03.2011
Added SubConfiguration: emi.cluster.HEAD Cris/Massimo 22.03.2011
Added SubConfiguration: emi-delegation_R_2_0_0_1 Cris/Joni 21.03.2011
Added SubConfiguration: emi-glite-amga_R_2_1_2_1 Cris 21.03.2011
Added SubConfiguration: emi-java-security_R_3_0_0_1 Cris/Joni 21.03.2011
Added SubConfiguration: emi-lb_R_3_0_4_3 Cris/Zdenek 21.03.2011
Added SubConfiguration: emi-dcache_B_emi_1 Cris/Christian 21.03.2011
Added SubConfiguration: emi-lcgutil_R_1_11_18_0 Cris/Oliver 21.03.2011
Added SubConfiguration: emi-lcgdm_R_1_8_1_0 Cris/Oliver 21.03.2011
Added SubConfiguration: emi-fts_R_2_2_6_1 Cris/Oliver 21.03.2011
Added SubConfiguration: emi.unicore.R_emi-1_rc2 Cris/Bernd 20.03.2011
Added SubConfiguration: emi-storm_B_1_7_0_RC2 Cris/Elisabetta 20.03.2011
Added SubConfiguration: emi-wms_B_3_3 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-wms-ui_B_3_3 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-resource-discovery_B_2_2 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-lrms-utils_B_HEAD Cris/Paolo 20.03.2011
Added SubConfiguration: emi-jdl_B_3_2 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-cream-ui_B_1_13 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-cream-ce_B_1_13 Cris/Paolo 20.03.2011
Added SubConfiguration: emi-dgas_R_4_0_2 Cris/AndreaG 18.03.2011
Added SubConfiguration: emi-apel_R_3_2_7_0 Cris/CristinaDCN 18.03.2011
Added SubConfiguration: emi-px_R_1_0_7_1 Cris/Zdenek 18.03.2011
Added SubConfiguration: emi-jobid_R_2_0_3_2 Cris/Zdenek 18.03.2011
Added SubConfiguration: emi-lbjp-common_R_3_0_2_2 Cris/Zdenek 18.03.2011
Added SubConfiguration: emi-arc_R_1_rc2 Cris/Bernd 18.03.2011
Added SubConfiguration: emi-bdii_R_1_0_0_1 Cris/Laurence 18.03.2011
Updated SubConfiguration: emi-saga_R_1_0_0_2 Cris/Steve 18.03.2011
Added SubConfiguration: emi-mpi_R_1_0_0_1 Cris/Enol 18.03.2011
Added SubConfiguration: emi-argus_R_1_3_0_RC2 Cris/Valery 18.03.2011
Added SubConfiguration: emi-yaim_B_HEAD Cris 17.03.2011
Added SubConfiguration: emi-misc_B_1_rc2 Cris 17.03.2011
Added SubConfiguration:
emi-saga_R_1_0_0_1
emi-saga-adapter_R_1_0_0_2
Cris/Steve 16.03.2011
Added SubConfiguration: emi.voms-EMI1 Cris/Vincenzo 16.03.2011
Added SubConfiguration: emi-sac_B_1_dev Cris/Mischa 16.03.2011
Added SubConfiguration: emi-gridsite_R_1_7_11_1 Cris/Zdenek 15.03.2011

External packages changes

Component name Configuration name Change or comments Who? Done? When?
apr1.4-devel-1.4.2-1static
apr-util1.3-devel-1.3.10-1static
apr1.4-devel v. 1.4.2-1static
apr-util1.3-devel v. 1.3.10-1static
static versions containing ONLY staticaly linked libraries Alberto/Cris Yes 23/03/2011
c-check-0.9.8-1.sl5 - needed by emi.lcgutils (B)
added to TC2 repo
Cris Yes 23/03/2011
activemq-cpp-library activemq-cpp-library v. 3.2.5 rpm in the repo is linked statically against apr to avoid conflicts with the standard versions of apr in SL5. Components using activemq-cpp-library do not have to set dependencies on apr or apr-util unless they themselves requires it. If they require higher versions of apr than those provided by SL5, they should be linked statically or in some way that doesn’t require upgrading the standard apr
replacing wrong 3.2.4 version
added to RC2 repo
Cris Yes 22/03/2011
editline-2.9-1.sl5 No config needed RPM needed by emi.amga components
aded to RC2 repo
Cris Yes 14/03/2011
cx_Oracle-5.0.3-10g-py24-1 - needed by FTM MP
added to RC2 repo
Cris Yes 21/03/2011
gwt-lib gwt-lib v. 1.7.1-1emi The RPM has been added to the EMI repo. Please note that the file structure is different from that of the tarball used until now. The jars are in /usr/share/java/gwt-lib
added to RC2 repo
Cris Yes 21/03/2011
editline-2.9-1.sl5 No config needed RPM needed by emi.amga components
added to RC2 repo
Cris Yes 21/03/2011
xmlrpc-c-* - needed by StoRM components, added to RC2 repo Cris Yes 21/03/2011
apr1.4-devel
apr-util1.3-devel
needed by emi.dgas.hlr-sensors-producers and some emi.lcgutil Cris Yes 20/03/2011
mm-mysql needed by emi.apel.core (BR), added ot RC2 repo Cris Yes 20/03/2011
voms-compat needed by myproxy-admin, added to RC2 repo Cris Yes 20/03/2011
lib64ldap2.4_2-2.4.22 needed by openldap2.4-servers, added to RC2 repo Cris Yes 20/03/2011
jug - jug-1.1-1.el5.noarch.rpm added, requested by transfer-fts Cris Yes 14/03/2011
axis1.4 axis1.4 v. 1.4-1 configurations that need to use the newer axis must set a dependency on this one rather than axis. The axis.location points by default to this version, which is installed in /usr/local/axis1.4
aded to RC2 repo
Cris Yes 14/03/2011
ant1.8 ant1.8 v. 1.8.1-1 configurations that need to use the newer ant must set a dependency on this one rather than ant. The ANT_HOME env var must be set by each configuration to point to this version if the want to use it. It is installed in /usr/local/ant1.8
added to RC2 repo
Cris Yes 14/03/2011
openldap2.4 - is now available in addition to openldap. If configurations need the newer version they can set a dependency on it (and other related openldap2.4 packages)
aded to RC2 repo
Alberto/Cris Yes 14/03/2011
activemq-cpp-library activemq-cpp-library v. 3.2.4 rpm in the repo is linked statically against apr to avoid conflicts with the standard versions of apr in SL5. Components using activemq-cpp-library do not have to set dependencies on apr or apr-util unless they themselves requires it. If they require higher versions of apr than those provided by SL5, they should be linked statically or in some way that doesn’t require upgrading the standard apr
aded to RC2 repo
Cris Yes 14/03/2011
editline-2.9-1.sl5 No config needed RPM needed by emi.amga components
aded to RC2 repo
Cris Yes 14/03/2011
globus-gridmap-callout-error
globus-gridmap-callout-error-devel
No configuration needed to be able to add the dependency The RPMS added to the EMI repo, waiting to become available from the EPEL5 repo Cris Yes 14/03/2011
oracle-instantclient-basic/devel 10.2.03 The RPMs have been added to the EMI repo, the old oracle-instantclient package has been removed
aded to RC2 repo
Cristina Yes 14/03/2011
maven maven v. 2.2.1-1emi The RPM has been added to the EMI repo
aded to RC2 repo
Cristina Yes 14/03/2011
gwt-lib gwt-lib v. 1.7.1-1emi The RPM has been added to the EMI repo. Please note that the file structure is different from that of the tarball used until now. The jars are in /usr/share/java/gwt-lib
aded to RC2 repo
Cris Yes 14/03/2011
activemq activemq 5.4.2-1 Added newest activemq maintenance release with both tarball (from Apache) and RPM (from James Casey)
aded to RC2 repo
Cris Yes 14/03/2011
jclassads jclassads v. 2.4.0-2 Created new configuration jclassads v. 2.4.0-2. This configuration has the original source code and can be built to produce a standard RPM installing classad.jar in /usr/share/java/jclassads as required by the linux java guidelines. The configuration having a dependency on this package must update the path to the jar file using the path /usr/share/java/jclassads
aded to RC2 repo
Cris Yes 14/02/2011

EMI Component configuration changes.

Component name Configuration name Change or comments Who? Done? When?
emi.sac
emi.sac.GLEXEC_wn emi-sac-GLEXEC_wn_R_3_2_4_1 readded to the sub-system configuration Cris Yes 21/03/2011
emi.sac.GLEXEC_wn emi-sac-GLEXEC_wn_R_3_2_4_1 temporary remove from the sub-system configuration gLexec_wn MP is not requested as dependency by other components and was failing because some other critical components were missing error_report Cris Yes 17/03/2011
emi.voms
emi.voms.emi-voms-mysql emi-voms-mysql_R_1_0_0_1 readded the sub-system configuration Vincenzo Yes 21/03/2011
emi.voms.emi-voms-mysql emi-voms-mysql_R_1_0_0_1 temporary remove from the sub-system configuration, VOMS MP is not requested as dependency by other components and was failing because some other critical components were missing error_report" target="_blank">http://bit.ly/voms_MP][error_report]] Cris Yes 17/03/2011

-- DoinaCristinaAiftimiei - 15-Mar-2011

Edit | Attach | Watch | Print version | History: r19 < r18 < r17 < r16 < r15 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r19 - 2011-03-28 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright &© 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback