EMI 1 (Kebnekaise) - Update 15 (24.04.2012)

The Update contains:

  • minor releases of DPM/LFC, v. 1.8.3 and GFAL/lcg_util, v. 1.12.0
  • revision releases of BLAH, v. 1.16.5, glite-proxyrenewal, v. 1.3.25 and WMS v. 3.3.5

BLAH v. 1.16.5, task #27056

What's new

  • This updates of BLAH fixes a problem with the new BLparser that can happen under high load.
  • It also addresses an issue with the new BLParser with LSF: bhist is not used anymore and therefore the load caused by the bupdater is much lower than before.
  • This new BLAH version also enables the submissions to Torque version 2.5.8

Affected services

  • CREAM

Deployment Notes:

  • Since BLAH is deployed together with CREAM, please refer to the installation and configuration notes for the whole CREAM-CE

Known issues

Updated Artefacts

Binary
glite-ce-blahp-1.16.5-2.sl5.x86_64.rpm
glite-ce-blahp-debuginfo-1.16.5-2.sl5.x86_64.rpm
glite-ce-yaim-cream-ce-4.2.4-1.sl5.x86_64.rpm
glite-ce-yaim-cream-ce-debuginfo-4.2.4-1.sl5.x86_64.rpm
Binary tarball
glite-ce-blahp-1.16.5-2.sl5.x86_64.tar.gz
glite-ce-blahp-debuginfo-1.16.5-2.sl5.x86_64.tar.gz
glite-ce-yaim-cream-ce-4.2.4-1.sl5.x86_64.tar.gz
glite-ce-yaim-cream-ce-debuginfo-4.2.4-1.sl5.x86_64.tar.gz
Sources RPM
glite-ce-blahp-1.16.5-2.sl5.src.rpm
glite-ce-yaim-cream-ce-4.2.4-1.sl5.src.rpm
Sources tarball
glite-ce-blahp-1.16.5.tar.gz
glite-ce-yaim-cream-ce-4.2.4.tar.gz

DPM v. 1.8.3, task #26740

What's new

  • Added thread safe CSEC_MECH
  • Packaging is now Fedora compliant
  • Added synchronous dpm_get support
  • Added support for MySQL 5.5 for the db creation script
  • SRMv1 is now disabled by default
  • Added sample my.cnf configuration file
  • New HTTP/DAV frontend daemon

Affected services

  • DPM, UI, WN

Deployment Notes:

  • No special instructions

Known issues:

  • None

Updated Artefacts

Binary
CGSI-gSOAP-debuginfo-1.3.5-1.el5.x86_64.rpm
CGSI-gSOAP-1.3.5-1.el5.x86_64.rpm
CGSI-gSOAP-devel-1.3.5-1.el5.x86_64.rpm
dpm-1.8.3-1.el5.x86_64.rpm
dpm-copy-server-mysql-1.8.3-1.el5.x86_64.rpm
dpm-copy-server-oracle-1.8.3-1.el5.x86_64.rpm
dpm-devel-1.8.3-1.el5.x86_64.rpm
dpm-libs-1.8.3-1.el5.x86_64.rpm
dpm-name-server-mysql-1.8.3-1.el5.x86_64.rpm
dpm-name-server-oracle-1.8.3-1.el5.x86_64.rpm
dpm-perl-1.8.3-1.el5.x86_64.rpm
dpm-python-1.8.3-1.el5.x86_64.rpm
dpm-python26-1.8.3-1.el5.x86_64.rpm
dpm-rfio-server-1.8.3-1.el5.x86_64.rpm
dpm-server-mysql-1.8.3-1.el5.x86_64.rpm
dpm-server-oracle-1.8.3-1.el5.x86_64.rpm
dpm-srm-server-mysql-1.8.3-1.el5.x86_64.rpm
dpm-srm-server-oracle-1.8.3-1.el5.x86_64.rpm
dpm-dsi-1.8.3-2.el5.x86_64.rpm
dpm-dsi-debuginfo-1.8.3-2.el5.x86_64.rpm
dpm-dsi-devel-1.8.3-2.el5.x86_64.rpm
dpm-yaim-4.2.7-1.el5.noarch.rpm
lcgdm-debuginfo-1.8.3-1.el5.x86_64.rpm
lcgdm-devel-1.8.3-1.el5.x86_64.rpm
lcgdm-libs-1.8.3-1.el5.x86_64.rpm
lcgdm-oracle-debuginfo-1.8.3-1.el5.x86_64.rpm
lcgdm-dav-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-debuginfo-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-devel-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-libs-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-server-0.7.1-1.el5.x86_64.rpm
nagios-plugins-dpm-disk-0.7.0-1.el5.x86_64.rpm
nagios-plugins-dpm-head-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-debuginfo-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-common-0.7.0-1.el5.x86_64.rpm
Binary tarball
CGSI-gSOAP-debuginfo-1.3.5-1.el5.x86_64.tar.gz
CGSI-gSOAP-1.3.5-1.el5.x86_64.tar.gz
CGSI-gSOAP-devel-1.3.5-1.el5.x86_64.tar.gz
dpm-1.8.3-1.el5.x86_64.tar.gz
dpm-copy-server-mysql-1.8.3-1.el5.x86_64.tar.gz
dpm-copy-server-oracle-1.8.3-1.el5.x86_64.tar.gz
dpm-devel-1.8.3-1.el5.x86_64.tar.gz
dpm-libs-1.8.3-1.el5.x86_64.tar.gz
dpm-name-server-mysql-1.8.3-1.el5.x86_64.tar.gz
dpm-name-server-oracle-1.8.3-1.el5.x86_64.tar.gz
dpm-perl-1.8.3-1.el5.x86_64.tar.gz
dpm-python-1.8.3-1.el5.x86_64.tar.gz
dpm-python26-1.8.3-1.el5.x86_64.tar.gz
dpm-rfio-server-1.8.3-1.el5.x86_64.tar.gz
dpm-server-mysql-1.8.3-1.el5.x86_64.tar.gz
dpm-server-oracle-1.8.3-1.el5.x86_64.tar.gz
dpm-srm-server-mysql-1.8.3-1.el5.x86_64.tar.gz
dpm-srm-server-oracle-1.8.3-1.el5.x86_64.tar.gz
dpm-dsi-1.8.3-2.el5.x86_64.tar.gz
dpm-dsi-debuginfo-1.8.3-2.el5.x86_64.tar.gz
dpm-dsi-devel-1.8.3-2.el5.x86_64.tar.gz
dpm-yaim-4.2.7-1.el5.noarch.tar.gz
lcgdm-devel-1.8.3-1.el5.x86_64.tar.gz
lcgdm-libs-1.8.3-1.el5.x86_64.tar.gz
lcgdm-oracle-debuginfo-1.8.3-1.el5.x86_64.tar.gz
lcgdm-dav-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-debuginfo-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-devel-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-libs-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-server-0.7.1-1.el5.x86_64.tar.gz
nagios-plugins-dpm-disk-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-dpm-head-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-debuginfo-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-common-0.7.0-1.el5.x86_64.tar.gz
Sources RPM
CGSI-gSOAP-1.3.5-1.src.rpm
dpm-dsi-1.8.3-2.src.rpm
dpm-yaim-4.2.7-1.src.rpm
lcgdm-1.8.3-1.src.rpm
lcgdm-meta-1.8.3-1.src.rpm
lcgdm-oracle-1.8.3-1.src.rpm
lcgdm-dav-0.7.1-1.src.rpm
nagios-plugins-lcgdm-0.7.0-1.src.rpm
Sources tarball
Metapackages
emi-dpm_oracle-1.8.3-1.el5.x86_64.rpm
emi-dpm_disk-1.8.3-1.el5.x86_64.rpm
emi-dpm_mysql-1.8.3-1.el5.x86_64.rpm
emi-dpm_oracle-1.8.3-1.el5.x86_64.tar.gz
emi-dpm_disk-1.8.3-1.el5.x86_64.tar.gz
emi-dpm_mysql-1.8.3-1.el5.x86_64.tar.gz

GFAL/lcg_util v. 1.12.0, task #26083

What's new

  • Main improvement: supporting GLUE 2. Minor bugfixes as well.
  • Other new features:
    • Return estimatedWaitTime for files in an asyncrhonous SRM request in Python
    • FTS overwrite changes to improve stat logic before deleting the dest file
    • services.xml usage with is-interface
  • Bug fixes:
    • cgsi-gsoap compilation failure with default debian compiler flags
    • cgsi-gsoap - license violation
    • Dealing with bugs in CGSI-Gsoap
    • FTS doesn't acknowledge GlueServiceAccessControlBaseRule attributes
    • bad memory read in bdii, and thread safety problem
    • lcg-get-checksum / lcg-rep seems to show checksum is case sensitive
    • fix minor memory leak when associated services not found - FTS specific/only problem
    • lcg-cp / cr srm-ifce invalid srm token
    • Change the order of querying ACBR to be more precise
    • srm-ifce -fstrack protector and gsoap memory corruption
    • add /etc/ file path for seeking services.xml cache file
    • Convert FileLocality management in srm-ifce
    • remove forgotten print statements - visible in glue2 mode only
    • gridftp changes to fix castor issues identified in FTS pilot
    • General EPEL packaging for all the lcg-utils components
    • lcg stmd finish with a "lcg_stmd: Cannot allocate memory" when processed with 1.11.19 and on the test bed
    • lcg-rep segmentation fault with dcache endpoints
  • Complete list, with links to the corresponding tracker items

Affected services

  • UI & WN

Deployment Notes:

Known issues:

  • None

Updated Artefacts

Binary
CGSI_gSOAP_2.7-voms-1.3.5-1.sl5.x86_64.rpm
CGSI_gSOAP_2.7-1.3.5-1.sl5.x86_64.rpm
CGSI_gSOAP_2.7-devel-1.3.5-1.sl5.x86_64.rpm
gfal-1.12.0-3.sl5.x86_64.rpm
gfal-py26-1.12.0-3.sl5.x86_64.rpm
gridftp-ifce-2.1.4-1.sl5.x86_64.rpm
is-interface-1.12.2-1.sl5.x86_64.rpm
lcg-util-1.11.21-1.sl5.x86_64.rpm
lcg-util-py26-1.11.21-1.sl5.x86_64.rpm
lcgutil-yaim-1.0.1-1.sl5.noarch.rpm
srm-ifce-1.1.0-3.sl5.x86_64.rpm
Binary tarball
gfal-1.12.0-3.sl5.x86_64.tar.gz
gfal-py26-1.12.0-3.sl5.x86_64.tar.gz
gridftp-ifce-2.1.4-1.sl5.x86_64.tar.gz
is-interface-1.12.2-1.sl5.x86_64.tar.gz
lcg-util-1.11.21-1.sl5.x86_64.tar.gz
lcg-util-py26-1.11.21-1.sl5.x86_64.tar.gz
lcgutil-yaim-1.0.1-1.sl5.noarch.tar.gz
srm-ifce-1.1.0-3.sl5.x86_64.tar.gz
Sources RPM
gridftp-ifce-2.1.4-1.sl5.src.rpm
is-interface-1.12.2-1.sl5.src.rpm
lcgutil-build-common-cpp-0.12.0-1.sl5.src.rpm
lcgutil-yaim-1.0.1-1.sl5.src.rpm
srm-ifce-1.1.0-3.sl5.src.rpm
Sources tarball
gfal-1.12.0.tar.gz
gfal-py26-1.12.0.tar.gz
gridftp-ifce-2.1.4.tar.gz
is-interface-1.12.2.tar.gz
lcg-util-1.11.21.tar.gz
lcg-util-py26-1.11.21.tar.gz
lcgutil-build-common-cpp-0.12.0.tar.gz
lcgutil-yaim-1.0.1.tar.gz
srm-ifce-1.1.0.tar.gz

glite-proxyrenewal v. 1.3.25, task #27541

What's new

  • This is a bugfix release for the previous version of ProxyRenewal, fixing problems with expired VOMS extensions

Affected services

  • FTS/FTA, PX, WMS

Deployment Notes:

  • Upon update, restart the ProxyRenewal daemon by calling /etc/init.d/glite-proxy-renewald restart

Known issues:

  • None

Updated Artefacts

Binary
glite-px-myproxy-yaim-4.1.6-2emi1.sl5.x86_64.rpm
glite-px-myproxy-yaim-debuginfo-4.1.6-2emi1.sl5.x86_64.rpm
glite-px-proxyrenewal-1.3.25-3emi1.sl5.x86_64.rpm
glite-px-proxyrenewal-debuginfo-1.3.25-3emi1.sl5.x86_64.rpm
Binary tarball
glite-px-myproxy-yaim-4.1.6-2emi1.sl5.x86_64.tar.gz
glite-px-myproxy-yaim-debuginfo-4.1.6-2emi1.sl5.x86_64.tar.gz
glite-px-proxyrenewal-1.3.25-3emi1.sl5.x86_64.tar.gz
glite-px-proxyrenewal-debuginfo-1.3.25-3emi1.sl5.x86_64.tar.gz
Sources RPM
glite-px-myproxy-yaim-4.1.6-2emi1.sl5.src.rpm
glite-px-proxyrenewal-1.3.25-0emi1.sl5.src.rpm
Sources tarball
glite-px-myproxy-yaim-4.1.6.tar.gz
glite-px-proxyrenewal-1.3.25.tar.gz

LFC v. 1.8.3, task #26741

What's new

  • Added thread safe CSEC_MECH
  • Packaging is now Fedora compliant
  • Added support for MySQL 5.5 for the db creation script
  • Added sample my.cnf configuration file
  • New HTTP/DAV frontend daemon

Other affected services

  • LFC, UI, WN

Deployment Notes:

  • Standard procedure: * metapackage update * yaim reconfiguration

Known issues:

  • None

Updated Artefacts

Binary
CGSI-gSOAP-debuginfo-1.3.5-1.el5.x86_64.rpm
CGSI-gSOAP-1.3.5-1.el5.x86_64.rpm
CGSI-gSOAP-devel-1.3.5-1.el5.x86_64.rpm
lcgdm-debuginfo-1.8.3-1.el5.x86_64.rpm
lcgdm-devel-1.8.3-1.el5.x86_64.rpm
lcgdm-libs-1.8.3-1.el5.x86_64.rpm
lcgdm-oracle-debuginfo-1.8.3-1.el5.x86_64.rpm
lcgdm-dav-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-debuginfo-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-devel-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-libs-0.7.1-1.el5.x86_64.rpm
lcgdm-dav-server-0.7.1-1.el5.x86_64.rpm
lfc-1.8.3-1.el5.x86_64.rpm
lfc-devel-1.8.3-1.el5.x86_64.rpm
lfc-dli-1.8.3-1.el5.x86_64.rpm
lfc-libs-1.8.3-1.el5.x86_64.rpm
lfc-perl-1.8.3-1.el5.x86_64.rpm
lfc-python-1.8.3-1.el5.x86_64.rpm
lfc-python26-1.8.3-1.el5.x86_64.rpm
lfc-server-mysql-1.8.3-1.el5.x86_64.rpm
lfc-server-oracle-1.8.3-1.el5.x86_64.rpm
lfc-yaim-4.2.4-1.el5.noarch.rpm
nagios-plugins-lfc-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-common-0.7.0-1.el5.x86_64.rpm
nagios-plugins-lcgdm-debuginfo-0.7.0-1.el5.x86_64.rpm
Binary tarball
CGSI-gSOAP-debuginfo-1.3.5-1.el5.x86_64.tar.gz
CGSI-gSOAP-1.3.5-1.el5.x86_64.tar.gz
CGSI-gSOAP-devel-1.3.5-1.el5.x86_64.tar.gz
lfc-1.8.3-1.el5.x86_64.tar.gz
lfc-devel-1.8.3-1.el5.x86_64.tar.gz
lfc-dli-1.8.3-1.el5.x86_64.tar.gz
lfc-libs-1.8.3-1.el5.x86_64.tar.gz
lfc-perl-1.8.3-1.el5.x86_64.tar.gz
lfc-python-1.8.3-1.el5.x86_64.tar.gz
lfc-python26-1.8.3-1.el5.x86_64.tar.gz
lfc-server-mysql-1.8.3-1.el5.x86_64.tar.gz
lfc-server-oracle-1.8.3-1.el5.x86_64.tar.gz
lfc-yaim-4.2.4-1.el5.noarch.tar.gz
lcgdm-devel-1.8.3-1.el5.x86_64.tar.gz
lcgdm-libs-1.8.3-1.el5.x86_64.tar.gz
lcgdm-oracle-debuginfo-1.8.3-1.el5.x86_64.tar.gz
lcgdm-dav-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-debuginfo-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-devel-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-libs-0.7.1-1.el5.x86_64.tar.gz
lcgdm-dav-server-0.7.1-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-common-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lcgdm-debuginfo-0.7.0-1.el5.x86_64.tar.gz
nagios-plugins-lfc-0.7.0-1.el5.x86_64.tar.gz
Sources RPM
CGSI-gSOAP-1.3.5-1.src.rpm
lcgdm-meta-1.8.3-1.src.rpm
lcgdm-oracle-1.8.3-1.src.rpm
lcgdm-dav-0.7.1-1.src.rpm
nagios-plugins-lcgdm-0.7.0-1.src.rpm
lfc-yaim-4.2.4-1.src.rpm
Sources tarball
Metapacakges
emi-lfc_mysql-1.8.3-1.el5.x86_64.rpm
emi-lfc_oracle-1.8.3-1.el5.x86_64.rpm
emi-lfc_mysql-1.8.3-1.el5.x86_64.tar.gz
emi-lfc_oracle-1.8.3-1.el5.x86_64.tar.gz

WMS v. 3.3.5, task #26837

What's new

  • This is a bug fix release meant to address two very specific issues:
    • enable wildcards in FQANs in WMproxy GACL file
    • a scalability issue that affected all the GRAM-based CEs: given that the grid_monitor process was not instantiated in the WMS, Condor felt back on non-scaling GRAM polling

Deployment Notes:

  • The same recommendations apply, as with the previous updates:
    • YAIM (re)configuration is required after installation/update. In case of co-location with the L&B, make sure that yaim is run also for the latter.
    • In case of update, before applying the update stop all the services. After the update (after yum update and after yaim configuration):
      • set the ownership of the directories /var and /var/log to root.root
      • execute the cron job /etc/cron.d/glite-wms-create-host-proxy.cron
    • In case of a clean install, after yaim configuration:
      • execute the cron job /etc/cron.d/glite-wms-create-host-proxy.cron
    • In the configuration file /etc/glite-wms/glite_wms.conf the following two parametes for the load_monitor must always have the same values, even if different from the default ones:
 
jobSubmit  = "${WMS_LOCATION_SBIN}/glite_wms_wmproxy_load_monitor --oper jobSubmit --load1 22 --load5 20 --load15 18 --memusage 99 --diskusage 95 --fdnum 1000 --jdnum 150000  --ftpconn 300";
jobRegister  =  "${WMS_LOCATION_SBIN}/glite_wms_wmproxy_load_monitor --oper jobRegister --load1 22 --load5 20 --load15 18 --memusage 99 --diskusage 95 --fdnum 1000 --jdnum 150000 --ftpconn 300";

  • The System Administrator Guide has been updated with the following information:
    • The location of the drain file has changed with respect to the gLite version
    • Configuration tips in case colocation with the LB
  • Check out the WMS admin guide for more details.

Known Issues:

  • #92742 - submission to ARC broken again

Updated Artefacts

Binary
glite-wms-wmproxy-3.3.5-1.sl5.x86_64.rpm
glite-yaim-wms-4.1.5-1.sl5.noarch.rpm
Binary tarball
glite-wms-wmproxy-3.3.5-1.sl5.x86_64.tar.gz
glite-yaim-wms-4.1.5-1.sl5.noarch.tar.gz
Sources RPM
glite-wms-wmproxy-3.3.5-1.sl5.src.rpm
glite-yaim-wms-4.1.5-1.sl5.src.rpm
Sources tarball
glite-wms-wmproxy-3.3.5.tar.gz
glite-yaim-wms-4.1.5.tar.gz

-- DoinaCristinaAiftimiei - 22-Apr-2012

Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r6 - 2012-04-23 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback