EMI 1 (Kebnekaise) - Update 3 (07.07.2011)

This Update contains the first release in EMI of StoRM, v. 1.7.0 and revision releases for L&B, v. 3.0.12, glite-proxyrenewal v. 1.3.21, glite-MPI, v. 1.0.1, UNICORE UVOS, v. 1.4.2

StoRM SE, v.1.7.0, task #18584

Release Notes and product information are available at EMI product page

L&B, v. 3.0.12, task #20814

What's new:

  • Fixes for several bugs
    • False background purge error messages
    • Problems with L&B server dump
    • Safe reaction to overly long HTTPs request headers
    • Fixed default path in glite-lb-purge.cron
  • A few more memory handling improvements

Deployment notes:

  • emi-lb metapackage is installed by yum.
  • yaim configuration requires, at the very least, setting MYSQL_PASSWORD, SITE_NAME and SITE_EMAIL in the site-info.def file.

  • Reconfiguration is required. Reconfiguration using YAIM will restart the service automatically.

Known Issues:

  • Due to faulty DNS over IPv6 resolution in the c-ares library (v. 1.6.0), L&B does not work in most scenarios involving IPv6-only machines. Upgrade c-ares to 1.7.3 and relaunch yaim to get full IPv6 functionality.
  • Background purge works and return code is handled correctly. It also results in a clean termination of a slave, though, which is currently reported by the master to syslog with priority 'Error' despite being harmless (The actual wording is 'Slave \d exited with return code 1'). This does not pose a problem, just a false alarm for a person reading the logs.

Updated Artefacts

Binary
glite-jobid-api-c-2.0.3-1.sl5.x86_64.rpm
glite-jobid-api-cpp-1.1.3-1.sl5.x86_64.rpm
glite-jobid-api-java-1.1.3-6.sl5.noarch.rpm
glite-lb-client-5.0.8-1.sl5.x86_64.rpm
glite-lb-client-java-1.1.6-1.sl5.x86_64.rpm
glite-lb-common-8.0.6-1.sl5.x86_64.rpm
glite-lb-doc-1.2.9-1.sl5.noarch.rpm
glite-lbjp-common-gsoap-plugin-3.0.2-7.sl5.x86_64.rpm
glite-lbjp-common-gss-3.0.4-1.sl5.x86_64.rpm
glite-lbjp-common-jp-interface-2.1.2-7.sl5.x86_64.rpm
glite-lbjp-common-maildir-2.1.2-7.sl5.x86_64.rpm
glite-lbjp-common-server-bones-2.1.3-1.sl5.x86_64.rpm
glite-lbjp-common-trio-2.1.2-7.sl5.x86_64.rpm
glite-lb-logger-2.2.6-1.sl5.x86_64.rpm
glite-lb-server-2.2.9-1.sl5.x86_64.rpm
glite-lb-utils-2.1.4-1.sl5.x86_64.rpm
glite-lb-yaim-4.3.9-1.sl5.noarch.rpm
Binary tarball
glite-jobid-api-c-2.0.3-1.tar.gz
glite-jobid-api-cpp-1.1.3-1.tar.gz
glite-jobid-api-java-1.1.3-6.tar.gz
glite-lb-client-5.0.8-1.tar.gz
glite-lb-client-java-1.1.6-1.tar.gz
glite-lb-common-8.0.6-1.tar.gz
glite-lb-doc-1.2.9-1.tar.gz
glite-lbjp-common-gsoap-plugin-3.0.2-7.tar.gz
glite-lbjp-common-gss-3.0.4-1.tar.gz
glite-lbjp-common-jp-interface-2.1.2-7.tar.gz
glite-lbjp-common-maildir-2.1.2-7.tar.gz
glite-lbjp-common-server-bones-2.1.3-1.tar.gz
glite-lbjp-common-trio-2.1.2-7.tar.gz
glite-lb-logger-2.2.6-1.tar.gz
glite-lb-server-2.2.9-1.tar.gz
glite-lb-utils-2.1.4-1.tar.gz
glite-lb-yaim-4.3.9-1.tar.gz
Sources RPM
glite-jobid-api-c-2.0.3-1.sl5.src.rpm
glite-jobid-api-cpp-1.1.3-1.sl5.src.rpm
glite-jobid-api-java-1.1.3-6.sl5.src.rpm
glite-lb-client-5.0.8-1.sl5.src.rpm
glite-lb-client-java-1.1.6-1.sl5.src.rpm
glite-lb-common-8.0.6-1.sl5.src.rpm
glite-lb-doc-1.2.9-1.sl5.src.rpm
glite-lbjp-common-gsoap-plugin-3.0.2-7.sl5.src.rpm
glite-lbjp-common-gss-3.0.4-1.sl5.src.rpm
glite-lbjp-common-jp-interface-2.1.2-7.sl5.src.rpm
glite-lbjp-common-maildir-2.1.2-7.sl5.src.rpm
glite-lbjp-common-server-bones-2.1.3-1.sl5.src.rpm
glite-lbjp-common-trio-2.1.2-7.sl5.src.rpm
glite-lb-logger-2.2.6-1.sl5.src.rpm
glite-lb-server-2.2.9-1.sl5.src.rpm
glite-lb-utils-2.1.4-1.sl5.src.rpm
glite-lb-yaim-4.3.9-1.sl5.src.rpm
Sources tarball
glite-jobid-api-c-2.0.3-1.src.tar.gz
glite-jobid-api-cpp-1.1.3-1.src.tar.gz
glite-jobid-api-java-1.1.3-6.src.tar.gz
glite-lb-client-5.0.8-1.src.tar.gz
glite-lb-client-java-1.1.6-1.src.tar.gz
glite-lb-common-8.0.6-1.src.tar.gz
glite-lb-doc-1.2.9-1.src.tar.gz
glite-lbjp-common-gsoap-plugin-3.0.2-7.src.tar.gz
glite-lbjp-common-gss-3.0.4-1.src.tar.gz
glite-lbjp-common-jp-interface-2.1.2-7.src.tar.gz
glite-lbjp-common-maildir-2.1.2-7.src.tar.gz
glite-lbjp-common-server-bones-2.1.3-1.src.tar.gz
glite-lbjp-common-trio-2.1.2-7.src.tar.gz
glite-lb-logger-2.2.6-1.src.tar.gz
glite-lb-server-2.2.9-1.src.tar.gz
glite-lb-utils-2.1.4-1.src.tar.gz
glite-lb-yaim-4.3.9-1.src.tar.gz

glite-proxyrenewal, v. 1.3.21, task #20914

What's new:

This is a bugfix release for the previous version of ProxyRenewal, containing the following improvements:
  • Workaround for problems with threaded globus by setting signal mask (SB #81371)
  • Preventive 'kill -9' into the startup script
  • Improved logging, more descriptive error messages
  • Corrected log levels
  • Increased backlog queue of listen(2)
  • Command identifiers added to some logs
  • Correct handling of multiple VOMS ACs (from multiple VOMS servers)

Deployment

Upon update, restart the ProxyRenewal daemon by calling /etc/init.d/glite-proxy-renewald restart

Known Issues:

None for ProxyRenewal

Updated Artefacts

Binary
glite-px-proxyrenewal-1.3.21-1.sl5.x86_64.rpm
Binary tarball
glite-px-proxyrenewal-1.3.21-1.tar.gz
Sources RPM
glite-px-proxyrenewal-1.3.21-1.sl5.src.rpm
Sources tarball
glite-px-proxyrenewal-1.3.21-1.src.tar.gz

glite-MPI, v. 1.0.1, task #20931

What's new:

  • Updated documentation for yaim configuration
  • yaim plugin does not try to create mpirun wrapper in the WN
  • yaim plugin uses current torque location (or TORQUE variable)
  • yaim plugin correctly defines the runtimeenvironment variables

Deployment notes:

No special installation requirements, no need for restarting services.

Yaim plugin available for configuration in WN and CEs.

Known Issues:

  • Fine grained process mapping is not supported with Slurm or Condor schedulers.
  • Shared filesystem detection only works in Linux.

Updated Artefacts

Metapackage
glite-mpi-1.0.1-0.sl5.noarch.rpm
glite-mpi-1.0.1-0.sl5.src.rpm
Binary
mpi-start-1.0.4-3.sl5.noarch.rpm
glite-yaim-mpi-1.1.9-1.sl5.noarch.rpm
Binary tarball
mpi-start-1.0.4-3.tar.gz
glite-yaim-mpi-1.1.9-1.tar.gz
Sources RPM
mpi-start-1.0.4-3.sl5.src.rpm
glite-yaim-mpi-1.1.9-1.sl5.src.rpm
Sources tarball
mpi-start-1.0.4-3.src.tar.gz
glite-yaim-mpi-1.1.9-1.src.tar.gz

UNICORE UVOS, v. 1.4.2, task #20815

What's new for UVOS server:

  • UVOS server was updated to use latest persistence libraries (JDBC drivers, MyBatis 3).
  • Support for MySQL database backend was added.
  • Support for attribute filtering on SAML interface is available.
  • Documentation was updated.

Installation and configuration:

  • There are no special issues regarding the fresh installation.
  • The standard yum update procedure can be taken, i.e. administrator should check if there are any .rpmnew or .rpmsave files after performing the update and merge changes according to the latest documentation. In this release such situation can happen in case of one file: uvosServer.conf.

Know issues:

NONE

Updated Artefacts

Binary
unicore-uvos-server-1.4.2-1.noarch.rpm
Binary tarball
unicore-uvos-server-1.4.2-1.tar.gz
Sources RPM
unicore-uvos-server-1.4.2-1.src.rpm
Sources tarball
unicore-uvos-server-1.4.2-1.src.tar.gz

-- DoinaCristinaAiftimiei - 07-Jul-2011

Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r3 - 2011-07-07 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback