EMI 3 (Monte Bianco) - Update 19 (07.08.2014) - v. 3.9.0-1

The Update contains:

  • minor release of CREAM GE module v. 2.3.0
  • revision releases of APEL 1.2.1-1 and APEL SSM 2.1.3, caNl v. 2.2.4, dCache server v. 2.6.31 and dCache srmclient v. 2.2.27, DPM-argus v. 1.8.8-2

APEL Parsers, v. 2.3.0 & APEL publiser 4.2.0 (APEL 1.2.1-1)

Affected services

  • affected service: CREAM

What's new:

  • Added support for version 9 LSF batch logs to LSF parser.
  • Improved input checking for SLURM and PBS parsers.
  • Improved message handling for regional servers and central APEL server.
  • When already parsed files are skipped the log message now gives a clearer reason.
  • Corrected line numbers in ‘skipping’ log messages which were 1 less than the actual value. (Also affects StopLine column of ProcessedFiles table).
  • Changed parsers to handle short FQANS properly.
  • Added a logratate script for client.log. ‘apel-client’ will be installed to the logrotate.d directory.

Installation & Configuration:

  • yum upgrade

Known Issues

  • Blah log parser chooses last role as primary when multiple FQANs listed.
  • Database unloader limited to current and previous month when unloading summaries.

Artifacts

SL5
Binaries
apel-client-1.2.1-1.el5.noarch.rpm
apel-lib-1.2.1-1.el5.noarch.rpm
apel-parsers-1.2.1-1.el5.noarch.rpm
apel-server-1.2.1-1.el5.noarch.rpm
apel-ssm-2.1.3-1.el5.noarch.rpm
Source RPM
apel-1.2.1-1.el5.src.rpm
apel-ssm-2.1.3-1.el5.src.rpm
SL6
Binaries
apel-client-1.2.1-1.el6.noarch.rpm
apel-lib-1.2.1-1.el6.noarch.rpm
apel-parsers-1.2.1-1.el6.noarch.rpm
apel-server-1.2.1-1.el6.noarch.rpm
apel-ssm-2.1.3-1.el6.noarch.rpm
Source RPM
apel-1.2.1-1.el6.src.rpm
apel-ssm-2.1.3-1.el6.src.rpm

APEL SSM v. 2.1.3

Affected services

  • affected service: CREAM

What's new:

  • The output of brokers.py has been improved so that it can be used to query the BDII for valid brokers.
  • The outgoing message directory will now be regularly cleared of empty directories, and locked messages will be unlocked after five minutes.
  • RPM now enforces the use of stomppy < 4.0.0 as versions greater than this are currently incompatible with SSM.
  • Changes made to disconnection method which should prevent threading exceptions (mostly during shutdown).
  • For more details see Extended Changelog

Installation & Configuration:

  • yum update apel-ssm

Artifacts

SL5
Binaries
apel-ssm-2.1.3-1.el5.noarch.rpm
Source RPM
apel-ssm-2.1.3-1.el5.src.rpm
SL6
Binaries
apel-ssm-2.1.3-1.el6.noarch.rpm
Source RPM
apel-ssm-2.1.3-1.el6.src.rpm

caNl,v. 2.2.4

Affected services

  • affected services: CREAM, GridSite, VOMS, WMS, WNoDeS

caNl-java, v. 1.3.3

What's new:

  • Two closely related bugfixes of OCSP handling:
    • failing OCSP responders are now cached (up to now only responses were cached)
    • the memory consumed by the in-memory cache of OCSP is now limited (was unconstrained).

Installation & Configuration:

  • yum update

List of RfC

Artifacts

SL5
x86_64 Binaries
canl-java-1.3.3-1.el5.noarch.rpm
canl-java-javadoc-1.3.3-1.el5.noarch.rpm
Source RPM
canl-java-1.3.3-1.el5.src.rpm
canl-java-javadoc-1.3.3-1.el5.src.rpm
SL6
x86_64 Binaries
canl-java-1.3.3-1.el6.noarch.rpm
canl-java-javadoc-1.3.3-1.el6.noarch.rpm
Source RPM
canl-java-1.3.3-1.el6.src.rpm
canl-java-javadoc-1.3.3-1.el6.src.rpm
Deb6 Binaries
libcanl-java-doc_1.3.3-1.deb6_all.deb
libcanl-java_1.3.3-1.deb6_all.deb
Deb6 Sources
libcanl-java-doc_1.3.3-1.deb6.debian.tar.gz
libcanl-java-doc_1.3.3-1.deb6.dsc
libcanl-java-doc_1.3.3.orig.tar.gz
libcanl-java_1.3.3-1.deb6.debian.tar.gz
libcanl-java_1.3.3-1.deb6.dsc
libcanl-java_1.3.3.orig.tar.gz

CREAM GE module, v. 2.3.0

Affected services

  • affected services: CREAM

What's new:

  • New features
    • Introduces an updated blah.config configuration for Grid Engine where GE environment variables are automatically loaded by blahd daemons.
    • Introduces a different path for the blah job registry (in compliance with blah releases for other LRMS releases).
  • Fixed Issues
    • Load of GE environment variables in blah.config: (GGUS #102418)

Instalaltion & Configuration:

  • Yaim reconfiguration is mandatory. However, before reconfiguration, the site admin has to migrate the blah job registry manually. Failure to complete this step will result in the lost of blah records for all existing jobs. Please carefully read the full procedure described at Extended Release Notes

Artifacts

SL5
Binaries
glite-yaim-ge-utils-4.5.0-3.1.noarch.rpm
Source RPM
glite-yaim-ge-utils-4.5.0-3.1.src.rpm
SL6
Binaries
glite-yaim-ge-utils-4.5.0-3.1.noarch.rpm
Source RPM
glite-yaim-ge-utils-4.5.0-3.1.src.rpm

dCache server v. 2.6.31 and dCache srmclient v. 2.2.27

Affected services

  • affected service: dCache server, UI, WN

What's new:

  • dCache server, v. 2.6.31
    • Webadmin
      • Fixes a regression that prevented the admin from deleting alerts in the alarm system.
      • Improve esthetics of the pool queue plot grid.
    • Pool
      • Fixes a problem where, under specific circumstances, a pool with a file's data will erroneously claim it does not have that file's data. This problem occurs only if an HTTP or xrootd client attempts to read a file immediately after uploading it; it does not affect other protocols. If a client triggers the problem then PnfsManager will remove the pool as the location of the file's data with two consequences: first, the file cannot be read; second, the orphaned entry will not be removed if the file is deleted. With this release, the problem is fixed; we recommend running the 'pnfs register' command on all pools as a precaution against orphaned entries.
    • Info-provider
      • Suppress publishing NFS door endpoints. Publishing these endpoints can result in sites failing functional tests since dCache running an NFS endpoint does not mean that files are accessible from the test machine.
    • For more details see dCache server 2.6.31 - Extended Release Notes
  • dCache srmclient, v. 2.2.27

Installation & Configuration

  • Please notice that due to the change to jpnfs-0.0.5, all NFS clients (v3 and v4) have to unmount prior update.
  • Please read the preliminary version of the Ultimate Golden Release Upgrade Guide carefully.
  • for the dCache srmclient an "yum update" should update to the latest version

Artifacts

SL5
Binaries
dcache-2.6.31-1.noarch.rpm
dcache-srmclient-2.2.27-1.noarch.rpm
SL6
Binaries
dcache-2.6.31-1.noarch.rpm
dcache-srmclient-2.2.27-1.noarch.rpm
Deb6 Binaries
dcache_2.6.31-1_all.deb

DPM-argus v. 1.8.8-2

Affected Services

  • affected services: DPM

What's new:

  • Little packaging fix to dpm-argus to make it work across EPEL and EMI, through different release numbers. dpm-argus now will work with any dpm-mysql-nameserver whose version is greater than 1.8.7.
  • The fix also adds to the dpm-argus package the dpns-arguspoll manpage, which was left behind by mistake in the recent release of this component.
  • For more details see Extended Release Notes

Installation & Configuration

  • yum update dpm-argus

Artifacts

SL5
Binaries
dpm-argus-1.8.8-2.el5.centos.x86_64.rpm
dpm-argus-1.8.8-2.el5.centos.i386.rpm
SL6
Binaries
dpm-argus-1.8.8-2.el6.x86_64.rpm
dpm-argus-1.8.8-2.el6.i686.rpm
Edit | Attach | Watch | Print version | History: r2 < r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r2 - 2014-08-06 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright &© 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback