EMI 3 (Monte Bianco) - Update 24 (16.02.2015) - v. 3.15.0-1

The Update contains:

  • minor releases of APEL , v. 1.4.0, UNICORE/X v. 7.2.0, UNICORE-Registry v. 7.2.0, UNICORE XUUDB v. 2.1.2, UNICORE-TSI v. 7.2.0, UNICORE Gatewat v. 7.2.0
  • revision releases of ARGUS PAP v. 1.6.2, CREAM v. 1.16.5, STORM v. 1.11.7 & 1.11.6 & 1.11.5, VOMS Admin v. 3.3.2
  • third-party packages: python-lockfile-0.8-3.el5, python-reportlab-2.5-3.el5, SOAPpy-0.11.6-13.el5

APEL Parsers, v. 2.5.0 & APEL Publisher 4.4.0 (APEL 1.4.0-1)

Affected services

  • affected service: CREAM

What's new:

  • Added ability to process files compressed with bzip2.
  • Added multiplier retrieval to GridEngine parser for CPU and wall-clock time.
  • Fixed integer overflow when loading normalised summaries into APEL servers.
  • Corrected the way some logging calls were made and reduced the logging level when trying to purge a directory that isn't empty.
  • Changed server authorization system to keep the list of DNs for a limited time if unable to update from GOCDB and updated GOCDB query URL.
  • Added Month and Year columns to primary key of CloudSummaries table in cloud schema.

Installation & Configuration:

* Regional servers should read the upgrade documentation below and open a GGUS ticket if they require assistance - https://github.com/apel/apel/blob/dev/server_upgrade.md
  • Clients can use their normal update procedure for the packages they use, i.e. yum update

Known Issues

  • Parser not yet compatible with new version of Univa Grid Engine (version 8.2.0) which now reports time in milliseconds instead of seconds.

Artifacts

SL5
Binaries
apel-client-1.4.0-1.el5.noarch.rpm
apel-lib-1.4.0-1.el5.noarch.rpm
apel-parsers-1.4.0-1.el5.noarch.rpm
apel-server-1.4.0-1.el5.noarch.rpm
Source RPM
apel-1.4.0-1.el5.src.rpm
SL6
Binaries
apel-client-1.4.0-1.el6.noarch.rpm
apel-lib-1.4.0-1.el6.noarch.rpm
apel-parsers-1.4.0-1.el6.noarch.rpm
apel-server-1.4.0-1.el6.noarch.rpm
Source RPM
apel-1.4.0-1.el6.src.rpm

ARGUS PAP, v. 1.6.4

Affected services

  • affected service: ARGUS

What's new:

Installation & Configuration:

  • Please run:
      # yum update argus-pap
      # service argus-pap restart
      

Artifacts

SL5
Binaries
argus-pap-1.6.2-1.noarch.rpm
Source RPM
argus-pap-1.6.2-1.src.rpm
SL6
Binaries
argus-pap-1.6.2-1.el6.noarch.rpm
Source RPM
argus-pap-1.6.2-1.el6.src.rpm
Deb6
Binaries
argus-pap_1.6.2-1_all.deb
Sources
argus-pap_1.6.2-1.debian.tar.gz
argus-pap_1.6.2-1_all.deb
argus-pap_1.6.2.orig.tar.gz

CREAM, v.1.16.5

Affected services

  • affected services: CREAM

What's new:

  • Fixed the following bugs:
    • CREAM-106 - YAIM restructuring
    • CREAM-163 - Support for mysql5.5 on SL5
    • CREAM-167 - Tracking robot certificate bearer for accounting
    • CREAM-171 - Re-introduce static ldif file path in scheduler.conf
    • CREAM-172 - maxOutputSandboxSize attribute parsing error: real in string context

  • On Scientific Linux 5 the following metapackages have been added, They can be used for installing the version 5.1 and 5.5 of mysql respectively
    • emi-cream-ce-mysql51
    • emi-cream-ce-mysql55
  • A metapackage, emi-cream-ce-no-mysql, with no dependency from mysql is available.
  • The different metapackages for emi-cream-ce conflict with each other. If an existing installation needs to move from a version of mysql into another it is necessary to manually remove the old rpm for the metapackage and install the new one corresponding to the new version of mysql.

  • In the section "Main" of the configuration file /etc/lrms/scheduler.conf it is possible to define the following variables:
    • static_ldif_file: custom location of the GLUE1 CE ldif template
    • static_glue2_ldif_file_computingshare: custom location of the GLUE2 Computing Share ldif template
  • if they're not defined the locations for each template are calculated according to the BDII configuration file.

  • The YAIM variable CREAM_CE_STATE is no more used to define the value of GLUE2ComputingShareServingState and GlueCEStateStatus. It is used to defined the attribute GLUE2ServiceQualityLevel.

Installation & Configuration:

  • Running the YAIM configurator is NOT required, CREAM service restart is necessary.

Artifacts

SL5
Binaries
dynsched-generic-2.5.5-1.el5.noarch.rpm
emi-cream-ce-1.2.4-1.el5.noarch.rpm
emi-cream-ce-mysql51-1.2.4-1.el5.noarch.rpm
emi-cream-ce-mysql55-1.2.4-1.el5.noarch.rpm
emi-cream-ce-no-mysql-1.2.4-1.el5.noarch.rpm
glite-ce-common-java-1.16.4-1.el5.noarch.rpm
glite-ce-common-java-doc-1.16.4-1.el5.noarch.rpm
glite-ce-cream-api-java-1.16.5-2.el5.noarch.rpm
glite-ce-cream-utils-1.3.5-1.el5.x86_64.rpm
glite-ce-yaim-cream-ce-4.4.6-2.el5.noarch.rpm
Source RPM
dynsched-generic-2.5.5-1.el5.src.rpm
emi-cream-ce-no-mysql-1.2.4-1.el5.src.rpm
glite-ce-common-java-1.16.4-1.el5.src.rpm
glite-ce-cream-api-java-1.16.5-2.el5.src.rpm
glite-ce-cream-utils-1.3.5-1.el5.src.rpm
glite-ce-yaim-cream-ce-4.4.6-2.el5.src.rpm
SL6
Binaries
emi-cream-ce-1.2.4-1.el6.noarch.rpm
emi-cream-ce-no-mysql-1.2.4-1.el6.noarch.rpm
emi-version-3.15.0-1.el6.x86_64.rpm
glite-ce-common-java-1.16.4-1.el6.noarch.rpm
glite-ce-common-java-doc-1.16.4-1.el6.noarch.rpm
glite-ce-cream-api-java-1.16.5-1.el6.noarch.rpm
glite-ce-cream-utils-1.3.5-1.el6.x86_64.rpm
glite-ce-yaim-cream-ce-4.4.6-2.el6.noarch.rpm
Source RPM
dynsched-generic-2.5.5-1.el6.src.rpm
emi-cream-ce-no-mysql-1.2.4-1.el6.src.rpm
emi-version-3.15.0-1.el6.src.rpm
glite-ce-common-java-1.16.4-1.el6.src.rpm
glite-ce-cream-api-java-1.16.5-1.el6.src.rpm
glite-ce-cream-utils-1.3.5-1.el6.src.rpm
glite-ce-yaim-cream-ce-4.4.6-2.el6.src.rpm

STORM, v. 1.11.7

Affected services

  • affected services: STORM

What's new:

Installation and configuration

Artifacts

SL5
Binaries
storm-backend-server-1.11.7-1.sl5.noarch.rpm
storm-dynamic-info-provider-1.7.7-1.el5.noarch.rpm
storm-frontend-server-1.8.7-1.x86_64.rpm
storm-frontend-server-debuginfo-1.8.7-1.x86_64.rpm
storm-globus-gridftp-server-1.2.0-5.x86_64.rpm
storm-gridhttps-server-3.0.3-1.el5.noarch.rpm
storm-native-libs-1.0.3-1.x86_64.rpm
storm-native-libs-debuginfo-1.0.3-1.x86_64.rpm
storm-native-libs-gpfs-1.0.3-1.x86_64.rpm
storm-native-libs-java-1.0.3-1.x86_64.rpm
storm-native-libs-lcmaps-1.0.3-1.x86_64.rpm
storm-srm-client-1.6.1-1.x86_64.rpm
yaim-storm-4.3.7-1.el5.noarch.rpm
Source RPMS
storm-backend-server-1.11.7-1.sl5.src.rpm
storm-dynamic-info-provider-1.7.7-1.el5.src.rpm
storm-frontend-server-1.8.7-1.src.rpm
storm-globus-gridftp-server-1.2.0-5.src.rpm
storm-gridhttps-server-3.0.3-1.el5.src.rpm
storm-native-libs-1.0.3-1.src.rpm
storm-srm-client-1.6.1-1.src.rpm
yaim-storm-4.3.7-1.src.rpm
SL6
Binaries
storm-backend-server-1.11.7-1.el6.noarch.rpm
storm-dynamic-info-provider-1.7.7-1.el6.noarch.rpm
storm-frontend-server-1.8.7-1.el6.x86_64.rpm
storm-frontend-server-debuginfo-1.8.7-1.el6.x86_64.rpm
storm-globus-gridftp-server-1.2.0-5.el6.x86_64.rpm
storm-gridhttps-server-3.0.3-1.el6.noarch.rpm
storm-native-libs-1.0.3-1.el6.x86_64.rpm
storm-native-libs-debuginfo-1.0.3-1.el6.x86_64.rpm
storm-native-libs-gpfs-1.0.3-1.el6.x86_64.rpm
storm-native-libs-java-1.0.3-1.el6.x86_64.rpm
storm-native-libs-lcmaps-1.0.3-1.el6.x86_64.rpm
storm-srm-client-1.6.1-1.el6.x86_64.rpm
storm-webdav-1.0.2-1.el6.noarch.rpm
yaim-storm-4.3.7-1.el6.noarch.rpm
Source RPMS
storm-backend-server-1.11.7-1.el6.src.rpm
storm-dynamic-info-provider-1.7.7-1.el6.src.rpm
storm-frontend-server-1.8.7-1.el6.src.rpm
storm-globus-gridftp-server-1.2.0-5.el6.src.rpm
storm-gridhttps-server-3.0.3-1.el6.src.rpm
storm-native-libs-1.0.3-1.el6.src.rpm
storm-srm-client-1.6.1-1.el6.src.rpm
storm-webdav-1.0.2-1.el6.src.rpm
yaim-storm-4.3.7-1.el6.src.rpm

UNICORE v. 7.2.0

Affected services

  • affected services: UNICORE

What's new:

  • UNICORE-Gateway v. 7.2.0:
    • fix: message charset was always ISO-8859-1, and UFT-8 characters were not properly transmitted (SF bug # 770)
    • initial support for multipart POST messages (but SOAP part must be first) (SF feature #292)
    • More details in the Extended Release Notes & Documentation
  • UNICORE Registry v. 7.2.0:
  • UNICORE TSI v. 7.2.0, versions for SL6 and Deb 6:
    • fixes
      • newline characters in filenames break listDirectory (SF #769)
      • Slurm: remove extra "\n" when setting account
      • cleanup SSL code, make it more portable with respect to IPv6/IPv4. Use separate key and certificate files.
      • in non-SSL mode, configuring the tsi.njsport is mandatory
    • updated docs on configuring SSL
    • added section on securing/hardening the TSI to the manual
    • More details in the Extended Release Notes & Documentation
  • UNICORE/X v. 7.2.0:
    • new features:
      • support Unity with OIDC (SF feature #344)
      • support S3 as backend storage (SF feature #342)
    • fixes:
      • data triggering could miss some files
      • file existence check (to compensate for slow filesystems) did not work (SF bug #762)
      • REST authentication: only first authentication option was used, SAML AuthN was buggy
    • More details in the Extended Release Notes & Documentation
  • UNICORE XUUDB v. 2.1.2:

Artifacts

SL6
Binaries
unicore-gateway-7.2.0-2.noarch.rpm
unicore-registry-7.2.0-1.noarch.rpm
unicore-tsi-lsf-7.2.0-1.noarch.rpm
unicore-tsi-nobatch-7.2.0-1.noarch.rpm
unicore-tsi-sge-7.2.0-1.noarch.rpm
unicore-tsi-slurm-7.2.0-1.noarch.rpm
unicore-tsi-torque-7.2.0-1.noarch.rpm
unicore-unicorex-7.2.0-2.noarch.rpm
unicore-xuudb-2.1.2-2.noarch.rpm
Deb6
Binaries
unicore-gateway_7.2.0-2_all.deb
unicore-registry_7.2.0-1_all.deb
unicore-tsi-lsf_7.2.0-1_all.deb
unicore-tsi-nobatch_7.2.0-1_all.deb
unicore-tsi-sge_7.2.0-1_all.deb
unicore-tsi-slurm_7.2.0-1_all.deb
unicore-tsi-torque_7.2.0-1_all.deb
unicore-unicorex_7.2.0-2_all.deb
unicore-xuudb_2.1.2-2_all.deb

VOMS-admin server, v. 3.3.2

Affected services

  • affected services: VOMS server

What's new:

  • VOMS-Admin server 3.3.2 provides fixes for:
    • fixes for the CERN OrgDB integration code
    • a new configuration option to skip checks on the certificate issuer during authentication.
  • More details in the VOMS-admin server 3.3.2 - Extended release notes.

Installation & Configuration:

  • VOMS-admin:
    • Clean install
    • Upgrade from v. 3.2.0
      • The upgrade requires a service restart. After the packages have been updated, run the following commands:
        service voms-admin stop
        service voms-admin undeploy
        service voms-admin start
    • Upgrade from earlier VOMS Admin versions
      • Upgrading to this version requires an upgrade of the database and a reconfiguration depending on the version of VOMS admin which is being upgraded. Follow the instructions in the VOMS System Administrator Guide.

Artifacts

SL5
Binaries
voms-admin-server-3.3.2-1.noarch.rpm
Sources
voms-admin-server-3.3.2-1.src.rpm
SL6
Binaries
voms-admin-server-3.3.2-1.el6.noarch.rpm
Sources
voms-admin-server-3.3.2-1.el6.src.rpm

Third-Party packages

What's new:

  • The EMI third-party repositories contain now the latest versions of python-lockfile-0.8-3.el5, python-reportlab-2.5-3.el5, SOAPpy-0.11.6-13.el5, that were removed from EPEL 5 repositories

Artifacts

SL5
Binaries
SOAPpy-0.11.6-13.el5.noarch.rpm
python-lockfile-0.8-3.el5.noarch.rpm
python-reportlab-2.5-3.el5.x86_64.rpm
Edit | Attach | Watch | Print version | History: r4 < r3 < r2 < r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r4 - 2015-02-16 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback