EMI Updates status at EGI-GridOperationMeeting

EMI 1 Updates status

Status - 12.10.2011

  • Previous update - Update 7 – 22.09.2011
    • minor releases:
      • ARGUS, v. 1.4.0
        • implement memory limit & change default logging configuration
        • fix TERENA certificate problem (repackaged)
        • fix PEPd - doesn't update link timestamp in gridmapdir
      • UNICORE TSI , v. 6.4.1
        • tsi_ls is returning more information on files: owner, owning group, full UNIX permissions
        • new module ACL.pm for getting/setting filesystem ACL
        • updated the manual
      • UNICORE/X, v. 6.4.1
        • ACL support on Linux (provided the file system supports it)
    • revision releases:
      • CEMon, v. 1.13.2
        • fix CEMon consumer (OSG) & Glue2 publication (yaim)
      • gLExec-wn, v. 1.0.1
        • configuration fix (yaim) & LCMAPS plugins verify-proxy (GGUS #67040)
      • UNICORE client, v. 6.4.1
        • missing filetransfer parameters (e.g. client host for UFTP) are automatically set
        • the "append" option (-a) is now also available for "get-file"
  • Next Update - Update 8 (13.10.2011)
    • minor releases:
      • ARC Core v.1.1.0
        • Nagios probes
        • Information system manual/guide
      • ARC CE v.1.1.0
        • publish version information for ARC CE
        • SRM transfer protocols are hard-coded
        • ARC incompatible with CERN voms server
        • EMI1 ARC CE 1.0.0 wrong user mapping (GGUS-Ticket-ID: #72340)
      • ARC Clients v.1.1.0
        • improving ngclean and arcclean error messages
        • bug fixes:
          • arctest does not set a queue in job description
          • arc1 client rejects submission of jobs with RTEs of same name but different versions
          • segmentation fault when looping a mapped std::list public member from Python
      • ARC gridftp server v.1.1.0
        • Downloaders take too long when files are not available
        • provide out-of-box configuration examples for server-side ARC (CE, EGIIS and SE)
      • ARC Infosys v.1.1.0
        • totalcpus in [queue/*] section is ignored
        • the client doesn't see the status of the job if hostname contains uppercase letters
        • infosys non-responsive on high-load
      • glite-MPI, v. 1.1.0
        • support for processor and memory affinity in MPI-Start
        • Allow definition of no. of processes per core, socket or host (MPI-START)
    • revision releases:
      • APEL parsers, v.1.0.1
        • Bug fixes for SGE and LSF parsers
      • dCache, v. 1.9.12-10
        • fixed bugs in the pool, poolmanager, spacemanager and tansfermanager services
  • Upcoming releases
    • major releases:
      • CREAM SGE module v. 1.0.0
        • Support of "Open Grid Scheduler" implementation of SGE
      • HYDRA v. 1.0.1
    • minor releases:
      • DPM & LFC v. 1.8.2
        • support for Catalog Synchronization (SEmsg)
        • improved scalability of all frontend daemons
        • faster DPM drain & better balancing of data among disk nodes
        • log to syslog & GLUE2 support
      • L&B, v. 3.1.0
        • Nagios probes & bug fixes
      • StoRM SE, v. 1.7.2
        • configuration improvements (new yaim vars & function)
        • provide source rpms
        • Bug fixes:
          • Correction of Glue 2 and dynamic information publication
          • Memory leak on BackEnd REST service calls
    • revision releases:
      • BLAH, v. 1.16.3
        • improve support for SGE
        • fixes problems related to the growth of the blah registry and Bupdater & BUpdaterPBS issues
      • GFAL/lcg_util v.1.11.19 fixes
        • is-interface - memory corruption & consolidate file names & wrong dependency on Globus
        • gSOAP generates too much log files
        • lcg-cr & lcg-cp with list of bdii’s issue
      • WMS v. 3.3.4 fixes
        • ICE doesn't send the iceId to CREAM
        • WMS stops accepting jobs after 31999th submission for the same
        • DN (on ext3) –workaround is to use ext4
        • WMS 'hangs' after several hours of operation
        • Configuration issues (yaim) - wrong permissions, Glue2 template

Status - 24.10.2011

  • Next Update - Update 9 (03.11.2011) now start Verification step:
    • minor releases:
      • L&B, v. 3.1.0
        • Nagios probes
      • StoRM SE, v. 1.7.2
        • new component, storm-xmlrpc-c, that is a repackage of XMLRPC-C package version 1.25.10 - runtime dependency of the StoRM FE.
        • configuration improvements (new yaim vars & function)
        • provide source rpms
        • Bug fixes:
          • Correction of Glue 2 and dynamic information publication
          • Memory leak on BackEnd REST service calls - StoRM FE
  • Upcoming releases
    • major releases:
      • CREAM SGE module v. 1.0.0
        • Support of "Open Grid Scheduler" implementation of SGE
      • HYDRA v. 1.0.1
    • minor releases:
      • DPM & LFC v. 1.8.2
        • support for Catalog Synchronization (SEmsg)
        • improved scalability of all frontend daemons
        • faster DPM drain & better balancing of data among disk nodes
        • log to syslog & GLUE2 support
    • revision releases:
      • BLAH, v. 1.16.3
        • improve support for SGE
        • fixes problems related to the growth of the blah registry and Bupdater & BUpdaterPBS issues
      • GFAL/lcg_util v.1.11.19 fixes
        • is-interface - memory corruption & consolidate file names & wrong dependency on Globus
        • gSOAP generates too much log files
        • lcg-cr & lcg-cp with list of bdii’s issue
      • WMS v. 3.3.4 fixes
        • ICE doesn't send the iceId to CREAM
        • WMS stops accepting jobs after 31999th submission for the same
        • DN (on ext3) –workaround is to use ext4
        • WMS 'hangs' after several hours of operation
        • Configuration issues (yaim) - wrong permissions, Glue2 template

Status - 07.11.2011

  • Previous update - Update 9 – 03.11.2011
  • Next Update - Update 10 (14.11.2011 - 24.11.2011)
  • Upcoming releases:
    • APEL publisher v. 3.2.8 - Emergency update
    • see above ones
    • UNICORE UVOS v. 1.5.0
      • New features:
        • UVOS server has now a GLUE 2 WS endpoint, which can be queried to get information about the server. Currently only minimal information is made available, including the server version. In uvos-clc a new operation was added (getServerInfo) which can be used to query the server.
        • For UVOS client and server web modules src.rpms are available.
      • Bug fixes:
        • bug with wrong ping query. This occurred with MySQL DB in log files
        • several bugs in the initdb script

Status - 21.11.2011

Current Update - Update 10 (14.11.2011 - 24.11.2011):
Product Version Release Type Changelog
APEL publisher 3.2.8 revision fix for a security vulerability
CREAM 1.13.3 revision - Sometimes CREAM does not update the state of a failed job
- Make JobDBAdminPurger script compliant with CREAM EMI environment
- JobDBAdminPurger cannot purge jobs if configured sandbox dir has changed
- config_cream_sudoers creates wrong sudoers file when the same gid is shared
- yaim-cream-ce: GlueForeignKey: GlueCEUniqueID: published using : instead of=
- No info published by the lcg-info-dynamic-scheduler for one VOView
CREAM (S)GE module 1.0.0 major first release in EMI
BLAH 1.16.3 revision - improved support for SGE (F)
- BUpdater has now an option to use cached batch system commands (F)
- blahp.log records should always contain CREAM job ID (F)
- problems related to the growth of the blah registry
- blah is slow in processing files in the registry.npudir directory
- BLAH job registry permissions fixed
- missing 'Iwd' Attribute when trasferring files with the 'TransferInput' attribute causes thread to loop
- problem in updater with very short jobs that can cause no notification to cream
- incorrect special character handling for BLAH Arguments and Environment attributes
- BUpdaterPBS seems to ignore tracejob_logs_to_read variable
- parsing error in BUpdaterPBS leads to segfault
- due to a syntax error hung child processes cannot be killed
- BLParserLSF segfault if log list is too long
DPM & LFC 1.8.2 miinor support for Catalog Synchronization (SEmsg) (F)
- improved scalability of all frontend daemons (F)
- faster DPM drain & better balancing of data among disk nodes
- log to syslog & GLUE2 support (F)
GFAL/lcg_util 1..11.19 revision is-interface - memory corruption & consolidate file names & wrong dependency on Globus
- gSOAP generates too much log files
- lcg-cr & lcg-cp with list of bdii’s issue
UNICORE UVOS 1.5.0 minor UVOS server has now a GLUE 2 WS endpoint, which can be queried to get information about the server. Currently only minimal information is made available, including the server version. In uvos-clc a new operation was added (getServerInfo) which can be used to query the server. (F)
- For UVOS client and server web modules src.rpms are available. (F)
- bug with wrong ping query. This occurred with MySQL DB in log files
- several bugs in the initdb script

Upcoming updates - tentatively 15th Dic. 2011 (Update 11):

Product Version Release Type Changelog
Hydra 1.0.0 major first release in EMI
UNICORE Gateway6 4.2.0 minor - source rpms
- improvements in Gateway logging (F)
- make the maximum SOAP header size configurable (F)
- Timeout when trying to access non-existing service
UNICORE XUUDB 1.3.2-3 repackaged - source rpms
- typo in packaging configuration, which included a wrong default logging configuration file
WMS 3.3.4 revision - ICE doesn't send the iceId to CREAM
- WMS stops accepting jobs after 31999th submission for the same DN (on ext3) – workaround is to use ext4
- WMS cannot submit to ARC CEs
- WMS 'hangs' after several hours of operation
- Configuration issues (yaim) - wrong permissions, Glue2 template
- Ice configuration section doesn't use environment variable
- Wrong replan token
- WM creates submit requests with old sequence code upon a replan
- CA certificate verification failed
- WMS: LCMAPS should log on file only and not on syslog

Status - 12.12.2011

Current Update - Update 11 (05.12.2011 - 15.12.2011):

Product Version Release Type Changelog
gLite MPI 1.2.0 minor - Affinity support in mpich2 with hydra
- several configuration directories/files for mpi-start
- NFS4 is not detected as shared fs
- Cleanup not invoked with cptoshared method
- mpiexec detection needs to be done earlier
- mpich2 startup ignores MPI_MPICH2_MPIEXEC_PARAMS
- readlink -f is not portable (used in cptoshared filedist)
StoRM SE 1.8.1 - source rpms
- StoRM BackEnd memory consumption grows indefinitely
- GridHTTPs components binary rpm names are not compliant with EMI guidelines
- StoRM backend stop command fails il a zombie backend process exists
- Execution of mmlsquota is slow in comparison to the performance by the command line
- srmGetSpaceMetadata fails if user proxy has not voms extensions
- StoRM backend does not update correctly storage space data upon namespace.xml updates
- BackEnd service name (in service status)
- StoRM BE info service fails when non mandatory parameters are missing
- Smart mmlsquota execution
- GridHTTPS - service initialization can fail due to a deadlock
- StoRM-GridHTTPS-Plugin - uses a beta version of maven-assembly-plugin
UNICORE Gateway6 4.2.0 minor - source rpms
- improvements in Gateway logging (F)
- make the maximum SOAP header size configurable (F)
- Timeout when trying to access non-existing service
UNICORE XUUDB 1.3.2-3 repackaged - source rpms
- typo in packaging configuration, which included a wrong default logging configuration file
WMS 3.3.4 revision - tested by Beta-Testers, GGUS tkt #76724
- ICE doesn't send the iceId to CREAM
- WMS stops accepting jobs after 31999th submission for the same DN (on ext3) – workaround is to use ext4
- WMS cannot submit to ARC CEs
- WMS 'hangs' after several hours of operation
- Configuration issues (yaim) - wrong permissions, Glue2 template
- Ice configuration section doesn't use environment variable
- Wrong replan token
- WM creates submit requests with old sequence code upon a replan
- CA certificate verification failed
- WMS: LCMAPS should log on file only and not on syslog

Upcoming updates - tentatively 19th Jan. 2012 (Update 12):

Product Version Release Type Changelog
Hydra 1.0.0 major first release in EMI
dCache 1.19.12-13 minor see savannah #24851 for details
UNICORE Client6 4.2.0 minor - UCC/BES: Display BESFactory existence via ucc system-info
- Command line options for alternative uftp networks
- Better upload semantics with UCC: target directories
- Make the UCC support directory transfers
- missing error reporting in copy-file
- other names for stderr/stdout not used locally
UNICORE Registry6 4.2.0 minor - source rpms
UNICORE TSI6 4.2.0 minor - server support for "project" tag for accounting purposes
- provide support for umask-like feature
UNICORE/X6 4.2.0 minor - source rpms
- scp support for data staging
- publishing information about jobs per queue
- server support for "project" tag for accounting purpose
- support for umask-like feature

IMPORTANT NEWS

Status - 13.02.2012

Current Update - Update 13 (06.02.2012 - 16.02.2012):

Product Version Release Type Changelog
BDII core 1.2.0 minor - security vulnerability fix
- ARGUS service-provider
- Configuration change – caching is enabled by default on the top-level BDII
BDII site 1.1.0 minor - enable OpenLDAP 2.4 use for BDII site
FTS 2.2.8 minor - nagios probes for FTS
- support FTS monitoring messages
- change FTS file overwrite logic
- support for gridftp endpoints
- Oracle 11g integration
StoRM 1.8.2 revision - Fixes for bugs affecting BE, FE, YAIM
- Authorization failures on SAs on certain conditions
- StoRM ignores database password as configured by YAIM

Upcoming updates - tentatively 15th Mar. 2012 (Update 14):

Product Version Release Type Changelog
Hydra 1.0.0 major first release in EMI
GFAL/lcg_util 1.12.0 minor - Glue 2.0 support in gLite data clients
- Return estimatedWaitTime for files in an asyncrhonous SRM request in Python
- Support querying and updating CGSI-plugin options
- checksum is case sensitive in lcg-get-checksum/lcg-rep
- is-interface, thread-safety problem
- fixes in CGSI-Gsoap
- lcg-rep segmentation fault with dcache endpoints

Status - 27.02.2012

Next Update - Update 14 (05.03.2012 - 15.03.2012 ):

Upcoming updates - tentatively 15th Mar. 2012 (Update 14):

Product Version Release Type Changelog
BDII core 1.3.0 minor - reduced disk and memory footprint
- database file are now in /var/lib rather than /var/run
- bdii update process now correctly handles base64 values
- metapackage for the resource information service (ERIS)
DPM/LFC 1.8.3 minor - thread safe client authz mechanism setting (was environment variable)
- EPEL compliant packaging and source rpms
- LFC load balacing
- support for synchronous dpm_get operation
- srmv1 disabled by default
- provide a sample (optimized) my.cnf & a default request cleanup value in shift.conf
- new http/dav frontend in read only mode
- publish version and distribution version along with glue
- improve logging of missed mappings
- support for MySQL 5.5 in database creation script
- yaim should not (re)set tcp/ip config parameters
- mutual trust between dpm disk nodes
- removed limitation on database password length
- DPM-gridftp problems with Globus 5.2
Hydra 1.0.0 major first release in EMI
GFAL/lcg_util 1.12.0 minor - Glue 2.0 support in gLite data clients
- Return estimatedWaitTime for files in an asyncrhonous SRM request in Python
- Support querying and updating CGSI-plugin options
- checksum is case sensitive in lcg-get-checksum/lcg-rep
- is-interface, thread-safety problem
- fixes in CGSI-Gsoap
- lcg-rep segmentation fault with dcache endpoints
StoRM 1.8.2-2 repackage - StoRM-GridFTP-Server component of the StoRM SE against the new Globus 5.2 libraries
VOMS 2.0.7 revision - fixing - AC query fails when more than two fqans are explicitly requested (proxy renewal issuses on WMS)

Status - 12.03.2012

Current Update - Update 14 (05.03.2012 - 15.03.2012):

Product Version Release Type Changelog
BDII core 1.3.0 minor - reduced disk and memory footprint
- database file are now in /var/lib rather than /var/run
- bdii update process now correctly handles base64 values
- metapackage for the resource information service (ERIS)
Gridsite 1.7.19 revision - fixing "VOMS role missing in latest delegation"
VOMS 2.0.7 revision - fixing - AC query fails when more than two fqans are explicitly requested (proxy renewal issuses on WMS)

Upcoming updates - tentatively 12th Apr. 2012 (Update 15):

Product Version Release Type Changelog
BLAH 1.16.5 revision - fixing registry corruption caused sometimes by the purge of registry
- BUpdaterLSF should use bjobs to detect final job state
DPM/LFC 1.8.3 minor - thread safe client authz mechanism setting (was environment variable)
- EPEL compliant packaging and source rpms
- LFC load balacing
- support for synchronous dpm_get operation
- srmv1 disabled by default
- provide a sample (optimized) my.cnf & a default request cleanup value in shift.conf
- new http/dav frontend in read only mode
- publish version and distribution version along with glue
- improve logging of missed mappings
- support for MySQL 5.5 in database creation script
- yaim should not (re)set tcp/ip config parameters
- mutual trust between dpm disk nodes
- removed limitation on database password length
- DPM-gridftp problems with Globus 5.2
Hydra 1.0.0 major first release in EMI
GFAL/lcg_util 1.12.0 minor - Glue 2.0 support in gLite data clients
- Return estimatedWaitTime for files in an asyncrhonous SRM request in Python
- Support querying and updating CGSI-plugin options
- checksum is case sensitive in lcg-get-checksum/lcg-rep
- is-interface, thread-safety problem
- fixes in CGSI-Gsoap
- lcg-rep segmentation fault with dcache endpoints
StoRM 1.8.2-2 repackage - StoRM-GridFTP-Server component of the StoRM SE against the new Globus 5.2 libraries
WMS 3.3.5 revision - fixing "EMI WMS doesn't use grid_monitor"
- fixing "WMproxy GACLs do not support wildcards (as they used to do)"

Status - 01.06.2012

Next Update - Update 16 (04.06.2012 - 14.06.2012):

Product Version Release Type Changelog
VOMS Oracle plugin 3.1.15 revision fixes crashes of the middleman process under some load
VOMS admin 2.7.0 minor fixes:
- a bug preventing the correct sending of warning emails to the VO managers before the users membership expiration date
adding new features to ease membership management like:
- New views to easily access expired and suspended users
- Now VOMS Admin allows for a configurable grace period before suspending expired users.
- It is now possible to disable the automatic suspension of expired users.
- It is now possible to restore multiple user membership with a single click of the mouse.
- Sign AUP warning message text has been expanded to better explain that users can restore their membership anytime by signing the AUP and no VO administrator intervention is required
- The default Sign AUP grace period has been extended from one day to 7 days
WMS 3.3.6 revision - fixing:
- submission to ARC broken again
- Condor gridmanager keeps crashing on wrong assertions about some ldap attributes ordering
- EMI-1 WMS does not propagate user job exit code
- some sensible information should be logged on syslog

EMI 1 & EMI 2 Updates status

Status - 01.06.2012

  • Backward incompatible:
    • ARC CE:
      • Compatibility of ARC WS endpoints with older ARC 11.05 clients that relied on incomplete GLUE2 to communicate to pre-production WS endpoints are broken due to the more compliant GLUE2 LDAP and XML rendering introduced in this release. Upgrade to new ARC 12.05 Clients is highly recommended.
      • No backward incompatibility is introduced w.r.t. the production gridftp interface.
    • ARC Clients:
      • Compute client library is completely rewritten, making client API backward incompatible. This requires re-writing all 3rd party tools based on the library. See Extended Release Notes for details.
      • Note that older ARC clients from ARC 11.05 are not forward compatible with newer ARC 12.05 WS endpoints that use more complete GLUE2 information schema, thus an upgrade to new clients is highly recommended.
    • ARC InfoSYS:
      • Note that the completed GLUE2 implementation breaks backwards compatibility with ARC 11.05 clients that relied on an incomplete implementation to interact with pre-production WS interfaces.
    • EMi-UI
      • dcap & srm-client:
        • The dCache client files of dCap and srmclient now all reside in FHS compliant locations. There is no migration script for switching form one version to another. An update deprecates the old tunnel packages and updates the old dCap package
      • WMS client:
        • removed option --default-jdl from the glite-wms-job-list-match command
        • removed the --output option from the glite-wms-job-output command

Status - 18.06.2012

  • EMI products planned updates
    • Minor updates: - EMI 2
      • DPM/LFC v. 1.8.4:
      • GFAL/lcg_util, v. 1.13.0
      • StoRM SE v. 1.10.0
    • Revision updates: EMI 1 & EMI 2
      • BDII top v. 1.0.2
      • BLAH, v. 1.16.6/1.18.1
      • WNoDeS v. 2.0.1
      • StoRM SE v. 1.8.3 (EMI 1)
    • Repackage updates:
      • GFAL/lcg_util v. 1.12.0 - EMI 1/SL5/i386
      • EMI UI v. 2.0.0-2 - EMI 2

Status - 16.07.2012

  • to be released on 19.07.2012: - EMI products updates ready
    • EMI 1: BDII top, BLAH; gLite-gsoap/gss
    • EMI 2: BDII top, BLAH; gLite-gsoap/gss, StoRM, WNoDES

Status - 30.07.2012

  • to be released on 09.08.2012
    • EMI 1
      • BDII core v. 1.4.0 - affects all services
        • A new cron job is run every hour to execute the glue-validator script and validate the information published by the BDII against glue 1.3 and glue 2.0 schema.
        • IPv6 support included with the new yaim variable BDII_IPV6_SUPPORT, which is set to "no" by default. If set to "yes", it enables both IPv4 and IPv6 support.
        • Fixed GLUE 2 bugs in the service information provider affecting VOMS and MyProxy, and improved the README files.
        • glite-yaim-bdii cleaning removing old variables and functions. Fixed minor errors printed at configuration time (this affected only the top level BDII).
        • emi-resource-information-service metapackage now depends on glite-yaim-bdii and glue-validaror-cron.
        • Improved description and summary of glue-validator rpm.
        • Fixed the version of glue-validator distributed in EMI 1, which was broken.
      • CREAM v. 1.13.4
        • GGUS #82670, 95480 - CREAM doesn't transfert the output files remotely under well known conditions
      • WMS v. 3.3.5-2 - important issue in WMS ICE
    • EMI 2
      • BDII core v. 1.4.0 - affects all services
      • Trustmanager v. 3.1.4 - affects ARGUS, CREAM, L&B, StoRM, Pseudonymity, UI
        • Trustmanager fails to read private keys that have text before the private key data
        • KnownIssue:
          • Openssl 1.0 uses for encrypted private keys pkcs8 format. support for it is only present in bouncycastle 1.46 and above, but SL5 uses bouncycastle 1.45. Thus, generating an encrypted private key in SL6 machine and using it in SL5 may fail. This is not a real problem in normal use:
            • servers use unencrypted private keys
            • users use proxies, that have unencrypted private keys
            • not aware of any clients that use trustmanager and support encrypted private keys.

Status - 10.09.2012

  • to be released on 20.09.2012
    • EMI 1
      • ARC gridftp server v.1.1.1
      • ARC Infosys v.1.1.1
      • ARC Clients v.1.1.1
      • ARC Core v.1.1.1
      • ARC CE v.1.1.1
        • A-REX wakeup thread is stuck
        • nordugridmap does not apply specified filters
        • cannot use dcache SRM
        • arcproxy fails to PUT credentials to MyProxy server when UI has one second desync
        • arcproxy not creating a proxy
        • arcproxy prints misleading ERROR when one of VOMS servers is unavailable
        • arcstat -a doesn't ask the status of all jobs if there is a problem for one of the jobs
      • WMS v. 3.3.8 fixing:
        • a bug that prevented the job to report the Done status with user exit code = 0 (Done ok was reported instead);
        • a crash in the condor gridmanager caused by an unexpected, but valid, ordering of some ldap attributes;
        • a bug that prevented submission to the ARC CE due to a wrong operator in the RSL string.
        • Detailed information about submitter's DN, FQAN, IP and job destination queue is now logged on syslog.
    • EMI 2
      • CREAM v. 1.14.1
        • CREAM doesn't transfert the output files remotely under well known conditions
        • CREAM cannot insert in the command queue if the lenght of the localUser field is > 14 chars
        • Malformed URL from glite-ce-glue2-endpoint-static
        • Better parsing for static definition files in lcg-info-dynamic-schedule
      • dCache v. 2.2.4
      • EMIR v.1.2.0
      • UNICORE/X6 v. 5.0.0-2
        • all probes were adapted to UCC 6.5.0
        • dependency upon registry address in some probes has been removed
        • check_workflow has been rewritten to the synchronous version
        • a new function was added to check_application: "number_of_lines_between"
        • a new probe, check_activemq, was added
        • bug in check_servorch due to api change has been fixed
        • invalid rss parsing in check_versions has been fixed
        • a missing dependency upon package poppler-info has been added
        • trust delegation support has been added to check_workflow
      • WNoDES v. 2.0.2
        • WNoDES_Hypervisor:
          • check disk space on the HV before copying an image
          • fix permissions when creating LOCAL_REPO_DIR
          • at boot time the bait says connection refused
          • check mandatory parameters in the conf file
        • WNoDES_Bait & WNoDES_Nameserver:
          • local variable 'bmod' referenced before assignment
          • check mandatory parameters in the conf file
        • Documentation:
          • update doc for failure when logical volumes are not defined

Status - 08.10.2012

  • to be released on 22/23.10.2012
    • EMI 1
      • MPI v. 1.4.0-1
        • Support for MVAPICH2 with hydra or mpirun
        • Avoid using /tmp for creation of temporal files
        • Support for loading MPI implementation configuration with modules
    • EMI 2
      • DPM & LFC v. 1.8.4
        • Introduction of new 'dmlite' library
        • New version of HTTP/DAV frontend relying on dmlite
        • New version of the DPM XROOTD plugin with improved performance and federation support
        • Thread friendly CNS API
        • Improved gLite to EMI migration procedure
        • Daemons set to start by default after YAIM config
        • Support for multiple pool config in YAIM
        • Reports using SI units
        • Improved support for load balancing of the daemons
        • Maximum number of daemon threads is now 1000 (was 100)
        • Support for wildcards on the list of trusted hosts
        • Support for py26 on the API
      • GFAL/lcg_util v. 1.13.9
      • EMI UI & WN - including dependencies on 32b libraries
      • L&B v. 3.2.9
        • fix for previously unhandled c-ares exceptions GGUS #85562 and a security update
      • lcg-info-clients v. 1.0.1-2 - debian porting
      • UNICORE HILA v. 2.3.0-1 - debian porting
      • WMS v. 3.4
        • GLUE 2.0 support in purchaser and match-making modules;
        • integration of Condor 7.8.0;
        • rewritten DAG engine, which replaces the Condor DAGMan functionality;
        • support for RFC proxies;
        • argus based authorization for access control.
        • Please checkout the extended release notes for more detailed information.
        • Compliance to the LCG Security Group policies in terms of history retained by the log files and traceability of job submitters and destinations was added, together with several bug fixes, code cleanup and refactoring. ICE, for example, provides an important fix to deal with hanging connections to myproxy upon proxy renewal requests. The logrotation mechanism is now uniform for all the WMS components and the locations for some log and pid files were reviewed, to be fully FHS. Code cleanup has been made both in the WMS interface (wmproxy), to accomodate for easier integration of Argus and the future caNl, and in the WMS engine, by virtue of the removal of DAGMan.
      • WNoDES v. 2.0.3-3
        • fixes for several problems:
          • failover in case NS is unreachable during pre-exec run
          • dhcp server running on the hv must provide null gateway and name server
          • batch real request must destroy unused and available VM in order to free resources
          • memory resources available must be obtained by free -m command each time the bait access resource data structure

Status - 05.11.2012

  • to be released on 22.11.2012
    • EMI 1
      • L&B v. 3.2.9
        • L&B 3.2 implements extended messaging capabilities (job history, anonymization), server-side statistics, finalized CREAM support, and provides fixes for multiple bugs identified in various stages of the product's life cycle.
        • Documentation was updated to reflect the changes.
        • This release also provides fixes for previously unhandled c-ares exceptions, occasional notification interlogger crashes and problems with dumping and loading L&B events. A few minor bugs have also been fixed and documentation was updated to reflect L&B's release status and several new tests.
      • gridsite v. 1.7.23 * addressing several bugs: VOMS attribute handling, httpd module loading priorities, mod_gridsite failure on access from machines with no reverse DNS records, and a memory leak in GRSTx509CreateProxyRequest().
    • EMI 2
      • DPM & LFC v. 1.8.5
        • new nagios-plugin
        • Extended RfC list
          • publication of version and distribution version along with glue
          • rfio opens/creates log file as 0666
          • dpm pid and lock files are world writable
          • semsg packages (libs and plugins-lcgdm) dependency issue
          • site_support_email in dav configuration should not be 'required'
      • VOMS v. 2.0.9
        • VOMS Java APIs do not enforce certificate CRLs
        • When creating a proxy from a certificate without a KeyUsage extension VOMS creates an invalid proxy (GGUS #78716, GGUS #85132)
        • VOMS does not use certificate signature algorithm when creating a proxy. This breaks SHA-2 support in the VOMS server and APIs.

Status - 03.12.2012

Status - 07.01.2013

Status - 28.01.2013

EMI 1 & EMI 2 & EMI 3 Updates status

Status - 20.03.2013

  • EMI 3 released - 11.03.2013 - SL5/64, SL6/64, some products Debian6 (ARC, ARGUS, CANL, dCache, EMIR, GridSite, gLexec-WN (LCAS/LCMAPS), L&B, MPI, ProxyRenewal, UNICORE, VOMS)
  • Content:
    • Major releases: 28
      • APEL parsers
      • APEL publisher
      • APEL SSM
        • Backward incompatibilities:
          • All the code has been rewritten (python), so all changes are 'backward incompatible', including a new database schema. However, no other product depends on the code
          • For the Parsers - Upgrade installation is possible if necessary.
          • For the Publisher - Upgrading from an existing installation is not sensible, since the packages, dependencies and database schema are all different.
        • Other Info:
          • Supported LRMS: LSF, PBS, GE; SLURM to come in the first update
          • Issue regarding empty accounting log files; pubblication of GlueCECapability (use float or integer)
      • ARC CE
        • Backward Compatibilities:
          • ngconfigtest is renamed to arc-config-check, installs to libexec instead of bin and is packaged with A-REX instead of common package.
          • Support for per-user control directories in A-REX is removed, as well as corresponding "control" option from arc.conf.
          • GridFactory back-end & RLS support are removed
          • EMI-ES rendering: one Endpoint per port-type including data capabilitiexrootd DMC is moved out of plugins-globus package and into a new package nordugrid-arc-plugins-xrootd
          • Upgrade – is straight fwd via binary updates
        • Other Info:
          • Support for EMI ES interface version 1.16 is implemented in A-REX service
          • Communications with ARGUS PEP and PDP are implemented and integrated into A-REX
          • CAR 1.2 accounting messages can be sent to an APEL destination
          • nordugridmap is updated to version 2.0
          • DTR is the default mechanism for A-REX data staging
      • ARC Clients
        • Backward Compatibilities:
          • Compat packages (ng* commands) are no longer distributed
          • arcsrmping utility is removed
          • Improved backwards compatibility when reading job list files (client side). Job records from 1.x and 2.x are supported, clients from 1.x and 2.x do not support the format used in 3.x. Support for NOX job record format is dropped. As always 'arcsync' can be used to recover the job list.
        • Other Info:
          • EMI ES interface is implemented in ARC client tools
          • xRSL parser is extended to parse "countpernode" and "exclusiveexecution" attributes used for expressing parallel setup requirements
          • New arcrename command as part of data clients
          • arcproxy supports the detection of NSS DB from default location of Firefox, Seamonkey and Thunderbird.
          • A new package nordugrid-arc-arcproxyalt has been released, containing a version of the arcproxy command line tool which depends on CAnL++
          • Some test and misc tools are moved to a new sub package nordugrid-arc-misc-utils: arcwsrf, arcperftest (renamed from perftest), saml_assertion_init
          • A new test utility arcemiestest is part of nordugrid-arc-misc-utils
          • Upgrade – is straight fwd via binary updates
      • ARC core
      • ARC GridFtp server
      • ARC InfoSys
      • ARC core
      • ARC GridFtp server
      • ARC InfoSys
      • ARGUS
      • CANl
        • Backward Incompatibilities:
          • Declaration of function canl_io_connect() has changed, it takes different attributes
          • Trustmanager migration to CANL
          • Upgrade is possible - As soon as the depending application introduces a dependence on caNl v. 2, it will be pulled automatically.
      • dCache
        • Backward Incompatibilities:
          • dCache installations that have previously been in the /opt layout need to be migrated to the FHS compliant layout. Doors and head nodes have to be updated at the same time.NFSv4.1 door and pools are incompatible and have to be updated at the same time.
          • Compatibility - if NFS4.1 is not used, then 2.2 doors, head nodes and SRM can be mixed with pools of releases 1.9.12-11, 1.9.13-4 or newer. Doors and head nodes have to be updated at the same time.
      • Delegation Java
        • Backward Incompatibilities:
      • EMI Nagios
      • EMI UI
      • EMI WN
      • EMIR
      • GridSite
        • Backward Incompatibilities:
          • Unused components removed: gsexec, slashgrid, gridsite-copy.cgi and gridsite-storage.cgi
          • gridsite_mod internals have been significantly refactored and new authentication features have been introduced by a dependence on EMI's common authentication library (caNl).
          • Upgrade from previous EMI releases is supported. No extra steps are necessary.
      • L&B
        • Backward Incompatibilities:
          • DB schema change. Configuration scripts update the DB automatically, *manual update script provided. *
          • Data structures changed, resulting in binary incompatibility of libraries. Rebuild of depending code required.
      • STS
      • UNICORE Clients6
      • UNICORE Gateway
      • UNICORE Registry
      • UNICORE XUUDB]
      • UNICORE/X6
        • Backward Incompatibilities:
          • Use the EMI Common authentication library (CAnL) for credential handling, will require configuration changes the property file format has changed, and that the use of a property file is now mandatory. Details can be found in the UCC manual.
          • The "backward incompatible" feature (CAnL adoption) means only that server-side configuration files MUST be updated, but older clients will still work.
      • VOMS
        • Major Changes/(In)Compatibilities
          • VOMS Java APIs v. 3.0.0
            • a complete redesign of the VOMS Java APIs based on the EMI Common Authentication Library.
            • Services and clients that want to move to this version will need to adapt their code to the new API.
            • v. 2.0.10 are released in EMI 3 to support those clients that haven't migrated to the new API.
          • VOMS clients v. 3.0.0
            • is a complete redesign of the VOMS clients based on the new VOMS Java API v. 3.0.0
            • the new clients maintain the same interface as the 2.0.x one
            • the output from the scripts has changed to provide more useful information
            • Unused options of vomd-proxy-init are removed
      • VOMS-admin
      • WMS
        • Major Changes:
          • Enabled Argus-based access control using the glite-CE/WN profile *Integration with the EMI Service Registry
          • Removed provision of WMProxy Java API (glite-wms-wmproxy-api-java) and WMProxy Python API (glite-wms-wmproxy-api-python)
      • WNoDES
    • Minor releases: 10
    • Revision releases: 4
    • Repackaged releases: 8

  • NEXT Updates for all Major Releases:
Edit | Attach | Watch | Print version | History: r58 < r57 < r56 < r55 < r54 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r58 - 2013-03-20 - DoinaCristinaAiftimiei
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright &© 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback