*********************************
EMI Test Report Template 
*********************************

- Product: pseudonymity 

- Release Task: 34063

- ETICS Subsystem Configuration Name: emi-pseudonymity_R_1_1_1_0_rc3

- VCS Tag: 1_1_1-rc3  

- EMI Major Release: EMI-3

- Platforms: SL5/x64_64

- Author: Henri Mikkonen 

- Date: 11-February-2013

- Test Report Template : v. 3.2

*************
Summary 
*************

1. Deployment tests: 
   1.1. Clean Installation - PASS
   1.2. Upgrade Installation - PASS 
2. Static Code Analysis - NA
3. Unit Tests Execution - YES
4. System tests:
  4.1. Functionality tests - PASS
  4.2. Regression tests - NA
  4.3. Standard Conformance tests - NA
  4.4. Performance tests - NA
  4.5. Scalability tests - NA
  4.6. Integration tests - NA

REMARKS:

*************************** Detailed Testing Report ***************************************

1. Deployment log 
************************

1.1. Clean Installation
-----------------------------
- YUM/APT Testing Repo file contents:

[root@hip-paha-virt5 yum.repos.d]# cat emi-3-rc-sl5.repo
[core]
name=name=SL 5 base
baseurl=http://linuxsoft.cern.ch/scientific/5x/$basearch/SL
        http://ftp.scientificlinux.org/linux/scientific/5x/$basearch/SL
        http://ftp1.scientificlinux.org/linux/scientific/5x/$basearch/SL
        http://ftp2.scientificlinux.org/linux/scientific/5x/$basearch/SL
protect=0

[extras]
name=epel
baseurl=http://mirror.uv.es/mirror/fedora-epel/5/$basearch
        http://ftp.fi.muni.cz/pub/linux/fedora/epel/5/$basearch
        http://mirror.switch.ch/ftp/mirror/epel/5/$basearch
        http://mirror.de.leaseweb.net/epel/5/$basearch
        http://ftp.rediris.es/mirror/fedora-epel/5/$basearch
protect=0
gpgcheck=0

[EGI-trustanchors]
name=EGI-trustanchors
baseurl=http://repository.egi.eu/sw/production/cas/1/current/
#gpgkey=http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
gpgcheck=0
enabled=1

[EMI-3-testing-base]
name=EMI 3 Testing Base Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/3/sl5/$basearch/base
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/3/RPM-GPG-KEY-emi
priority=45
protect=1
enabled=1
gpgcheck=0

[EMI-3-testing-third-party]
name=EMI 3 Testing Third-Party Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/3/sl5/$basearch/third-party
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/3/RPM-GPG-KEY-emi
protect=1
enabled=1
priority=45
gpgcheck=0

[Oracle-11]
name=Oracle Repository (not for distribution)
baseurl=http://emisoft.web.cern.ch/emisoft/dist/elcaro/oracle-instantclient/11/repo/sl5/$basearch
protect=1
enabled=1
priority=45
gpgcheck=0

- YUM/APT Install command:

yum install pseudonymity-ui pseudonymity-server

- YUM/APT log:

Loaded plugins: kernel-module
EGI-trustanchors                                                                                                                                                                                                   |  951 B     00:00
EGI-trustanchors/primary                                                                                                                                                                                           |  31 kB     00:00
EGI-trustanchors                                                                                                                                                                                                                  215/215
EMI-3-testing-base                                                                                                                                                                                                 | 1.9 kB     00:00
EMI-3-testing-base/primary_db                                                                                                                                                                                      | 683 kB     00:00
EMI-3-testing-third-party                                                                                                                                                                                          | 1.9 kB     00:00
EMI-3-testing-third-party/primary_db                                                                                                                                                                               |  61 kB     00:00
Oracle-11                                                                                                                                                                                                          | 1.9 kB     00:00
Oracle-11/primary_db                                                                                                                                                                                               | 3.3 kB     00:00
core                                                                                                                                                                                                               | 2.1 kB     00:00
core/primary_db                                                                                                                                                                                                    | 2.2 MB     00:00
extras                                                                                                                                                                                                             | 3.7 kB     00:00
extras/primary_db                                                                                                                                                                                                  | 3.9 MB     00:01
Excluding Packages from SL 5 base
Finished
Reducing SL 5 base jdk to included packages only
Finished
Excluding Packages from SL 5 security updates
Finished
Reducing SL 5 security updates jdk only to included packages only
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pseudonymity-server.noarch 0:1.1.1-0.el5 set to be updated
--> Processing Dependency: java >= 1.6 for package: pseudonymity-server
--> Processing Dependency: pseudonymity-common >= 1.1.1 for package: pseudonymity-server
--> Processing Dependency: canl-java >= 1.1 for package: pseudonymity-server
---> Package pseudonymity-ui.noarch 0:1.1.1-0.el5 set to be updated
--> Running transaction check
---> Package canl-java.noarch 0:1.1.0-1.sl5 set to be updated
--> Processing Dependency: bcprov = 1.46 for package: canl-java
--> Processing Dependency: jakarta-commons-io >= 1.4 for package: canl-java
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.33.1.11.6.el5_9 set to be updated
--> Processing Dependency: tzdata-java for package: java-1.6.0-openjdk
---> Package pseudonymity-common.noarch 0:1.1.1-0.el5 set to be updated
--> Running transaction check
---> Package bouncycastle146.noarch 0:1.46-1.el5 set to be updated
---> Package jakarta-commons-io.noarch 0:1.4-3.el5 set to be updated
---> Package tzdata-java.x86_64 0:2012j-1.el5 set to be updated
--> Finished Dependency Resolution
Beginning Kernel Module Plugin
Finished Kernel Module Plugin

Dependencies Resolved

==========================================================================================================================================================================================================================================
 Package                                                   Arch                                         Version                                                            Repository                                                Size
==========================================================================================================================================================================================================================================
Installing:
 pseudonymity-server                                       noarch                                       1.1.1-0.el5                                                        EMI-3-testing-base                                        21 M
 pseudonymity-ui                                           noarch                                       1.1.1-0.el5                                                        EMI-3-testing-base                                       2.1 M
Installing for dependencies:
 bouncycastle146                                           noarch                                       1.46-1.el5                                                         EMI-3-testing-base                                       1.9 M
 canl-java                                                 noarch                                       1.1.0-1.sl5                                                        EMI-3-testing-base                                       262 k
 jakarta-commons-io                                        noarch                                       1.4-3.el5                                                          extras                                                   105 k
 java-1.6.0-openjdk                                        x86_64                                       1:1.6.0.0-1.33.1.11.6.el5_9                                        sl-security                                               36 M
 pseudonymity-common                                       noarch                                       1.1.1-0.el5                                                        EMI-3-testing-base                                       1.5 M
 tzdata-java                                               x86_64                                       2012j-1.el5                                                        sl-security                                              183 k

Transaction Summary
==========================================================================================================================================================================================================================================
Install       8 Package(s)
Upgrade       0 Package(s)

Total download size: 63 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): jakarta-commons-io-1.4-3.el5.noarch.rpm                                                                                                                                                                     | 105 kB     00:00
(2/8): tzdata-java-2012j-1.el5.x86_64.rpm                                                                                                                                                                          | 183 kB     00:01
(3/8): canl-java-1.1.0-1.sl5.noarch.rpm                                                                                                                                                                            | 262 kB     00:00
(4/8): pseudonymity-common-1.1.1-0.el5.noarch.rpm                                                                                                                                                                  | 1.5 MB     00:00
(5/8): bouncycastle146-1.46-1.el5.noarch.rpm                                                                                                                                                                       | 1.9 MB     00:00
(6/8): pseudonymity-ui-1.1.1-0.el5.noarch.rpm                                                                                                                                                                      | 2.1 MB     00:00
(7/8): pseudonymity-server-1.1.1-0.el5.noarch.rpm                                                                                                                                                                  |  21 MB     00:00
(8/8): java-1.6.0-openjdk-1.6.0.0-1.33.1.11.6.el5_9.x86_64.rpm                                                                                                                                                     |  36 MB     00:09
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                     4.7 MB/s |  63 MB     00:13
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : tzdata-java                                                                                                                                                                                                        1/8
  Installing     : java-1.6.0-openjdk                                                                                                                                                                                                 2/8
  Installing     : bouncycastle146                                                                                                                                                                                                    3/8
  Installing     : jakarta-commons-io                                                                                                                                                                                                 4/8
  Installing     : canl-java                                                                                                                                                                                                          5/8
  Installing     : pseudonymity-common                                                                                                                                                                                                6/8
  Installing     : pseudonymity-ui                                                                                                                                                                                                    7/8
warning: group mockbuild does not exist - using root
  Installing     : pseudonymity-server                                                                                                                                                                                                8/8

Installed:
  pseudonymity-server.noarch 0:1.1.1-0.el5                                                                              pseudonymity-ui.noarch 0:1.1.1-0.el5

Dependency Installed:
  bouncycastle146.noarch 0:1.46-1.el5       canl-java.noarch 0:1.1.0-1.sl5       jakarta-commons-io.noarch 0:1.4-3.el5       java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.33.1.11.6.el5_9       pseudonymity-common.noarch 0:1.1.1-0.el5
  tzdata-java.x86_64 0:2012j-1.el5

Complete!

- Configuration log:

Followed the details at: https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityServerConfiguration , the configuration is confidential as it contains secret information towards the online CA.

1.2. Upgrade Installation
--------------------------------
- YUM/APT Production Repo file contents:

[root@hip-paha-virt5 yum.repos.d]# cat emi2-base.repo
[EMI-2-base]
name=EMI 2 base
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/sl5/$basearch/base
protect=1
enabled=1
# To use priorities you must have yum-priorities installed
priority=40
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-emi

- YUM/APT Install command:

yum install pseudonymity-ui pseudonymity-server

- YUM/APT Testing Repo file contents:

[root@hip-paha-virt5 yum.repos.d]# cat emi-3-rc-sl5.repo
[core]
name=name=SL 5 base
baseurl=http://linuxsoft.cern.ch/scientific/5x/$basearch/SL
        http://ftp.scientificlinux.org/linux/scientific/5x/$basearch/SL
        http://ftp1.scientificlinux.org/linux/scientific/5x/$basearch/SL
        http://ftp2.scientificlinux.org/linux/scientific/5x/$basearch/SL
protect=0

[extras]
name=epel
baseurl=http://mirror.uv.es/mirror/fedora-epel/5/$basearch
        http://ftp.fi.muni.cz/pub/linux/fedora/epel/5/$basearch
        http://mirror.switch.ch/ftp/mirror/epel/5/$basearch
        http://mirror.de.leaseweb.net/epel/5/$basearch
        http://ftp.rediris.es/mirror/fedora-epel/5/$basearch
protect=0
gpgcheck=0

[EGI-trustanchors]
name=EGI-trustanchors
baseurl=http://repository.egi.eu/sw/production/cas/1/current/
#gpgkey=http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
gpgcheck=0
enabled=1

[EMI-3-testing-base]
name=EMI 3 Testing Base Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/3/sl5/$basearch/base
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/3/RPM-GPG-KEY-emi
priority=45
protect=1
enabled=1
gpgcheck=0

[EMI-3-testing-third-party]
name=EMI 3 Testing Third-Party Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/3/sl5/$basearch/third-party
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/3/RPM-GPG-KEY-emi
protect=1
enabled=1
priority=45
gpgcheck=0

[Oracle-11]
name=Oracle Repository (not for distribution)
baseurl=http://emisoft.web.cern.ch/emisoft/dist/elcaro/oracle-instantclient/11/repo/sl5/$basearch
protect=1
enabled=1
priority=45
gpgcheck=0

- YUM/APT Upgrade command:

Normally:
yum update

Due to an error in the pseudonymity 1.1.0 post uninstall script: 
yum reinstall pseudonymity-ui pseudonymity-server

- YUM/APT log:

[root@hip-paha-virt5 yum.repos.d]# yum update
Loaded plugins: fastestmirror, kernel-module, priorities, protectbase
Loading mirror speeds from cached hostfile
 * core: ftp2.scientificlinux.org
 * epel: mirror.nsc.liu.se
 * extras: mirror.de.leaseweb.net
 * sl-base: ftp2.scientificlinux.org
 * sl-security: ftp2.scientificlinux.org
 * sl5x-base: ftp2.scientificlinux.org
 * sl5x-security: ftp2.scientificlinux.org
EGI-trustanchors                                                                                                                                                     |  951 B     00:00
EGI-trustanchors/primary                                                                                                                                             |  31 kB     00:00
EGI-trustanchors                                                                                                                                                                    215/215
EMI-3-testing-base                                                                                                                                                   | 1.9 kB     00:00
EMI-3-testing-base/primary_db                                                                                                                                        | 683 kB     00:01
EMI-3-testing-third-party                                                                                                                                            | 1.9 kB     00:00
EMI-3-testing-third-party/primary_db                                                                                                                                 |  61 kB     00:00
Oracle-11                                                                                                                                                            | 1.9 kB     00:00
Oracle-11/primary_db                                                                                                                                                 | 3.3 kB     00:00
core                                                                                                                                                                 | 2.1 kB     00:00
core/primary_db                                                                                                                                                      | 2.2 MB     00:06
extras                                                                                                                                                               | 3.7 kB     00:00
extras/primary_db                                                                                                                                                    | 3.9 MB     00:04
11452 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package emi-release.noarch 0:3.0.0-1.el5 set to be updated
---> Package freetype.i386 0:2.2.1-32.el5_9.1 set to be updated
---> Package freetype.x86_64 0:2.2.1-32.el5_9.1 set to be updated
---> Package glite-ce-common-java.noarch 0:1.15.1-2.sl5 set to be updated
--> Processing Dependency: tomcat5 for package: glite-ce-common-java
--> Processing Dependency: axis2 for package: glite-ce-common-java
--> Processing Dependency: mysql-connector-java for package: glite-ce-common-java
--> Processing Dependency: jclassads for package: glite-ce-common-java
--> Processing Dependency: voms-api-java for package: glite-ce-common-java
---> Package kernel.x86_64 0:2.6.18-348.1.1.el5 set to be installed
---> Package nspr.i386 0:4.9.2-2.el5_9 set to be updated
---> Package nspr.x86_64 0:4.9.2-2.el5_9 set to be updated
---> Package nss.i386 0:3.13.6-3.el5_9 set to be updated
---> Package nss.x86_64 0:3.13.6-3.el5_9 set to be updated
---> Package nss-tools.x86_64 0:3.13.6-3.el5_9 set to be updated
---> Package pseudonymity-common.noarch 0:1.1.1-0.el5 set to be updated
--> Processing Dependency: canl-java >= 1.1 for package: pseudonymity-common
---> Package pseudonymity-server.noarch 0:1.1.1-0.el5 set to be updated
---> Package pseudonymity-ui.noarch 0:1.1.1-0.el5 set to be updated
---> Package tzdata.x86_64 0:2012j-1.el5 set to be updated
--> Running transaction check
---> Package axis2.noarch 0:1.6.1-1.emi set to be updated
---> Package canl-java.noarch 0:1.1.0-1.sl5 set to be updated
--> Processing Dependency: bcprov = 1.46 for package: canl-java
--> Processing Dependency: jakarta-commons-io >= 1.4 for package: canl-java
---> Package jclassads.noarch 0:2.4.0-3.sl5 set to be updated
---> Package mysql-connector-java.x86_64 1:5.1.12-2.el5 set to be updated
--> Processing Dependency: jta >= 1.0 for package: mysql-connector-java
---> Package tomcat5.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
--> Processing Dependency: tomcat5-server-lib = 5.5.23-0jpp.37.el5 for package: tomcat5
--> Processing Dependency: tomcat5-common-lib = 5.5.23-0jpp.37.el5 for package: tomcat5
--> Processing Dependency: tomcat5-server-lib = 5.5.23-0jpp.37.el5 for package: tomcat5
--> Processing Dependency: tomcat5-common-lib = 5.5.23-0jpp.37.el5 for package: tomcat5
--> Processing Dependency: jakarta-commons-daemon >= 1.0.1 for package: tomcat5
--> Processing Dependency: xerces-j2 >= 2.7.1 for package: tomcat5
--> Processing Dependency: jakarta-commons-launcher >= 0.9 for package: tomcat5
---> Package voms-api-java.noarch 0:2.0.10-1.el5 set to be updated
--> Processing Dependency: jakarta-commons-cli for package: voms-api-java
--> Processing Dependency: jakarta-commons-lang for package: voms-api-java
--> Running transaction check
---> Package bouncycastle146.noarch 0:1.46-1.el5 set to be updated
---> Package geronimo-specs-compat.x86_64 0:1.0-0.M2.2jpp.12 set to be updated
--> Processing Dependency: geronimo-specs = 1.0-0.M2.2jpp.12 for package: geronimo-specs-compat
---> Package jakarta-commons-cli.x86_64 0:1.0-6jpp_10.el5 set to be updated
---> Package jakarta-commons-daemon.x86_64 1:1.0.1-6jpp.1 set to be updated
---> Package jakarta-commons-io.noarch 0:1.4-3.el5 set to be updated
---> Package jakarta-commons-lang.x86_64 0:2.1-5jpp.1 set to be updated
---> Package jakarta-commons-launcher.x86_64 0:0.9-6jpp.1 set to be updated
---> Package tomcat5-common-lib.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
--> Processing Dependency: tomcat5-jasper = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jasper = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.37.el5 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-dbcp >= 1.2.1 for package: tomcat5-common-lib
--> Processing Dependency: eclipse-ecj >= 3.1.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-collections >= 3.1 for package: tomcat5-common-lib
--> Processing Dependency: ant >= 1.6 for package: tomcat5-common-lib
--> Processing Dependency: mx4j >= 3.0.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-el >= 1.0 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-pool >= 1.2 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-dbcp >= 1.2.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-collections >= 3.1 for package: tomcat5-common-lib
--> Processing Dependency: ant >= 1.6 for package: tomcat5-common-lib
--> Processing Dependency: mx4j >= 3.0.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-el >= 1.0 for package: tomcat5-common-lib
--> Processing Dependency: eclipse-ecj >= 3.1.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-pool >= 1.2 for package: tomcat5-common-lib
---> Package tomcat5-server-lib.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
--> Processing Dependency: jakarta-commons-digester >= 1.6 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-beanutils >= 1.7.0 for package: tomcat5-server-lib
--> Processing Dependency: regexp >= 1.3 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-modeler >= 1.1-8jpp.1.0.1 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-fileupload >= 1.0-1jpp for package: tomcat5-server-lib
--> Processing Dependency: regexp >= 1.3 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-digester >= 1.6 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-beanutils >= 1.7.0 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-modeler >= 1.1-8jpp.1.0.1 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-fileupload >= 1.0-1jpp for package: tomcat5-server-lib
---> Package xerces-j2.x86_64 0:2.7.1-7jpp.2.el5_4.2 set to be updated
--> Processing Dependency: xml-commons-resolver >= 1.1 for package: xerces-j2
--> Running transaction check
---> Package ant.x86_64 0:1.6.5-2jpp.2 set to be updated
--> Processing Dependency: java-devel for package: ant
---> Package eclipse-ecj.x86_64 1:3.2.1-19.el5 set to be updated
---> Package geronimo-specs.x86_64 0:1.0-0.M2.2jpp.12 set to be updated
---> Package jakarta-commons-beanutils.x86_64 0:1.7.0-5jpp.1 set to be updated
---> Package jakarta-commons-collections.x86_64 0:3.2-2jpp.3 set to be updated
---> Package jakarta-commons-dbcp.x86_64 0:1.2.1-7jpp.1 set to be updated
---> Package jakarta-commons-digester.x86_64 0:1.7-5jpp.1 set to be updated
---> Package jakarta-commons-el.x86_64 0:1.0-7jpp.1 set to be updated
---> Package jakarta-commons-fileupload.x86_64 1:1.0-6jpp.1 set to be updated
---> Package jakarta-commons-modeler.x86_64 0:1.1-8jpp.3.el5 set to be updated
--> Processing Dependency: jaxp_transform_impl for package: jakarta-commons-modeler
---> Package jakarta-commons-pool.x86_64 0:1.3-5jpp.1 set to be updated
---> Package mx4j.x86_64 1:3.0.1-6jpp.4 set to be updated
--> Processing Dependency: bcel >= 5.0 for package: mx4j
---> Package regexp.x86_64 0:1.4-2jpp.2 set to be updated
---> Package tomcat5-jasper.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
---> Package tomcat5-jsp-2.0-api.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
---> Package tomcat5-servlet-2.4-api.x86_64 0:5.5.23-0jpp.37.el5 set to be updated
---> Package xml-commons-resolver.x86_64 0:1.1-1jpp.12 set to be updated
--> Running transaction check
---> Package bcel.x86_64 0:5.1-8jpp.1 set to be updated
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.33.1.11.6.el5_9 set to be updated
---> Package xalan-j2.x86_64 0:2.7.0-6jpp.1 set to be updated
--> Finished Dependency Resolution
Beginning Kernel Module Plugin
Finished Kernel Module Plugin

Dependencies Resolved

============================================================================================================================================================================================
 Package                                            Arch                          Version                                            Repository                                        Size
============================================================================================================================================================================================
Installing:
 glite-ce-common-java                               noarch                        1.15.1-2.sl5                                       EMI-3-testing-base                               635 k
     replacing  emi-trustmanager.noarch 3.1.4-1.sl5

 kernel                                             x86_64                        2.6.18-348.1.1.el5                                 sl-security                                       22 M
Updating:
 emi-release                                        noarch                        3.0.0-1.el5                                        EMI-3-testing-base                               4.7 k
 freetype                                           i386                          2.2.1-32.el5_9.1                                   sl-security                                      313 k
 freetype                                           x86_64                        2.2.1-32.el5_9.1                                   sl-security                                      312 k
 nspr                                               i386                          4.9.2-2.el5_9                                      sl-security                                      122 k
 nspr                                               x86_64                        4.9.2-2.el5_9                                      sl-security                                      121 k
 nss                                                i386                          3.13.6-3.el5_9                                     sl-security                                      1.1 M
 nss                                                x86_64                        3.13.6-3.el5_9                                     sl-security                                      1.1 M
 nss-tools                                          x86_64                        3.13.6-3.el5_9                                     sl-security                                      1.1 M
 pseudonymity-common                                noarch                        1.1.1-0.el5                                        EMI-3-testing-base                               1.5 M
 pseudonymity-server                                noarch                        1.1.1-0.el5                                        EMI-3-testing-base                                21 M
 pseudonymity-ui                                    noarch                        1.1.1-0.el5                                        EMI-3-testing-base                               2.1 M
 tzdata                                             x86_64                        2012j-1.el5                                        sl-security                                      793 k
Installing for dependencies:
 ant                                                x86_64                        1.6.5-2jpp.2                                       sl5x-base                                        2.3 M
 axis2                                              noarch                        1.6.1-1.emi                                        EMI-3-testing-third-party                         19 M
 bcel                                               x86_64                        5.1-8jpp.1                                         sl5x-base                                        1.1 M
 bouncycastle146                                    noarch                        1.46-1.el5                                         EMI-3-testing-base                               1.9 M
 canl-java                                          noarch                        1.1.0-1.sl5                                        EMI-3-testing-base                               262 k
 eclipse-ecj                                        x86_64                        1:3.2.1-19.el5                                     sl5x-base                                        9.0 M
 geronimo-specs                                     x86_64                        1.0-0.M2.2jpp.12                                   sl5x-base                                        258 k
 geronimo-specs-compat                              x86_64                        1.0-0.M2.2jpp.12                                   sl5x-base                                        5.4 k
 jakarta-commons-beanutils                          x86_64                        1.7.0-5jpp.1                                       sl5x-base                                        567 k
 jakarta-commons-cli                                x86_64                        1.0-6jpp_10.el5                                    epel                                              76 k
 jakarta-commons-collections                        x86_64                        3.2-2jpp.3                                         sl5x-base                                        1.2 M
 jakarta-commons-daemon                             x86_64                        1:1.0.1-6jpp.1                                     sl5x-base                                         46 k
 jakarta-commons-dbcp                               x86_64                        1.2.1-7jpp.1                                       sl5x-base                                        278 k
 jakarta-commons-digester                           x86_64                        1.7-5jpp.1                                         sl5x-base                                        349 k
 jakarta-commons-el                                 x86_64                        1.0-7jpp.1                                         sl5x-base                                        269 k
 jakarta-commons-fileupload                         x86_64                        1:1.0-6jpp.1                                       sl5x-base                                         53 k
 jakarta-commons-io                                 noarch                        1.4-3.el5                                          epel                                             105 k
 jakarta-commons-lang                               x86_64                        2.1-5jpp.1                                         sl5x-base                                        508 k
 jakarta-commons-launcher                           x86_64                        0.9-6jpp.1                                         sl5x-base                                         97 k
 jakarta-commons-modeler                            x86_64                        1.1-8jpp.3.el5                                     sl5x-base                                        259 k
 jakarta-commons-pool                               x86_64                        1.3-5jpp.1                                         sl5x-base                                        142 k
 java-1.6.0-openjdk-devel                           x86_64                        1:1.6.0.0-1.33.1.11.6.el5_9                        sl-security                                       12 M
 jclassads                                          noarch                        2.4.0-3.sl5                                        EMI-3-testing-third-party                         95 k
 mx4j                                               x86_64                        1:3.0.1-6jpp.4                                     sl5x-base                                        2.7 M
 mysql-connector-java                               x86_64                        1:5.1.12-2.el5                                     epel                                             2.5 M
 regexp                                             x86_64                        1.4-2jpp.2                                         sl5x-base                                        102 k
 tomcat5                                            x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        394 k
 tomcat5-common-lib                                 x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        226 k
 tomcat5-jasper                                     x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        1.1 M
 tomcat5-jsp-2.0-api                                x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        105 k
 tomcat5-server-lib                                 x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        4.0 M
 tomcat5-servlet-2.4-api                            x86_64                        5.5.23-0jpp.37.el5                                 sl5x-base                                        165 k
 voms-api-java                                      noarch                        2.0.10-1.el5                                       EMI-3-testing-base                               155 k
 xalan-j2                                           x86_64                        2.7.0-6jpp.1                                       sl5x-base                                        4.6 M
 xerces-j2                                          x86_64                        2.7.1-7jpp.2.el5_4.2                               sl5x-base                                        3.1 M
 xml-commons-resolver                               x86_64                        1.1-1jpp.12                                        sl5x-base                                        170 k

Transaction Summary
============================================================================================================================================================================================
Install      38 Package(s)
Upgrade      12 Package(s)

Total download size: 121 M
Is this ok [y/N]: y
Downloading Packages:
(1/50): emi-release-3.0.0-1.el5.noarch.rpm                                                                                                                           | 4.7 kB     00:00
(2/50): geronimo-specs-compat-1.0-0.M2.2jpp.12.x86_64.rpm                                                                                                            | 5.4 kB     00:00
(3/50): jakarta-commons-daemon-1.0.1-6jpp.1.x86_64.rpm                                                                                                               |  46 kB     00:00
(4/50): jakarta-commons-fileupload-1.0-6jpp.1.x86_64.rpm                                                                                                             |  53 kB     00:00
(5/50): jakarta-commons-cli-1.0-6jpp_10.el5.x86_64.rpm                                                                                                               |  76 kB     00:00
(6/50): jclassads-2.4.0-3.sl5.noarch.rpm                                                                                                                             |  95 kB     00:00
(7/50): jakarta-commons-launcher-0.9-6jpp.1.x86_64.rpm                                                                                                               |  97 kB     00:01
(8/50): regexp-1.4-2jpp.2.x86_64.rpm                                                                                                                                 | 102 kB     00:00
(9/50): tomcat5-jsp-2.0-api-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                            | 105 kB     00:00
(10/50): jakarta-commons-io-1.4-3.el5.noarch.rpm                                                                                                                     | 105 kB     00:00
(11/50): nspr-4.9.2-2.el5_9.x86_64.rpm                                                                                                                               | 121 kB     00:01
(12/50): nspr-4.9.2-2.el5_9.i386.rpm                                                                                                                                 | 122 kB     00:00
(13/50): jakarta-commons-pool-1.3-5jpp.1.x86_64.rpm                                                                                                                  | 142 kB     00:00
(14/50): voms-api-java-2.0.10-1.el5.noarch.rpm                                                                                                                       | 155 kB     00:00
(15/50): tomcat5-servlet-2.4-api-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                       | 165 kB     00:01
(16/50): xml-commons-resolver-1.1-1jpp.12.x86_64.rpm                                                                                                                 | 170 kB     00:00
(17/50): tomcat5-common-lib-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                            | 226 kB     00:00
(18/50): geronimo-specs-1.0-0.M2.2jpp.12.x86_64.rpm                                                                                                                  | 258 kB     00:00
(19/50): jakarta-commons-modeler-1.1-8jpp.3.el5.x86_64.rpm                                                                                                           | 259 kB     00:00
(20/50): canl-java-1.1.0-1.sl5.noarch.rpm                                                                                                                            | 262 kB     00:00
(21/50): jakarta-commons-el-1.0-7jpp.1.x86_64.rpm                                                                                                                    | 269 kB     00:01
(22/50): jakarta-commons-dbcp-1.2.1-7jpp.1.x86_64.rpm                                                                                                                | 278 kB     00:00
(23/50): freetype-2.2.1-32.el5_9.1.x86_64.rpm                                                                                                                        | 312 kB     00:00
(24/50): freetype-2.2.1-32.el5_9.1.i386.rpm                                                                                                                          | 313 kB     00:00
(25/50): jakarta-commons-digester-1.7-5jpp.1.x86_64.rpm                                                                                                              | 349 kB     00:00
(26/50): tomcat5-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                                       | 394 kB     00:00
(27/50): jakarta-commons-lang-2.1-5jpp.1.x86_64.rpm                                                                                                                  | 508 kB     00:01
(28/50): jakarta-commons-beanutils-1.7.0-5jpp.1.x86_64.rpm                                                                                                           | 567 kB     00:01
(29/50): glite-ce-common-java-1.15.1-2.sl5.noarch.rpm                                                                                                                | 635 kB     00:01
(30/50): tzdata-2012j-1.el5.x86_64.rpm                                                                                                                               | 793 kB     00:02
(31/50): nss-tools-3.13.6-3.el5_9.x86_64.rpm                                                                                                                         | 1.1 MB     00:02
(32/50): tomcat5-jasper-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                                | 1.1 MB     00:02
(33/50): nss-3.13.6-3.el5_9.i386.rpm                                                                                                                                 | 1.1 MB     00:02
(34/50): bcel-5.1-8jpp.1.x86_64.rpm                                                                                                                                  | 1.1 MB     00:02
(35/50): nss-3.13.6-3.el5_9.x86_64.rpm                                                                                                                               | 1.1 MB     00:02
(36/50): jakarta-commons-collections-3.2-2jpp.3.x86_64.rpm                                                                                                           | 1.2 MB     00:03
(37/50): pseudonymity-common-1.1.1-0.el5.noarch.rpm                                                                                                                  | 1.5 MB     00:02
(38/50): bouncycastle146-1.46-1.el5.noarch.rpm                                                                                                                       | 1.9 MB     00:03
(39/50): pseudonymity-ui-1.1.1-0.el5.noarch.rpm                                                                                                                      | 2.1 MB     00:03
(40/50): ant-1.6.5-2jpp.2.x86_64.rpm                                                                                                                                 | 2.3 MB     00:07
(41/50): mysql-connector-java-5.1.12-2.el5.x86_64.rpm                                                                                                                | 2.5 MB     00:01
(42/50): mx4j-3.0.1-6jpp.4.x86_64.rpm                                                                                                                                | 2.7 MB     00:07
(43/50): xerces-j2-2.7.1-7jpp.2.el5_4.2.x86_64.rpm                                                                                                                   | 3.1 MB     00:08
(44/50): tomcat5-server-lib-5.5.23-0jpp.37.el5.x86_64.rpm                                                                                                            | 4.0 MB     00:10
(45/50): xalan-j2-2.7.0-6jpp.1.x86_64.rpm                                                                                                                            | 4.6 MB     00:14
(46/50): eclipse-ecj-3.2.1-19.el5.x86_64.rpm                                                                                                                         | 9.0 MB     00:23
(47/50): java-1.6.0-openjdk-devel-1.6.0.0-1.33.1.11.6.el5_9.x86_64.rpm                                                                                               |  12 MB     00:30
(48/50): axis2-1.6.1-1.emi.noarch.rpm                                                                                                                                |  19 MB     00:28
(49/50): pseudonymity-server-1.1.1-0.el5.noarch.rpm                                                                                                                  |  21 MB     00:43
(50/50): kernel-2.6.18-348.1.1.el5.x86_64.rpm                                                                                                                        |  22 MB     01:03
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                       274 kB/s | 121 MB     07:30
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : nspr                                                                                                                                                                1/64
  Installing     : tomcat5-servlet-2.4-api                                                                                                                                             2/64
  Installing     : jakarta-commons-collections                                                                                                                                         3/64
  Installing     : jakarta-commons-beanutils                                                                                                                                           4/64
  Updating       : nss                                                                                                                                                                 5/64
  Installing     : jakarta-commons-digester                                                                                                                                            6/64
  Installing     : tomcat5-jasper                                                                                                                                                      7/64
  Installing     : regexp                                                                                                                                                              8/64
  Installing     : jakarta-commons-el                                                                                                                                                  9/64
  Installing     : jakarta-commons-pool                                                                                                                                               10/64
  Installing     : jakarta-commons-lang                                                                                                                                               11/64
  Installing     : jakarta-commons-cli                                                                                                                                                12/64
  Installing     : jakarta-commons-dbcp                                                                                                                                               13/64
  Installing     : bcel                                                                                                                                                               14/64
  Installing     : tomcat5-jsp-2.0-api                                                                                                                                                15/64
  Installing     : jakarta-commons-fileupload                                                                                                                                         16/64
  Installing     : jakarta-commons-daemon                                                                                                                                             17/64
  Updating       : freetype                                                                                                                                                           18/64
  Installing     : eclipse-ecj                                                                                                                                                        19/64
  Installing     : jakarta-commons-launcher                                                                                                                                           20/64
  Installing     : java-1.6.0-openjdk-devel                                                                                                                                           21/64
  Installing     : voms-api-java                                                                                                                                                      22/64
  Installing     : bouncycastle146                                                                                                                                                    23/64
  Installing     : jclassads                                                                                                                                                          24/64
  Installing     : axis2                                                                                                                                                              25/64
  Installing     : jakarta-commons-io                                                                                                                                                 26/64
  Updating       : nspr                                                                                                                                                               27/64
  Updating       : nss-tools                                                                                                                                                          28/64
  Installing     : canl-java                                                                                                                                                          29/64
  Updating       : pseudonymity-common                                                                                                                                                30/64
  Updating       : pseudonymity-ui                                                                                                                                                    31/64
warning: group mockbuild does not exist - using root
  Updating       : pseudonymity-server                                                                                                                                                32/64
/bin/rm: cannot remove `/etc/pseudonymity/server': Is a directory
  Updating       : emi-release                                                                                                                                                        33/64
  Updating       : tzdata                                                                                                                                                             34/64
  Installing     : kernel                                                                                                                                                             35/64
  Updating       : nss                                                                                                                                                                36/64
  Updating       : freetype                                                                                                                                                           37/64
  Installing     : xerces-j2                                                                                                                                                          38/64
  Installing     : xml-commons-resolver                                                                                                                                               39/64
  Installing     : mx4j                                                                                                                                                               40/64
  Installing     : geronimo-specs                                                                                                                                                     41/64
  Installing     : xalan-j2                                                                                                                                                           42/64
  Installing     : jakarta-commons-modeler                                                                                                                                            43/64
  Installing     : tomcat5-server-lib                                                                                                                                                 44/64
  Installing     : ant                                                                                                                                                                45/64
  Installing     : geronimo-specs-compat                                                                                                                                              46/64
  Installing     : tomcat5-common-lib                                                                                                                                                 47/64
  Installing     : tomcat5                                                                                                                                                            48/64
  Installing     : mysql-connector-java                                                                                                                                               49/64
  Installing     : glite-ce-common-java                                                                                                                                               50/64
touch: cannot touch `/etc/grid-security/admin-list': No such file or directory
  Cleanup        : nspr                                                                                                                                                               51/64
  Cleanup        : nspr                                                                                                                                                               52/64
  Cleanup        : freetype                                                                                                                                                           53/64
  Cleanup        : tzdata                                                                                                                                                             54/64
  Cleanup        : pseudonymity-ui                                                                                                                                                    55/64
  Cleanup        : pseudonymity-server                                                                                                                                                56/64
  Cleanup        : nss                                                                                                                                                                57/64
  Cleanup        : nss-tools                                                                                                                                                          58/64
  Cleanup        : freetype                                                                                                                                                           59/64
  Erasing        : emi-trustmanager                                                                                                                                                   60/64
  Erasing        : emi-trustmanager-tomcat                                                                                                                                            61/64
  Cleanup        : pseudonymity-common                                                                                                                                                62/64
  Cleanup        : nss                                                                                                                                                                63/64
  Cleanup        : emi-release                                                                                                                                                        64/64

Installed:
  glite-ce-common-java.noarch 0:1.15.1-2.sl5                                                       kernel.x86_64 0:2.6.18-348.1.1.el5

Dependency Installed:
  ant.x86_64 0:1.6.5-2jpp.2                                            axis2.noarch 0:1.6.1-1.emi                                   bcel.x86_64 0:5.1-8jpp.1
  bouncycastle146.noarch 0:1.46-1.el5                                  canl-java.noarch 0:1.1.0-1.sl5                               eclipse-ecj.x86_64 1:3.2.1-19.el5
  geronimo-specs.x86_64 0:1.0-0.M2.2jpp.12                             geronimo-specs-compat.x86_64 0:1.0-0.M2.2jpp.12              jakarta-commons-beanutils.x86_64 0:1.7.0-5jpp.1
  jakarta-commons-cli.x86_64 0:1.0-6jpp_10.el5                         jakarta-commons-collections.x86_64 0:3.2-2jpp.3              jakarta-commons-daemon.x86_64 1:1.0.1-6jpp.1
  jakarta-commons-dbcp.x86_64 0:1.2.1-7jpp.1                           jakarta-commons-digester.x86_64 0:1.7-5jpp.1                 jakarta-commons-el.x86_64 0:1.0-7jpp.1
  jakarta-commons-fileupload.x86_64 1:1.0-6jpp.1                       jakarta-commons-io.noarch 0:1.4-3.el5                        jakarta-commons-lang.x86_64 0:2.1-5jpp.1
  jakarta-commons-launcher.x86_64 0:0.9-6jpp.1                         jakarta-commons-modeler.x86_64 0:1.1-8jpp.3.el5              jakarta-commons-pool.x86_64 0:1.3-5jpp.1
  java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.33.1.11.6.el5_9          jclassads.noarch 0:2.4.0-3.sl5                               mx4j.x86_64 1:3.0.1-6jpp.4
  mysql-connector-java.x86_64 1:5.1.12-2.el5                           regexp.x86_64 0:1.4-2jpp.2                                   tomcat5.x86_64 0:5.5.23-0jpp.37.el5
  tomcat5-common-lib.x86_64 0:5.5.23-0jpp.37.el5                       tomcat5-jasper.x86_64 0:5.5.23-0jpp.37.el5                   tomcat5-jsp-2.0-api.x86_64 0:5.5.23-0jpp.37.el5
  tomcat5-server-lib.x86_64 0:5.5.23-0jpp.37.el5                       tomcat5-servlet-2.4-api.x86_64 0:5.5.23-0jpp.37.el5          voms-api-java.noarch 0:2.0.10-1.el5
  xalan-j2.x86_64 0:2.7.0-6jpp.1                                       xerces-j2.x86_64 0:2.7.1-7jpp.2.el5_4.2                      xml-commons-resolver.x86_64 0:1.1-1jpp.12

Updated:
  emi-release.noarch 0:3.0.0-1.el5                 freetype.i386 0:2.2.1-32.el5_9.1                 freetype.x86_64 0:2.2.1-32.el5_9.1           nspr.i386 0:4.9.2-2.el5_9
  nspr.x86_64 0:4.9.2-2.el5_9                      nss.i386 0:3.13.6-3.el5_9                        nss.x86_64 0:3.13.6-3.el5_9                  nss-tools.x86_64 0:3.13.6-3.el5_9
  pseudonymity-common.noarch 0:1.1.1-0.el5         pseudonymity-server.noarch 0:1.1.1-0.el5         pseudonymity-ui.noarch 0:1.1.1-0.el5         tzdata.x86_64 0:2012j-1.el5

Replaced:
  emi-trustmanager.noarch 0:3.1.4-1.sl5                                                     emi-trustmanager-tomcat.noarch 0:3.0.1-1.sl5

Complete!
 
NOTE! Due to an error in the pseudonymity 1.1.0 post-install script that can not be corrected in the current version (since it is in the former version), we had also to reinstall the service:

[root@hip-paha-virt5 yum.repos.d]# yum reinstall pseudonymity-ui pseudonymity-server
Loaded plugins: fastestmirror, kernel-module, priorities, protectbase
Setting up Reinstall Process
Loading mirror speeds from cached hostfile
 * core: linuxsoft.cern.ch
 * epel: mirror.nsc.liu.se
 * extras: mirror.de.leaseweb.net
 * sl-base: ftp1.scientificlinux.org
 * sl-security: ftp1.scientificlinux.org
 * sl5x-base: ftp1.scientificlinux.org
 * sl5x-security: ftp1.scientificlinux.org
EMI-3-base                                                                                                                                                           | 1.9 kB     00:00
EMI-3-base/primary_db                                                                                                                                                | 1.1 kB     00:00
EMI-3-contribs                                                                                                                                                       | 1.9 kB     00:00
EMI-3-contribs/primary_db                                                                                                                                            | 1.1 kB     00:00
EMI-3-third-party                                                                                                                                                    | 1.9 kB     00:00
EMI-3-third-party/primary_db                                                                                                                                         |  44 kB     00:00
EMI-3-updates                                                                                                                                                        | 1.9 kB     00:00
EMI-3-updates/primary_db                                                                                                                                             | 1.1 kB     00:00
11526 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package pseudonymity-server.noarch 0:1.1.1-0.el5 set to be updated
---> Package pseudonymity-ui.noarch 0:1.1.1-0.el5 set to be updated
--> Finished Dependency Resolution
Beginning Kernel Module Plugin
Finished Kernel Module Plugin

Dependencies Resolved

============================================================================================================================================================================================
 Package                                           Arch                                 Version                                      Repository                                        Size
============================================================================================================================================================================================
Reinstalling:
 pseudonymity-server                               noarch                               1.1.1-0.el5                                  EMI-3-testing-base                                21 M
 pseudonymity-ui                                   noarch                               1.1.1-0.el5                                  EMI-3-testing-base                               2.1 M

Transaction Summary
============================================================================================================================================================================================
Remove        0 Package(s)
Reinstall     2 Package(s)
Downgrade     0 Package(s)

Total download size: 23 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): pseudonymity-ui-1.1.1-0.el5.noarch.rpm                                                                                                                        | 2.1 MB     00:03
(2/2): pseudonymity-server-1.1.1-0.el5.noarch.rpm                                                                                                                    |  21 MB     00:30
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                       460 kB/s |  23 MB     00:50
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : pseudonymity-ui                                                                                                                                                      1/2
warning: group mockbuild does not exist - using root
  Installing     : pseudonymity-server                                                                                                                                                  2/2
/bin/rm: cannot remove `/etc/pseudonymity/server': Is a directory
/bin/ln: creating symbolic link `/etc/pseudonymity/server/conf' to `/usr/share/pseudonymity/server/conf': File exists

Installed:
  pseudonymity-server.noarch 0:1.1.1-0.el5                                                       pseudonymity-ui.noarch 0:1.1.1-0.el5

Complete!
 
- Configuration log:

Followed the details at: https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityServerConfiguration , the configuration is confidential as it contains secret information towards the online CA.
No configuration changes between the versions.

2. Static Code Analysis
******************************
- URL where static code analysis results can be accessed NA

3. Unit Tests
*****************
- URL pointing to the results of the Unit Tests.

NA (Unit tests are run during the build, and the build fails if any unit test fails).

- Code Coverage %, if available.

NA

4. System tests 
*********************
- URL where the tests/testsuite can be accessed:

https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityTestPlan

- URL where the test results can be accessed:

see Summary / 4.1 below

OR 

please, use the template below to include the test results in this document:

--------------- System Test Summary ------------------
For each Basic Functionality test, please include the following summary:
* Description of the test: see 4.1
* Result: PASSED/FAILED: see 4.1

For each Regression test, please include the following summary:
* Description of the test: NA
* Test Unique ID/RfC unique ID: NA                
* Result: PASSED/FAILED: NA

For each of Performance and Scalability tests, please include the following summary:
* Description of the test: NA
* Description of the specific context: NA
* Result: PASSED/FAILED: NA

For each Standards Compliance/Conformance test, please include the following summary:
* Description of the test: NA
* Adopted Standard: NA
* Result: PASSED/FAILED: NA

For each Integration test, please include the following summary:
* Description of involved components and testbed setup: NA
* Description of the test: NA
* Description of the specific context: NA
* Result: PASSED/FAILED: NA

4.1. Basic Functionality tests
*************************************
For each test:
COPY & PASTE TEST OUTPUT.

Test-Server-Config-1:

(The configuration is invalid, because the host certificate filename is wrong:)

[root@hip-paha-virt5 .globus]# /etc/init.d/pseudonymity-service start
[root@hip-paha-virt5 .globus]# ERROR PseudonymityService - The service encountered an error that could not be dealt with, shutting down!
ERROR PseudonymityService - Could not read the private key and/or certificate from the file
The service encountered an error that could not be dealt with, shutting down!
Error: Could not read the private key and/or certificate from the file
org.glite.pseudo.server.PseudoServerException: Could not read the private key and/or certificate from the file
        at org.glite.pseudo.server.standalone.PseudonymityService.configureConnector(PseudonymityService.java:165)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureServer(PseudonymityService.java:234)
        at org.glite.pseudo.server.standalone.PseudonymityService.<init>(PseudonymityService.java:119)
        at org.glite.pseudo.server.standalone.PseudonymityService.main(PseudonymityService.java:346)
Caused by: java.io.FileNotFoundException: /etc/grid-security/hostcert_WRONG.pem (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:137)
        at java.io.FileInputStream.<init>(FileInputStream.java:96)
        at eu.emi.security.authn.x509.impl.PEMCredential.<init>(PEMCredential.java:222)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureConnector(PseudonymityService.java:155)
        ... 3 more
ERROR PseudonymityService - Could not read the private key and/or certificate from the file
org.glite.pseudo.server.PseudoServerException: Could not read the private key and/or certificate from the file
        at org.glite.pseudo.server.standalone.PseudonymityService.configureConnector(PseudonymityService.java:165) [pseudonymity-server-1.1.1.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureServer(PseudonymityService.java:234) [pseudonymity-server-1.1.1.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.<init>(PseudonymityService.java:119) [pseudonymity-server-1.1.1.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.main(PseudonymityService.java:346) [pseudonymity-server-1.1.1.jar:na]
Caused by: java.io.FileNotFoundException: /etc/grid-security/hostcert_WRONG.pem (No such file or directory)
        at java.io.FileInputStream.open(Native Method) ~[na:1.6.0_24]
        at java.io.FileInputStream.<init>(FileInputStream.java:137) ~[na:1.6.0_24]
        at java.io.FileInputStream.<init>(FileInputStream.java:96) ~[na:1.6.0_24]
        at eu.emi.security.authn.x509.impl.PEMCredential.<init>(PEMCredential.java:222) ~[canl-1.1.0.jar:1.1.0]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureConnector(PseudonymityService.java:155) [pseudonymity-server-1.1.1.jar:na]
        ... 3 common frames omitted

[root@hip-paha-virt5 .globus]# /etc/init.d/pseudonymity-service status
Pseudonymity Service not running...removing stale pid file
Pseudonymity Service not running!
[root@hip-paha-virt5 .globus]#

PASSED

Test-Server-Config-2:

[root@hip-paha-virt5 .globus]# /etc/init.d/pseudonymity-service start
The pseudonymity service has been successfully started.
[root@hip-paha-virt5 .globus]# /etc/init.d/pseudonymity-service status
Pseudonymity Service running!

PASSED

Test-Func-1:

[root@hip-paha-virt5 .globus]# pseudo-cert-request --url https://hip-paha-virt5.cern.ch:8443/pseudo/Login -p /tmp/x509up_u0 -v
pseudo-cert-request: org.glite.pseudo.ui.PseudoInit - Copyright (c) 2011. Members of the EMI Collaboration

ServiceUrl: https://hip-paha-virt5.cern.ch:8443/pseudo/Login
New Key Password:
Retype:
Proxy Filename: /tmp/x509up_u0
Connecting to the pseudonymity service ... ok
Generating a public/private keypair (1024 bit) ... ok
Submitting the certificate request ... ok

Pseudo certificate (/root/.globus/pseudocert.pem) expires on 'Wed Feb 11 15:29:29 CET 2015'.
[root@hip-paha-virt5 .globus]#

PASSED

Test-Func-2:

[root@hip-paha-virt4 .globus]# openssl x509 -in /root/.globus/pseudocert.pem -subject -noout
subject= /C=FI/DC=pseudotest/O=HIP/OU=Tech/CN=5bd9aef7ce6545b2
[root@hip-paha-virt4 .globus]#

Test-Func-3:

Output is in the Web browser.

For the user "CN=Henri Johannes Mikkonen, CN=610244, CN=mikkonen, OU=Users, OU=Organic Units, DC=cern, DC=ch", the pseudonym "CN=5bd9aef7ce6545b2,DC=pseudotest,OU=Tech,O=HIP,C=FI" exists with four events: "301: Requested certificate", "302: Issued certificate", "303: Registered certificate", "201: Issued DN".

PASSED

Test-Func-4:

Output is in the Web browser.

For the admin "CN=Henri Johannes Mikkonen, CN=610244, CN=mikkonen, OU=Users, OU=Organic Units, DC=cern, DC=ch", there is information that he has listed event details for the pseudonym.

PASSED

4.2. Regression tests
*****************************
For each test: NA

4.3. Standard Conformance tests
******************************************
For each test: NA

4.4. Performance tests 
*******************************
For each test: NA

4.5. Scalability tests 
**************************
For each test: NA

4.6. Integration tests 
**************************
For each test: NA

---------------End of System Test Summary ------------------
Edit | Attach | Watch | Print version | History: r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r1 - 2013-02-11 - HenriMikkonen
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback