*********************************
EMI Test Report Template 
*********************************

- Product: pseudonymity 

- Release Task: https://savannah.cern.ch/task/?38335

- ETICS Subsystem Configuration Name: emi-pseudonymity_R_1_1_0_2_rc1

- VCS Tag: tags/1_1_0-2-rc1

- EMI Major Release: EMI-2

- Platforms: SL6/x64_64

- Author: Henri Mikkonen 

- Date: 4-March-2013

- Test Report Template : v. 3.2

*************
Summary 
*************

1. Deployment tests: 
   1.1. Clean Installation - PASS
   1.2. Upgrade Installation - PASS 
2. Static Code Analysis - NA
3. Unit Tests Execution - YES
4. System tests:
  4.1. Functionality tests - PASS
  4.2. Regression tests - NA
  4.3. Standard Conformance tests - NA
  4.4. Performance tests - NA
  4.5. Scalability tests - NA
  4.6. Integration tests - NA

REMARKS:

*************************** Detailed Testing Report ***************************************

1. Deployment log 
************************

1.1. Clean Installation
-----------------------------
- YUM/APT Testing Repo file contents:

[root@hip-paha-virt4 yum.repos.d]# cat emi-2-rc-sl6.repo
[core]
name=name=SL 6 base
baseurl=http://linuxsoft.cern.ch/scientific/6x/$basearch/os
        http://ftp.scientificlinux.org/linux/scientific/6x/$basearch/os
        http://ftp1.scientificlinux.org/linux/scientific/6x/$basearch/os
        http://ftp2.scientificlinux.org/linux/scientific/6x/$basearch/os
protect=0

[extras]
name=epel
baseurl=http://ftp.heanet.ie/pub/fedora/epel/6/$basearch
        http://mirror.switch.ch/ftp/mirror/epel/6/$basearch
        http://ftp.fi.muni.cz/pub/linux/fedora/epel/6/$basearch
        http://ftp.nluug.nl/pub/os/Linux/distr/fedora-epel/6/$basearch
        http://nl.mirror.eurid.eu/epel/6/$basearch
protect=0

[EGI-trustanchors]
name=EGI-trustanchors
baseurl=http://repository.egi.eu/sw/production/cas/1/current/
#gpgkey=http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
gpgcheck=0
enabled=1

[EMI-2-testing-base]
name=EMI 2 Testing Base Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/2/sl6/$basearch/base
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
priority=40
protect=1
enabled=1
gpgcheck=0

[EMI-2-testing-third-party]
name=EMI 2 Testing Third-Party Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/2/sl6/$basearch/third-party
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
protect=1
enabled=1
priority=40
gpgcheck=0

[Oracle]
name=Oracle Repository (not for distribution)
baseurl=http://emisoft.web.cern.ch/emisoft/dist/elcaro/oracle-instantclient/10.2.0.4/repo/sl6/$basearch
gpgcheck=0
protect=1
enabled=1
priority=40

- YUM/APT Install command:

yum install pseudonymity-server pseudonymity-ui

- YUM/APT log:

[root@hip-paha-virt4 yum.repos.d]# yum install pseudonymity-server pseudonymity-ui
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pseudonymity-server.noarch 0:1.1.0-2.sl6 will be installed
--> Processing Dependency: emi-trustmanager for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: bouncycastle for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: pseudonymity-common for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: emi-trustmanager-axis for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: emi-trustmanager-tomcat for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: java-1.6.0-openjdk for package: pseudonymity-server-1.1.0-2.sl6.noarch
--> Processing Dependency: voms-api-java for package: pseudonymity-server-1.1.0-2.sl6.noarch
---> Package pseudonymity-ui.noarch 0:1.1.0-2.sl6 will be installed
--> Running transaction check
---> Package bouncycastle.noarch 0:1.46-1.el6 will be installed
--> Processing Dependency: jpackage-utils >= 1.7 for package: bouncycastle-1.46-1.el6.noarch
--> Processing Dependency: jpackage-utils >= 1.5 for package: bouncycastle-1.46-1.el6.noarch
--> Processing Dependency: jpackage-utils >= 1.7 for package: bouncycastle-1.46-1.el6.noarch
---> Package emi-trustmanager.noarch 0:3.1.4-1.sl6 will be installed
---> Package emi-trustmanager-axis.noarch 0:2.0.2-1.sl6 will be installed
--> Processing Dependency: axis for package: emi-trustmanager-axis-2.0.2-1.sl6.noarch
---> Package emi-trustmanager-tomcat.noarch 0:3.0.1-1.sl6 will be installed
--> Processing Dependency: log4j for package: emi-trustmanager-tomcat-3.0.1-1.sl6.noarch
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.56.1.11.8.el6_3 will be installed
--> Processing Dependency: libjpeg = 6b for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: fontconfig for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: tzdata-java for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: rhino for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libpulse.so.0()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libjpeg.so.62()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libpng12.so.0()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64
---> Package pseudonymity-common.noarch 0:1.1.0-2.sl6 will be installed
---> Package voms-api-java.noarch 0:2.0.10-2.el6 will be installed
--> Processing Dependency: jakarta-commons-lang for package: voms-api-java-2.0.10-2.el6.noarch
--> Processing Dependency: jakarta-commons-cli for package: voms-api-java-2.0.10-2.el6.noarch
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.0.22-3.el6 will be installed
---> Package axis.noarch 0:1.2.1-7.3.el6_3 will be installed
--> Processing Dependency: jakarta-commons-httpclient for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: jaf for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: javamail for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: jakarta-commons-discovery for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: jakarta-commons-logging for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: wsdl4j for package: axis-1.2.1-7.3.el6_3.noarch
--> Processing Dependency: jaxp_parser_impl for package: axis-1.2.1-7.3.el6_3.noarch
---> Package fontconfig.x86_64 0:2.8.0-3.el6 will be installed
---> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be installed
---> Package giflib.x86_64 0:4.1.6-3.1.el6 will be installed
--> Processing Dependency: libICE.so.6()(64bit) for package: giflib-4.1.6-3.1.el6.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: giflib-4.1.6-3.1.el6.x86_64
---> Package jakarta-commons-cli.x86_64 0:1.1-5.el6 will be installed
--> Processing Dependency: java-gcj-compat >= 1.0.31 for package: jakarta-commons-cli-1.1-5.el6.x86_64
--> Processing Dependency: java-gcj-compat >= 1.0.31 for package: jakarta-commons-cli-1.1-5.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: jakarta-commons-cli-1.1-5.el6.x86_64
--> Processing Dependency: /usr/bin/rebuild-gcj-db for package: jakarta-commons-cli-1.1-5.el6.x86_64
--> Processing Dependency: libgcj_bc.so.1()(64bit) for package: jakarta-commons-cli-1.1-5.el6.x86_64
---> Package jakarta-commons-lang.noarch 0:2.4-1.1.el6 will be installed
---> Package jpackage-utils.noarch 0:1.7.5-3.12.el6 will be installed
---> Package libX11.x86_64 0:1.3-2.el6 will be installed
--> Processing Dependency: libX11-common = 1.3-2.el6 for package: libX11-1.3-2.el6.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.3-2.el6.x86_64
---> Package libXext.x86_64 0:1.1-3.el6 will be installed
---> Package libXi.x86_64 0:1.3-3.el6 will be installed
---> Package libXrender.x86_64 0:0.9.5-1.el6 will be installed
---> Package libXtst.x86_64 0:1.0.99.2-3.el6 will be installed
---> Package libjpeg-turbo.x86_64 0:1.2.1-1.el6 will be installed
---> Package libpng.x86_64 2:1.2.49-1.el6_2 will be installed
---> Package log4j.x86_64 0:1.2.14-6.4.el6 will be installed
--> Processing Dependency: xml-commons-apis for package: log4j-1.2.14-6.4.el6.x86_64
---> Package pulseaudio-libs.x86_64 0:0.9.21-13.el6 will be installed
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
--> Processing Dependency: libasyncns.so.0()(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
--> Processing Dependency: libsndfile.so.1()(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
---> Package rhino.noarch 0:1.7-0.7.r2.2.el6 will be installed
--> Processing Dependency: jline for package: rhino-1.7-0.7.r2.2.el6.noarch
---> Package tzdata-java.noarch 0:2012j-1.el6 will be installed
--> Running transaction check
---> Package classpathx-jaf.x86_64 0:1.0-15.4.el6 will be installed
---> Package classpathx-mail.noarch 0:1.1.1-9.4.el6 will be installed
---> Package jakarta-commons-discovery.noarch 1:0.4-5.4.el6 will be installed
---> Package jakarta-commons-httpclient.x86_64 1:3.1-0.7.el6_3 will be installed
---> Package jakarta-commons-logging.noarch 0:1.0.4-10.el6 will be installed
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: sinjdoc for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: perl for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package jline.noarch 0:0.9.94-0.8.el6 will be installed
---> Package libICE.x86_64 0:1.0.6-1.el6 will be installed
---> Package libSM.x86_64 0:1.1.0-7.1.el6 will be installed
---> Package libX11-common.noarch 0:1.3-2.el6 will be installed
---> Package libasyncns.x86_64 0:0.8-1.1.el6 will be installed
---> Package libgcj.x86_64 0:4.4.6-4.el6 will be installed
--> Processing Dependency: zip >= 2.1 for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libart_lgpl >= 2.1.0 for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: gtk2 >= 2.4.0 for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libpangoft2-1.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: libgcj-4.4.6-4.el6.x86_64
---> Package libsndfile.x86_64 0:1.0.20-5.el6 will be installed
--> Processing Dependency: libogg.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libFLAC.so.8()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
---> Package libxcb.x86_64 0:1.5-1.el6 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.5-1.el6.x86_64
---> Package wsdl4j.noarch 0:1.5.2-7.8.el6 will be installed
---> Package xerces-j2.x86_64 0:2.7.1-12.6.el6_0 will be installed
--> Processing Dependency: xml-commons-resolver >= 1.1 for package: xerces-j2-2.7.1-12.6.el6_0.x86_64
---> Package xml-commons-apis.x86_64 0:1.3.04-3.6.el6 will be installed
--> Running transaction check
---> Package atk.x86_64 0:1.28.0-2.el6 will be installed
---> Package cairo.x86_64 0:1.8.8-3.1.el6 will be installed
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64
---> Package flac.x86_64 0:1.2.1-6.1.el6 will be installed
---> Package gtk2.x86_64 0:2.18.9-10.el6 will be installed
--> Processing Dependency: libtiff >= 3.6.1 for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libtiff.so.3()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libjasper.so.1()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libXfixes.so.3()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libXdamage.so.1()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-2.18.9-10.el6.x86_64
---> Package libXau.x86_64 0:1.0.5-1.el6 will be installed
---> Package libXrandr.x86_64 0:1.3.0-4.el6 will be installed
---> Package libart_lgpl.x86_64 0:2.3.20-5.1.el6 will be installed
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
---> Package pango.x86_64 0:1.28.1-3.el6_0.5 will be installed
--> Processing Dependency: libthai >= 0.1.9 for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
---> Package perl.x86_64 4:5.10.1-127.el6 will be installed
--> Processing Dependency: perl-libs = 4:5.10.1-127.el6 for package: 4:perl-5.10.1-127.el6.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.10.1-127.el6.x86_64
--> Processing Dependency: perl(version) for package: 4:perl-5.10.1-127.el6.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-127.el6.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-127.el6.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-127.el6.x86_64
---> Package sinjdoc.x86_64 0:0.5-9.1.el6 will be installed
--> Processing Dependency: java_cup >= 0.10 for package: sinjdoc-0.5-9.1.el6.x86_64
---> Package xml-commons-resolver.x86_64 0:1.1-4.18.el6 will be installed
---> Package zip.x86_64 0:3.0-1.el6 will be installed
--> Running transaction check
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: 1:cups-libs-1.4.2-50.el6_4.4.x86_64
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: 1:cups-libs-1.4.2-50.el6_4.4.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: 1:cups-libs-1.4.2-50.el6_4.4.x86_64
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: 1:cups-libs-1.4.2-50.el6_4.4.x86_64
---> Package hicolor-icon-theme.noarch 0:0.11-1.1.el6 will be installed
---> Package jasper-libs.x86_64 0:1.900.1-15.el6_1.1 will be installed
---> Package java_cup.x86_64 1:0.10k-5.el6 will be installed
---> Package libXcomposite.x86_64 0:0.4.1-2.el6 will be installed
---> Package libXcursor.x86_64 0:1.1.10-2.el6 will be installed
---> Package libXdamage.x86_64 0:1.1.2-1.el6 will be installed
---> Package libXfixes.x86_64 0:4.0.4-1.el6 will be installed
---> Package libXft.x86_64 0:2.1.13-4.1.el6 will be installed
---> Package libXinerama.x86_64 0:1.1-1.el6 will be installed
---> Package libthai.x86_64 0:0.1.12-3.el6 will be installed
---> Package libtiff.x86_64 0:3.9.4-9.el6_3 will be installed
---> Package perl-Module-Pluggable.x86_64 1:3.90-127.el6 will be installed
---> Package perl-Pod-Simple.x86_64 1:3.13-127.el6 will be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-127.el6.x86_64
---> Package perl-libs.x86_64 4:5.10.1-127.el6 will be installed
---> Package perl-version.x86_64 3:0.77-127.el6 will be installed
---> Package pixman.x86_64 0:0.18.4-1.el6_0.1 will be installed
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.25-11.el6 will be installed
---> Package gnutls.x86_64 0:2.8.5-4.el6_2.2 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: gnutls-2.8.5-4.el6_2.2.x86_64
--> Processing Dependency: libtasn1.so.3()(64bit) for package: gnutls-2.8.5-4.el6_2.2.x86_64
---> Package perl-Pod-Escapes.x86_64 1:1.04-127.el6 will be installed
--> Running transaction check
---> Package libtasn1.x86_64 0:2.3-3.el6_2.1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                         Arch                                        Version                                                           Repository                                               Size
=============================================================================================================================================================================================================================================
Installing:
 pseudonymity-server                                             noarch                                      1.1.0-2.sl6                                                       EMI-2-testing-base                                       21 M
 pseudonymity-ui                                                 noarch                                      1.1.0-2.sl6                                                       EMI-2-testing-base                                      3.2 M
Installing for dependencies:
 alsa-lib                                                        x86_64                                      1.0.22-3.el6                                                      core                                                    369 k
 atk                                                             x86_64                                      1.28.0-2.el6                                                      core                                                    190 k
 avahi-libs                                                      x86_64                                      0.6.25-11.el6                                                     core                                                     53 k
 axis                                                            noarch                                      1.2.1-7.3.el6_3                                                   sl-security                                             1.5 M
 bouncycastle                                                    noarch                                      1.46-1.el6                                                        extras                                                  2.3 M
 cairo                                                           x86_64                                      1.8.8-3.1.el6                                                     core                                                    308 k
 classpathx-jaf                                                  x86_64                                      1.0-15.4.el6                                                      core                                                     99 k
 classpathx-mail                                                 noarch                                      1.1.1-9.4.el6                                                     core                                                    478 k
 cups-libs                                                       x86_64                                      1:1.4.2-50.el6_4.4                                                sl-security                                             316 k
 emi-trustmanager                                                noarch                                      3.1.4-1.sl6                                                       EMI-2-testing-base                                      249 k
 emi-trustmanager-axis                                           noarch                                      2.0.2-1.sl6                                                       EMI-2-testing-base                                       27 k
 emi-trustmanager-tomcat                                         noarch                                      3.0.1-1.sl6                                                       EMI-2-testing-base                                       28 k
 flac                                                            x86_64                                      1.2.1-6.1.el6                                                     core                                                    242 k
 fontconfig                                                      x86_64                                      2.8.0-3.el6                                                       core                                                    185 k
 freetype                                                        x86_64                                      2.3.11-14.el6_3.1                                                 sl-security                                             358 k
 giflib                                                          x86_64                                      4.1.6-3.1.el6                                                     core                                                     36 k
 gnutls                                                          x86_64                                      2.8.5-4.el6_2.2                                                   core                                                    341 k
 gtk2                                                            x86_64                                      2.18.9-10.el6                                                     core                                                    3.3 M
 hicolor-icon-theme                                              noarch                                      0.11-1.1.el6                                                      core                                                     39 k
 jakarta-commons-cli                                             x86_64                                      1.1-5.el6                                                         extras                                                   73 k
 jakarta-commons-discovery                                       noarch                                      1:0.4-5.4.el6                                                     core                                                     72 k
 jakarta-commons-httpclient                                      x86_64                                      1:3.1-0.7.el6_3                                                   sl-security                                             586 k
 jakarta-commons-lang                                            noarch                                      2.4-1.1.el6                                                       core                                                    251 k
 jakarta-commons-logging                                         noarch                                      1.0.4-10.el6                                                      core                                                     51 k
 jasper-libs                                                     x86_64                                      1.900.1-15.el6_1.1                                                core                                                    135 k
 java-1.5.0-gcj                                                  x86_64                                      1.5.0.0-29.1.el6                                                  core                                                    138 k
 java-1.6.0-openjdk                                              x86_64                                      1:1.6.0.0-1.56.1.11.8.el6_3                                       sl-security                                              25 M
 java_cup                                                        x86_64                                      1:0.10k-5.el6                                                     core                                                    196 k
 jline                                                           noarch                                      0.9.94-0.8.el6                                                    core                                                     85 k
 jpackage-utils                                                  noarch                                      1.7.5-3.12.el6                                                    core                                                     58 k
 libICE                                                          x86_64                                      1.0.6-1.el6                                                       core                                                     52 k
 libSM                                                           x86_64                                      1.1.0-7.1.el6                                                     core                                                     25 k
 libX11                                                          x86_64                                      1.3-2.el6                                                         core                                                    581 k
 libX11-common                                                   noarch                                      1.3-2.el6                                                         core                                                    187 k
 libXau                                                          x86_64                                      1.0.5-1.el6                                                       core                                                     21 k
 libXcomposite                                                   x86_64                                      0.4.1-2.el6                                                       core                                                     16 k
 libXcursor                                                      x86_64                                      1.1.10-2.el6                                                      core                                                     31 k
 libXdamage                                                      x86_64                                      1.1.2-1.el6                                                       core                                                     15 k
 libXext                                                         x86_64                                      1.1-3.el6                                                         core                                                     32 k
 libXfixes                                                       x86_64                                      4.0.4-1.el6                                                       core                                                     19 k
 libXft                                                          x86_64                                      2.1.13-4.1.el6                                                    core                                                     48 k
 libXi                                                           x86_64                                      1.3-3.el6                                                         core                                                     31 k
 libXinerama                                                     x86_64                                      1.1-1.el6                                                         core                                                     14 k
 libXrandr                                                       x86_64                                      1.3.0-4.el6                                                       core                                                     29 k
 libXrender                                                      x86_64                                      0.9.5-1.el6                                                       core                                                     26 k
 libXtst                                                         x86_64                                      1.0.99.2-3.el6                                                    core                                                     21 k
 libart_lgpl                                                     x86_64                                      2.3.20-5.1.el6                                                    core                                                     64 k
 libasyncns                                                      x86_64                                      0.8-1.1.el6                                                       core                                                     23 k
 libgcj                                                          x86_64                                      4.4.6-4.el6                                                       core                                                     19 M
 libjpeg-turbo                                                   x86_64                                      1.2.1-1.el6                                                       sl-security                                             173 k
 libogg                                                          x86_64                                      2:1.1.4-2.1.el6                                                   core                                                     20 k
 libpng                                                          x86_64                                      2:1.2.49-1.el6_2                                                  core                                                    181 k
 libsndfile                                                      x86_64                                      1.0.20-5.el6                                                      core                                                    232 k
 libtasn1                                                        x86_64                                      2.3-3.el6_2.1                                                     core                                                    237 k
 libthai                                                         x86_64                                      0.1.12-3.el6                                                      core                                                    182 k
 libtiff                                                         x86_64                                      3.9.4-9.el6_3                                                     sl-security                                             341 k
 libvorbis                                                       x86_64                                      1:1.2.3-4.el6_2.1                                                 core                                                    167 k
 libxcb                                                          x86_64                                      1.5-1.el6                                                         core                                                     99 k
 log4j                                                           x86_64                                      1.2.14-6.4.el6                                                    core                                                    678 k
 pango                                                           x86_64                                      1.28.1-3.el6_0.5                                                  core                                                    350 k
 perl                                                            x86_64                                      4:5.10.1-127.el6                                                  core                                                     10 M
 perl-Module-Pluggable                                           x86_64                                      1:3.90-127.el6                                                    core                                                     37 k
 perl-Pod-Escapes                                                x86_64                                      1:1.04-127.el6                                                    core                                                     30 k
 perl-Pod-Simple                                                 x86_64                                      1:3.13-127.el6                                                    core                                                    209 k
 perl-libs                                                       x86_64                                      4:5.10.1-127.el6                                                  core                                                    575 k
 perl-version                                                    x86_64                                      3:0.77-127.el6                                                    core                                                     48 k
 pixman                                                          x86_64                                      0.18.4-1.el6_0.1                                                  core                                                    146 k
 pseudonymity-common                                             noarch                                      1.1.0-2.sl6                                                       EMI-2-testing-base                                      1.3 M
 pulseaudio-libs                                                 x86_64                                      0.9.21-13.el6                                                     core                                                    461 k
 rhino                                                           noarch                                      1.7-0.7.r2.2.el6                                                  core                                                    777 k
 sinjdoc                                                         x86_64                                      0.5-9.1.el6                                                       core                                                    704 k
 tzdata-java                                                     noarch                                      2012j-1.el6                                                       sl-security                                             154 k
 voms-api-java                                                   noarch                                      2.0.10-2.el6                                                      extras                                                  155 k
 wsdl4j                                                          noarch                                      1.5.2-7.8.el6                                                     core                                                    156 k
 xerces-j2                                                       x86_64                                      2.7.1-12.6.el6_0                                                  core                                                    2.9 M
 xml-commons-apis                                                x86_64                                      1.3.04-3.6.el6                                                    core                                                    438 k
 xml-commons-resolver                                            x86_64                                      1.1-4.18.el6                                                      core                                                    144 k
 zip                                                             x86_64                                      3.0-1.el6                                                         core                                                    259 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install      80 Package(s)

Total download size: 102 M
Installed size: 269 M
Is this ok [y/N]: y
Downloading Packages:
(1/80): alsa-lib-1.0.22-3.el6.x86_64.rpm                                                                                                                                                                              | 369 kB     00:00
(2/80): atk-1.28.0-2.el6.x86_64.rpm                                                                                                                                                                                   | 190 kB     00:00
(3/80): avahi-libs-0.6.25-11.el6.x86_64.rpm                                                                                                                                                                           |  53 kB     00:00
(4/80): axis-1.2.1-7.3.el6_3.noarch.rpm                                                                                                                                                                               | 1.5 MB     00:02
(5/80): bouncycastle-1.46-1.el6.noarch.rpm                                                                                                                                                                            | 2.3 MB     00:04
(6/80): cairo-1.8.8-3.1.el6.x86_64.rpm                                                                                                                                                                                | 308 kB     00:00
(7/80): classpathx-jaf-1.0-15.4.el6.x86_64.rpm                                                                                                                                                                        |  99 kB     00:00
(8/80): classpathx-mail-1.1.1-9.4.el6.noarch.rpm                                                                                                                                                                      | 478 kB     00:00
(9/80): cups-libs-1.4.2-50.el6_4.4.x86_64.rpm                                                                                                                                                                         | 316 kB     00:00
(10/80): emi-trustmanager-3.1.4-1.sl6.noarch.rpm                                                                                                                                                                      | 249 kB     00:00
(11/80): emi-trustmanager-axis-2.0.2-1.sl6.noarch.rpm                                                                                                                                                                 |  27 kB     00:00
(12/80): emi-trustmanager-tomcat-3.0.1-1.sl6.noarch.rpm                                                                                                                                                               |  28 kB     00:00
(13/80): flac-1.2.1-6.1.el6.x86_64.rpm                                                                                                                                                                                | 242 kB     00:00
(14/80): fontconfig-2.8.0-3.el6.x86_64.rpm                                                                                                                                                                            | 185 kB     00:00
(15/80): freetype-2.3.11-14.el6_3.1.x86_64.rpm                                                                                                                                                                        | 358 kB     00:00
(16/80): giflib-4.1.6-3.1.el6.x86_64.rpm                                                                                                                                                                              |  36 kB     00:00
(17/80): gnutls-2.8.5-4.el6_2.2.x86_64.rpm                                                                                                                                                                            | 341 kB     00:00
(18/80): gtk2-2.18.9-10.el6.x86_64.rpm                                                                                                                                                                                | 3.3 MB     00:00
(19/80): hicolor-icon-theme-0.11-1.1.el6.noarch.rpm                                                                                                                                                                   |  39 kB     00:00
(20/80): jakarta-commons-cli-1.1-5.el6.x86_64.rpm                                                                                                                                                                     |  73 kB     00:00
(21/80): jakarta-commons-discovery-0.4-5.4.el6.noarch.rpm                                                                                                                                                             |  72 kB     00:00
(22/80): jakarta-commons-httpclient-3.1-0.7.el6_3.x86_64.rpm                                                                                                                                                          | 586 kB     00:00
(23/80): jakarta-commons-lang-2.4-1.1.el6.noarch.rpm                                                                                                                                                                  | 251 kB     00:00
(24/80): jakarta-commons-logging-1.0.4-10.el6.noarch.rpm                                                                                                                                                              |  51 kB     00:00
(25/80): jasper-libs-1.900.1-15.el6_1.1.x86_64.rpm                                                                                                                                                                    | 135 kB     00:00
(26/80): java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64.rpm                                                                                                                                                                   | 138 kB     00:00
(27/80): java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64.rpm                                                                                                                                                      |  25 MB     00:03
(28/80): java_cup-0.10k-5.el6.x86_64.rpm                                                                                                                                                                              | 196 kB     00:00
(29/80): jline-0.9.94-0.8.el6.noarch.rpm                                                                                                                                                                              |  85 kB     00:00
(30/80): jpackage-utils-1.7.5-3.12.el6.noarch.rpm                                                                                                                                                                     |  58 kB     00:00
(31/80): libICE-1.0.6-1.el6.x86_64.rpm                                                                                                                                                                                |  52 kB     00:00
(32/80): libSM-1.1.0-7.1.el6.x86_64.rpm                                                                                                                                                                               |  25 kB     00:00
(33/80): libX11-1.3-2.el6.x86_64.rpm                                                                                                                                                                                  | 581 kB     00:00
(34/80): libX11-common-1.3-2.el6.noarch.rpm                                                                                                                                                                           | 187 kB     00:00
(35/80): libXau-1.0.5-1.el6.x86_64.rpm                                                                                                                                                                                |  21 kB     00:00
(36/80): libXcomposite-0.4.1-2.el6.x86_64.rpm                                                                                                                                                                         |  16 kB     00:00
(37/80): libXcursor-1.1.10-2.el6.x86_64.rpm                                                                                                                                                                           |  31 kB     00:00
(38/80): libXdamage-1.1.2-1.el6.x86_64.rpm                                                                                                                                                                            |  15 kB     00:00
(39/80): libXext-1.1-3.el6.x86_64.rpm                                                                                                                                                                                 |  32 kB     00:00
(40/80): libXfixes-4.0.4-1.el6.x86_64.rpm                                                                                                                                                                             |  19 kB     00:00
(41/80): libXft-2.1.13-4.1.el6.x86_64.rpm                                                                                                                                                                             |  48 kB     00:00
(42/80): libXi-1.3-3.el6.x86_64.rpm                                                                                                                                                                                   |  31 kB     00:00
(43/80): libXinerama-1.1-1.el6.x86_64.rpm                                                                                                                                                                             |  14 kB     00:00
(44/80): libXrandr-1.3.0-4.el6.x86_64.rpm                                                                                                                                                                             |  29 kB     00:00
(45/80): libXrender-0.9.5-1.el6.x86_64.rpm                                                                                                                                                                            |  26 kB     00:00
(46/80): libXtst-1.0.99.2-3.el6.x86_64.rpm                                                                                                                                                                            |  21 kB     00:00
(47/80): libart_lgpl-2.3.20-5.1.el6.x86_64.rpm                                                                                                                                                                        |  64 kB     00:00
(48/80): libasyncns-0.8-1.1.el6.x86_64.rpm                                                                                                                                                                            |  23 kB     00:00
(49/80): libgcj-4.4.6-4.el6.x86_64.rpm                                                                                                                                                                                |  19 MB     00:00
(50/80): libjpeg-turbo-1.2.1-1.el6.x86_64.rpm                                                                                                                                                                         | 173 kB     00:00
(51/80): libogg-1.1.4-2.1.el6.x86_64.rpm                                                                                                                                                                              |  20 kB     00:00
(52/80): libpng-1.2.49-1.el6_2.x86_64.rpm                                                                                                                                                                             | 181 kB     00:00
(53/80): libsndfile-1.0.20-5.el6.x86_64.rpm                                                                                                                                                                           | 232 kB     00:00
(54/80): libtasn1-2.3-3.el6_2.1.x86_64.rpm                                                                                                                                                                            | 237 kB     00:00
(55/80): libthai-0.1.12-3.el6.x86_64.rpm                                                                                                                                                                              | 182 kB     00:00
(56/80): libtiff-3.9.4-9.el6_3.x86_64.rpm                                                                                                                                                                             | 341 kB     00:00
(57/80): libvorbis-1.2.3-4.el6_2.1.x86_64.rpm                                                                                                                                                                         | 167 kB     00:00
(58/80): libxcb-1.5-1.el6.x86_64.rpm                                                                                                                                                                                  |  99 kB     00:00
(59/80): log4j-1.2.14-6.4.el6.x86_64.rpm                                                                                                                                                                              | 678 kB     00:00
(60/80): pango-1.28.1-3.el6_0.5.x86_64.rpm                                                                                                                                                                            | 350 kB     00:00
(61/80): perl-5.10.1-127.el6.x86_64.rpm                                                                                                                                                                               |  10 MB     00:00
(62/80): perl-Module-Pluggable-3.90-127.el6.x86_64.rpm                                                                                                                                                                |  37 kB     00:00
(63/80): perl-Pod-Escapes-1.04-127.el6.x86_64.rpm                                                                                                                                                                     |  30 kB     00:00
(64/80): perl-Pod-Simple-3.13-127.el6.x86_64.rpm                                                                                                                                                                      | 209 kB     00:00
(65/80): perl-libs-5.10.1-127.el6.x86_64.rpm                                                                                                                                                                          | 575 kB     00:00
(66/80): perl-version-0.77-127.el6.x86_64.rpm                                                                                                                                                                         |  48 kB     00:00
(67/80): pixman-0.18.4-1.el6_0.1.x86_64.rpm                                                                                                                                                                           | 146 kB     00:00
(68/80): pseudonymity-common-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                   | 1.3 MB     00:00
(69/80): pseudonymity-server-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                   |  21 MB     00:02
(70/80): pseudonymity-ui-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                       | 3.2 MB     00:00
(71/80): pulseaudio-libs-0.9.21-13.el6.x86_64.rpm                                                                                                                                                                     | 461 kB     00:00
(72/80): rhino-1.7-0.7.r2.2.el6.noarch.rpm                                                                                                                                                                            | 777 kB     00:00
(73/80): sinjdoc-0.5-9.1.el6.x86_64.rpm                                                                                                                                                                               | 704 kB     00:00
(74/80): tzdata-java-2012j-1.el6.noarch.rpm                                                                                                                                                                           | 154 kB     00:00
(75/80): voms-api-java-2.0.10-2.el6.noarch.rpm                                                                                                                                                                        | 155 kB     00:00
(76/80): wsdl4j-1.5.2-7.8.el6.noarch.rpm                                                                                                                                                                              | 156 kB     00:00
(77/80): xerces-j2-2.7.1-12.6.el6_0.x86_64.rpm                                                                                                                                                                        | 2.9 MB     00:00
(78/80): xml-commons-apis-1.3.04-3.6.el6.x86_64.rpm                                                                                                                                                                   | 438 kB     00:00
(79/80): xml-commons-resolver-1.1-4.18.el6.x86_64.rpm                                                                                                                                                                 | 144 kB     00:00
(80/80): zip-3.0-1.el6.x86_64.rpm                                                                                                                                                                                     | 259 kB     00:00
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                        4.6 MB/s | 102 MB     00:22
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : jpackage-utils-1.7.5-3.12.el6.noarch                                                                                                                                                                                     1/80
  Installing : freetype-2.3.11-14.el6_3.1.x86_64                                                                                                                                                                                        2/80
  Installing : fontconfig-2.8.0-3.el6.x86_64                                                                                                                                                                                            3/80
  Installing : libjpeg-turbo-1.2.1-1.el6.x86_64                                                                                                                                                                                         4/80
  Installing : libICE-1.0.6-1.el6.x86_64                                                                                                                                                                                                5/80
  Installing : jakarta-commons-logging-1.0.4-10.el6.noarch                                                                                                                                                                              6/80
  Installing : 2:libpng-1.2.49-1.el6_2.x86_64                                                                                                                                                                                           7/80
  Installing : libSM-1.1.0-7.1.el6.x86_64                                                                                                                                                                                               8/80
  Installing : alsa-lib-1.0.22-3.el6.x86_64                                                                                                                                                                                             9/80
  Installing : 2:libogg-1.1.4-2.1.el6.x86_64                                                                                                                                                                                           10/80
  Installing : libtiff-3.9.4-9.el6_3.x86_64                                                                                                                                                                                            11/80
  Installing : jakarta-commons-lang-2.4-1.1.el6.noarch                                                                                                                                                                                 12/80
  Installing : atk-1.28.0-2.el6.x86_64                                                                                                                                                                                                 13/80
  Installing : 1:libvorbis-1.2.3-4.el6_2.1.x86_64                                                                                                                                                                                      14/80
  Installing : flac-1.2.1-6.1.el6.x86_64                                                                                                                                                                                               15/80
  Installing : libsndfile-1.0.20-5.el6.x86_64                                                                                                                                                                                          16/80
  Installing : 1:jakarta-commons-discovery-0.4-5.4.el6.noarch                                                                                                                                                                          17/80
  Installing : jasper-libs-1.900.1-15.el6_1.1.x86_64                                                                                                                                                                                   18/80
  Installing : 1:perl-Pod-Escapes-1.04-127.el6.x86_64                                                                                                                                                                                  19/80
  Installing : 4:perl-libs-5.10.1-127.el6.x86_64                                                                                                                                                                                       20/80
  Installing : 1:perl-Pod-Simple-3.13-127.el6.x86_64                                                                                                                                                                                   21/80
  Installing : 1:perl-Module-Pluggable-3.90-127.el6.x86_64                                                                                                                                                                             22/80
  Installing : 3:perl-version-0.77-127.el6.x86_64                                                                                                                                                                                      23/80
  Installing : 4:perl-5.10.1-127.el6.x86_64                                                                                                                                                                                            24/80
  Installing : pixman-0.18.4-1.el6_0.1.x86_64                                                                                                                                                                                          25/80
  Installing : libasyncns-0.8-1.1.el6.x86_64                                                                                                                                                                                           26/80
  Installing : libtasn1-2.3-3.el6_2.1.x86_64                                                                                                                                                                                           27/80
  Installing : gnutls-2.8.5-4.el6_2.2.x86_64                                                                                                                                                                                           28/80
  Installing : avahi-libs-0.6.25-11.el6.x86_64                                                                                                                                                                                         29/80
  Installing : 1:cups-libs-1.4.2-50.el6_4.4.x86_64                                                                                                                                                                                     30/80
  Installing : tzdata-java-2012j-1.el6.noarch                                                                                                                                                                                          31/80
  Installing : jline-0.9.94-0.8.el6.noarch                                                                                                                                                                                             32/80
  Installing : rhino-1.7-0.7.r2.2.el6.noarch                                                                                                                                                                                           33/80
  Installing : libthai-0.1.12-3.el6.x86_64                                                                                                                                                                                             34/80
  Installing : hicolor-icon-theme-0.11-1.1.el6.noarch                                                                                                                                                                                  35/80
  Installing : zip-3.0-1.el6.x86_64                                                                                                                                                                                                    36/80
  Installing : libart_lgpl-2.3.20-5.1.el6.x86_64                                                                                                                                                                                       37/80
  Installing : libXau-1.0.5-1.el6.x86_64                                                                                                                                                                                               38/80
  Installing : libxcb-1.5-1.el6.x86_64                                                                                                                                                                                                 39/80
  Installing : libX11-common-1.3-2.el6.noarch                                                                                                                                                                                          40/80
  Installing : libX11-1.3-2.el6.x86_64                                                                                                                                                                                                 41/80
  Installing : libXrender-0.9.5-1.el6.x86_64                                                                                                                                                                                           42/80
  Installing : libXext-1.1-3.el6.x86_64                                                                                                                                                                                                43/80
  Installing : libXfixes-4.0.4-1.el6.x86_64                                                                                                                                                                                            44/80
  Installing : libXi-1.3-3.el6.x86_64                                                                                                                                                                                                  45/80
  Installing : libXtst-1.0.99.2-3.el6.x86_64                                                                                                                                                                                           46/80
  Installing : cairo-1.8.8-3.1.el6.x86_64                                                                                                                                                                                              47/80
  Installing : libXrandr-1.3.0-4.el6.x86_64                                                                                                                                                                                            48/80
  Installing : pulseaudio-libs-0.9.21-13.el6.x86_64                                                                                                                                                                                    49/80
  Installing : libXcomposite-0.4.1-2.el6.x86_64                                                                                                                                                                                        50/80
  Installing : libXcursor-1.1.10-2.el6.x86_64                                                                                                                                                                                          51/80
  Installing : libXdamage-1.1.2-1.el6.x86_64                                                                                                                                                                                           52/80
  Installing : libXinerama-1.1-1.el6.x86_64                                                                                                                                                                                            53/80
  Installing : libXft-2.1.13-4.1.el6.x86_64                                                                                                                                                                                            54/80
  Installing : pango-1.28.1-3.el6_0.5.x86_64                                                                                                                                                                                           55/80
  Installing : gtk2-2.18.9-10.el6.x86_64                                                                                                                                                                                               56/80
  Installing : libgcj-4.4.6-4.el6.x86_64                                                                                                                                                                                               57/80
  Installing : java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64                                                                                                                                                                                  58/80
  Installing : 1:java_cup-0.10k-5.el6.x86_64                                                                                                                                                                                           59/80
  Installing : sinjdoc-0.5-9.1.el6.x86_64                                                                                                                                                                                              60/80
  Installing : xml-commons-apis-1.3.04-3.6.el6.x86_64                                                                                                                                                                                  61/80
  Installing : xerces-j2-2.7.1-12.6.el6_0.x86_64                                                                                                                                                                                       62/80
  Installing : xml-commons-resolver-1.1-4.18.el6.x86_64                                                                                                                                                                                63/80
  Installing : log4j-1.2.14-6.4.el6.x86_64                                                                                                                                                                                             64/80
  Installing : classpathx-jaf-1.0-15.4.el6.x86_64                                                                                                                                                                                      65/80
  Installing : 1:jakarta-commons-httpclient-3.1-0.7.el6_3.x86_64                                                                                                                                                                       66/80
  Installing : jakarta-commons-cli-1.1-5.el6.x86_64                                                                                                                                                                                    67/80
  Installing : giflib-4.1.6-3.1.el6.x86_64                                                                                                                                                                                             68/80
  Installing : 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64                                                                                                                                                                   69/80
  Installing : bouncycastle-1.46-1.el6.noarch                                                                                                                                                                                          70/80
  Installing : emi-trustmanager-3.1.4-1.sl6.noarch                                                                                                                                                                                     71/80
  Installing : pseudonymity-common-1.1.0-2.sl6.noarch                                                                                                                                                                                  72/80
  Installing : emi-trustmanager-tomcat-3.0.1-1.sl6.noarch                                                                                                                                                                              73/80
  Installing : voms-api-java-2.0.10-2.el6.noarch                                                                                                                                                                                       74/80
  Installing : classpathx-mail-1.1.1-9.4.el6.noarch                                                                                                                                                                                    75/80
  Installing : wsdl4j-1.5.2-7.8.el6.noarch                                                                                                                                                                                             76/80
  Installing : axis-1.2.1-7.3.el6_3.noarch                                                                                                                                                                                             77/80
  Installing : emi-trustmanager-axis-2.0.2-1.sl6.noarch                                                                                                                                                                                78/80
  Installing : pseudonymity-server-1.1.0-2.sl6.noarch                                                                                                                                                                                  79/80
  Installing : pseudonymity-ui-1.1.0-2.sl6.noarch                                                                                                                                                                                      80/80
  Verifying  : 1:cups-libs-1.4.2-50.el6_4.4.x86_64                                                                                                                                                                                      1/80
  Verifying  : classpathx-mail-1.1.1-9.4.el6.noarch                                                                                                                                                                                     2/80
  Verifying  : libX11-common-1.3-2.el6.noarch                                                                                                                                                                                           3/80
  Verifying  : libjpeg-turbo-1.2.1-1.el6.x86_64                                                                                                                                                                                         4/80
  Verifying  : libX11-1.3-2.el6.x86_64                                                                                                                                                                                                  5/80
  Verifying  : pango-1.28.1-3.el6_0.5.x86_64                                                                                                                                                                                            6/80
  Verifying  : libxcb-1.5-1.el6.x86_64                                                                                                                                                                                                  7/80
  Verifying  : 1:jakarta-commons-discovery-0.4-5.4.el6.noarch                                                                                                                                                                           8/80
  Verifying  : pulseaudio-libs-0.9.21-13.el6.x86_64                                                                                                                                                                                     9/80
  Verifying  : 1:libvorbis-1.2.3-4.el6_2.1.x86_64                                                                                                                                                                                      10/80
  Verifying  : 1:java_cup-0.10k-5.el6.x86_64                                                                                                                                                                                           11/80
  Verifying  : libXau-1.0.5-1.el6.x86_64                                                                                                                                                                                               12/80
  Verifying  : 2:libpng-1.2.49-1.el6_2.x86_64                                                                                                                                                                                          13/80
  Verifying  : libart_lgpl-2.3.20-5.1.el6.x86_64                                                                                                                                                                                       14/80
  Verifying  : fontconfig-2.8.0-3.el6.x86_64                                                                                                                                                                                           15/80
  Verifying  : rhino-1.7-0.7.r2.2.el6.noarch                                                                                                                                                                                           16/80
  Verifying  : 3:perl-version-0.77-127.el6.x86_64                                                                                                                                                                                      17/80
  Verifying  : sinjdoc-0.5-9.1.el6.x86_64                                                                                                                                                                                              18/80
  Verifying  : 4:perl-5.10.1-127.el6.x86_64                                                                                                                                                                                            19/80
  Verifying  : libtiff-3.9.4-9.el6_3.x86_64                                                                                                                                                                                            20/80
  Verifying  : gnutls-2.8.5-4.el6_2.2.x86_64                                                                                                                                                                                           21/80
  Verifying  : zip-3.0-1.el6.x86_64                                                                                                                                                                                                    22/80
  Verifying  : pseudonymity-common-1.1.0-2.sl6.noarch                                                                                                                                                                                  23/80
  Verifying  : 4:perl-libs-5.10.1-127.el6.x86_64                                                                                                                                                                                       24/80
  Verifying  : 1:perl-Pod-Escapes-1.04-127.el6.x86_64                                                                                                                                                                                  25/80
  Verifying  : 1:perl-Pod-Simple-3.13-127.el6.x86_64                                                                                                                                                                                   26/80
  Verifying  : 1:java-1.6.0-openjdk-1.6.0.0-1.56.1.11.8.el6_3.x86_64                                                                                                                                                                   27/80
  Verifying  : jakarta-commons-lang-2.4-1.1.el6.noarch                                                                                                                                                                                 28/80
  Verifying  : hicolor-icon-theme-0.11-1.1.el6.noarch                                                                                                                                                                                  29/80
  Verifying  : cairo-1.8.8-3.1.el6.x86_64                                                                                                                                                                                              30/80
  Verifying  : xerces-j2-2.7.1-12.6.el6_0.x86_64                                                                                                                                                                                       31/80
  Verifying  : freetype-2.3.11-14.el6_3.1.x86_64                                                                                                                                                                                       32/80
  Verifying  : jakarta-commons-logging-1.0.4-10.el6.noarch                                                                                                                                                                             33/80
  Verifying  : wsdl4j-1.5.2-7.8.el6.noarch                                                                                                                                                                                             34/80
  Verifying  : log4j-1.2.14-6.4.el6.x86_64                                                                                                                                                                                             35/80
  Verifying  : libXft-2.1.13-4.1.el6.x86_64                                                                                                                                                                                            36/80
  Verifying  : pseudonymity-server-1.1.0-2.sl6.noarch                                                                                                                                                                                  37/80
  Verifying  : libXext-1.1-3.el6.x86_64                                                                                                                                                                                                38/80
  Verifying  : 2:libogg-1.1.4-2.1.el6.x86_64                                                                                                                                                                                           39/80
  Verifying  : libSM-1.1.0-7.1.el6.x86_64                                                                                                                                                                                              40/80
  Verifying  : classpathx-jaf-1.0-15.4.el6.x86_64                                                                                                                                                                                      41/80
  Verifying  : jpackage-utils-1.7.5-3.12.el6.noarch                                                                                                                                                                                    42/80
  Verifying  : axis-1.2.1-7.3.el6_3.noarch                                                                                                                                                                                             43/80
  Verifying  : voms-api-java-2.0.10-2.el6.noarch                                                                                                                                                                                       44/80
  Verifying  : 1:perl-Module-Pluggable-3.90-127.el6.x86_64                                                                                                                                                                             45/80
  Verifying  : libthai-0.1.12-3.el6.x86_64                                                                                                                                                                                             46/80
  Verifying  : jline-0.9.94-0.8.el6.noarch                                                                                                                                                                                             47/80
  Verifying  : libXrandr-1.3.0-4.el6.x86_64                                                                                                                                                                                            48/80
  Verifying  : libXi-1.3-3.el6.x86_64                                                                                                                                                                                                  49/80
  Verifying  : alsa-lib-1.0.22-3.el6.x86_64                                                                                                                                                                                            50/80
  Verifying  : atk-1.28.0-2.el6.x86_64                                                                                                                                                                                                 51/80
  Verifying  : tzdata-java-2012j-1.el6.noarch                                                                                                                                                                                          52/80
  Verifying  : pseudonymity-ui-1.1.0-2.sl6.noarch                                                                                                                                                                                      53/80
  Verifying  : xml-commons-resolver-1.1-4.18.el6.x86_64                                                                                                                                                                                54/80
  Verifying  : bouncycastle-1.46-1.el6.noarch                                                                                                                                                                                          55/80
  Verifying  : libXcomposite-0.4.1-2.el6.x86_64                                                                                                                                                                                        56/80
  Verifying  : libgcj-4.4.6-4.el6.x86_64                                                                                                                                                                                               57/80
  Verifying  : xml-commons-apis-1.3.04-3.6.el6.x86_64                                                                                                                                                                                  58/80
  Verifying  : libXcursor-1.1.10-2.el6.x86_64                                                                                                                                                                                          59/80
  Verifying  : 1:jakarta-commons-httpclient-3.1-0.7.el6_3.x86_64                                                                                                                                                                       60/80
  Verifying  : libXfixes-4.0.4-1.el6.x86_64                                                                                                                                                                                            61/80
  Verifying  : giflib-4.1.6-3.1.el6.x86_64                                                                                                                                                                                             62/80
  Verifying  : flac-1.2.1-6.1.el6.x86_64                                                                                                                                                                                               63/80
  Verifying  : emi-trustmanager-tomcat-3.0.1-1.sl6.noarch                                                                                                                                                                              64/80
  Verifying  : gtk2-2.18.9-10.el6.x86_64                                                                                                                                                                                               65/80
  Verifying  : libICE-1.0.6-1.el6.x86_64                                                                                                                                                                                               66/80
  Verifying  : libsndfile-1.0.20-5.el6.x86_64                                                                                                                                                                                          67/80
  Verifying  : libXrender-0.9.5-1.el6.x86_64                                                                                                                                                                                           68/80
  Verifying  : avahi-libs-0.6.25-11.el6.x86_64                                                                                                                                                                                         69/80
  Verifying  : libXinerama-1.1-1.el6.x86_64                                                                                                                                                                                            70/80
  Verifying  : emi-trustmanager-axis-2.0.2-1.sl6.noarch                                                                                                                                                                                71/80
  Verifying  : jakarta-commons-cli-1.1-5.el6.x86_64                                                                                                                                                                                    72/80
  Verifying  : libXdamage-1.1.2-1.el6.x86_64                                                                                                                                                                                           73/80
  Verifying  : libtasn1-2.3-3.el6_2.1.x86_64                                                                                                                                                                                           74/80
  Verifying  : libXtst-1.0.99.2-3.el6.x86_64                                                                                                                                                                                           75/80
  Verifying  : libasyncns-0.8-1.1.el6.x86_64                                                                                                                                                                                           76/80
  Verifying  : pixman-0.18.4-1.el6_0.1.x86_64                                                                                                                                                                                          77/80
  Verifying  : java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64                                                                                                                                                                                  78/80
  Verifying  : emi-trustmanager-3.1.4-1.sl6.noarch                                                                                                                                                                                     79/80
  Verifying  : jasper-libs-1.900.1-15.el6_1.1.x86_64                                                                                                                                                                                   80/80

Installed:
  pseudonymity-server.noarch 0:1.1.0-2.sl6                                                                                pseudonymity-ui.noarch 0:1.1.0-2.sl6

Dependency Installed:
  alsa-lib.x86_64 0:1.0.22-3.el6                  atk.x86_64 0:1.28.0-2.el6                              avahi-libs.x86_64 0:0.6.25-11.el6          axis.noarch 0:1.2.1-7.3.el6_3                  bouncycastle.noarch 0:1.46-1.el6
  cairo.x86_64 0:1.8.8-3.1.el6                    classpathx-jaf.x86_64 0:1.0-15.4.el6                   classpathx-mail.noarch 0:1.1.1-9.4.el6     cups-libs.x86_64 1:1.4.2-50.el6_4.4            emi-trustmanager.noarch 0:3.1.4-1.sl6
  emi-trustmanager-axis.noarch 0:2.0.2-1.sl6      emi-trustmanager-tomcat.noarch 0:3.0.1-1.sl6           flac.x86_64 0:1.2.1-6.1.el6                fontconfig.x86_64 0:2.8.0-3.el6                freetype.x86_64 0:2.3.11-14.el6_3.1
  giflib.x86_64 0:4.1.6-3.1.el6                   gnutls.x86_64 0:2.8.5-4.el6_2.2                        gtk2.x86_64 0:2.18.9-10.el6                hicolor-icon-theme.noarch 0:0.11-1.1.el6       jakarta-commons-cli.x86_64 0:1.1-5.el6
  jakarta-commons-discovery.noarch 1:0.4-5.4.el6  jakarta-commons-httpclient.x86_64 1:3.1-0.7.el6_3      jakarta-commons-lang.noarch 0:2.4-1.1.el6  jakarta-commons-logging.noarch 0:1.0.4-10.el6  jasper-libs.x86_64 0:1.900.1-15.el6_1.1
  java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6        java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.56.1.11.8.el6_3  java_cup.x86_64 1:0.10k-5.el6              jline.noarch 0:0.9.94-0.8.el6                  jpackage-utils.noarch 0:1.7.5-3.12.el6
  libICE.x86_64 0:1.0.6-1.el6                     libSM.x86_64 0:1.1.0-7.1.el6                           libX11.x86_64 0:1.3-2.el6                  libX11-common.noarch 0:1.3-2.el6               libXau.x86_64 0:1.0.5-1.el6
  libXcomposite.x86_64 0:0.4.1-2.el6              libXcursor.x86_64 0:1.1.10-2.el6                       libXdamage.x86_64 0:1.1.2-1.el6            libXext.x86_64 0:1.1-3.el6                     libXfixes.x86_64 0:4.0.4-1.el6
  libXft.x86_64 0:2.1.13-4.1.el6                  libXi.x86_64 0:1.3-3.el6                               libXinerama.x86_64 0:1.1-1.el6             libXrandr.x86_64 0:1.3.0-4.el6                 libXrender.x86_64 0:0.9.5-1.el6
  libXtst.x86_64 0:1.0.99.2-3.el6                 libart_lgpl.x86_64 0:2.3.20-5.1.el6                    libasyncns.x86_64 0:0.8-1.1.el6            libgcj.x86_64 0:4.4.6-4.el6                    libjpeg-turbo.x86_64 0:1.2.1-1.el6
  libogg.x86_64 2:1.1.4-2.1.el6                   libpng.x86_64 2:1.2.49-1.el6_2                         libsndfile.x86_64 0:1.0.20-5.el6           libtasn1.x86_64 0:2.3-3.el6_2.1                libthai.x86_64 0:0.1.12-3.el6
  libtiff.x86_64 0:3.9.4-9.el6_3                  libvorbis.x86_64 1:1.2.3-4.el6_2.1                     libxcb.x86_64 0:1.5-1.el6                  log4j.x86_64 0:1.2.14-6.4.el6                  pango.x86_64 0:1.28.1-3.el6_0.5
  perl.x86_64 4:5.10.1-127.el6                    perl-Module-Pluggable.x86_64 1:3.90-127.el6            perl-Pod-Escapes.x86_64 1:1.04-127.el6     perl-Pod-Simple.x86_64 1:3.13-127.el6          perl-libs.x86_64 4:5.10.1-127.el6
  perl-version.x86_64 3:0.77-127.el6              pixman.x86_64 0:0.18.4-1.el6_0.1                       pseudonymity-common.noarch 0:1.1.0-2.sl6   pulseaudio-libs.x86_64 0:0.9.21-13.el6         rhino.noarch 0:1.7-0.7.r2.2.el6
  sinjdoc.x86_64 0:0.5-9.1.el6                    tzdata-java.noarch 0:2012j-1.el6                       voms-api-java.noarch 0:2.0.10-2.el6        wsdl4j.noarch 0:1.5.2-7.8.el6                  xerces-j2.x86_64 0:2.7.1-12.6.el6_0
  xml-commons-apis.x86_64 0:1.3.04-3.6.el6        xml-commons-resolver.x86_64 0:1.1-4.18.el6             zip.x86_64 0:3.0-1.el6

Complete!

- Configuration log:

Followed the details at: https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityServerConfiguration , the configuration is confidential as it contains secret information towards the online CA.

1.2. Upgrade Installation
--------------------------------
- YUM/APT Production Repo file contents:

[root@hip-paha-virt4 yum.repos.d]# cat emi2-*
[EMI-2-base]
name=EMI 2 base
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/sl6/$basearch/base
protect=1
enabled=1
# To use priorities you must have yum-priorities installed
priority=40
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-emi

[EMI-2-contribs]
name=EMI 2 contribs
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/sl6/$basearch/contribs
protect=1
enabled=1
# To use priorities you must have yum-priorities installed
priority=40
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-emi

[EMI-2-third-party]
name=EMI 2 third-party
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/sl6/$basearch/third-party
protect=1
enabled=1
# To use priorities you must have yum-priorities installed
priority=40
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-emi

[EMI-2-updates]
name=EMI 2 updates
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/sl6/$basearch/updates
protect=1
enabled=1
# To use priorities you must have yum-priorities installed
priority=40
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-emi

- YUM/APT Install command:

yum install pseudonymity-server pseudonymity-ui

- YUM/APT Testing Repo file contents:

[root@hip-paha-virt4 yum.repos.d]# cat emi-2-rc-sl6.repo
[core]
name=name=SL 6 base
baseurl=http://linuxsoft.cern.ch/scientific/6x/$basearch/os
        http://ftp.scientificlinux.org/linux/scientific/6x/$basearch/os
        http://ftp1.scientificlinux.org/linux/scientific/6x/$basearch/os
        http://ftp2.scientificlinux.org/linux/scientific/6x/$basearch/os
protect=0

[extras]
name=epel
baseurl=http://ftp.heanet.ie/pub/fedora/epel/6/$basearch
        http://mirror.switch.ch/ftp/mirror/epel/6/$basearch
        http://ftp.fi.muni.cz/pub/linux/fedora/epel/6/$basearch
        http://ftp.nluug.nl/pub/os/Linux/distr/fedora-epel/6/$basearch
        http://nl.mirror.eurid.eu/epel/6/$basearch
protect=0

[EGI-trustanchors]
name=EGI-trustanchors
baseurl=http://repository.egi.eu/sw/production/cas/1/current/
#gpgkey=http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
gpgcheck=0
enabled=1

[EMI-2-testing-base]
name=EMI 2 Testing Base Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/2/sl6/$basearch/base
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
priority=40
protect=1
enabled=1
gpgcheck=0

[EMI-2-testing-third-party]
name=EMI 2 Testing Third-Party Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/testing/2/sl6/$basearch/third-party
#gpgkey=http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
protect=1
enabled=1
priority=40
gpgcheck=0

[Oracle]
name=Oracle Repository (not for distribution)
baseurl=http://emisoft.web.cern.ch/emisoft/dist/elcaro/oracle-instantclient/10.2.0.4/repo/sl6/$basearch
gpgcheck=0
protect=1
enabled=1
priority=40

- YUM/APT Upgrade command:

yum update

- YUM/APT log:

[root@hip-paha-virt4 yum.repos.d]# yum update
Loaded plugins: priorities, protectbase, security
167 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-279.22.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-279.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-279.22.1.el6 will be an update
---> Package pseudonymity-common.noarch 0:1.1.0-0.sl6 will be updated
---> Package pseudonymity-common.noarch 0:1.1.0-2.sl6 will be an update
---> Package pseudonymity-server.noarch 0:1.1.0-0.sl6 will be updated
---> Package pseudonymity-server.noarch 0:1.1.0-2.sl6 will be an update
--> Processing Dependency: voms-api-java for package: pseudonymity-server-1.1.0-2.sl6.noarch
---> Package pseudonymity-ui.noarch 0:1.1.0-0.sl6 will be updated
---> Package pseudonymity-ui.noarch 0:1.1.0-2.sl6 will be an update
--> Running transaction check
---> Package voms-api-java.noarch 0:2.0.10-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                      Arch                                            Version                                                      Repository                                                   Size
=============================================================================================================================================================================================================================================
Installing:
 kernel                                                       x86_64                                          2.6.32-279.22.1.el6                                          sl-security                                                  25 M
Updating:
 kernel-firmware                                              noarch                                          2.6.32-279.22.1.el6                                          sl-security                                                 8.7 M
 pseudonymity-common                                          noarch                                          1.1.0-2.sl6                                                  EMI-2-testing-base                                          1.3 M
 pseudonymity-server                                          noarch                                          1.1.0-2.sl6                                                  EMI-2-testing-base                                           21 M
 pseudonymity-ui                                              noarch                                          1.1.0-2.sl6                                                  EMI-2-testing-base                                          3.2 M
Installing for dependencies:
 voms-api-java                                                noarch                                          2.0.10-1.el6                                                 EMI-2-testing-base                                          154 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install       2 Package(s)
Upgrade       4 Package(s)

Total download size: 59 M
Is this ok [y/N]: y
Downloading Packages:
(1/6): kernel-2.6.32-279.22.1.el6.x86_64.rpm                                                                                                                                                                          |  25 MB     00:04
(2/6): kernel-firmware-2.6.32-279.22.1.el6.noarch.rpm                                                                                                                                                                 | 8.7 MB     00:00
(3/6): pseudonymity-common-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                     | 1.3 MB     00:00
(4/6): pseudonymity-server-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                     |  21 MB     00:00
(5/6): pseudonymity-ui-1.1.0-2.sl6.noarch.rpm                                                                                                                                                                         | 3.2 MB     00:00
(6/6): voms-api-java-2.0.10-1.el6.noarch.rpm                                                                                                                                                                          | 154 kB     00:00
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                        7.8 MB/s |  59 MB     00:07
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : pseudonymity-common-1.1.0-2.sl6.noarch                                                                                                                                                                                   1/10
  Installing : voms-api-java-2.0.10-1.el6.noarch                                                                                                                                                                                        2/10
  Updating   : kernel-firmware-2.6.32-279.22.1.el6.noarch                                                                                                                                                                               3/10
  Installing : kernel-2.6.32-279.22.1.el6.x86_64                                                                                                                                                                                        4/10
  Updating   : pseudonymity-server-1.1.0-2.sl6.noarch                                                                                                                                                                                   5/10
warning: /etc/pseudonymity/server/pseudonymity-server.ini created as /etc/pseudonymity/server/pseudonymity-server.ini.rpmnew
  Updating   : pseudonymity-ui-1.1.0-2.sl6.noarch                                                                                                                                                                                       6/10
  Cleanup    : pseudonymity-ui-1.1.0-0.sl6.noarch                                                                                                                                                                                       7/10
  Cleanup    : pseudonymity-server-1.1.0-0.sl6.noarch                                                                                                                                                                                   8/10
  Cleanup    : pseudonymity-common-1.1.0-0.sl6.noarch                                                                                                                                                                                   9/10
  Cleanup    : kernel-firmware-2.6.32-279.el6.noarch                                                                                                                                                                                   10/10
  Verifying  : pseudonymity-common-1.1.0-2.sl6.noarch                                                                                                                                                                                   1/10
  Verifying  : kernel-firmware-2.6.32-279.22.1.el6.noarch                                                                                                                                                                               2/10
  Verifying  : pseudonymity-server-1.1.0-2.sl6.noarch                                                                                                                                                                                   3/10
  Verifying  : voms-api-java-2.0.10-1.el6.noarch                                                                                                                                                                                        4/10
  Verifying  : pseudonymity-ui-1.1.0-2.sl6.noarch                                                                                                                                                                                       5/10
  Verifying  : kernel-2.6.32-279.22.1.el6.x86_64                                                                                                                                                                                        6/10
  Verifying  : pseudonymity-common-1.1.0-0.sl6.noarch                                                                                                                                                                                   7/10
  Verifying  : pseudonymity-ui-1.1.0-0.sl6.noarch                                                                                                                                                                                       8/10
  Verifying  : pseudonymity-server-1.1.0-0.sl6.noarch                                                                                                                                                                                   9/10
  Verifying  : kernel-firmware-2.6.32-279.el6.noarch                                                                                                                                                                                   10/10

Installed:
  kernel.x86_64 0:2.6.32-279.22.1.el6

Dependency Installed:
  voms-api-java.noarch 0:2.0.10-1.el6

Updated:
  kernel-firmware.noarch 0:2.6.32-279.22.1.el6                   pseudonymity-common.noarch 0:1.1.0-2.sl6                   pseudonymity-server.noarch 0:1.1.0-2.sl6                   pseudonymity-ui.noarch 0:1.1.0-2.sl6

Complete!

- Configuration log:

Followed the details at: https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityServerConfiguration , the configuration is confidential as it contains secret information towards the online CA.

2. Static Code Analysis
******************************
- URL where static code analysis results can be accessed NA

3. Unit Tests
*****************
- URL pointing to the results of the Unit Tests.

NA (Unit tests are run during the build, and the build fails if any unit test fails).

- Code Coverage %, if available.

NA

4. System tests 
*********************
- URL where the tests/testsuite can be accessed:

https://twiki.cern.ch/twiki/bin/view/EMI/PseudonymityTestPlan

- URL where the test results can be accessed:

see Summary / 4.1 below

OR 

please, use the template below to include the test results in this document:

--------------- System Test Summary ------------------
For each Basic Functionality test, please include the following summary:
* Description of the test: see 4.1
* Result: PASSED/FAILED: see 4.1

For each Regression test, please include the following summary:
* Description of the test: NA
* Test Unique ID/RfC unique ID: NA                
* Result: PASSED/FAILED: NA

For each of Performance and Scalability tests, please include the following summary:
* Description of the test: NA
* Description of the specific context: NA
* Result: PASSED/FAILED: NA

For each Standards Compliance/Conformance test, please include the following summary:
* Description of the test: NA
* Adopted Standard: NA
* Result: PASSED/FAILED: NA

For each Integration test, please include the following summary:
* Description of involved components and testbed setup: NA
* Description of the test: NA
* Description of the specific context: NA
* Result: PASSED/FAILED: NA

4.1. Basic Functionality tests
*************************************
For each test:
COPY & PASTE TEST OUTPUT.

Test-Server-Config-1:

(The configuration is invalid, because the host certificate filename is wrong:)

[root@hip-paha-virt4 yum.repos.d]# nano /etc/pseudonymity/server/pseudonymity-server.ini
[root@hip-paha-virt4 yum.repos.d]# /etc/init.d/pseudonymity-service start
[root@hip-paha-virt4 yum.repos.d]# FATAL [main] (UpdatingKeyManager.java180) - credentials loading failed: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
FATAL [main] (ContextWrapper.java523) - The credentials reading failed:  Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
FATAL [main] (ContextWrapper.java467) - ContextWrapper initialization failed: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
ERROR PseudonymityService - Error initializing trustmanager connector: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
ERROR PseudonymityService - Error initializing trustmanager connector: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
        at org.glite.security.trustmanager.UpdatingKeyManager.loadKeystore(UpdatingKeyManager.java:322) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.UpdatingKeyManager.<init>(UpdatingKeyManager.java:178) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.initKeyManagers(ContextWrapper.java:490) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.init(ContextWrapper.java:412) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.<init>(ContextWrapper.java:263) ~[trustmanager.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureTMConnector(PseudonymityService.java:181) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureServer(PseudonymityService.java:248) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.<init>(PseudonymityService.java:121) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.main(PseudonymityService.java:342) [pseudo.jar:na]
ERROR PseudonymityService - The service encountered an error that could not be dealt with, shutting down!
ERROR PseudonymityService - java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
The service encountered an error that could not be dealt with, shutting down!
Error: java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
org.glite.pseudo.server.PseudoServerException: java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureTMConnector(PseudonymityService.java:194)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureServer(PseudonymityService.java:248)
        at org.glite.pseudo.server.standalone.PseudonymityService.<init>(PseudonymityService.java:121)
        at org.glite.pseudo.server.standalone.PseudonymityService.main(PseudonymityService.java:342)
Caused by: java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
        at org.glite.security.trustmanager.UpdatingKeyManager.loadKeystore(UpdatingKeyManager.java:322)
        at org.glite.security.trustmanager.UpdatingKeyManager.<init>(UpdatingKeyManager.java:178)
        at org.glite.security.trustmanager.ContextWrapper.initKeyManagers(ContextWrapper.java:490)
        at org.glite.security.trustmanager.ContextWrapper.init(ContextWrapper.java:412)
        at org.glite.security.trustmanager.ContextWrapper.<init>(ContextWrapper.java:263)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureTMConnector(PseudonymityService.java:181)
        ... 3 more
ERROR PseudonymityService - java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
org.glite.pseudo.server.PseudoServerException: java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
        at org.glite.pseudo.server.standalone.PseudonymityService.configureTMConnector(PseudonymityService.java:194) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureServer(PseudonymityService.java:248) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.<init>(PseudonymityService.java:121) [pseudo.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.main(PseudonymityService.java:342) [pseudo.jar:na]
Caused by: java.security.cert.CertificateException: Error while reading certificates or CRLs: /etc/grid-security/hostcert.pem_WRONG (No such file or directory)
        at org.glite.security.trustmanager.UpdatingKeyManager.loadKeystore(UpdatingKeyManager.java:322) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.UpdatingKeyManager.<init>(UpdatingKeyManager.java:178) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.initKeyManagers(ContextWrapper.java:490) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.init(ContextWrapper.java:412) ~[trustmanager.jar:na]
        at org.glite.security.trustmanager.ContextWrapper.<init>(ContextWrapper.java:263) ~[trustmanager.jar:na]
        at org.glite.pseudo.server.standalone.PseudonymityService.configureTMConnector(PseudonymityService.java:181) [pseudo.jar:na]
        ... 3 common frames omitted

[root@hip-paha-virt4 yum.repos.d]# /etc/init.d/pseudonymity-service status
Pseudonymity Service not running...removing stale pid file
Pseudonymity Service not running!

PASSED

Test-Server-Config-2:

[root@hip-paha-virt4 yum.repos.d]# /etc/init.d/pseudonymity-service start
The pseudonymity service has been successfully started.
[root@hip-paha-virt4 yum.repos.d]# /etc/init.d/pseudonymity-service status
Pseudonymity Service running!

PASSED

Test-Func-1:

[root@hip-paha-virt4 yum.repos.d]# pseudo-cert-request --url https://hip-paha-virt4.cern.ch:8443/pseudo/Login -p /tmp/x509up_u0 -v
pseudo-cert-request: org.glite.pseudo.ui.PseudoInit - Copyright (c) 2011. Members of the EMI Collaboration

ServiceUrl: https://hip-paha-virt4.cern.ch:8443/pseudo/Login
New Key Password:
Retype:
Proxy Filename: /tmp/x509up_u0
Connecting to the pseudonymity service ... ok
Generating a public/private keypair (1024 bit) ... ok
Submitting the certificate request ... ok

Pseudo certificate (/root/.globus/pseudocert.pem) expires on 'Wed Mar 3 07:55:22 CET 2015'.
[root@hip-paha-virt4 yum.repos.d]#

PASSED

Test-Func-2:

[root@hip-paha-virt4 yum.repos.d]# openssl x509 -in /root/.globus/pseudocert.pem -subject -noout
subject= /C=FI/DC=pseudotest/O=HIP/OU=Tech/CN=92898ac8d98bb72a

Test-Func-3:

Output is in the Web browser.

For the user "CN=Henri Johannes Mikkonen, CN=610244, CN=mikkonen, OU=Users, OU=Organic Units, DC=cern, DC=ch", the pseudonym "CN=92898ac8d98bb72a,DC=pseudotest,OU=Tech,O=HIP,C=FI" exists with four events: "301: Requested certificate", "302: Issued certificate", "303: Registered certificate", "201: Issued DN".

PASSED

Test-Func-4:

Output is in the Web browser.

For the admin "CN=Henri Johannes Mikkonen, CN=610244, CN=mikkonen, OU=Users, OU=Organic Units, DC=cern, DC=ch", there is information that he has listed event details for the pseudonym.

PASSED

4.2. Regression tests
*****************************
For each test: NA

4.3. Standard Conformance tests
******************************************
For each test: NA

4.4. Performance tests 
*******************************
For each test: NA

4.5. Scalability tests 
**************************
For each test: NA

4.6. Integration tests 
**************************
For each test: NA

---------------End of System Test Summary ------------------
Edit | Attach | Watch | Print version | History: r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r1 - 2013-03-11 - HenriMikkonen
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback