External dependencies for StoRM components

StoRM FE

Dependency =/>= Version SL5_x86_64 Build Runtime
curl >= 7.15.5-9 aligned - x
curl-devel >= 7.15.5-9 aligned x -
xmlrpc-c >= 1.16.6-2 aligned x -
xmlrpc-c-devel >= 1.16.6-2 aligned - x
boost >= 1.37.0-1 aligned - x
boost-devel >= 1.37.0-1 aligned x -
globus >= 4.0.7 aligned x -
gsoap >= 2.7.6b-2 aligned x -
mysql >= 5.0.77-4 aligned x -
mysql-devel >= 5.0.77-4 aligned x -
org.glite.security.voms >= 1.8.12-2 aligned x -
org.glite.security.voms-api >= 1.8.12-2 aligned x -
org.glite.security.voms-api-cpp >= 1.8.12-2 aligned x x
vdt_globus_essentials >= 4.0.7 aligned - x

StoRM BE

Dependency =/>= Version SL5_x86_64 Build Runtime
ant >= 1.8.1 aligned x -
jdk >= 1.6.0 aligned x -
libattr-devel >= 2.4.32-1.1 aligned x -
libacl-devel >= 2.2.39-6 aligned x -
org.glite.build.common-cpp >= ?? aligned x -
org.glite.security.lcmaps >= 1.4.7-1 aligned x x
org.glite.security.lcmaps-interface >= 1.4.1-1 aligned x -
org.glite.security.lcmaps-plugins-basic >= 1.3.10-2 aligned x x
org.glite.security.lcmaps-plugins-voms >= 1.3.7-5 aligned x x
org.glite.security.lcmaps-without-gsi >= 1.4.3-4 aligned x x
org.glite.security.voms >= 1.8.12-2 aligned x -
org.glite.security.voms-api >= 1.8.12-2 aligned x -
org.glite.security.voms-api-cpp >= 1.8.12-2 aligned x x
swig >= 1.3.29 aligned x -
xfsprogs >= 2.9.4-1 aligned x x
xfsprogs-devel >= 2.9.4-1 aligned x -

SRMClient

Dependency =/>= Version SL5_x86_64 Build Runtime
globus >= 4.0.7 aligned x -
gsoap >= 2.7.6b-2 aligned x -
org.glite.security.cgsi-gsoap-2.7 >= 2.7.6b-2 aligned x -
org.glite.security.voms >= 1.8.12-2 aligned x -
org.glite.security.voms-api >= 1.8.12-2 aligned x -
org.glite.security.voms-api-cpp >= 1.8.12-2 aligned x x
vdt_globus_essentials >= 4.0.7 aligned - x

Checksummer

Dependency =/>= Version SL5_x86_64 Build Runtime
none N/A N/A N/A N/A N/A

Info Provider

Dependency =/>= Version SL5_x86_64 Build Runtime
none N/A N/A N/A N/A N/A

StoRM GridFTP dsi plugin

Dependency =/>= Version SL5_x86_64 Build RuntimeSorted ascending
globus >= 4.0.7 aligned x -
libattr-devel >= 2.4.32-1.1 aligned x -
vdt_globus_data_server >= 4.0.7 aligned - x
zlib >= 1.2.3-3 aligned - x

-- RiccardoZappi - 09-Sep-2010

Edit | Attach | Watch | Print version | History: r2 < r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r2 - 2010-09-20 - RiccardoZappiExternal
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback