Deployment Feedback Form

Please fill fields in the tables below by clicking on EDIT button on each of the following tables, then save once done.

General Data

Site Name: cs.tcd.ie
Site Administrator: Eamonn Kenny
with help from John Walsh
Service Deployed emi-wn
Service Instance Details (hostname, OS, HW) EMI Release 1, emi-wn on sl5-em64t-testwn.testgrid, SL 5.5, Dell MD1000.
Service Instance Configuration/Setup Details (Enabled VOs, installed components..) EMI Release 1, emi-wn, VO: gene, gitest. Machines running on OpenNebula 1.4 using KVM

Deployment Report

Comment on the release notes Release notes are very short and in my opinion contain the wrong information. I would include a separate installation section.

This is a bit pedantic, but the 64b should be 64-bits.

There is no pointer to the existence of a tarball installation, which would be likely to work on SL6, openSUSE 11 and possibly even on Ubuntu/Debian.

I would link the yum repo into the release notes so that there is a one place explains all explanation of the installation.
DONE
Comment on System Administrator Documentation: I would provide a hyperlink inside the system administators guide to point to the Generic installation notes, and in this way an administrator can jump straight to this information.

It would give the installer a much more fluid presentation.

Other than that, the information although short is probably sufficient.
DONE
Comment on the installation process (Warnings, Missing repositories/dependencies): If you think that:

1. obtaining a yum repo for emi-release-1
2. yum install emi-wn
3. yaim ... -n WN

is sufficient and know Yaim really well, the release notes are fine.

However, if you don't, the release notes should point to:

1. Generic installation (to show torque and other batch system configurations).
2. Point to the Yaim configuration for WNs.

Missing information:

If using a pristine minimal cloud/virtual image you will find that the following is needed as a first step:

yum install yum-priorities yum-protectbase

before steps 1-3 above.
DONE
Comment on the (re)-configuration with YAIM (Issues/Warnings/Errors found when configuring, services which should be restarted, etc.) Yaim site-info.def needed explicit definition of INSTALL_ROOT otherwise it assumed its value was /usr, when in fact emi-torque is still using /opt which doesn't conform to the FHS (File hierarchy Standard).

No other issues inside Yaim itself.
DONE
Comment about the functionality of the service - Refer to the Service Reference Card in the Documentation (- Have the deamons started/restarted OK - Does it pass minimal functionality tests - Any problem about normal production usage to report? ) Passes simple glite WMS job submission through a CREAM CE with a separate torque batch server, when the WN is running torque mom. DONE
Any other comment or suggestion for improvement I had the usual testbed troubleshooting issues:

* if fetch-crl not uptodate on UI, voms-proxy-init fails
* firewall turned off on WN otherwise jobs run forever without returning
* slightly different setup required for shared pool account iin mom_priv
* uberftp failing so fetch-crl needed to be uptodate on CE and WMS.
* ntpdate must be used on Xen hosts, not guests to ensure correct times
DONE

-- DaniloDongiovanni - 30-May-2011

Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r6 - 2011-06-16 - unknown
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    EMI All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback