Introduction

The main purpose of this document is to make easier the installation of a DPM on a 64-bit machine. For the moment, there is no official way to install a DPM on a 64-bit as on 32-bit machine. This document does not aim at minimizing the number of rpms to be used to install a rpm. However, the list is complete for dpm developers.

Prerequisite

To install rpms on a 64-bit machine, YUM MUST BE INSTALLED and USED. In /etc/yum.repos.d, you should have many files with the .repo extension.

atrpms.repo cern-update.repo
cern-extra.repo cern-update-srpms.repo
cern-extra-srpms.repo dag.repo
cern-only.repo gd-security.repo
cern-only-srpms.repo glite.repo
cern.repo jpackage.repo
cern-srpms.repo rhaps2.repo
cern-test.repo rhaps2-srpms.repo
cern-test-srpms.repo

Check that in all of them the flag enabled is set to 1.

Edit/Create your /etc/yum.repos.d/glite.repo.

[main]
[lcg-mdw]
name=gLite 3.0 middleware
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/apt-cert/SL4/RPMS.sl4/
enabled=1
protected=1

[CA]
name=CAs
baseurl=http://linuxsoft.cern.ch/LCG-CAs/current
enabled=1

You also need to install j2sdk as a rpm (http://java.sun.com/j2se/1.4.2/download.html).

Yaim (latest version) should also be there:

wget http://grid-deployment.web.cern.ch/grid-deployment/gis/yaim/glite-yaim-3.0.1-15.noarch.rpm

rpm -ivh glite-yaim-3.0.1-15.noarch.rpm

Installation of the RPMs using yum

yum install lcg-vomscert-na48

yum install lcg-vomscert-4.5.0-1

yum install gsiopenssh gssklog-cern

yum install openldap-clients openldap-servers

yum install glite-rgma-command-line

yum install glite-rgma-api-java glite-rgma-stubs-servlet-java

yum install edg-profile lcg-version lcg-profile

yum install j2sdk_profile globus-config globus-initialization

yum install lcg-info

yum install pyOpenSSL

mkdir -p /opt/glite/yaim/etc

cp -p /opt/glite/yaim/examples/users.conf /opt/glite/yaim/etc/users.conf

cp -p /opt/glite/yaim/examples/groups.conf /opt/glite/yaim/etc/groups.conf

Installation of the Globus RPMs

These RPMs allow also developers to use globus toolkit. wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0//release-3/vdt_globus_data_server-VDT1.6.0x86_64_rhas_4-3.x86_64.rpm rpm -ivh vdt_globus_data_server-VDT1.6.0x86_64_rhas_4-3.x86_64.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-2//x86_64_rhas_4/vdt_globus_essentials-VDT1.6.0x86_64_rhas_4-2.x86_64.rpm rpm -ivh vdt_globus_essentials-VDT1.6.0x86_64_rhas_4-2.x86_64.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-1//x86_rhas_4/vdt_globus_info_server-VDT1.6.0x86_rhas_4-1.i386.rpm rpm -ivh vdt_globus_info_server-VDT1.6.0x86_rhas_4-1.i386.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-1//x86_64_rhas_4/vdt_globus_sdk-VDT1.6.0x86_64_rhas_4-1.x86_64.rpm rpm -ivh vdt_globus_sdk-VDT1.6.0x86_64_rhas_4-1.x86_64.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-1//x86_rhas_4/vdt_globus_info_client-VDT1.6.0x86_rhas_4-1.i386.rpm rpm -ivh vdt_globus_info_client-VDT1.6.0x86_rhas_4-1.i386.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-1//x86_rhas_4/vdt_globus_info_essentials-VDT1.6.0x86_rhas_4-1.i386.rpm rpm -ivh vdt_globus_info_essentials-VDT1.6.0x86_rhas_4-1.i386.rpm

wget http://vdt.cs.wisc.edu/vdt_rpms/1.6.0/release-1//x86_64_rhas_4/vdt_compile_globus_core-VDT1.6.0-1.x86_64.rpm rpm -ivh vdt_compile_globus_core-VDT1.6.0-1.x86_64.rpm

Installtion of the voms rpm

Don't get the version 1.7.16-2 as it is not compatible with libCsec_plugin_GSI.so wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.security.voms-api-c/1.7.15/slc4_x86_64_gcc346/glite-security-voms-api-c-1.7.15-2.slc4.x86_64.rpm rpm -ivh glite-security-voms-api-c-1.7.15-2.slc4.x86_64.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.security.voms-api/1.7.15/slc4_x86_64_gcc346/glite-security-voms-api-1.7.16-2.slc4.x86_64.rpm rpm -ivh glite-security-voms-api-1.7.15-2.slc4.x86_64.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.security.voms-clients/1.7.15/slc4_x86_64_gcc346/glite-security-voms-clients-1.7.16-2.slc4.x86_64.rpm rpm -ivh glite-security-voms-clients-1.7.15-2.slc4.x86_64.rpm

Installation of gsoap and CGSI_soap

The version should be 2.6.9 otherwise it doesn't work. wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.security.cgsi-gsoap/1.1.17/slc4_x86_64_gcc346/CGSI_gSOAP_2.6-dev-1.1.17-2.x86_64.rpm

rpm -ivh CGSI_gSOAP_2.6-dev-1.1.17-2.x86_64.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.security.cgsi-gsoap/1.1.17/slc4_x86_64_gcc346/CGSI_gSOAP_2.6-voms-1.1.17-2.x86_64.rpm

rpm -ivh CGSI_gSOAP_2.6-voms-1.1.17-2.x86_64.rpm

Download the gsoap tar file (see the bottom of the page) and install it. (./configure, make and make install).

N.B : if you encounter some problems with this version of CGSI_soap, try to install version 1.1.15-6 of CGSI_soap instead.

Installation of other rpms

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/org.glite.rgma.gin/5.0.9/slc4_x86_64_gcc346/glite-rgma-gin-5.0.9-1.noarch.rpm

rpm -ivh glite-rgma-gin-5.0.9-1.noarch.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/lcg-info-dynamic-dpm/1.3.3/noarch/lcg-info-dynamic-dpm-1.3.3-1.noarch.rpm rpm -ivh lcg-info-dynamic-dpm-1.3.3-1.noarch.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/lcg-info-templates/1.0.15/noarch/lcg-info-templates-1.0.15-1.noarch.rpm

rpm -ivh lcg-info-templates-1.0.15-1.noarch.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/lcg-infosites/2.6.2/slc4_x86_64_gcc346/lcg-infosites-2.6.2-1.slc4.x86_64.rpm rpm -ivh lcg-infosites-2.6.2-1.slc4.x86_64.rpm

wget http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/LCG-DM/1.6.4/slc4_x86_64_gcc346/lcg-dm-common-1.6.4-3sec.x86_64.rpm

rpm -ivh lcg-dm-common-1.6.4-3sec.x86_64.rpm

Installtion of the MySQL rpms

wget http://mysql.isu.edu.tw/Downloads/MySQL-4.1/MySQL-server-standard-4.1.22-0.rhel4.x86_64.rpm

rpm -ivh MySQL-server-standard-4.1.22-0.rhel4.x86_64.rpm

wget http://mysql.isu.edu.tw/Downloads/MySQL-4.1/MySQL-devel-standard-4.1.22-0.rhel4.x86_64.rpm

rpm -ivh MySQL-devel-standard-4.1.22-0.rhel4.x86_64.rpm

wget http://mysql.isu.edu.tw/Downloads/MySQL-4.1/MySQL-shared-standard-4.1.22-0.rhel4.x86_64.rpm

rpm -ivh MySQL-shared-standard-4.1.22-0.rhel4.x86_64.rpm

Get and install the perl-DBD from http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/perl-DBD-MySQL-2.9004-3.1.src.rpm

Installation of the DPM rpms (version 1.6.4)

wget from http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/LCG-DM/1.6.4/slc4_x86_64_gcc346/ and

rpm -ivh DPM-client-1.6.4-3sec.x86_64.rpm

rpm -ivh --nodeps DPM-server-mysql-1.6.4-3sec.x86_64.rpm

rpm -ivh --nodeps DPM-name-server-mysql-1.6.4-3sec.x86_64.rpm

rpm -ivh --nodeps DPM-srm-server-mysql-1.6.4-3sec.x86_64.rpm

rpm -ivh DPM-rfio-server-1.6.4-3sec.x86_64.rpm

rpm -ivh DPM-interfaces-1.6.4-3.x86_64.rpm

Configuration of the DPM

  • Fill in the site-info.def as described here:https://twiki.cern.ch/twiki/bin/view/LCG/YaimGuide301

  • launch /opt/glite/yaim/scripts/configure_node SE_dpm_mysql

If for what any reasons, you need to reexecute the configure_node script, you need to kill the srm services first, using kill -9 `pidof srmv1 srmv2 srmv2.2`.

Problems

Don't hesitate to report any problems.

-- LanaAbadie - 23 May 2007

Topic attachments
I Attachment HistorySorted ascending Action Size Date Who Comment
Compressed Zip archivetar gsoap-linux-2.6.2.tar r1 manage 8180.0 K 2007-05-24 - 16:57 LanaAbadie gsoap 2.6 tar file
Edit | Attach | Watch | Print version | History: r8 < r7 < r6 < r5 < r4 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r6 - 2007-05-30 - LanaAbadie
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    LCG All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback