• Check if the package you want to use is in the SPMA repositories (on dns-sx-01 in /var/www/html/swrep/i386_sl4*). It should if the package comes from a known place, as the cron task (on gw01) that synchronise them seems to work now.
  • check that it is own by apache.
  • Choose in which namespace (dev or pro) you want to make the change.
  • in that namespace, check if the software version you want to use is already in the repositories templates (software/repository*)
    • If not, either regenerate them with the swrep-soap-client command (if there are many updates) or just edit the file and add the right line (if it's a new version of an existing package, I usually copy the line of this package and change the version number).
  • If it is a change you want to apply to all nodes, modify the file "software/pro_software_packages_defaults_i386sl4.tpl".
  • If you want to apply it to only one node or to node of a certain type, you have to add or change a line like the following to the nodes or the system type template:
    "/software/packages"=pkg_repl("busybox-anaconda","1.00.rc1-5", "i386");
Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r3 - 2008-03-11 - LoicBrarda
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    LHCb All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback