Fedora 27 @ dom5     

On this page:

Installed software: diaries

  1. (04.03.18) System installation (Fedora 27)

    General notes

  • The installation was triggered by clicking on the desktop icon "Install to Hard Drive"

  • We did not turn off the "Secure boot" in BIOS despite the fact that the turn-off is often recommended.

  • We shrank the sda3 partition (C disk in Windows 10) of the hard disk such that a free space of
               332427952100 bytes = ~332.43 GB = ~309.60 GiB
    was created between the partitions sda3 and sda4,
    see https://twiki.cern.ch/twiki/bin/view/Main/AVFedotovHowToDom5#8_06_01_18_Shrinking_disk_C_from.
    The disk status after that was:
    liveuser@localhost ~]$ sudo fdisk -l /dev/sda
    
    Disk /dev/sda: 465.8 !GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: DB3ADAE8-183D-4E4E-9B79-38095BEC8515
    
    Device         Start       End   Sectors   Size Type
    /dev/sda1       2048   1026047   1024000   500M EFI System
    /dev/sda2    1026048   1288191    262144   128M Microsoft reserved
    /dev/sda3    1288192 301287423 299999232 143.1G Microsoft basic data
    /dev/sda4  950560768 951482367    921600   450M Windows recovery environment
    /dev/sda5  951482368 976773119  25290752  12.1G Windows recovery environment

  • In Fedora installation, the sda1 EFI system partition was also used by Fedora 27 under the /boot/efi mount point.

  • Details of the installation procedure, step-by-step with screenshots, are described in the next next subsection.
  • The current subsection gives a general description.

  • In the free 332.43 GB HDD space, a new 182 GB partition sda6 was created (leaving 332.43 - 182 = 150.43 GB still free).
  • The new partition is an LVM physical volume with the volume group vg01, of which free 70 GB are reserved for the future, while 112 GB are distributed among the following logical volumes
    lv name label fs-type mount-point size
    lv_swap LV1_SWAP     12 GB
    lv_root1 LV1_ROOT1 ext4 / 30 GB
    lv_opt1 LV1_OPT1 ext4 /opt 20 GB
    lv_x01 LV1_X01 ext4 /x01 50 GB

  • Having run the Fedora installer, called anaconda, we were back to the Fedora Live session.

  • We found installation logs, *.log , in the /tmp/ dir of the Live-Fedora session.
  • We copied them to an external USB flash drive, then stored finally in the
               /opt/root/Install/initial_installation/anaconda_logs
    directory:
    [root@dom5 anaconda_logs]# ll
    total 984
    -rw-r--r--. 1 root root  88370 Mar  4 03:14 anaconda.log
    -rw-r--r--. 1 root root      0 Mar  3 23:42 blivet-gui-utils.log
    -rw-r--r--. 1 root root   2524 Mar  4 00:11 ifcfg.log
    -rw-r--r--. 1 root root      0 Mar  4 03:14 ks-script-3nxws48b.log
    -rw-r--r--. 1 root root      0 Mar  4 03:14 ks-script-uudh4qf6.log
    -rw-r--r--. 1 root root      0 Mar  4 03:14 ks-script-yqvokc6v.log
    -rw-r--r--. 1 root root 394283 Mar  4 02:17 lvm.log
    -rw-r--r--. 1 root root    133 Mar  4 02:20 packaging.log
    -rw-r--r--. 1 root root  70915 Mar  4 03:14 program.log
    -rw-r--r--. 1 root root      0 Mar  3 23:38 sensitive-info.log
    -rw-r--r--. 1 root root 435156 Mar  4 02:21 storage.log
    (see local copies: anaconda.log , ifcfg.log , lvm.log , packaging.log , program.log , storage.log )

  • The screenshots made with Shift+PrtScr, were found in the /home/liveuser/Pictures directory (unlike to what is said about their location in the Installation Guide). We also copied them to the external USB flash drive, and finaly stored in the
               /opt/root/Install/initial_installation/anaconda_screenshots
    directory under the names
               screenshot-NNN.png , NNN = 001-058
    (the initial names were Screenshot_DATETAG_TIMETAG.png, see file renaming_history in the same directory).

  • Two anaconda config files *.cfg were found in the ~root (/root) directory of the final Fedora system. They were copied to the
               /opt/root/Install/initial_installation/anaconda_cfg
    directory:
    [root@dom5 anaconda_cfg]# ll
    total 8
    -rw-------. 1 root root 2124 Mar  4 11:14 anaconda-ks.cfg
    -rw-r--r--. 1 root root 2141 Mar  4 03:43 initial-setup-ks.cfg
    (see local copies: anaconda-ks.cfg , initial-setup-ks.cfg )

    Detailed procedure with screenshots

  • Boot -> Interrupt with F12 in order to change the boot preferences for the current boot
  • Boot mode is set to: UEFI; Secure boot: ON
    • UEFI OPTIONS: -> USB1 - UEFI OS (VerbatimSTORE N GO 5.00)
  • Boot menu:
    • Start Fedora-KDE-Live 27

  • After Fedora-Live has loaded: press the icon "Install to Hard Drive"

  • Press Ctrl+Alt+F2 -> Switch to the root console
    The screenshots are found in /home/liveuser/Pictures
    • mkdir /mnt/sysimage/root/af_copy
      cp -rp /home/liveuser/Pictures /mnt/sysimage/root/af_copy/
      chown root.root /mnt/sysimage/root/af_copy/Pictures
      chown root.root /mnt/sysimage/root/af_copy/Pictures/*
      mkdir /mnt/sysimage/root/af_copy/logs
      cp -rp /tmp/*log /mnt/sysimage/root/af_copy/logs/
    • Also copy /mnt/sysimage/root/af_copy onto a 4gb external usb flash drive. ( mkdir /mnt/usb ; mount /dev/sdc1 /mnt/usb ; ...copy... ; umount /mnt/usb )

  • Press Ctrl+Alt+F1 -> Back to graphical installation window
    screenshot-057.png Show image Close image Show fixed size Show original size
    • Press Finish Configuration
      ....
      "Fedora is now successfully installed and ready for you to use!
      Go ahead and reboot to start using it!"

  • Press Ctrl+Alt+F2 -> Move to the root console
    • copy /tmp/*log and last pic to the 4gb external usb flash drive (.../af_copy_2 dir)

  • Press Ctrl+Alt+F1
    Press Quit
    • Back to liveuser F27-Live session

  • Shutdown...
  • Boot -> a grub2 boot manager screen appears with three options:
    • Fedora ... (Twenty Seven),
    • something like Fedora Rescue,
    • Windows
  • Booting Fedora 27: the boot (this is the firstboot! ) is ok,
    get an invitation (a graphical screen) to login as testuser.

  • Press Ctrl+Alt+F2
    login as root.
    Rename /home and /usr/local:
           cd /
           mv home /opt/
           ln -s opt/home /
    
           mv /usr/local /opt/usr_local
           ln -s /opt/usr_local /usr/local

  2. (05.03.18) Post-installation summaries

    Installed rpm packages

  • 1718 installed packages are listed (sorted) in
               /opt/root/Install/rpm_history/180305.1935.rpm-qa.Initially_installed
    (see here )

  • Missing zsh, emacs, xterm (!) and so on...

    Xorg.log

  • The /var/log/Xorg.0.log of the current session is saved in
               /opt/root/Install/Inst_SW_aux/180304.0439.Xorg.0.log.Soon_after_initial_installation
    (see here )

    fdisk -l /dev/sda

  • [root@dom5 ~]# fdisk -l /dev/sda
    Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: DB3ADAE8-183D-4E4E-9B79-38095BEC8515
    
    Device         Start       End   Sectors   Size Type
    /dev/sda1       2048   1026047   1024000   500M EFI System
    /dev/sda2    1026048   1288191    262144   128M Microsoft reserved
    /dev/sda3    1288192 301287423 299999232 143.1G Microsoft basic data
    /dev/sda4  950560768 951482367    921600   450M Windows recovery environment
    /dev/sda5  951482368 976773119  25290752  12.1G Windows recovery environment
    /dev/sda6  301287424 656771071 355483648 169.5G Linux LVM
    
    Partition table entries are not in disk order.
    

    /etc/fstab

  • [root@dom5 tm]# cat /etc/fstab
    
    #
    # /etc/fstab
    # Created by anaconda on Sun Mar  4 10:21:37 2018
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg01-lv_root1 /                       ext4    defaults        1 1
    UUID=0893-88F0          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
    /dev/mapper/vg01-lv_opt1 /opt                    ext4    defaults        1 2
    /dev/mapper/vg01-lv_x01 /x01                    ext4    defaults        1 2
    /dev/mapper/vg01-lv_swap swap                    swap    defaults        0 0
    

    df

  • [root@dom5 tm]# df -BMB               # MB units, not MiB
    Filesystem                1MB-blocks   Used Available Use% Mounted on
    devtmpfs                      4110MB    0MB    4110MB   0% /dev
    tmpfs                         4124MB    0MB    4124MB   0% /dev/shm
    tmpfs                         4124MB    2MB    4123MB   1% /run
    tmpfs                         4124MB    0MB    4124MB   0% /sys/fs/cgroup
    /dev/mapper/vg01-lv_root1    29397MB 5082MB   22799MB  19% /
    tmpfs                         4124MB    1MB    4124MB   1% /tmp
    /dev/sda1                      521MB   69MB     452MB  14% /boot/efi
    /dev/mapper/vg01-lv_opt1     19555MB  330MB   18208MB   2% /opt
    /dev/mapper/vg01-lv_x01      48947MB   55MB   46375MB   1% /x01
    tmpfs                          825MB    1MB     825MB   1% /run/user/1000
    /dev/sdb1                     3998MB 1706MB    2292MB  43% /run/media/testuser/KINGSTON
    

    blkid

  • [root@dom5 tm]# blkid
    /dev/sda1: LABEL="ESP" UUID="0893-88F0" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="704600fb-4d71-4e5a-88c5-e3ab33b0690d"
    /dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="b501b9fb-801b-42af-9b7f-2d6c5b7da35d"
    /dev/sda3: LABEL="Win10" UUID="EA2247182246E961" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="abf85815-1a5d-40b8-b4e4-92c832c41bce"
    /dev/sda4: LABEL="WINRETOOLS" UUID="7C8E3A828E3A34CC" TYPE="ntfs" PARTUUID="f1e2a51c-5271-45d4-a44a-c3479cf323d9"
    /dev/sda5: LABEL="Image" UUID="06423B7E423B7193" TYPE="ntfs" PARTUUID="a58ba18f-bc35-4d72-90f2-d20576859e86"
    /dev/sda6: UUID="lubohO-vygY-Mv9H-lN4I-k4oy-lD1x-zgOZG5" TYPE="LVM2_member" PARTUUID="e47bf59c-df26-430d-b5b5-4dee202f0285"
    /dev/mapper/vg01-lv_root1: LABEL="LV1_ROOT1" UUID="ef091460-8a7b-4aba-8acb-9a6ce24fbbb8" TYPE="ext4"
    /dev/mapper/vg01-lv_swap: LABEL="LV1_SWAP" UUID="3b983a53-50fe-4c5f-afff-2872d89f76c1" TYPE="swap"
    /dev/mapper/vg01-lv_opt1: LABEL="LV1_OPT1" UUID="0c25dca9-35d0-4913-ad0e-a6e17f714daa" TYPE="ext4"
    /dev/mapper/vg01-lv_x01: LABEL="LV1_X01" UUID="0e9bf704-a8eb-41aa-a92b-b87c663c781d" TYPE="ext4"
    /dev/sdb1: LABEL="KINGSTON" UUID="F985-88DE" TYPE="vfat" PARTUUID="5eb7cc3f-01"
    

    mount

  • root@dom5 ~]# mount      # split the output lines with "\^J     "
                             # for a better readability
    sysfs on /sys type sysfs \
         (rw,nosuid,nodev,noexec,relatime,seclabel)
    proc on /proc type proc \
         (rw,nosuid,nodev,noexec,relatime)
    devtmpfs on /dev type devtmpfs \
         (rw,nosuid,seclabel,size=4013468k,nr_inodes=1003367,mode=755)
    securityfs on /sys/kernel/security type securityfs \
         (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs \
         (rw,nosuid,nodev,seclabel)
    devpts on /dev/pts type devpts \
         (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs \
         (rw,nosuid,nodev,seclabel,mode=755)
    tmpfs on /sys/fs/cgroup type tmpfs \
         (ro,nosuid,nodev,noexec,seclabel,mode=755)
    cgroup on /sys/fs/cgroup/unified type cgroup2 \
         (rw,nosuid,nodev,noexec,relatime,seclabel)
    cgroup on /sys/fs/cgroup/systemd type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,xattr,name=systemd)
    pstore on /sys/fs/pstore type pstore \
         (rw,nosuid,nodev,noexec,relatime,seclabel)
    efivarfs on /sys/firmware/efi/efivars type efivarfs \
         (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/cpuset type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,cpuset)
    cgroup on /sys/fs/cgroup/devices type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,devices)
    cgroup on /sys/fs/cgroup/memory type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,memory)
    cgroup on /sys/fs/cgroup/blkio type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,blkio)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/freezer type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,freezer)
    cgroup on /sys/fs/cgroup/hugetlb type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,hugetlb)
    cgroup on /sys/fs/cgroup/perf_event type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,perf_event)
    cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,net_cls,net_prio)
    cgroup on /sys/fs/cgroup/pids type cgroup \
         (rw,nosuid,nodev,noexec,relatime,seclabel,pids)
    configfs on /sys/kernel/config type configfs \
         (rw,relatime)
    /dev/mapper/vg01-lv_root1 on / type ext4 \
         (rw,relatime,seclabel,data=ordered)
    selinuxfs on /sys/fs/selinux type selinuxfs \
         (rw,relatime)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs \
         (rw,relatime,fd=38,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,\
         pipe_ino=1008)
    mqueue on /dev/mqueue type mqueue \
         (rw,relatime,seclabel)
    debugfs on /sys/kernel/debug type debugfs \
         (rw,relatime,seclabel)
    hugetlbfs on /dev/hugepages type hugetlbfs \
         (rw,relatime,seclabel,pagesize=2M)
    tmpfs on /tmp type tmpfs \
         (rw,nosuid,nodev,seclabel)
    /dev/sda1 on /boot/efi type vfat \
         (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,\
         shortname=winnt,errors=remount-ro)
    /dev/mapper/vg01-lv_opt1 on /opt type ext4 \
         (rw,relatime,seclabel,data=ordered)
    /dev/mapper/vg01-lv_x01 on /x01 type ext4 \
         (rw,relatime,seclabel,data=ordered)
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs \
         (rw,relatime)
    tmpfs on /run/user/1000 type tmpfs \
         (rw,nosuid,nodev,relatime,seclabel,size=805420k,mode=700,uid=1000,gid=1000)
    /dev/sdb1 on /run/media/testuser/KINGSTON type vfat \
         (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,\
         codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,\
         errors=remount-ro,uhelper=udisks2)
    

    vgscan, vgdisplay

  • [root@dom5 ~]# vgscan
      Reading volume groups from cache.
      Found volume group "vg01" using metadata type lvm2
    

  • [root@dom5 ~]# vgdisplay
      --- Volume group ---
      VG Name               vg01
      System ID             
      Format                lvm2
      Metadata Areas        1
      Metadata Sequence No  5
      VG Access             read/write
      VG Status             resizable
      MAX LV                0
      Cur LV                4
      Open LV               4
      Max PV                0
      Cur PV                1
      Act PV                1
      VG Size               169.50 GiB
      PE Size               4.00 MiB
      Total PE              43393
      Alloc PE / Size       26705 / <104.32 GiB
      Free  PE / Size       16688 / <65.19 GiB
      VG UUID               RHrKDR-mEoH-UtHZ-wZtP-hks6-aAwc-TasQYQ
    

    lvscan, lvdisplay

  • [root@dom5 ~]# lvscan
      ACTIVE            '/dev/vg01/lv_root1' [27.94 GiB] inherit
      ACTIVE            '/dev/vg01/lv_opt1' [<18.63 GiB] inherit
      ACTIVE            '/dev/vg01/lv_x01' [<46.57 GiB] inherit
      ACTIVE            '/dev/vg01/lv_swap' [<11.18 GiB] inherit
    

  • [root@dom5 ~]# lvdisplay
      --- Logical volume ---
      LV Path                /dev/vg01/lv_root1
      LV Name                lv_root1
      VG Name                vg01
      LV UUID                WwGQHy-pirL-TMc7-43mV-Vwou-yR9F-SfSJ1n
      LV Write Access        read/write
      LV Creation host, time dom5, 2018-03-04 10:17:02 +0300
      LV Status              available
      # open                 1
      LV Size                27.94 GiB
      Current LE             7153
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:0
       
      --- Logical volume ---
      LV Path                /dev/vg01/lv_opt1
      LV Name                lv_opt1
      VG Name                vg01
      LV UUID                TQeyrX-7VLy-Ltg1-EUhm-t3rb-eFTG-8d0oWx
      LV Write Access        read/write
      LV Creation host, time dom5, 2018-03-04 10:17:04 +0300
      LV Status              available
      # open                 1
      LV Size                <18.63 GiB
      Current LE             4769
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:2
       
      --- Logical volume ---
      LV Path                /dev/vg01/lv_x01
      LV Name                lv_x01
      VG Name                vg01
      LV UUID                LBfcaw-qCQn-Xjfe-5AIV-2jB9-QmcS-Nqp7im
      LV Write Access        read/write
      LV Creation host, time dom5, 2018-03-04 10:17:07 +0300
      LV Status              available
      # open                 1
      LV Size                <46.57 GiB
      Current LE             11921
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:3
       
      --- Logical volume ---
      LV Path                /dev/vg01/lv_swap
      LV Name                lv_swap
      VG Name                vg01
      LV UUID                GV6Uce-00Iw-HEuu-uudV-iney-OCBf-XN4muM
      LV Write Access        read/write
      LV Creation host, time dom5, 2018-03-04 10:17:11 +0300
      LV Status              available
      # open                 2
      LV Size                <11.18 GiB
      Current LE             2862
      Segments               1
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           253:1
    

  3. (12.03.18) The first Software Update

  • The update is done from the testuser session:
    Sys.tray -> Hidden icons -> Software Updates -> Check for updates
    • ... message: "892 new updates"
    • ~03:30 start by clicking "Install Updates" -> ...downloading...
    • ~04:07 updating packages...
    • ~04:17 message "Successfully updated 892 packages"
  • NB. The downloaded packages may have been temporarily stored in /var/cache/PackageKit/metadata/updates/packages : du -ms reported 1076 MB at the "updating packages" step, then the directory became empty after the update had finished.

  4. (16.03.18) A regular system SW Update (no.2)

  • The update was done like in sec.3 after a notification on "244 new updates" had appeared.

  • 1741 rpm packages are reported by the rpm -qa (there were 1736 after the first update in sec.3).
    The (sorted) output is stored in
               /opt/root/Install/rpm_history/180316.0201.rpm-qa.After_sw_update_No2
    (see local copy )

  5. (16.03.18) Installing zsh, emacs, xterm

  • The packages zsh (+ zsh-html, zsh-lovers), emacs and xterm are installed via the Software Management tool dnfdragora ( f -> Applications -> Administration -> Install & Remove Software) by (searching for, and) selecting all the needed 5 packages, then pressing Apply.
    13 packages in total (5 selected + 8 additionally required) are installed

  • The `rpm -qa | sort' output after the installation (1754 packages in total):
               /opt/root/Install/rpm_history/180316.0318.rpm-qa.zsh_emacs_xterm_installed
    (see local copy )

  • The 13 installed packages are:
    [root@dom5 rpm_history]# diff 180316.0201.After_sw_update_No2 \
                                  180316.0318.zsh_emacs_xterm_installed \
                             |grep ">"
    
    > emacs-25.3-3.fc27.x86_64
    > emacs-common-25.3-3.fc27.x86_64
    > ImageMagick-libs-6.9.9.27-1.fc27.x86_64
    > liblockfile-1.09-7.fc27.x86_64
    > libotf-0.9.13-10.fc27.x86_64
    > libwmf-lite-0.2.8.4-53.fc27.x86_64
    > m17n-db-1.7.0-9.fc27.noarch
    > m17n-lib-1.7.0-8.fc27.x86_64
    > xterm-330-3.fc27.x86_64
    > xterm-resize-330-3.fc27.x86_64
    > zsh-5.4.1-2.fc27.x86_64
    > zsh-html-5.4.1-2.fc27.noarch
    > zsh-lovers-0.9.0-5.fc27.noarch
    

    zsh-html

  • zsh-html installs a multi-page html document "The Z Shell Manual" in the /usr/share/doc/zsh-html/ directory with the top page being
               /usr/share/doc/zsh-html/index.html

    zsh-lovers

  • zsh-lovers "is a collection of tips, tricks and examples for the Z shell".
    It is installed as a man page (man zsh-lovers):
    [testuser@dom5 ~]$ rpm -ql zsh-lovers
    /usr/share/doc/zsh-lovers
    /usr/share/doc/zsh-lovers/COPYING
    /usr/share/doc/zsh-lovers/README
    /usr/share/man/man1/zsh-lovers.1.gz
    

  6. (16.03.18) ~testuser/.emacs, ~root/.emacs

  • We copy .emacs from ~fedotov/.emacs @ Fedora 18 @ dom3

  • ~testuser/.emacs:
    [testuser@dom5 ~]$ pwd
    /home/testuser
    [testuser@dom5 ~]$ ll .emacs
    ls: cannot access '.emacs': No such file or directory
    [testuser@dom5 ~]$ scp -p fedotov@192.168.100.102:.emacs .
    fedotov@192.168.100.102's password: 
    .emacs                                        100% 3505   215.8KB/s   00:00    
    [testuser@dom5 ~]$ ll .emacs
    -rw-r--r--. 1 testuser testuser 3505 Aug 26  2010 .emacs
    

  • ~root/.emacs:
    [root@dom5 ~]# pwd
    /root
    [root@dom5 ~]# ll .emacs
    ls: cannot access '.emacs': No such file or directory
    [root@dom5 ~]# cp -p ~testuser/.emacs .
    [root@dom5 ~]# chown root.root .emacs
    [root@dom5 ~]# ll .emacs
    -rw-r--r--. 1 root root 3505 Aug 26  2010 .emacs
    

  7. (17.03.18) A regular SW update (No.3)

The update was done like in sec.4 after a notification on "7 new updates" had appeared.

  • The update finished with the following notifications:
    • Update Error:The PackageKit daemon has crashed
    • Updates Installed: Successfully installed 7 packages

  • Despite the crash, the update seems to really have finished.
    1754 rpm packages are reported by the rpm -qa -- the same number as it was after the prev.update in sect.5 .
    Although warnings appear at the first call:
    [root@dom5 rpm_history]# rpm -qa |wc -l
    warning: rpmdb: BDB2053 Freeing read locks for locker 0x5d: 1638/139879117266304
    warning: rpmdb: BDB2053 Freeing read locks for locker 0x5f: 1638/139879117266304
    1754
    [root@dom5 rpm_history]# rpm -qa |wc -l
    1754
    
    The (sorted) rpm -qa output is stored in
               /opt/root/Install/rpm_history/180317.2243.rpm-qa.After_reg_sw_update_No3
    (see local copy )

  • The 7 updated packeges can be seen from
    [root@dom5 rpm_history]# diff 180316.0318.zsh_emacs_xterm_installed \
                                  180317.2243.rpm-qa.After_reg_sw_update_No3 \
                                  | grep -E "<|>"
    < firefox-58.0.2-1.fc27.x86_64
    > firefox-59.0-4.fc27.x86_64
    < kernel-4.13.9-300.fc27.x86_64
    < kernel-core-4.13.9-300.fc27.x86_64
    > kernel-4.15.9-300.fc27.x86_64
    < kernel-modules-4.13.9-300.fc27.x86_64
    > kernel-core-4.15.9-300.fc27.x86_64
    < kernel-modules-extra-4.13.9-300.fc27.x86_64
    > kernel-modules-4.15.9-300.fc27.x86_64
    > kernel-modules-extra-4.15.9-300.fc27.x86_64
    < python3-3.6.4-8.fc27.x86_64
    > python3-3.6.4-9.fc27.x86_64
    < python3-libs-3.6.4-8.fc27.x86_64
    > python3-libs-3.6.4-9.fc27.x86_64
    
    • NB. There were 3 versions of the kernel packages before this update. The oldest one, 4.13.9-300, has been removed.
      Thus, there are again 3 versions installed:
      [root@dom5 rpm_history]# rpm -q kernel
      kernel-4.15.7-300.fc27.x86_64
      kernel-4.15.8-300.fc27.x86_64
      kernel-4.15.9-300.fc27.x86_64
      

  8. ( 18.03.18) Creating account `fedotov'

  • The graphical application invoked with
               f -> type `user' -> User Manager
    seems to be oversimplified and dos not allow e.g. user and group id's to be specified.

  • Therefore, we use command line interfaces.

  • We try to create the user fedotov with
               (user id, group id) = (501,501)
    as it was in F10 @ dom2 and F17,F18 @ dom3.

  • First we specify the UID only:
               [root@dom5 ~]# useradd -c "Alexander Fedotov" -u 501 -s /bin/zsh fedotov
    The result for GID is sort of wrong:
               [root@dom5 ~]# id fedotov
               uid=501(fedotov) gid=1001(fedotov) groups=1001(fedotov)
    Therefore, we delete the account with
               [root@dom5 ~]# userdel -r fedotov
    And create first the group, then create the user inside the already existing group:
    [root@dom5 ~]# groupadd -g 501 fedotov
    [root@dom5 ~]# useradd -c "Alexander Fedotov" -u 501 -g 501 -s /bin/zsh fedotov
    [root@dom5 ~]# id fedotov
    uid=501(fedotov) gid=501(fedotov) groups=501(fedotov)
    [root@dom5 ~]# ls -a /home/fedotov/
    .  ..  .bash_logout  .bash_profile  .bashrc  .emacs  .mozilla  .zshrc
    

  • Next -- set a password:
    [root@dom5 ~]# passwd fedotov
    Changing password for user fedotov.
    New password: 
    BAD PASSWORD: The password is shorter than 8 characters
    Retype new password: 
    passwd: all authentication tokens updated successfully.
    

  • We could then login as fedotov via the Ctrl+Alt+F2 console.
  • The second login is here:
    [testuser@dom5 ~]$ su fedotov
    Password: 
    [fedotov@dom5]/opt/home/testuser% cd
    [fedotov@dom5]~% ll -a
    total 80
    drwx------. 3 fedotov fedotov  4096 Mar 18 05:59 .
    drwxr-xr-x. 4 root    root     4096 Mar 18 05:50 ..
    -rw-r--r--. 1 fedotov fedotov    18 Feb 13 17:05 .bash_logout
    -rw-r--r--. 1 fedotov fedotov   193 Feb 13 17:05 .bash_profile
    -rw-r--r--. 1 fedotov fedotov   231 Feb 13 17:05 .bashrc
    -rw-r--r--. 1 fedotov fedotov   334 Sep 15  2017 .emacs
    drwxr-xr-x. 4 fedotov fedotov  4096 Nov  5 10:25 .mozilla
    -rw-------. 1 fedotov fedotov    98 Mar 18 05:59 .xauthKFJclK
    -rw-rw-r--. 1 fedotov fedotov 42428 Mar 18 05:55 .zcompdump
    -rw-r--r--. 1 fedotov fedotov   658 Mar  6 18:46 .zshrc
    [fedotov@dom5]~% echo $SHELL
    /bin/zsh
    

  • So far, everythinng look reasonable...
  • Now, reboot ... and perform a KDE login ... success.
    The amount of files/dirs in the home dir has increased:
    [fedotov@dom5]~% ll -a
    total 144
    drwx------. 15 fedotov fedotov  4096 Mar 18 06:39 .
    drwxr-xr-x.  4 root    root     4096 Mar 18 05:50 ..
    -rw-r--r--.  1 fedotov fedotov    18 Feb 13 17:05 .bash_logout
    -rw-r--r--.  1 fedotov fedotov   193 Feb 13 17:05 .bash_profile
    -rw-r--r--.  1 fedotov fedotov   231 Feb 13 17:05 .bashrc
    drwxr-xr-x. 10 fedotov fedotov  4096 Mar 18 06:52 .cache
    drwxrwxr-x. 11 fedotov fedotov  4096 Mar 18 06:52 .config
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:40 Desktop
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Documents
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Downloads
    -rw-r--r--.  1 fedotov fedotov   334 Sep 15  2017 .emacs
    -rw-------.  1 fedotov fedotov    16 Mar 18 06:39 .esd_auth
    -rw-r--r--.  1 fedotov fedotov    76 Sep 21 10:40 .gtkrc-2.0-kde4
    drwxr-xr-x.  3 fedotov fedotov  4096 Mar 18 06:40 .kde
    drwxr-xr-x.  3 fedotov fedotov  4096 Mar 18 06:39 .local
    drwxr-xr-x.  6 fedotov fedotov  4096 Mar 18 06:43 .mozilla
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Music
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Pictures
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Public
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Templates
    drwxr-xr-x.  2 fedotov fedotov  4096 Mar 18 06:39 Videos
    -rw-r--r--.  1 fedotov fedotov    98 Mar 18 06:39 .Xauthority
    -rw-------.  1 fedotov fedotov  7859 Mar 18 06:48 .xsession-errors
    -rw-rw-r--.  1 fedotov fedotov 42428 Mar 18 05:55 .zcompdump
    -rw-r--r--.  1 fedotov fedotov   658 Mar  6 18:46 .zshrc
    

  9. (18.03.18) ~fedotov/.emacs

  • We copy .emacs from ~testuser/.emacs (the latter being a copy of ~fedotov/.emacs @ Fedora 18 @ dom3
    [fedotov@dom5]~% mv .emacs .emacs.original
    [root@dom5 ~]# cp -p ~testuser/.emacs ~fedotov/
    [root@dom5 ~]# chown fedotov.fedotov  ~fedotov/.emacs
    

  10. (18.03.18) Modify /etc/sddm.conf to enable an arbitrary-user invitation in Login Screen

  • By default, the Login Screen contained only an invitation for the "Test User AF" (with a password field only). In order to login as "fedotov" we had to press ~ "Login as different user", a new screen appeared, with username,password fields.

  • The following modification of /etc/sddm.conf results in a new Login Screen appearance where username,password fields are available from the very beginning, and, moreover, the username field is prefilled with the username from the previous KDE session.
    • The /etc/sddm.conf (coming from the sddm-0.15.0-1.fc27.x86_64 package) is saved in the /etc/sddm.conf.original
    • The sddm.conf moved to /usr/local/etc/ with a link left in /etc:
                 [root@dom5 etc]# mv /etc/sddm.conf /usr/local/etc/
                 [root@dom5 etc]# ln -s /usr/local/etc/sddm.conf  /etc/
    • Inserted into the sddm.conf is the line with MinimumUid=501 :
      ...
      [Users]
      ...
      # Minimum user id for displayed users
      #MinimumUid=1000
      # AF 18.03.18 Add an uncommented setting with value=501
      # in order a login-screen invitation for an arbitrary user (including
      # the username field) to be shown i.o. a single invitation for the
      # `Test User AF'
      MinimumUid=501
      ...
      

  11. (24.03.18) A regular SW update (No.4)

  • The update was done like in sec.7 after a notification on "53 new updates" had appeared.
    Finished with the message:
    • "Updates Installed: Successfully installed 53 packages"

  • The number of installed packages is 1754, it did not change since the previous update in sect.7 .
    The (sorted) rpm -qa output is stored in
               /opt/root/Install/rpm_history/180324.0024.rpm-qa.After_reg_sw_update_No4
    (see local copy )

  • The new packages are: More... Close
    ...
    root@dom5 rpm_history]# diff 180317.2243.rpm-qa.After_reg_sw_update_No3 \
                                 180324.0024.rpm-qa.After_reg_sw_update_No4 \
                                 |grep ">"
    > curl-7.55.1-10.fc27.x86_64
    > desktop-file-utils-0.23-6.fc27.x86_64
    > elfutils-0.170-10.fc27.x86_64
    > elfutils-default-yama-scope-0.170-10.fc27.noarch
    > elfutils-libelf-0.170-10.fc27.x86_64
    > elfutils-libs-0.170-10.fc27.x86_64
    > firefox-59.0.1-1.fc27.x86_64
    > freerdp-2.0.0-39.20180314gitf8baeb7.fc27.x86_64
    > freerdp-libs-2.0.0-39.20180314gitf8baeb7.fc27.x86_64
    > ImageMagick-libs-6.9.9.38-1.fc27.x86_64
    > jansson-2.11-1.fc27.x86_64
    > jemalloc-4.5.0-5.fc27.x86_64
    > kde-runtime-17.08.3-6.fc27.x86_64
    > kde-runtime-flags-17.08.3-6.fc27.noarch
    > kde-runtime-libs-17.08.3-6.fc27.x86_64
    > kernel-4.15.10-300.fc27.x86_64
    > kernel-core-4.15.10-300.fc27.x86_64
    > kernel-modules-4.15.10-300.fc27.x86_64
    > kernel-modules-extra-4.15.10-300.fc27.x86_64
    > libappstream-glib-0.7.7-1.fc27.x86_64
    > libcurl-7.55.1-10.fc27.x86_64
    > libgit2-0.26.3-1.fc27.x86_64
    > libipa_hbac-1.16.1-1.fc27.x86_64
    > libsss_autofs-1.16.1-1.fc27.x86_64
    > libsss_certmap-1.16.1-1.fc27.x86_64
    > libsss_idmap-1.16.1-1.fc27.x86_64
    > libsss_nss_idmap-1.16.1-1.fc27.x86_64
    > libsss_sudo-1.16.1-1.fc27.x86_64
    > libtirpc-1.0.3-0.fc27.x86_64
    > libvorbis-1.3.6-1.fc27.x86_64
    > libwinpr-2.0.0-39.20180314gitf8baeb7.fc27.x86_64
    > microcode_ctl-2.1-22.fc27.x86_64
    > pcre2-10.31-3.fc27.x86_64
    > pcre2-utf16-10.31-3.fc27.x86_64
    > python2-2.7.14-10.fc27.x86_64
    > python2-libs-2.7.14-10.fc27.x86_64
    > python3-pytz-2017.2-7.fc27.noarch
    > python3-sssdconfig-1.16.1-1.fc27.noarch
    > selinux-policy-3.13.1-283.28.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.28.fc27.noarch
    > shared-mime-info-1.9-2.fc27.x86_64
    > sssd-1.16.1-1.fc27.x86_64
    > sssd-ad-1.16.1-1.fc27.x86_64
    > sssd-client-1.16.1-1.fc27.x86_64
    > sssd-common-1.16.1-1.fc27.x86_64
    > sssd-common-pac-1.16.1-1.fc27.x86_64
    > sssd-ipa-1.16.1-1.fc27.x86_64
    > sssd-kcm-1.16.1-1.fc27.x86_64
    > sssd-krb5-1.16.1-1.fc27.x86_64
    > sssd-krb5-common-1.16.1-1.fc27.x86_64
    > sssd-ldap-1.16.1-1.fc27.x86_64
    > sssd-nfs-idmap-1.16.1-1.fc27.x86_64
    > sssd-proxy-1.16.1-1.fc27.x86_64
    

  12. (25.03.18) /x01/legacy

  • The directory is a copy of
               dom3 -> Fedora 18 -> /x01/legacy
    where we added a current status of
               Fedora 18 @ dom3 in /x01/legacy/dom3/F18
    (a tar ball was copied via
               [root@dom5 x01]# scp -p  fedotov@192.168.100.102:/x01/legacy.tar .
    )

  13. (26.03.18) A regular SW update

  • 9 packages updated via SW Updates in two steps: 8 first, then one more.
    The (sorted) rpm -qa output (1754 entries) is stored in
               /opt/root/Install/rpm_history/180326.1720.rpm-qa.After_reg_sw_update
    (see local copy )

  • The new versions of the packages are:
    [root@dom5 rpm_history]# diff 180324.0024.rpm-qa.After_reg_sw_update_No4 \
                                  180326.1720.rpm-qa.After_reg_sw_update \
                                  | grep ">"
    > llvm-libs-5.0.1-5.fc27.x86_64
    > nspr-4.19.0-1.fc27.x86_64
    > nss-3.36.0-1.0.fc27.x86_64
    > nss-softokn-3.36.0-1.0.fc27.x86_64
    > nss-softokn-freebl-3.36.0-1.0.fc27.x86_64
    > nss-sysinit-3.36.0-1.0.fc27.x86_64
    > nss-tools-3.36.0-1.0.fc27.x86_64
    > nss-util-3.36.0-1.0.fc27.x86_64
    > qt5-qtwebengine-5.10.1-4.fc27.x86_64
    

  14. (26.03.18) xx, xxx scripts

  • copied from dom3 F18 to /usr/local/bin/ :
    [root@dom5 ~]# cp -p  /x01/legacy/dom3/F18/opt/usr_local/bin/xx* /usr/local/bin/
    [root@dom5 ~]# ll /usr/local/bin/xx*
    -rwxr-xr-x. 1 root root 1162 Dec 10  2001 /usr/local/bin/xx
    -rwxr-xr-x. 1 root root  311 Jan  6  2000 /usr/local/bin/xxx
    

    UPD 14.05.18: xx,xxx modified

  • Both scripts have been modified: the option
               -xrm "xterm*allowTitleOps: false"
    added to xterm in order to protect the window name from changes by programs running in the window (e.g. a shell under root).

    UPD 21.05.18: xx modified

  • The code strongly simplified by using the xterm option
               `-e "$*"' i.o. `-e $*'
    both with and without pipe.

  15. (26.03.18) ~root/.bashrc -- change the interactive prompt

  • Copy it from F18 @ dom3 to get a "nicer" command prompt
    (see a discussion in /x01/legacy/dom3/F18/opt/root/Install/Installed_SW , section 33, or a web version ) :
    [root] ~ $ mv .bashrc .bashrc.original_from_sys_install
    [root] ~ $ cp -p /x01/legacy/dom3/F18/root/.bashrc .
    [root] ~ $ diff .bashrc.original_from_sys_install .bashrc
    > # AF 11.06.14 Change the variable PS1 defining command prompt
    > #             The sys default was "[\u@\h \W]\\$"
    > # export PS1="[\u] \w $ "
    > #             make it the prompt "bold purple"
    > export PS1="\[\033[1;35m\][\u] \w $\[\033[0m\] "
    

  16. (26.03.18) /usr/local/etc/lesskey.bin

  • copied from F18 @ dom5 :
    [root] ~ $ cp -p /x01/legacy/dom3/F18/opt/usr_local/etc/lesskey.bin \
                     /usr/local/etc/
    [root] ~ $ ll /usr/local/etc/lesskey.bin 
    -rw-r--r--. 1 root root 534 Apr 13  2006 /usr/local/etc/lesskey.bin
    
    The file origin is described in /x01/legacy/dom3/F18/opt/root/Install/Installed_SW, section 34 ( a web version )

  • The reason to install it: /usr/local/etc/lesskey.bin is the contents of LESSKEY env. variable defined traditionally in .zprofile

  • UPD 28.03.18
    We do not know what is this ancient file good for, but a negative effect of LESSKEY=/usr/local/etc/lesskey.bin is observed: man pages get desplayed in an unreadable format with all the numerous control / escapes sequences on the screen.
    This can be cured by giving the "-R" command to "less" which is used as a pager in "man".
    Unfortunately, the "-R" option can not be transferred via LESS="-i -M -R" in .zprofile (tried, not worked). We force this option via export PAGER="/usr/bin/less -R" in .zprofile .

  17. (26.03.18) ~fedotov/.zprofile

  • An edited version of ~fedotov/.zprofile.dom3-F18 taken from /x01/legacy/dom3/F18/home/fedotov/.zprofile

  • Writes env|sort output to the stdout -- to be found in = $HOME/.xsession-errors=

  • Defines variables:
         SCREEN_RESOLUTION=768
         EDITOR=/usr/bin/emacs 
         LANG=en_US       # (i.o. system default "en_US.UTF-8")
         (RUSFONT=...     # not yet, to be worked out later)    
         HISTFILE=$HOME/.history.${HOST}
         HISTSIZE=2000
         SAVEHIST=$HISTSIZE
         LESS="-i -M"
         LESSCHARSET=latin1
         LESSKEY=/usr/local/etc/lesskey.bin
         (LESSOPEN='|/usr/bin/lesspipe.sh %s'  # already defined by F27)
    

  • UPD 28.03.18
    The `-R' option added to `less' called from `man' to neutralize the negative effect of LESSKEY=/usr/local/etc/lesskey.bin that causes man pages to be displayed in an unreadable format (with control sequences seen):
         PAGER="/usr/bin/less -R"
    

  • UPD 10.04.18
         RUSFONT=-bitstream-terminal-medium-r-normal--18-180-75-75-c-11-koi8-r
    

  18. (26.03.18) Switch on Restore Previous Session (user fedotov)

  • f -> Computer -> System Settings -> Workspace -> Startup and Shutdown -> Desktop session -> panel "On login" -> check Restore previous session -> Apply

  19. (27.03.18) ~fedotov/.config/plasma-workspace/env/fedotov_settings.sh -- reset LANG=en_US

  • The LANG=en_US setting in .zprofile (see sect.17) gets overriden somewhere back to LANG=en_US.UTF-8, which is observed in all the processes in the KDE session.

  • google search: kde lang variable

  • Following the above hint, we create
               ~fedotov/.config/plasma-workspace/env/fedotov_settings.sh
    (note that the directory ~/.config/plasma-workspace did not exist before)
    with the following properties and contents:
    [fedotov@dom5]~% ll .config/plasma-workspace/env/fedotov_settings.sh      
    -rwxrwxr-x. 1 fedotov fedotov 47 Mar 27 01:40 .config/plasma-workspace/env/fedotov_settings.sh
    
    [fedotov@dom5]~% cat .config/plasma-workspace/env/fedotov_settings.sh
    export LANG=en_US
    export FEDOTOV_SETTINGS=true
    

  • After the logout / login we observe the desired behaviour:
    [fedotov@dom5]~% echo $FEDOTOV_SETTINGS 
    true
    [fedotov@dom5]~% echo $LANG
    en_US
    

  20. (31.03.18) A regular SW update

  • 165 updates installed via SW Updates.
    All the installed packages (1756 in total -- vs 1754 before) are listed in
               /opt/root/Install/rpm_history/180331.2123.rpm-qa.After_reg_sw_update
    (see local copy )

  • The 165 updated + new ones: More... Close
    [root] ~/opt_root_Install/rpm_history $ \
         diff   180326.1720.rpm-qa.After_reg_sw_update \
                180331.2123.rpm-qa.After_reg_sw_update \
                | grep ">"
    > akonadi-import-wizard-17.12.3-1.fc27.x86_64
    > akregator-17.12.3-1.fc27.x86_64
    > akregator-libs-17.12.3-1.fc27.x86_64
    > bind-libs-9.11.3-2.fc27.x86_64
    > bind-libs-lite-9.11.3-2.fc27.x86_64
    > bind-license-9.11.3-2.fc27.noarch
    > bind-utils-9.11.3-2.fc27.x86_64
    > bluedevil-5.12.3-1.fc27.x86_64
    > breeze-cursor-theme-5.12.3-1.fc27.noarch
    > calligra-core-3.1.0-2.fc27.x86_64
    > calligra-libs-3.1.0-2.fc27.x86_64
    > calligra-sheets-3.1.0-2.fc27.x86_64
    > calligra-sheets-libs-3.1.0-2.fc27.x86_64
    > calligra-stage-3.1.0-2.fc27.x86_64
    > calligra-stage-libs-3.1.0-2.fc27.x86_64
    > calligra-words-3.1.0-2.fc27.x86_64
    > calligra-words-libs-3.1.0-2.fc27.x86_64
    > dnsmasq-2.79-1.fc27.x86_64
    > firefox-59.0.2-1.fc27.x86_64
    > flatpak-0.10.4-1.fc27.x86_64
    > flatpak-libs-0.10.4-1.fc27.x86_64
    > freerdp-2.0.0-40.20180320gitde83f4d.fc27.x86_64
    > freerdp-libs-2.0.0-40.20180320gitde83f4d.fc27.x86_64
    > gd-2.2.5-3.fc27.x86_64
    > grantlee-editor-17.12.3-1.fc27.x86_64
    > grantlee-editor-libs-17.12.3-1.fc27.x86_64
    > grubby-8.40-8.fc27.x86_64
    > gsm-1.0.17-4.fc27.x86_64
    > kactivitymanagerd-5.12.3-1.fc27.x86_64
    > kaddressbook-17.12.3-1.fc27.x86_64
    > kaddressbook-libs-17.12.3-1.fc27.x86_64
    > kde-cli-tools-5.12.3-1.fc27.x86_64
    > kdecoration-5.12.3-1.fc27.x86_64
    > kde-gtk-config-5.12.3-1.fc27.x86_64
    > kdepim-addons-17.12.3-2.fc27.x86_64
    > kdepim-apps-libs-17.12.3-1.fc27.x86_64
    > kdepim-runtime-17.12.3-1.fc27.x86_64
    > kdepim-runtime-libs-17.12.3-1.fc27.x86_64
    > kdeplasma-addons-5.12.3-1.fc27.x86_64
    > kde-style-breeze-5.12.3-1.fc27.x86_64
    > kdesu-5.12.3-1.fc27.x86_64
    > kernel-4.15.13-300.fc27.x86_64
    > kernel-core-4.15.13-300.fc27.x86_64
    > kernel-modules-4.15.13-300.fc27.x86_64
    > kernel-modules-extra-4.15.13-300.fc27.x86_64
    > kf5-akonadi-calendar-17.12.3-1.fc27.x86_64
    > kf5-akonadi-contacts-17.12.3-1.fc27.x86_64
    > kf5-akonadi-mime-17.12.3-1.fc27.x86_64
    > kf5-akonadi-notes-17.12.3-1.fc27.x86_64
    > kf5-akonadi-search-17.12.3-1.fc27.x86_64
    > kf5-akonadi-server-17.12.3-1.fc27.x86_64
    > kf5-akonadi-server-mysql-17.12.3-1.fc27.x86_64
    > kf5-calendarsupport-17.12.3-1.fc27.x86_64
    > kf5-eventviews-17.12.3-1.fc27.x86_64
    > kf5-grantleetheme-17.12.3-1.fc27.x86_64
    > kf5-incidenceeditor-17.12.3-1.fc27.x86_64
    > kf5-kalarmcal-17.12.3-1.fc27.x86_64
    > kf5-kcalendarcore-17.12.3-1.fc27.x86_64
    > kf5-kcalendarutils-17.12.3-1.fc27.x86_64
    > kf5-kcontacts-17.12.3-1.fc27.x86_64
    > kf5-kdav-17.12.3-1.fc27.x86_64
    > kf5-kidentitymanagement-17.12.3-1.fc27.x86_64
    > kf5-kimap-17.12.3-1.fc27.x86_64
    > kf5-kldap-17.12.3-1.fc27.x86_64
    > kf5-kmailtransport-17.12.3-1.fc27.x86_64
    > kf5-kmailtransport-akonadi-17.12.3-1.fc27.x86_64
    > kf5-kmbox-17.12.3-1.fc27.x86_64
    > kf5-kmime-17.12.3-1.fc27.x86_64
    > kf5-kontactinterface-17.12.3-1.fc27.x86_64
    > kf5-kpimtextedit-17.12.3-1.fc27.x86_64
    > kf5-ksmtp-17.12.3-1.fc27.x86_64
    > kf5-ktnef-17.12.3-1.fc27.x86_64
    > kf5-libgravatar-17.12.3-1.fc27.x86_64
    > kf5-libkdepim-17.12.3-1.fc27.x86_64
    > kf5-libkdepim-akonadi-17.12.3-1.fc27.x86_64
    > kf5-libkleo-17.12.3-2.fc27.x86_64
    > kf5-libksieve-17.12.3-1.fc27.x86_64
    > kf5-mailcommon-17.12.3-1.fc27.x86_64
    > kf5-mailimporter-17.12.3-1.fc27.x86_64
    > kf5-mailimporter-akonadi-17.12.3-1.fc27.x86_64
    > kf5-messagelib-17.12.3-1.fc27.x86_64
    > kf5-pimcommon-17.12.3-1.fc27.x86_64
    > kf5-pimcommon-akonadi-17.12.3-1.fc27.x86_64
    > kf5-syndication-17.12.3-1.fc27.x86_64
    > khotkeys-5.12.3-1.fc27.x86_64
    > kinfocenter-5.12.3-1.fc27.x86_64
    > kmail-17.12.3-1.fc27.x86_64
    > kmail-account-wizard-17.12.3-1.fc27.x86_64
    > kmail-libs-17.12.3-1.fc27.x86_64
    > kmenuedit-5.12.3-1.fc27.x86_64
    > kontact-17.12.3-1.fc27.x86_64
    > kontact-libs-17.12.3-1.fc27.x86_64
    > korganizer-17.12.3-1.fc27.x86_64
    > korganizer-libs-17.12.3-1.fc27.x86_64
    > kproperty-3.1.0-1.fc27.x86_64
    > kreport-3.1.0-1.fc27.x86_64
    > kscreen-5.12.3-1.fc27.x86_64
    > kscreenlocker-5.12.3-1.fc27.x86_64
    > ksshaskpass-5.12.3-1.fc27.x86_64
    > ksysguard-5.12.3-1.fc27.x86_64
    > ksysguardd-5.12.3-1.fc27.x86_64
    > kwin-5.12.3-2.fc27.x86_64
    > kwin-common-5.12.3-2.fc27.x86_64
    > kwin-libs-5.12.3-2.fc27.x86_64
    > kwrited-5.12.3-1.fc27.x86_64
    > libdrm-2.4.91-1.fc27.x86_64
    > libkgapi-17.12.3-1.fc27.x86_64
    > libkscreen-qt5-5.12.3-1.fc27.x86_64
    > libksysguard-5.12.3-1.fc27.x86_64
    > libksysguard-common-5.12.3-1.fc27.x86_64
    > libkworkspace5-5.12.3-1.fc27.x86_64
    > libsolv-0.6.34-1.fc27.x86_64
    > libtiff-4.0.9-7.fc27.x86_64
    > libvncserver-0.9.11-5.fc27.x86_64
    > libwinpr-2.0.0-40.20180320gitde83f4d.fc27.x86_64
    > llvm-libs-5.0.1-6.fc27.x86_64
    > lyx-fonts-2.3.0-1.fc27.noarch
    > nmap-ncat-7.60-8.fc27.x86_64
    > nss-mdns-0.14.1-1.fc27.x86_64
    > ostree-2018.3-1.fc27.x86_64
    > ostree-libs-2018.3-1.fc27.x86_64
    > oxygen-sound-theme-5.12.3-1.fc27.noarch
    > pam-kwallet-5.12.3-1.fc27.x86_64
    > pim-data-exporter-17.12.3-1.fc27.x86_64
    > pim-data-exporter-libs-17.12.3-1.fc27.x86_64
    > pim-sieve-editor-17.12.3-1.fc27.x86_64
    > plasma-breeze-5.12.3-1.fc27.x86_64
    > plasma-breeze-common-5.12.3-1.fc27.noarch
    > plasma-desktop-5.12.3-2.fc27.x86_64
    > plasma-desktop-doc-5.12.3-2.fc27.noarch
    > plasma-discover-5.12.3-1.fc27.x86_64
    > plasma-discover-flatpak-5.12.3-1.fc27.x86_64
    > plasma-discover-libs-5.12.3-1.fc27.x86_64
    > plasma-drkonqi-5.12.3-1.fc27.x86_64
    > plasma-integration-5.12.3-1.fc27.x86_64
    > plasma-lookandfeel-fedora-5.12.3-1.fc27.noarch
    > plasma-milou-5.12.3-1.fc27.x86_64
    > plasma-nm-5.12.3-1.fc27.x86_64
    > plasma-nm-l2tp-5.12.3-1.fc27.x86_64
    > plasma-nm-openconnect-5.12.3-1.fc27.x86_64
    > plasma-nm-openswan-5.12.3-1.fc27.x86_64
    > plasma-nm-openvpn-5.12.3-1.fc27.x86_64
    > plasma-nm-pptp-5.12.3-1.fc27.x86_64
    > plasma-nm-vpnc-5.12.3-1.fc27.x86_64
    > plasma-pa-5.12.3-1.fc27.x86_64
    > plasma-systemsettings-5.12.3-1.fc27.x86_64
    > plasma-user-manager-5.12.3-1.fc27.x86_64
    > plasma-workspace-5.12.3-1.fc27.x86_64
    > plasma-workspace-common-5.12.3-1.fc27.x86_64
    > plasma-workspace-geolocation-5.12.3-1.fc27.x86_64
    > plasma-workspace-geolocation-libs-5.12.3-1.fc27.x86_64
    > plasma-workspace-libs-5.12.3-1.fc27.x86_64
    > policycoreutils-2.7-6.fc27.x86_64
    > policycoreutils-python3-2.7-6.fc27.x86_64
    > policycoreutils-python-utils-2.7-6.fc27.x86_64
    > polkit-kde-5.12.3-1.fc27.x86_64
    > powerdevil-5.12.3-1.fc27.x86_64
    > python3-bind-9.11.3-2.fc27.noarch
    > qemu-guest-agent-2.10.1-3.fc27.x86_64
    > qt5-qtvirtualkeyboard-5.9.4-1.fc27.x86_64
    > sddm-breeze-5.12.3-1.fc27.noarch
    > sddm-kcm-5.12.3-1.fc27.x86_64
    > selinux-policy-3.13.1-283.29.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.29.fc27.noarch
    > sqlite-libs-3.20.1-2.fc27.x86_64
    

  • The 2 new ones:
               # from  diff -y --suppress-common-lines \
               #       180326.1720.rpm-qa.After_reg_sw_update \
               #       180331.2123.rpm-qa.After_reg_sw_update \
               #       | grep ">"
    > kdepim-apps-libs-17.12.3-1.fc27.x86_64
    > qt5-qtvirtualkeyboard-5.9.4-1.fc27.x86_64
    

  21. (03.04.18) A regular SW update

  • 70 updates installed via SW Updates.
    All the installed packages (1756 in total -- did not change) are listed in
               /opt/root/Install/rpm_history/180403.2251.rpm-qa.After_reg_sw_update
    (see local copy )

  • The updated packages: More... Close
    [root] .../rpm_history $ diff 180331.2123.rpm-qa.After_reg_sw_update \
                                  180403.2251.rpm-qa.After_reg_sw_update \
                                  | grep ">"
    > appstream-data-27-10.fc27.noarch
    > cmake-filesystem-3.11.0-1.fc27.x86_64
    > kernel-4.15.14-300.fc27.x86_64
    > kernel-core-4.15.14-300.fc27.x86_64
    > kernel-modules-4.15.14-300.fc27.x86_64
    > kernel-modules-extra-4.15.14-300.fc27.x86_64
    > kf5-kactivities-stats-5.44.0-2.fc27.x86_64
    > kf5-kholidays-5.44.0-1.fc27.x86_64
    > libblkid-2.30.2-3.fc27.x86_64
    > libfdisk-2.30.2-3.fc27.x86_64
    > libidn2-2.0.4-4.fc27.x86_64
    > libipa_hbac-1.16.1-2.fc27.x86_64
    > libmount-2.30.2-3.fc27.x86_64
    > libreport-2.9.3-3.fc27.x86_64
    > libreport-anaconda-2.9.3-3.fc27.x86_64
    > libreport-cli-2.9.3-3.fc27.x86_64
    > libreport-fedora-2.9.3-3.fc27.x86_64
    > libreport-filesystem-2.9.3-3.fc27.x86_64
    > libreport-gtk-2.9.3-3.fc27.x86_64
    > libreport-plugin-bugzilla-2.9.3-3.fc27.x86_64
    > libreport-plugin-kerneloops-2.9.3-3.fc27.x86_64
    > libreport-plugin-logger-2.9.3-3.fc27.x86_64
    > libreport-plugin-reportuploader-2.9.3-3.fc27.x86_64
    > libreport-plugin-systemd-journal-2.9.3-3.fc27.x86_64
    > libreport-plugin-ureport-2.9.3-3.fc27.x86_64
    > libreport-web-2.9.3-3.fc27.x86_64
    > libsmartcols-2.30.2-3.fc27.x86_64
    > libsss_autofs-1.16.1-2.fc27.x86_64
    > libsss_certmap-1.16.1-2.fc27.x86_64
    > libsss_idmap-1.16.1-2.fc27.x86_64
    > libsss_nss_idmap-1.16.1-2.fc27.x86_64
    > libsss_sudo-1.16.1-2.fc27.x86_64
    > libuuid-2.30.2-3.fc27.x86_64
    > libzstd-1.3.4-1.fc27.x86_64
    > mariadb-10.2.14-1.fc27.x86_64
    > mariadb-backup-10.2.14-1.fc27.x86_64
    > mariadb-common-10.2.14-1.fc27.x86_64
    > mariadb-config-10.2.14-1.fc27.x86_64
    > mariadb-embedded-10.2.14-1.fc27.x86_64
    > mariadb-errmsg-10.2.14-1.fc27.x86_64
    > mariadb-gssapi-server-10.2.14-1.fc27.x86_64
    > mariadb-libs-10.2.14-1.fc27.x86_64
    > mariadb-rocksdb-engine-10.2.14-1.fc27.x86_64
    > mariadb-server-10.2.14-1.fc27.x86_64
    > mariadb-server-utils-10.2.14-1.fc27.x86_64
    > mariadb-tokudb-engine-10.2.14-1.fc27.x86_64
    > openssl-1.1.0h-1.fc27.x86_64
    > openssl-libs-1.1.0h-1.fc27.x86_64
    > passwd-0.80-1.fc27.x86_64
    > publicsuffix-list-dafsa-20180328-1.fc27.noarch
    > python3-libreport-2.9.3-3.fc27.x86_64
    > python3-sssdconfig-1.16.1-2.fc27.noarch
    > satyr-0.25-2.fc27.x86_64
    > selinux-policy-3.13.1-283.30.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.30.fc27.noarch
    > sssd-1.16.1-2.fc27.x86_64
    > sssd-ad-1.16.1-2.fc27.x86_64
    > sssd-client-1.16.1-2.fc27.x86_64
    > sssd-common-1.16.1-2.fc27.x86_64
    > sssd-common-pac-1.16.1-2.fc27.x86_64
    > sssd-ipa-1.16.1-2.fc27.x86_64
    > sssd-kcm-1.16.1-2.fc27.x86_64
    > sssd-krb5-1.16.1-2.fc27.x86_64
    > sssd-krb5-common-1.16.1-2.fc27.x86_64
    > sssd-ldap-1.16.1-2.fc27.x86_64
    > sssd-nfs-idmap-1.16.1-2.fc27.x86_64
    > sssd-proxy-1.16.1-2.fc27.x86_64
    > tzdata-2018d-1.fc27.noarch
    > util-linux-2.30.2-3.fc27.x86_64
    > util-linux-user-2.30.2-3.fc27.x86_64
    

  22. (04.04.18) /usr/local/etc/zshrc.desy.bindings -- zsh options, completions and bindings

  • A version from 2004 (2000?): copied from F18 @ dom3 /x01/legacy/dom3/F18/opt/usr_local/etc/zshrc.desy.bindings (see a history in sect.36 of /x01/legacy/dom3/F18/opt/root/Install/Installed_SW , or on the web ).

  • Aim: to be sourced to .zshrc in order to have habitual desy-like options, completions and bindings ("TAB comletion", in particular).

  23. (04.04.18) ~fedotov/.zshrc

  • The initial version installed by OS comes from /etc/skel/.zshrc :
    [fedotov@dom5]~% diff /etc/skel/.zshrc .zshrc 
    [fedotov@dom5]~% rpm -qf /etc/skel/.zshrc
    zsh-5.4.1-2.fc27.x86_64
    
    We save it in ~/.zshrc.orig_installed_by_sys .

  • The new version is a copy of F18 @ dom3 version
    [fedotov@dom5]~% ll /x01/legacy/dom3/F18/home/fedotov/.zshrc
    -rw-r--r--. 1 fedotov fedotov 4345 Jun 11  2014 /x01/legacy/dom3/F18/home/fedotov/.zshrc
    
    The F18 version in is also saved in ~/.zshrc.dom3.F18.140111

  • NB: Prompt setting as defined elsewhere (the "screennshot" below was taken prior to the new .zshrc installation)
    [fedotov@dom5]~% echo $PS1
    [%n@%m]%~%# 
    [fedotov@dom5]~% echo $PROMPT
    [%n@%m]%~%# 
    
    gets changed in .zshrc with
               export PROMPT="[%B%m%b] %~ $ "

  • For the moment, we do not modify the copied F18 version...

  • UPD 11.04.18: alias  emacsrus='emacs -fn $RUSFONT' COMMENTED OUT in view of the new script /usr/local/bin/emacsrus (see sect.27).

  24. (05.04.18) xorg-x11-fonts-ISO8859-1-75dpi package

  • The package
               xorg-x11-fonts-ISO8859-1-75dpi-7.5-18.fc27.noarch
    installed via SW Management (dnfdragora).

  • Motivation:
    • xterm produced a warning when pressing Ctrl-RightMouse (an invocation of menu "VT Fonts")
      Warning: Cannot convert string
               "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*"
               to type FontStruct
      
      We found a font fitting this pattern in F18 @ dom3 and traced it down to the xorg-x11-fonts-ISO8859-1-75dpi package.

  • The package has installed the /usr/share/X11/fonts/75dpi directory, where the file fonts.dir contains the description of a suitable font:
    helvB12-ISO8859-1.pcf.gz -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
    

  • The xterm warning does not appear any longer.

  • All the installed packages (1757 in total -- vs 1756 before):
               /opt/root/Install/rpm_history/180405.2231.rpm-qa.xorg-x11-fonts-ISO8859-1-75dpi_installed

  25. (06.04.18) Additional X11 fonts from DESY in /usr/local/share/X11/fonts

  • Additional fonts installed in subdirs of /usr/local/share/X11/fonts/ .

    A "nice desy font" in ./desy_nice_font

  • ./desy_nice_font.COMMENTS -- a detailed installation procedure

  • A nice "typographic" desy font (used to be aliased to Vt)
               -ncd-terminaleuro-medium-r-normal--18-140-100-100-c-110-iso8859-15
    and its BOLD version (used to be aliased to VtB)
               -ncd-terminaleuro-bold-r-normal--18-140-100-100-c-110-iso8859-15
  • Aliased now to DesyNice and DesyNiceB

  • We are going to use the font as a default one in xterm and emacs.

  • Files
               term18euro.bdf , termB18euro.bdf
    copied from an F18 @ dom5 directory
               /x01/legacy/dom3/F18/opt/usr_local/share/X11/fonts/desy_fedotov-public-fonts/dw100dpi/
    (see a desription in sect.29 of /x01/legacy/dom3/F18/opt/root/Install/Installed_SW (web version))

  • fonts.dir created with mkfontdir .
  • fonts.alias created manually

  • Make the dir known to the font server:
    [root] /usr/local/share/X11/fonts/desy_nice_font $ cd /etc/X11/fontpath.d
    [root] /etc/X11/fontpath.d $ ln -s /usr/local/share/X11/fonts/desy_nice_font .
    

    A nice koi8-r desy font in ./desy_nice_koi_font

  • ./desy_nice_koi_font.COMMENTS -- a detailed installation procedure.

  • The font is a koi8-r partner of the "nice desy font" from the prev. section

  • We are going to use the font in emacsrus and -- as an option -- in xterm .

  • The medium and bold versions are
               -bitstream-terminal-medium-r-normal--18-180-75-75-c-11-koi8-1
               -bitstream-terminal-bold-r-normal--18-180-75-75-c-11-koi8-1
  • They are aliased to:
    • medium:
      • DesyNiceKoi and
      • -bitstream-terminal-medium-r-normal--18-180-75-75-c-11-koi8-r (with just the last symbol modified: "1" -> "r")
    • bold :
      • DesyNiceKoiB and
      • -bitstream-terminal-bold-r-normal--18-180-75-75-c-11-koi8-r (with just the last symbol modified: "1" -> "r")


    • The "..medium...koi8-r" alias will be used with emacs in LANG=ru_RU.KOI8-R environment.
    • To be noted:
      • emacs refuses to work with the direct font definition.
      • Using a suitable alias is much simpler than what we did in F18 and F10 where we created a renamed versions of fonts, see sect.43 of /x01/legacy/dom3/F18/opt/root/Install/Installed_SW ( web version ).
        E.g., in F10 we had a renamed version that defined
                   -koibitstream-terminal-medium-r-normal--18-180-75-75-c-11-iso8859-15
        In F10,F18 we worked in en_US environment, but used xruskb to type in russian...
      • With the alias like in F10 , " -koibitstream...iso8859-15", emacs draws the ru symbols with a different, not monospaced, font (in ru_RU.KOI8-R mode)
      • The koi6-r alias is OK in ru_RU.KOI8-R, where the system version of RU keyboard is working perfectly too.
      • The koi8-r alias is NOT OK in the LANG=en_US environment.

  • Files
               term18.pcf.Z , term18b.pcf.Z
    copied from an F18 @ dom5 directory
               /x01/legacy/dom3/F18/opt/usr_local/share/X11/fonts/desy_fedotov-public-fonts/xcyr-koi8-r/
    (see a desription in sect.29 of /x01/legacy/dom3/F18/opt/root/Install/Installed_SW (web version))

  • fonts.dir created with mkfontdir .
  • fonts.alias created manually .

  • Make the dir known to the font server:
    [root] /usr/local/share/X11/fonts/desy_nice_koi_font $ cd /etc/X11/fontpath.d
    [root] /etc/X11/fontpath.d $ ln -s /usr/local/share/X11/fonts/desy_nice_koi_font .
    

    Adobe-courier koi8-r desy fonts in ./desy_adobe-courier-koi

  • ./desy_adobe-courier-koi.COMMENTS -- a detailed installation procedure.

  • The fonts are
               adobe-courier * medium + bold * sizes 8,10,12,14,18,24 koi8 fonts

  • The files are of "koi8-1" flavour (fonts.dir).
    They are aliased to identical "koi8-r" names -- just in case.

  • We are going to use one or two of them in xterm as "small/medium" ru fonts.

  • The files are:
    -rw-r--r--. 1 root root 4168 Jan 10  1996 cour08b.pcf.Z
    -rw-r--r--. 1 root root 4186 Jan 10  1996 cour08.pcf.Z
    -rw-r--r--. 1 root root 4463 Jan 10  1996 cour10b.pcf.Z
    -rw-r--r--. 1 root root 4391 Jan 10  1996 cour10.pcf.Z
    -rw-r--r--. 1 root root 4685 Jan 10  1996 cour12b.pcf.Z
    -rw-r--r--. 1 root root 4654 Jan 10  1996 cour12.pcf.Z
    -rw-r--r--. 1 root root 5045 Jan 10  1996 cour14b.pcf.Z
    -rw-r--r--. 1 root root 5014 Jan 10  1996 cour14.pcf.Z
    -rw-r--r--. 1 root root 5709 Jan 10  1996 cour18b.pcf.Z
    -rw-r--r--. 1 root root 5402 Jan 10  1996 cour18.pcf.Z
    -rw-r--r--. 1 root root 6655 Jan 10  1996 cour24b.pcf.Z
    -rw-r--r--. 1 root root 6672 Jan 10  1996 cour24.pcf.Z
    
    Copied from an F18 @ dom5 directory
               /x01/legacy/dom3/F18/opt/usr_local/share/X11/fonts/desy_fedotov-public-fonts/xcyr-koi8-r/
    (see a desription in sect.29 of /x01/legacy/dom3/F18/opt/root/Install/Installed_SW (web version))

  • fonts.dir created with mkfontdir .
    ... $ cat fonts.dir 
    12
    cour08.pcf.Z -adobe-courier-medium-r-normal--8-80-75-75-m-50-koi8-1
    cour08b.pcf.Z -adobe-courier-bold-r-normal--8-80-75-75-m-50-koi8-1
    cour10.pcf.Z -adobe-courier-medium-r-normal--10-100-75-75-m-60-koi8-1
    cour10b.pcf.Z -adobe-courier-bold-r-normal--10-100-75-75-m-60-koi8-1
    cour12.pcf.Z -adobe-courier-medium-r-normal--12-120-75-75-m-70-koi8-1
    cour12b.pcf.Z -adobe-courier-bold-r-normal--12-120-75-75-m-70-koi8-1
    cour14.pcf.Z -adobe-courier-medium-r-normal--14-140-75-75-m-90-koi8-1
    cour14b.pcf.Z -adobe-courier-bold-r-normal--14-140-75-75-m-90-koi8-1
    cour18.pcf.Z -adobe-courier-medium-r-normal--18-180-75-75-m-110-koi8-1
    cour18b.pcf.Z -adobe-courier-bold-r-normal--18-180-75-75-m-110-koi8-1
    cour24.pcf.Z -adobe-courier-medium-r-normal--24-240-75-75-m-150-koi8-1
    cour24b.pcf.Z -adobe-courier-bold-r-normal--24-240-75-75-m-150-koi8-1
    

  • fonts.alias created manually.

  • Make the dir known to the font server:
    [root] /usr/local/share/X11/fonts/desy_nice_koi_font $ cd /etc/X11/fontpath.d
    [root] /etc/X11/fontpath.d $ ln -s /usr/local/share/X11/fonts/desy_adobe-courier-koi .
    

  26. (09.04.18) A regular SW update

  • 87 updates installed via SW Updates (87 modified + 0 new)
    A list of all the installed packages (1757 in total -- did not change):
               /opt/root/Install/rpm_history/180409.2038.rpm-qa.After_reg_sw_update
    ( local copy )

  • The new versions of packages: More... Close
    [root] .../rpm_history $ \
            diff 180405.2231.rpm-qa.xorg-x11-fonts-ISO8859-1-75dpi_installed \
                 180409.2038.rpm-qa.After_reg_sw_update \
            | grep ">"
    > amarok-2.9.0-1.fc27.x86_64
    > amarok-libs-2.9.0-1.fc27.x86_64
    > amarok-utils-2.9.0-1.fc27.x86_64
    > bind-libs-9.11.3-3.fc27.x86_64
    > bind-libs-lite-9.11.3-3.fc27.x86_64
    > bind-license-9.11.3-3.fc27.noarch
    > bind-utils-9.11.3-3.fc27.x86_64
    > bluedevil-5.12.4-1.fc27.x86_64
    > breeze-cursor-theme-5.12.4-1.fc27.noarch
    > chrony-3.3-1.fc27.x86_64
    > cups-2.2.4-9.fc27.x86_64
    > cups-client-2.2.4-9.fc27.x86_64
    > cups-filesystem-2.2.4-9.fc27.noarch
    > cups-libs-2.2.4-9.fc27.x86_64
    > GeoIP-GeoLite-data-2018.04-1.fc27.noarch
    > hwdata-0.311-1.fc27.noarch
    > kactivitymanagerd-5.12.4-1.fc27.x86_64
    > kde-cli-tools-5.12.4-1.fc27.x86_64
    > kdecoration-5.12.4-1.fc27.x86_64
    > kde-gtk-config-5.12.4-1.fc27.x86_64
    > kdeplasma-addons-5.12.4-1.fc27.x86_64
    > kde-style-breeze-5.12.4-1.fc27.x86_64
    > kdesu-5.12.4-1.fc27.x86_64
    > khotkeys-5.12.4-1.fc27.x86_64
    > kinfocenter-5.12.4-1.fc27.x86_64
    > kmenuedit-5.12.4-1.fc27.x86_64
    > krb5-libs-1.15.2-8.fc27.x86_64
    > kscreen-5.12.4-1.fc27.x86_64
    > kscreenlocker-5.12.4-1.fc27.x86_64
    > ksshaskpass-5.12.4-1.fc27.x86_64
    > ksysguard-5.12.4-1.fc27.x86_64
    > ksysguardd-5.12.4-1.fc27.x86_64
    > kwin-5.12.4-1.fc27.x86_64
    > kwin-common-5.12.4-1.fc27.x86_64
    > kwin-libs-5.12.4-1.fc27.x86_64
    > kwrited-5.12.4-1.fc27.x86_64
    > libidn-1.34-1.fc27.x86_64
    > libkadm5-1.15.2-8.fc27.x86_64
    > libkscreen-qt5-5.12.4-1.fc27.x86_64
    > libksysguard-5.12.4-1.fc27.x86_64
    > libksysguard-common-5.12.4-1.fc27.x86_64
    > libkworkspace5-5.12.4-1.fc27.x86_64
    > libtirpc-1.0.3-1.fc27.x86_64
    > openssl-1.1.0h-3.fc27.x86_64
    > openssl-libs-1.1.0h-3.fc27.x86_64
    > ostree-2018.3-2.fc27.x86_64
    > ostree-libs-2018.3-2.fc27.x86_64
    > oxygen-sound-theme-5.12.4-1.fc27.noarch
    > pam-kwallet-5.12.4-2.fc27.x86_64
    > pcre2-10.31-4.fc27.x86_64
    > pcre2-utf16-10.31-4.fc27.x86_64
    > pcre-8.42-1.fc27.x86_64
    > plasma-breeze-5.12.4-1.fc27.x86_64
    > plasma-breeze-common-5.12.4-1.fc27.noarch
    > plasma-desktop-5.12.4-1.fc27.x86_64
    > plasma-desktop-doc-5.12.4-1.fc27.noarch
    > plasma-discover-5.12.4-1.fc27.x86_64
    > plasma-discover-flatpak-5.12.4-1.fc27.x86_64
    > plasma-discover-libs-5.12.4-1.fc27.x86_64
    > plasma-drkonqi-5.12.4-1.fc27.x86_64
    > plasma-integration-5.12.4-1.fc27.x86_64
    > plasma-lookandfeel-fedora-5.12.4-1.fc27.noarch
    > plasma-milou-5.12.4-1.fc27.x86_64
    > plasma-nm-5.12.4-1.fc27.x86_64
    > plasma-nm-l2tp-5.12.4-1.fc27.x86_64
    > plasma-nm-openconnect-5.12.4-1.fc27.x86_64
    > plasma-nm-openswan-5.12.4-1.fc27.x86_64
    > plasma-nm-openvpn-5.12.4-1.fc27.x86_64
    > plasma-nm-pptp-5.12.4-1.fc27.x86_64
    > plasma-nm-vpnc-5.12.4-1.fc27.x86_64
    > plasma-pa-5.12.4-1.fc27.x86_64
    > plasma-systemsettings-5.12.4-1.fc27.x86_64
    > plasma-user-manager-5.12.4-1.fc27.x86_64
    > plasma-workspace-5.12.4-1.fc27.x86_64
    > plasma-workspace-common-5.12.4-1.fc27.x86_64
    > plasma-workspace-geolocation-5.12.4-1.fc27.x86_64
    > plasma-workspace-geolocation-libs-5.12.4-1.fc27.x86_64
    > plasma-workspace-libs-5.12.4-1.fc27.x86_64
    > polkit-kde-5.12.4-1.fc27.x86_64
    > powerdevil-5.12.4-1.fc27.x86_64
    > python3-bind-9.11.3-3.fc27.noarch
    > qt5-qtdeclarative-5.9.4-2.fc27.x86_64
    > sddm-breeze-5.12.4-1.fc27.noarch
    > sddm-kcm-5.12.4-1.fc27.x86_64
    > webkitgtk4-2.20.0-1.fc27.x86_64
    > webkitgtk4-jsc-2.20.0-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.20.0-1.fc27.x86_64
    

    UPD 10.04.18

  • 15 updates installed via SW Updates (15 modified + 0 new)
    All the installed packages (1757 in total -- did not change):
               /opt/root/Install/rpm_history/180410.2337.rpm-qa.After_reg_sw_update
    ( local copy )

  • The added new versions: More... Close
    [root] .../rpm_history $ \
    [root] .../rpm_history $ \
        diff 180409.2038.rpm-qa.After_reg_sw_update \
             180410.2337.rpm-qa.After_reg_sw_update \
        | grep ">"
    > bind-libs-9.11.3-4.fc27.x86_64
    > bind-libs-lite-9.11.3-4.fc27.x86_64
    > bind-license-9.11.3-4.fc27.noarch
    > bind-utils-9.11.3-4.fc27.x86_64
    > bluez-5.49-1.fc27.x86_64
    > bluez-cups-5.49-1.fc27.x86_64
    > bluez-libs-5.49-1.fc27.x86_64
    > compat-openssl10-1.0.2o-1.fc27.x86_64
    > python2-pip-9.0.3-1.fc27.noarch
    > python3-3.6.5-1.fc27.x86_64
    > python3-bind-9.11.3-4.fc27.noarch
    > python3-libs-3.6.5-1.fc27.x86_64
    > python3-pip-9.0.3-1.fc27.noarch
    > xorg-x11-server-common-1.19.6-6.fc27.x86_64
    > xorg-x11-server-Xorg-1.19.6-6.fc27.x86_64
    

    UPD 13.04.18

  • 13 updates installed via SW Updates (13 modified + 0 new)
    All the installed packages (1757 in total -- did not change):
               /opt/root/Install/rpm_history/180413.2153.rpm-qa.After_reg_sw_update
    ( local copy )

    The added new versions: More... Close
    [root] .../rpm_history $ diff 180410.2337.rpm-qa.After_reg_sw_update \
                                  180413.2153.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > avahi-0.7-11.fc27.x86_64
    > avahi-glib-0.7-11.fc27.x86_64
    > avahi-gobject-0.7-11.fc27.x86_64
    > avahi-libs-0.7-11.fc27.x86_64
    > kernel-4.15.15-300.fc27.x86_64
    > kernel-core-4.15.15-300.fc27.x86_64
    > kernel-modules-4.15.15-300.fc27.x86_64
    > kernel-modules-extra-4.15.15-300.fc27.x86_64
    > libtalloc-2.1.13-1.fc27.x86_64
    > NetworkManager-l2tp-1.2.10-1.fc27.x86_64
    > python2-talloc-2.1.13-1.fc27.x86_64
    > vim-minimal-8.0.1666-1.fc27.x86_64
    > xl2tpd-1.3.8-7.fc27.x86_64
    

    UPD 18.04.18

  • 54 updates installed via SW Updates (54 modified + 0 new)
    All the installed packages (1757 in total -- did not change):
               /opt/root/Install/rpm_history/180418.2327.rpm-qa.After_reg_sw_update
    ( local copy )

    The added new versions: More... Close
    [root] .../rpm_history $ diff 180413.2153.rpm-qa.After_reg_sw_update \
                                  180418.2327.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > calligra-core-3.1.0-6.fc27.x86_64
    > calligra-libs-3.1.0-6.fc27.x86_64
    > calligra-sheets-3.1.0-6.fc27.x86_64
    > calligra-sheets-libs-3.1.0-6.fc27.x86_64
    > calligra-stage-3.1.0-6.fc27.x86_64
    > calligra-stage-libs-3.1.0-6.fc27.x86_64
    > calligra-words-3.1.0-6.fc27.x86_64
    > calligra-words-libs-3.1.0-6.fc27.x86_64
    > cifs-utils-6.8-1.fc27.x86_64
    > cups-2.2.4-10.fc27.x86_64
    > cups-client-2.2.4-10.fc27.x86_64
    > cups-filesystem-2.2.4-10.fc27.noarch
    > cups-libs-2.2.4-10.fc27.x86_64
    > desktop-file-utils-0.23-8.fc27.x86_64
    > freerdp-2.0.0-41.20180405gita9ecd6a.fc27.x86_64
    > freerdp-libs-2.0.0-41.20180405gita9ecd6a.fc27.x86_64
    > gnupg2-2.2.6-1.fc27.x86_64
    > gnupg2-smime-2.2.6-1.fc27.x86_64
    > google-noto-fonts-common-20161022-7.fc27.noarch
    > google-noto-sans-fonts-20161022-7.fc27.noarch
    > google-noto-sans-lisu-fonts-20161022-7.fc27.noarch
    > google-noto-sans-mandaic-fonts-20161022-7.fc27.noarch
    > google-noto-sans-meetei-mayek-fonts-20161022-7.fc27.noarch
    > google-noto-sans-sinhala-fonts-20161022-7.fc27.noarch
    > google-noto-sans-tagalog-fonts-20161022-7.fc27.noarch
    > google-noto-sans-tai-tham-fonts-20161022-7.fc27.noarch
    > google-noto-sans-tai-viet-fonts-20161022-7.fc27.noarch
    > kernel-4.15.17-300.fc27.x86_64
    > kernel-core-4.15.17-300.fc27.x86_64
    > kernel-modules-4.15.17-300.fc27.x86_64
    > kernel-modules-extra-4.15.17-300.fc27.x86_64
    > libwinpr-2.0.0-41.20180405gita9ecd6a.fc27.x86_64
    > passwd-0.80-2.fc27.x86_64
    > qupzilla-2.2.6-1.fc27.x86_64
    > rsyslog-8.34.0-1.fc27.x86_64
    > unbound-libs-1.7.0-4.fc27.x86_64
    > urw-base35-bookman-fonts-20170801-6.fc27.noarch
    > urw-base35-c059-fonts-20170801-6.fc27.noarch
    > urw-base35-d050000l-fonts-20170801-6.fc27.noarch
    > urw-base35-fonts-20170801-6.fc27.noarch
    > urw-base35-fonts-common-20170801-6.fc27.noarch
    > urw-base35-gothic-fonts-20170801-6.fc27.noarch
    > urw-base35-nimbus-mono-ps-fonts-20170801-6.fc27.noarch
    > urw-base35-nimbus-roman-fonts-20170801-6.fc27.noarch
    > urw-base35-nimbus-sans-fonts-20170801-6.fc27.noarch
    > urw-base35-p052-fonts-20170801-6.fc27.noarch
    > urw-base35-standard-symbols-ps-fonts-20170801-6.fc27.noarch
    > urw-base35-z003-fonts-20170801-6.fc27.noarch
    > vim-minimal-8.0.1704-1.fc27.x86_64
    > webkitgtk4-2.20.1-1.fc27.x86_64
    > webkitgtk4-jsc-2.20.1-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.20.1-1.fc27.x86_64
    > xorg-x11-server-common-1.19.6-7.fc27.x86_64
    > xorg-x11-server-Xorg-1.19.6-7.fc27.x86_64
    

    UPD 21.04.18

  • 7 updates installed via SW Updates (7 modified + 0 new).
    A new full list of 1757 (did not change) installed packages:
               /opt/root/Install/rpm_history/180421.1834.rpm-qa.After_reg_sw_update
    ( local copy ).
    The added new versions: More... Close
    [root] .../rpm_history $ diff 180418.2327.rpm-qa.After_reg_sw_update \
                                  180421.1834.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > ethtool-4.16-1.fc27.x86_64
    > kf5-kipi-plugins-5.9.0-1.fc27.x86_64
    > kf5-kipi-plugins-libs-5.9.0-1.fc27.x86_64
    > libappstream-glib-0.7.7-2.fc27.x86_64
    > PackageKit-1.1.9-3.fc27.x86_64
    > PackageKit-glib-1.1.9-3.fc27.x86_64
    > PackageKit-gstreamer-plugin-1.1.9-3.fc27.x86_64
    

    UPD 29.04.18

  • +52 updates installed via SW Updates (52 modified + 0 new) A new full list of 1760 (did not change since the update of sect.30 ) installed packages:
               /opt/root/Install/rpm_history/180429.0220.rpm-qa.After_reg_sw_update
    ( local copy )
    The added new versions: More... Close
    [root] .../rpm_history $ diff 180425.2110.rpm-qa.flash-plugin_installed
                                  180429.0220.rpm-qa.After_reg_sw_update
                             | grep ">"
    > appstream-data-27-11.fc27.noarch
    > bluez-5.49-3.fc27.x86_64
    > bluez-cups-5.49-3.fc27.x86_64
    > bluez-libs-5.49-3.fc27.x86_64
    > boost-atomic-1.64.0-6.fc27.x86_64
    > boost-chrono-1.64.0-6.fc27.x86_64
    > boost-date-time-1.64.0-6.fc27.x86_64
    > boost-filesystem-1.64.0-6.fc27.x86_64
    > boost-system-1.64.0-6.fc27.x86_64
    > boost-thread-1.64.0-6.fc27.x86_64
    > coreutils-8.27-21.fc27.x86_64
    > coreutils-common-8.27-21.fc27.x86_64
    > fftw-libs-double-3.3.5-8.fc27.x86_64
    > file-5.31-11.fc27.x86_64
    > file-libs-5.31-11.fc27.x86_64
    > findutils-4.6.0-19.fc27.x86_64
    > firewall-config-0.4.4.5-4.fc27.noarch
    > firewalld-0.4.4.5-4.fc27.noarch
    > firewalld-filesystem-0.4.4.5-4.fc27.noarch
    > gpgme-1.10.0-4.fc27.x86_64
    > gpgmepp-1.10.0-4.fc27.x86_64
    > kernel-4.16.3-200.fc27.x86_64
    > kernel-core-4.16.3-200.fc27.x86_64
    > kernel-modules-4.16.3-200.fc27.x86_64
    > kernel-modules-extra-4.16.3-200.fc27.x86_64
    > libcgroup-0.41-17.fc27.x86_64
    > libnghttp2-1.31.1-1.fc27.x86_64
    > libsmbclient-4.7.7-0.fc27.x86_64
    > libtiff-4.0.9-8.fc27.x86_64
    > libwbclient-4.7.7-0.fc27.x86_64
    > lmdb-libs-0.9.22-1.fc27.x86_64
    > perl-Errno-1.28-404.fc27.x86_64
    > perl-interpreter-5.26.2-404.fc27.x86_64
    > perl-IO-1.38-404.fc27.x86_64
    > perl-libs-5.26.2-404.fc27.x86_64
    > perl-macros-5.26.2-404.fc27.x86_64
    > perl-Math-Complex-1.59-404.fc27.noarch
    > python3-firewall-0.4.4.5-4.fc27.noarch
    > python3-gpg-1.10.0-4.fc27.x86_64
    > qgpgme-1.10.0-4.fc27.x86_64
    > samba-client-4.7.7-0.fc27.x86_64
    > samba-client-libs-4.7.7-0.fc27.x86_64
    > samba-common-4.7.7-0.fc27.noarch
    > samba-common-libs-4.7.7-0.fc27.x86_64
    > samba-dc-libs-4.7.7-0.fc27.x86_64
    > samba-libs-4.7.7-0.fc27.x86_64
    > sane-backends-1.0.27-17.fc27.x86_64
    > sane-backends-drivers-cameras-1.0.27-17.fc27.x86_64
    > sane-backends-drivers-scanners-1.0.27-17.fc27.x86_64
    > sane-backends-libs-1.0.27-17.fc27.x86_64
    > selinux-policy-3.13.1-283.32.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.32.fc27.noarch
    

    UPD 14.05.18

  • +85 updates installed via SW Updates (85 modified + 0 new)
    A new full list of 1895 (did not change since the update of sect.36) installed packages :
               /opt/root/Install/rpm_history/180514.0116.rpm-qa.After_reg_sw_update
    ( local copy )
    The added new versions: More... Close
    [root] .../rpm_history $ diff 180504.0518.rpm-qa.vidyodesktop_installed \
                                  180514.0116.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > cups-filters-1.16.1-5.fc27.x86_64
    > cups-filters-libs-1.16.1-5.fc27.x86_64
    > flash-plugin-29.0.0.171-release.x86_64
    > ghostscript-9.22-4.fc27.x86_64
    > ghostscript-core-9.22-4.fc27.x86_64
    > ghostscript-x11-9.22-4.fc27.x86_64
    > gpgme-1.10.0-4.fc27.1.x86_64
    > gpgmepp-1.10.0-4.fc27.1.x86_64
    > hwdata-0.312-1.fc27.noarch
    > iptables-1.6.2-3.fc27.x86_64
    > iptables-libs-1.6.2-3.fc27.x86_64
    > kde-connect-1.3.0-1.fc27.x86_64
    > kdeconnectd-1.3.0-1.fc27.x86_64
    > kde-connect-libs-1.3.0-1.fc27.x86_64
    > kdiagram-2.6.1-2.fc27.x86_64
    > kernel-4.16.7-200.fc27.x86_64
    > kernel-core-4.16.7-200.fc27.x86_64
    > kernel-headers-4.16.7-200.fc27.x86_64
    > kernel-modules-4.16.7-200.fc27.x86_64
    > kernel-modules-extra-4.16.7-200.fc27.x86_64
    > krb5-libs-1.15.2-9.fc27.x86_64
    > libappstream-glib-0.7.8-1.fc27.x86_64
    > libetonyek-0.1.8-1.fc27.x86_64
    > libinput-1.10.5-3.fc27.x86_64
    > libipa_hbac-1.16.1-3.fc27.x86_64
    > libkadm5-1.15.2-9.fc27.x86_64
    > libpsl-0.18.0-2.fc27.x86_64
    > libpurple-2.13.0-1.fc27.x86_64
    > librados2-12.2.4-2.fc27.x86_64
    > LibRaw-0.18.9-1.fc27.x86_64
    > libsss_autofs-1.16.1-3.fc27.x86_64
    > libsss_certmap-1.16.1-3.fc27.x86_64
    > libsss_idmap-1.16.1-3.fc27.x86_64
    > libsss_nss_idmap-1.16.1-3.fc27.x86_64
    > libsss_sudo-1.16.1-3.fc27.x86_64
    > libtirpc-1.0.3-2.fc27.x86_64
    > libwebp-1.0.0-1.fc27.x86_64
    > libwps-0.4.9-1.fc27.x86_64
    > net-tools-2.0-0.47.20160912git.fc27.x86_64
    > nss-3.36.1-1.0.fc27.x86_64
    > nss-softokn-3.36.1-1.0.fc27.x86_64
    > nss-softokn-freebl-3.36.1-1.0.fc27.x86_64
    > nss-sysinit-3.36.1-1.0.fc27.x86_64
    > nss-tools-3.36.1-1.0.fc27.x86_64
    > nss-util-3.36.1-1.0.fc27.x86_64
    > openvpn-2.4.6-1.fc27.x86_64
    > PackageKit-1.1.10-1.fc27.x86_64
    > PackageKit-glib-1.1.10-1.fc27.x86_64
    > PackageKit-gstreamer-plugin-1.1.10-1.fc27.x86_64
    > perl-Carp-1.42-395.fc27.noarch
    > perl-Storable-3.09-1.fc27.x86_64
    > powerdevil-5.12.4-2.fc27.x86_64
    > publicsuffix-list-dafsa-20180419-1.fc27.noarch
    > python3-gpg-1.10.0-4.fc27.1.x86_64
    > python3-requests-2.18.4-2.fc27.noarch
    > python3-sssdconfig-1.16.1-3.fc27.noarch
    > python3-urllib3-1.22-5.fc27.noarch
    > qgpgme-1.10.0-4.fc27.1.x86_64
    > qpdf-libs-7.1.1-5.fc27.x86_64
    > qt5-qtdeclarative-5.9.4-3.fc27.x86_64
    > rpmfusion-free-release-27-2.noarch
    > rpmfusion-nonfree-release-27-2.noarch
    > selinux-policy-3.13.1-283.34.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.34.fc27.noarch
    > spirv-tools-libs-2018.3.0-0.1.20180407.git26a698c.fc27.x86_64
    > sssd-1.16.1-3.fc27.x86_64
    > sssd-ad-1.16.1-3.fc27.x86_64
    > sssd-client-1.16.1-3.fc27.x86_64
    > sssd-common-1.16.1-3.fc27.x86_64
    > sssd-common-pac-1.16.1-3.fc27.x86_64
    > sssd-ipa-1.16.1-3.fc27.x86_64
    > sssd-kcm-1.16.1-3.fc27.x86_64
    > sssd-krb5-1.16.1-3.fc27.x86_64
    > sssd-krb5-common-1.16.1-3.fc27.x86_64
    > sssd-ldap-1.16.1-3.fc27.x86_64
    > sssd-nfs-idmap-1.16.1-3.fc27.x86_64
    > sssd-proxy-1.16.1-3.fc27.x86_64
    > thai-scalable-fonts-common-0.6.5-1.fc27.noarch
    > thai-scalable-waree-fonts-0.6.5-1.fc27.noarch
    > vim-minimal-8.0.1788-1.fc27.x86_64
    > vulkan-1.1.73.0-1.fc27.x86_64
    > vulkan-filesystem-1.1.73.0-1.fc27.noarch
    > xorg-x11-drv-libinput-0.27.1-2.fc27.x86_64
    > zsh-5.4.1-3.fc27.x86_64
    > zsh-html-5.4.1-3.fc27.noarch
    

    UPD 19.05.18

  • +104 updates installed via SW Updates (104 modified + 0 new)
    A new full list of 2479 (did not change since the update of sect.42) installed packages :
               /opt/root/Install/rpm_history/180519.2050.rpm-qa.After_reg_sw_update
    ( local copy )
    The added new versions: More... Close
    [root] .../rpm_history $ diff 180519.0300.rpm-qa.misc_installed \
                                  180519.2050.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > bluedevil-5.12.5-1.fc27.x86_64
    > breeze-cursor-theme-5.12.5-1.fc27.noarch
    > clang-libs-5.0.2-1.fc27.x86_64
    > compiler-rt-5.0.2-1.fc27.x86_64
    > dhcp-client-4.3.6-10.fc27.x86_64
    > dhcp-common-4.3.6-10.fc27.noarch
    > dhcp-libs-4.3.6-10.fc27.x86_64
    > flac-libs-1.3.2-7.fc27.x86_64
    > GraphicsMagick-1.3.29-1.fc27.x86_64
    > kactivitymanagerd-5.12.5-1.fc27.x86_64
    > kde-cli-tools-5.12.5-1.fc27.x86_64
    > kdecoration-5.12.5-1.fc27.x86_64
    > kde-gtk-config-5.12.5-1.fc27.x86_64
    > kdeplasma-addons-5.12.5-1.fc27.x86_64
    > kde-style-breeze-5.12.5-1.fc27.x86_64
    > kdesu-5.12.5-1.fc27.x86_64
    > khotkeys-5.12.5-1.fc27.x86_64
    > kinfocenter-5.12.5-1.fc27.x86_64
    > kmenuedit-5.12.5-1.fc27.x86_64
    > kscreen-5.12.5-1.fc27.x86_64
    > kscreenlocker-5.12.5-1.fc27.x86_64
    > ksshaskpass-5.12.5-1.fc27.x86_64
    > ksysguard-5.12.5-1.fc27.x86_64
    > ksysguardd-5.12.5-1.fc27.x86_64
    > kwin-5.12.5-1.fc27.x86_64
    > kwin-common-5.12.5-1.fc27.x86_64
    > kwin-libs-5.12.5-1.fc27.x86_64
    > kwrited-5.12.5-1.fc27.x86_64
    > libipa_hbac-1.16.1-4.fc27.x86_64
    > libkscreen-qt5-5.12.5-1.fc27.x86_64
    > libksysguard-5.12.5-1.fc27.x86_64
    > libksysguard-common-5.12.5-1.fc27.x86_64
    > libkworkspace5-5.12.5-1.fc27.x86_64
    > libmicrodns-0.0.10-1.fc27.x86_64
    > librados2-12.2.5-1.fc27.x86_64
    > LibRaw-0.18.11-1.fc27.x86_64
    > libsss_autofs-1.16.1-4.fc27.x86_64
    > libsss_certmap-1.16.1-4.fc27.x86_64
    > libsss_idmap-1.16.1-4.fc27.x86_64
    > libsss_nss_idmap-1.16.1-4.fc27.x86_64
    > libsss_sudo-1.16.1-4.fc27.x86_64
    > llvm-libs-5.0.2-1.fc27.x86_64
    > open-vm-tools-10.2.5-2.fc27.x86_64
    > open-vm-tools-desktop-10.2.5-2.fc27.x86_64
    > oxygen-sound-theme-5.12.5-1.fc27.noarch
    > pam-kwallet-5.12.5-3.fc27.x86_64
    > plasma-breeze-5.12.5-1.fc27.x86_64
    > plasma-breeze-common-5.12.5-1.fc27.noarch
    > plasma-desktop-5.12.5-1.fc27.x86_64
    > plasma-desktop-doc-5.12.5-1.fc27.noarch
    > plasma-discover-5.12.5-1.fc27.x86_64
    > plasma-discover-flatpak-5.12.5-1.fc27.x86_64
    > plasma-discover-libs-5.12.5-1.fc27.x86_64
    > plasma-drkonqi-5.12.5-1.fc27.x86_64
    > plasma-integration-5.12.5-1.fc27.x86_64
    > plasma-lookandfeel-fedora-5.12.5-1.fc27.noarch
    > plasma-milou-5.12.5-1.fc27.x86_64
    > plasma-nm-5.12.5-2.fc27.x86_64
    > plasma-nm-l2tp-5.12.5-2.fc27.x86_64
    > plasma-nm-openconnect-5.12.5-2.fc27.x86_64
    > plasma-nm-openswan-5.12.5-2.fc27.x86_64
    > plasma-nm-openvpn-5.12.5-2.fc27.x86_64
    > plasma-nm-pptp-5.12.5-2.fc27.x86_64
    > plasma-nm-vpnc-5.12.5-2.fc27.x86_64
    > plasma-pa-5.12.5-1.fc27.x86_64
    > plasma-systemsettings-5.12.5-1.fc27.x86_64
    > plasma-user-manager-5.12.5-1.fc27.x86_64
    > plasma-workspace-5.12.5-1.fc27.x86_64
    > plasma-workspace-common-5.12.5-1.fc27.x86_64
    > plasma-workspace-geolocation-5.12.5-1.fc27.x86_64
    > plasma-workspace-geolocation-libs-5.12.5-1.fc27.x86_64
    > plasma-workspace-libs-5.12.5-1.fc27.x86_64
    > polkit-kde-5.12.5-1.fc27.x86_64
    > powerdevil-5.12.5-1.fc27.x86_64
    > python2-2.7.15-1.fc27.x86_64
    > python2-libs-2.7.15-1.fc27.x86_64
    > python2-pip-9.0.3-2.fc27.noarch
    > python3-pip-9.0.3-2.fc27.noarch
    > python3-sssdconfig-1.16.1-4.fc27.noarch
    > python3-urllib3-1.22-6.fc27.noarch
    > sddm-breeze-5.12.5-1.fc27.noarch
    > sddm-kcm-5.12.5-1.fc27.x86_64
    > sssd-1.16.1-4.fc27.x86_64
    > sssd-ad-1.16.1-4.fc27.x86_64
    > sssd-client-1.16.1-4.fc27.x86_64
    > sssd-common-1.16.1-4.fc27.x86_64
    > sssd-common-pac-1.16.1-4.fc27.x86_64
    > sssd-ipa-1.16.1-4.fc27.x86_64
    > sssd-kcm-1.16.1-4.fc27.x86_64
    > sssd-krb5-1.16.1-4.fc27.x86_64
    > sssd-krb5-common-1.16.1-4.fc27.x86_64
    > sssd-ldap-1.16.1-4.fc27.x86_64
    > sssd-nfs-idmap-1.16.1-4.fc27.x86_64
    > sssd-proxy-1.16.1-4.fc27.x86_64
    > systemd-234-11.git5f8984e.fc27.x86_64
    > systemd-libs-234-11.git5f8984e.fc27.x86_64
    > systemd-pam-234-11.git5f8984e.fc27.x86_64
    > systemd-udev-234-11.git5f8984e.fc27.x86_64
    > vim-minimal-8.0.1806-1.fc27.x86_64
    > webkitgtk4-2.20.2-1.fc27.x86_64
    > webkitgtk4-jsc-2.20.2-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.20.2-1.fc27.x86_64
    > wget-1.19.5-1.fc27.x86_64
    > xdg-utils-1.1.3-1.fc27.noarch
    

    UPD 04.06.18

  • 195 available updates were claimed by SW Updates, but one package, firefox-60.0.1-3.fc27.x86_64 could not be downloaded twice during an update -> was excluded (unmarked) from the update list manually

  • +194 updates installed via SW Updates (193 modified - 1 removed (qupzilla) + 1 new (falkon -- a "modern web browser" ))
    A new full list of 2489 (did not change since the update of sect.51) installed packages :
               /opt/root/Install/rpm_history/180604.0230.rpm-qa.After_reg_sw_update
    ( local copy )
    The added new versions: More... Close
    [root] .../rpm_history $ diff 180524.0422.rpm-qa.rar_installed \
                                  180604.0230.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > accountsservice-0.6.49-1.fc27.x86_64
    > autocorr-en-5.4.7.2-1.fc27.noarch
    > babl-0.1.50-3.fc27.x86_64
    > breeze-icon-theme-5.46.0-1.fc27.noarch
    > ca-certificates-2018.2.24-1.0.fc27.noarch
    > cmake-filesystem-3.11.2-1.fc27.x86_64
    > conky-1.10.8-1.fc27.x86_64
    > curl-7.55.1-11.fc27.x86_64
    > exiv2-0.26-10.fc27.x86_64
    > exiv2-libs-0.26-10.fc27.x86_64
    > falkon-3.0.1-2.fc27.x86_64
    > glibc-2.26-28.fc27.i686
    > glibc-2.26-28.fc27.x86_64
    > glibc-all-langpacks-2.26-28.fc27.x86_64
    > glibc-common-2.26-28.fc27.x86_64
    > glibc-devel-2.26-28.fc27.x86_64
    > glibc-headers-2.26-28.fc27.x86_64
    > glibc-langpack-en-2.26-28.fc27.x86_64
    > goffice-0.10.41-1.fc27.x86_64
    > kernel-4.16.12-200.fc27.x86_64
    > kernel-core-4.16.12-200.fc27.x86_64
    > kernel-headers-4.16.12-200.fc27.x86_64
    > kernel-modules-4.16.12-200.fc27.x86_64
    > kernel-modules-extra-4.16.12-200.fc27.x86_64
    > kf5-attica-5.46.0-1.fc27.x86_64
    > kf5-baloo-5.46.0-1.fc27.x86_64
    > kf5-baloo-file-5.46.0-1.fc27.x86_64
    > kf5-baloo-libs-5.46.0-1.fc27.x86_64
    > kf5-bluez-qt-5.46.0-1.fc27.x86_64
    > kf5-filesystem-5.46.0-1.fc27.x86_64
    > kf5-frameworkintegration-5.46.0-1.fc27.x86_64
    > kf5-frameworkintegration-libs-5.46.0-1.fc27.x86_64
    > kf5-kactivities-libs-5.46.0-1.fc27.x86_64
    > kf5-kactivities-stats-5.46.0-1.fc27.x86_64
    > kf5-karchive-5.46.0-1.fc27.x86_64
    > kf5-kauth-5.46.0-1.fc27.x86_64
    > kf5-kbookmarks-5.46.0-1.fc27.x86_64
    > kf5-kcmutils-5.46.0-1.fc27.x86_64
    > kf5-kcodecs-5.46.0-1.fc27.x86_64
    > kf5-kcompletion-5.46.0-1.fc27.x86_64
    > kf5-kconfig-core-5.46.0-1.fc27.x86_64
    > kf5-kconfig-gui-5.46.0-1.fc27.x86_64
    > kf5-kconfigwidgets-5.46.0-1.fc27.x86_64
    > kf5-kcoreaddons-5.46.0-1.fc27.x86_64
    > kf5-kcrash-5.46.0-1.fc27.x86_64
    > kf5-kdbusaddons-5.46.0-1.fc27.x86_64
    > kf5-kdeclarative-5.46.0-1.fc27.x86_64
    > kf5-kded-5.46.0-1.fc27.x86_64
    > kf5-kdelibs4support-5.46.0-1.fc27.x86_64
    > kf5-kdelibs4support-libs-5.46.0-1.fc27.x86_64
    > kf5-kdesu-5.46.0-1.fc27.x86_64
    > kf5-kdewebkit-5.46.0-1.fc27.x86_64
    > kf5-kdnssd-5.46.0-1.fc27.x86_64
    > kf5-kdoctools-5.46.0-1.fc27.x86_64
    > kf5-kemoticons-5.46.0-1.fc27.x86_64
    > kf5-kfilemetadata-5.46.0-1.fc27.x86_64
    > kf5-kglobalaccel-5.46.0-1.fc27.x86_64
    > kf5-kglobalaccel-libs-5.46.0-1.fc27.x86_64
    > kf5-kguiaddons-5.46.0-1.fc27.x86_64
    > kf5-kholidays-5.46.0-1.fc27.x86_64
    > kf5-khtml-5.46.0-1.fc27.x86_64
    > kf5-ki18n-5.46.0-1.fc27.x86_64
    > kf5-kiconthemes-5.46.0-1.fc27.x86_64
    > kf5-kidletime-5.46.0-1.fc27.x86_64
    > kf5-kimageformats-5.46.0-1.fc27.x86_64
    > kf5-kinit-5.46.0-1.fc27.x86_64
    > kf5-kio-core-5.46.0-2.fc27.x86_64
    > kf5-kio-core-libs-5.46.0-2.fc27.x86_64
    > kf5-kio-doc-5.46.0-2.fc27.noarch
    > kf5-kio-file-widgets-5.46.0-2.fc27.x86_64
    > kf5-kio-gui-5.46.0-2.fc27.x86_64
    > kf5-kio-ntlm-5.46.0-2.fc27.x86_64
    > kf5-kio-widgets-5.46.0-2.fc27.x86_64
    > kf5-kio-widgets-libs-5.46.0-2.fc27.x86_64
    > kf5-kirigami2-5.46.0-1.fc27.x86_64
    > kf5-kitemmodels-5.46.0-1.fc27.x86_64
    > kf5-kitemviews-5.46.0-1.fc27.x86_64
    > kf5-kjobwidgets-5.46.0-1.fc27.x86_64
    > kf5-kjs-5.46.0-1.fc27.x86_64
    > kf5-kjsembed-5.46.0-1.fc27.x86_64
    > kf5-knewstuff-5.46.0-1.fc27.x86_64
    > kf5-knotifications-5.46.0-1.fc27.x86_64
    > kf5-knotifyconfig-5.46.0-1.fc27.x86_64
    > kf5-kpackage-5.46.0-1.fc27.x86_64
    > kf5-kparts-5.46.0-1.fc27.x86_64
    > kf5-kpeople-5.46.0-1.fc27.x86_64
    > kf5-kplotting-5.46.0-1.fc27.x86_64
    > kf5-kpty-5.46.0-1.fc27.x86_64
    > kf5-kross-core-5.46.0-1.fc27.x86_64
    > kf5-kross-ui-5.46.0-1.fc27.x86_64
    > kf5-krunner-5.46.0-1.fc27.x86_64
    > kf5-kservice-5.46.0-1.fc27.x86_64
    > kf5-ktexteditor-5.46.0-1.fc27.x86_64
    > kf5-ktextwidgets-5.46.0-1.fc27.x86_64
    > kf5-kunitconversion-5.46.0-1.fc27.x86_64
    > kf5-kwallet-5.46.0-1.fc27.x86_64
    > kf5-kwallet-libs-5.46.0-1.fc27.x86_64
    > kf5-kwayland-5.46.0-1.fc27.x86_64
    > kf5-kwidgetsaddons-5.46.0-1.fc27.x86_64
    > kf5-kwindowsystem-5.46.0-1.fc27.x86_64
    > kf5-kxmlgui-5.46.0-1.fc27.x86_64
    > kf5-kxmlrpcclient-5.46.0-1.fc27.x86_64
    > kf5-modemmanager-qt-5.46.0-1.fc27.x86_64
    > kf5-networkmanager-qt-5.46.0-1.fc27.x86_64
    > kf5-plasma-5.46.0-1.fc27.x86_64
    > kf5-prison-5.46.0-1.fc27.x86_64
    > kf5-purpose-5.46.0-1.fc27.x86_64
    > kf5-solid-5.46.0-1.fc27.x86_64
    > kf5-solid-libs-5.46.0-1.fc27.x86_64
    > kf5-sonnet-core-5.46.0-1.fc27.x86_64
    > kf5-sonnet-ui-5.46.0-1.fc27.x86_64
    > kf5-syntax-highlighting-5.46.0-1.fc27.x86_64
    > kf5-threadweaver-5.46.0-1.fc27.x86_64
    > libcrypt-nss-2.26-28.fc27.x86_64
    > libcurl-7.55.1-11.fc27.x86_64
    > libidn2-2.0.5-1.fc27.x86_64
    > libipa_hbac-1.16.1-8.fc27.x86_64
    > libpsl-0.18.0-3.fc27.x86_64
    > libreoffice-5.4.7.2-1.fc27.x86_64
    > libreoffice-base-5.4.7.2-1.fc27.x86_64
    > libreoffice-calc-5.4.7.2-1.fc27.x86_64
    > libreoffice-core-5.4.7.2-1.fc27.x86_64
    > libreoffice-data-5.4.7.2-1.fc27.noarch
    > libreoffice-draw-5.4.7.2-1.fc27.x86_64
    > libreoffice-emailmerge-5.4.7.2-1.fc27.x86_64
    > libreoffice-graphicfilter-5.4.7.2-1.fc27.x86_64
    > libreoffice-gtk2-5.4.7.2-1.fc27.x86_64
    > libreoffice-gtk3-5.4.7.2-1.fc27.x86_64
    > libreoffice-help-en-5.4.7.2-1.fc27.x86_64
    > libreoffice-impress-5.4.7.2-1.fc27.x86_64
    > libreoffice-langpack-en-5.4.7.2-1.fc27.x86_64
    > libreoffice-math-5.4.7.2-1.fc27.x86_64
    > libreoffice-opensymbol-fonts-5.4.7.2-1.fc27.noarch
    > libreoffice-pdfimport-5.4.7.2-1.fc27.x86_64
    > libreoffice-pyuno-5.4.7.2-1.fc27.x86_64
    > libreoffice-ure-5.4.7.2-1.fc27.x86_64
    > libreoffice-ure-common-5.4.7.2-1.fc27.noarch
    > libreoffice-writer-5.4.7.2-1.fc27.x86_64
    > libreoffice-x11-5.4.7.2-1.fc27.x86_64
    > libsss_autofs-1.16.1-8.fc27.x86_64
    > libsss_certmap-1.16.1-8.fc27.x86_64
    > libsss_idmap-1.16.1-8.fc27.x86_64
    > libsss_nss_idmap-1.16.1-8.fc27.x86_64
    > libsss_sudo-1.16.1-8.fc27.x86_64
    > ncurses-6.0-14.20170722.fc27.x86_64
    > ncurses-base-6.0-14.20170722.fc27.noarch
    > ncurses-libs-6.0-14.20170722.fc27.x86_64
    > netpbm-10.82.00-1.fc27.x86_64
    > netpbm-progs-10.82.00-1.fc27.x86_64
    > oxygen-icon-theme-5.46.0-1.fc27.noarch
    > perl-Errno-1.28-405.fc27.x86_64
    > perl-interpreter-5.26.2-405.fc27.x86_64
    > perl-IO-1.38-405.fc27.x86_64
    > perl-libs-5.26.2-405.fc27.x86_64
    > perl-macros-5.26.2-405.fc27.x86_64
    > perl-Math-Complex-1.59-405.fc27.noarch
    > perl-Net-HTTP-6.18-1.fc27.noarch
    > perl-open-1.11-405.fc27.noarch
    > perl-SelfLoader-1.23-405.fc27.noarch
    > plasma-discover-5.12.5-2.fc27.x86_64
    > plasma-discover-flatpak-5.12.5-2.fc27.x86_64
    > plasma-discover-libs-5.12.5-2.fc27.x86_64
    > poppler-0.57.0-9.fc27.x86_64
    > poppler-glib-0.57.0-9.fc27.x86_64
    > poppler-qt5-0.57.0-9.fc27.x86_64
    > poppler-utils-0.57.0-9.fc27.x86_64
    > postgresql-libs-9.6.9-1.fc27.x86_64
    > procps-ng-3.3.10-16.fc27.x86_64
    > publicsuffix-list-dafsa-20180514-1.fc27.noarch
    > python2-2.7.15-2.fc27.x86_64
    > python2-libs-2.7.15-2.fc27.x86_64
    > python3-sssdconfig-1.16.1-8.fc27.noarch
    > rsyslog-8.35.0-2.fc27.x86_64
    > SDL2-2.0.7-3.fc27.x86_64
    > skypeforlinux-8.22.0.2-1.x86_64
    > sssd-1.16.1-8.fc27.x86_64
    > sssd-ad-1.16.1-8.fc27.x86_64
    > sssd-client-1.16.1-8.fc27.x86_64
    > sssd-common-1.16.1-8.fc27.x86_64
    > sssd-common-pac-1.16.1-8.fc27.x86_64
    > sssd-ipa-1.16.1-8.fc27.x86_64
    > sssd-kcm-1.16.1-8.fc27.x86_64
    > sssd-krb5-1.16.1-8.fc27.x86_64
    > sssd-krb5-common-1.16.1-8.fc27.x86_64
    > sssd-ldap-1.16.1-8.fc27.x86_64
    > sssd-nfs-idmap-1.16.1-8.fc27.x86_64
    > sssd-proxy-1.16.1-8.fc27.x86_64
    > tzdata-2018e-1.fc27.noarch
    > tzdata-java-2018e-1.fc27.noarch
    > vim-minimal-8.1.026-1.fc27.x86_64
    > vlc-3.0.3-1.fc27.x86_64
    > vlc-core-3.0.3-1.fc27.x86_64
    > volume_key-libs-0.3.10-1.fc27.x86_64
    > wavpack-5.1.0-8.fc27.x86_64
    

  • Both removed and added new packages can be seen via the command
    [root] .../rpm_history $ \
    diff -y --suppress-common-lines \
                    180524.0422.rpm-qa.rar_installed \
                    180604.0230.rpm-qa.After_reg_sw_update \
    | grep -E "<|>"
    

    UPD 20.06.18

  • +210 updates installed via SW Updates (210 modified + 0 new)
  • A new full list of 2489 installed packages (did not change since the update of sect.26 - UPD 04.06.18).
               /opt/root/Install/rpm_history/180620.0251.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added new versions: More... Close
    [root] .../rpm_history $ diff 180604.0230.rpm-qa.After_reg_sw_update \
                                  180620.0251.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > appstream-0.12.0-1.fc27.x86_64
    > appstream-qt-0.12.0-1.fc27.x86_64
    > autocorr-en-5.4.7.2-2.fc27.noarch
    > breeze-icon-theme-5.47.0-1.fc27.noarch
    > cryptsetup-1.7.5-4.fc27.x86_64
    > cryptsetup-libs-1.7.5-4.fc27.x86_64
    > curl-7.55.1-12.fc27.x86_64
    > dbus-1.12.8-1.fc27.x86_64
    > dbus-libs-1.12.8-1.fc27.x86_64
    > dbus-x11-1.12.8-1.fc27.x86_64
    > firefox-60.0.2-1.fc27.x86_64
    > flash-plugin-30.0.0.113-release.x86_64
    > foomatic-db-4.0-55.20170503.fc27.noarch
    > foomatic-db-filesystem-4.0-55.20170503.fc27.noarch
    > foomatic-db-ppds-4.0-55.20170503.fc27.noarch
    > gnupg2-2.2.8-1.fc27.x86_64
    > gnupg2-smime-2.2.8-1.fc27.x86_64
    > iwl1000-firmware-39.31.5.1-85.fc27.1.noarch
    > iwl100-firmware-39.31.5.1-85.fc27.1.noarch
    > iwl105-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl135-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl2000-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl2030-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl3160-firmware-25.30.13.0-85.fc27.1.noarch
    > iwl3945-firmware-15.32.2.9-85.fc27.1.noarch
    > iwl4965-firmware-228.61.2.24-85.fc27.1.noarch
    > iwl5000-firmware-8.83.5.1_1-85.fc27.1.noarch
    > iwl5150-firmware-8.24.2.2-85.fc27.1.noarch
    > iwl6000-firmware-9.221.4.1-85.fc27.1.noarch
    > iwl6000g2a-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl6000g2b-firmware-18.168.6.1-85.fc27.1.noarch
    > iwl6050-firmware-41.28.5.1-85.fc27.1.noarch
    > iwl7260-firmware-25.30.13.0-85.fc27.1.noarch
    > jasper-libs-2.0.14-5.fc27.x86_64
    > java-openjdk-10.0.1.10-4.fc27.x86_64
    > java-openjdk-headless-10.0.1.10-4.fc27.x86_64
    > kernel-4.16.15-200.fc27.x86_64
    > kernel-core-4.16.15-200.fc27.x86_64
    > kernel-headers-4.16.15-200.fc27.x86_64
    > kernel-modules-4.16.15-200.fc27.x86_64
    > kernel-modules-extra-4.16.15-200.fc27.x86_64
    > kf5-attica-5.47.0-1.fc27.x86_64
    > kf5-baloo-5.47.0-1.fc27.x86_64
    > kf5-baloo-file-5.47.0-1.fc27.x86_64
    > kf5-baloo-libs-5.47.0-1.fc27.x86_64
    > kf5-bluez-qt-5.47.0-1.fc27.x86_64
    > kf5-filesystem-5.47.0-1.fc27.x86_64
    > kf5-frameworkintegration-5.47.0-1.fc27.x86_64
    > kf5-frameworkintegration-libs-5.47.0-1.fc27.x86_64
    > kf5-kactivities-libs-5.47.0-1.fc27.x86_64
    > kf5-kactivities-stats-5.47.0-1.fc27.x86_64
    > kf5-karchive-5.47.0-1.fc27.x86_64
    > kf5-kauth-5.47.0-1.fc27.x86_64
    > kf5-kbookmarks-5.47.0-1.fc27.x86_64
    > kf5-kcmutils-5.47.0-1.fc27.x86_64
    > kf5-kcodecs-5.47.0-1.fc27.x86_64
    > kf5-kcompletion-5.47.0-1.fc27.x86_64
    > kf5-kconfig-core-5.47.0-1.fc27.x86_64
    > kf5-kconfig-gui-5.47.0-1.fc27.x86_64
    > kf5-kconfigwidgets-5.47.0-1.fc27.x86_64
    > kf5-kcoreaddons-5.47.0-1.fc27.x86_64
    > kf5-kcrash-5.47.0-1.fc27.x86_64
    > kf5-kdbusaddons-5.47.0-1.fc27.x86_64
    > kf5-kdeclarative-5.47.0-1.fc27.x86_64
    > kf5-kded-5.47.0-1.fc27.x86_64
    > kf5-kdelibs4support-5.47.0-1.fc27.x86_64
    > kf5-kdelibs4support-libs-5.47.0-1.fc27.x86_64
    > kf5-kdesu-5.47.0-1.fc27.x86_64
    > kf5-kdewebkit-5.47.0-1.fc27.x86_64
    > kf5-kdnssd-5.47.0-1.fc27.x86_64
    > kf5-kdoctools-5.47.0-1.fc27.x86_64
    > kf5-kemoticons-5.47.0-1.fc27.x86_64
    > kf5-kfilemetadata-5.47.0-1.fc27.x86_64
    > kf5-kglobalaccel-5.47.0-1.fc27.x86_64
    > kf5-kglobalaccel-libs-5.47.0-1.fc27.x86_64
    > kf5-kguiaddons-5.47.0-1.fc27.x86_64
    > kf5-kholidays-5.47.0-1.fc27.x86_64
    > kf5-khtml-5.47.0-1.fc27.x86_64
    > kf5-ki18n-5.47.0-1.fc27.x86_64
    > kf5-kiconthemes-5.47.0-1.fc27.x86_64
    > kf5-kidletime-5.47.0-1.fc27.x86_64
    > kf5-kimageformats-5.47.0-1.fc27.x86_64
    > kf5-kinit-5.47.0-1.fc27.x86_64
    > kf5-kio-core-5.47.0-2.fc27.x86_64
    > kf5-kio-core-libs-5.47.0-2.fc27.x86_64
    > kf5-kio-doc-5.47.0-2.fc27.noarch
    > kf5-kio-file-widgets-5.47.0-2.fc27.x86_64
    > kf5-kio-gui-5.47.0-2.fc27.x86_64
    > kf5-kio-ntlm-5.47.0-2.fc27.x86_64
    > kf5-kio-widgets-5.47.0-2.fc27.x86_64
    > kf5-kio-widgets-libs-5.47.0-2.fc27.x86_64
    > kf5-kirigami2-5.47.0-1.fc27.x86_64
    > kf5-kitemmodels-5.47.0-1.fc27.x86_64
    > kf5-kitemviews-5.47.0-1.fc27.x86_64
    > kf5-kjobwidgets-5.47.0-1.fc27.x86_64
    > kf5-kjs-5.47.0-1.fc27.x86_64
    > kf5-kjsembed-5.47.0-1.fc27.x86_64
    > kf5-knewstuff-5.47.0-1.fc27.x86_64
    > kf5-knotifications-5.47.0-1.fc27.x86_64
    > kf5-knotifyconfig-5.47.0-1.fc27.x86_64
    > kf5-kpackage-5.47.0-1.fc27.x86_64
    > kf5-kparts-5.47.0-1.fc27.x86_64
    > kf5-kpeople-5.47.0-1.fc27.x86_64
    > kf5-kplotting-5.47.0-1.fc27.x86_64
    > kf5-kpty-5.47.0-1.fc27.x86_64
    > kf5-kross-core-5.47.0-1.fc27.x86_64
    > kf5-kross-ui-5.47.0-1.fc27.x86_64
    > kf5-krunner-5.47.0-1.fc27.x86_64
    > kf5-kservice-5.47.0-1.fc27.x86_64
    > kf5-ktexteditor-5.47.0-1.fc27.x86_64
    > kf5-ktextwidgets-5.47.0-1.fc27.x86_64
    > kf5-kunitconversion-5.47.0-1.fc27.x86_64
    > kf5-kwallet-5.47.0-1.fc27.x86_64
    > kf5-kwallet-libs-5.47.0-1.fc27.x86_64
    > kf5-kwayland-5.47.0-1.fc27.x86_64
    > kf5-kwidgetsaddons-5.47.0-1.fc27.x86_64
    > kf5-kwindowsystem-5.47.0-1.fc27.x86_64
    > kf5-kxmlgui-5.47.0-1.fc27.x86_64
    > kf5-kxmlrpcclient-5.47.0-1.fc27.x86_64
    > kf5-modemmanager-qt-5.47.0-1.fc27.x86_64
    > kf5-networkmanager-qt-5.47.0-1.fc27.x86_64
    > kf5-plasma-5.47.0-1.fc27.x86_64
    > kf5-prison-5.47.0-1.fc27.x86_64
    > kf5-purpose-5.47.0-1.fc27.x86_64
    > kf5-solid-5.47.0-1.fc27.x86_64
    > kf5-solid-libs-5.47.0-1.fc27.x86_64
    > kf5-sonnet-core-5.47.0-1.fc27.x86_64
    > kf5-sonnet-ui-5.47.0-1.fc27.x86_64
    > kf5-syntax-highlighting-5.47.0-1.fc27.x86_64
    > kf5-threadweaver-5.47.0-1.fc27.x86_64
    > libcurl-7.55.1-12.fc27.x86_64
    > libertas-usb8388-firmware-20180525-85.git7518922b.fc27.noarch
    > libgcrypt-1.8.3-1.fc27.x86_64
    > libgpg-error-1.31-1.fc27.x86_64
    > libpcap-1.8.1-7.fc27.x86_64
    > libreoffice-5.4.7.2-2.fc27.x86_64
    > libreoffice-base-5.4.7.2-2.fc27.x86_64
    > libreoffice-calc-5.4.7.2-2.fc27.x86_64
    > libreoffice-core-5.4.7.2-2.fc27.x86_64
    > libreoffice-data-5.4.7.2-2.fc27.noarch
    > libreoffice-draw-5.4.7.2-2.fc27.x86_64
    > libreoffice-emailmerge-5.4.7.2-2.fc27.x86_64
    > libreoffice-graphicfilter-5.4.7.2-2.fc27.x86_64
    > libreoffice-gtk2-5.4.7.2-2.fc27.x86_64
    > libreoffice-gtk3-5.4.7.2-2.fc27.x86_64
    > libreoffice-help-en-5.4.7.2-2.fc27.x86_64
    > libreoffice-impress-5.4.7.2-2.fc27.x86_64
    > libreoffice-langpack-en-5.4.7.2-2.fc27.x86_64
    > libreoffice-math-5.4.7.2-2.fc27.x86_64
    > libreoffice-opensymbol-fonts-5.4.7.2-2.fc27.noarch
    > libreoffice-pdfimport-5.4.7.2-2.fc27.x86_64
    > libreoffice-pyuno-5.4.7.2-2.fc27.x86_64
    > libreoffice-ure-5.4.7.2-2.fc27.x86_64
    > libreoffice-ure-common-5.4.7.2-2.fc27.noarch
    > libreoffice-writer-5.4.7.2-2.fc27.x86_64
    > libreoffice-x11-5.4.7.2-2.fc27.x86_64
    > libtiff-4.0.9-10.fc27.x86_64
    > libunistring-0.9.10-1.fc27.x86_64
    > linux-firmware-20180525-85.git7518922b.fc27.noarch
    > nss-3.37.3-1.0.fc27.x86_64
    > nss-softokn-3.37.3-1.0.fc27.x86_64
    > nss-softokn-freebl-3.37.3-1.0.fc27.x86_64
    > nss-sysinit-3.37.3-1.0.fc27.x86_64
    > nss-tools-3.37.3-1.0.fc27.x86_64
    > nss-util-3.37.3-1.0.fc27.x86_64
    > ntfs-3g-2017.3.23-6.fc27.x86_64
    > ntfsprogs-2017.3.23-6.fc27.x86_64
    > openblas-0.3.0-1.fc27.x86_64
    > openblas-openmp-0.3.0-1.fc27.x86_64
    > openblas-threads-0.3.0-1.fc27.x86_64
    > openblas-threads64_-0.3.0-1.fc27.x86_64
    > oxygen-icon-theme-5.47.0-1.fc27.noarch
    > p11-kit-0.23.12-1.fc27.x86_64
    > p11-kit-trust-0.23.12-1.fc27.x86_64
    > perl-Errno-1.28-406.fc27.x86_64
    > perl-HTTP-Message-6.18-1.fc27.noarch
    > perl-interpreter-5.26.2-406.fc27.x86_64
    > perl-IO-1.38-406.fc27.x86_64
    > perl-libs-5.26.2-406.fc27.x86_64
    > perl-libwww-perl-6.34-1.fc27.noarch
    > perl-macros-5.26.2-406.fc27.x86_64
    > perl-Math-Complex-1.59-406.fc27.noarch
    > perl-open-1.11-406.fc27.noarch
    > perl-SelfLoader-1.23-406.fc27.noarch
    > perl-Storable-3.11-2.fc27.x86_64
    > plasma-discover-5.12.5.1-3.fc27.x86_64
    > plasma-discover-flatpak-5.12.5.1-3.fc27.x86_64
    > plasma-discover-libs-5.12.5.1-3.fc27.x86_64
    > plasma-pk-updates-0.3.2-1.fc27.x86_64
    > quota-4.03-12.fc27.x86_64
    > quota-nls-4.03-12.fc27.noarch
    > ruby-2.4.4-89.fc27.x86_64
    > rubygem-bigdecimal-1.3.2-89.fc27.x86_64
    > rubygem-did_you_mean-1.1.0-89.fc27.x86_64
    > rubygem-io-console-0.4.6-89.fc27.x86_64
    > rubygem-openssl-2.0.7-89.fc27.x86_64
    > rubygem-psych-2.2.2-89.fc27.x86_64
    > rubygems-2.6.14.1-89.fc27.noarch
    > ruby-irb-2.4.4-89.fc27.noarch
    > ruby-libs-2.4.4-89.fc27.x86_64
    > sos-3.5.1-1.fc27.noarch
    > sqlite-3.20.1-3.fc27.x86_64
    > sqlite-libs-3.20.1-3.fc27.x86_64
    > tcpdump-4.9.1-4.fc27.x86_64
    > tigervnc-license-1.8.0-10.fc27.noarch
    > tigervnc-server-minimal-1.8.0-10.fc27.x86_64
    > vim-minimal-8.1.055-1.fc27.x86_64
    > vlc-3.0.3-2.fc27.x86_64
    > vlc-core-3.0.3-2.fc27.x86_64
    > xdg-utils-1.1.3-2.fc27.noarch
    

    UPD 09.07.18

  • +166 updates installed via SW Updates (162 modified + 4 new)
  • A new full list of 2493 (vs 2489 after the update of sect.26 - UPD 20.06.18) installed packages :
               /opt/root/Install/rpm_history/180620.0251.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added 166 modified/new versions: More... Close
    [root] .../rpm_history $ diff 180620.0251.rpm-qa.After_reg_sw_update \
                                  180709.0234.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > autocorr-en-5.4.7.2-3.fc27.noarch
    > bash-4.4.23-1.fc27.x86_64
    > blas-3.8.0-9.fc27.x86_64
    > bubblewrap-0.2.1-1.fc27.x86_64
    > copy-jdk-configs-3.7-1.fc27.noarch
    > editorconfig-libs-0.12.2-3.fc27.x86_64
    > emacs-25.3-4.fc27.x86_64
    > emacs-common-25.3-4.fc27.x86_64
    > emacs-filesystem-25.3-4.fc27.noarch
    > ethtool-4.17-1.fc27.x86_64
    > file-5.31-12.fc27.x86_64
    > file-libs-5.31-12.fc27.x86_64
    > firefox-61.0-4.fc27.x86_64
    > flatpak-0.99.2-1.fc27.x86_64
    > flatpak-libs-0.99.2-1.fc27.x86_64
    > GeoIP-GeoLite-data-2018.06-1.fc27.noarch
    > gnupg-1.4.23-1.fc27.x86_64
    > java-1.8.0-openjdk-headless-1.8.0.172-9.b11.fc27.x86_64
    > kernel-4.17.3-100.fc27.x86_64
    > kernel-core-4.17.3-100.fc27.x86_64
    > kernel-headers-4.17.3-100.fc27.x86_64
    > kernel-modules-4.17.3-100.fc27.x86_64
    > kernel-modules-extra-4.17.3-100.fc27.x86_64
    > kf5-akonadi-server-17.12.3-1.fc27.1.x86_64
    > kf5-akonadi-server-mysql-17.12.3-1.fc27.1.x86_64
    > kf5-frameworkintegration-5.47.0-1.fc27.1.x86_64
    > kf5-frameworkintegration-libs-5.47.0-1.fc27.1.x86_64
    > kf5-kdeclarative-5.47.0-1.fc27.1.x86_64
    > kf5-ktexteditor-5.47.0-4.fc27.x86_64
    > kf5-kwayland-5.47.0-1.fc27.1.x86_64
    > kf5-kxmlgui-5.47.0-1.fc27.1.x86_64
    > kwin-5.12.5-1.fc27.1.x86_64
    > kwin-common-5.12.5-1.fc27.1.x86_64
    > kwin-libs-5.12.5-1.fc27.1.x86_64
    > lapack-3.8.0-9.fc27.x86_64
    > libappstream-glib-0.7.9-1.fc27.x86_64
    > libass-0.13.4-6.fc27.x86_64
    > libgit2-0.26.4-1.fc27.x86_64
    > libgxps-0.3.0-5.fc27.x86_64
    > libipa_hbac-1.16.2-1.fc27.x86_64
    > libodfgen-0.1.7-1.fc27.x86_64
    > LibRaw-0.18.12-1.fc27.x86_64
    > libreoffice-5.4.7.2-3.fc27.x86_64
    > libreoffice-base-5.4.7.2-3.fc27.x86_64
    > libreoffice-calc-5.4.7.2-3.fc27.x86_64
    > libreoffice-core-5.4.7.2-3.fc27.x86_64
    > libreoffice-data-5.4.7.2-3.fc27.noarch
    > libreoffice-draw-5.4.7.2-3.fc27.x86_64
    > libreoffice-emailmerge-5.4.7.2-3.fc27.x86_64
    > libreoffice-graphicfilter-5.4.7.2-3.fc27.x86_64
    > libreoffice-gtk2-5.4.7.2-3.fc27.x86_64
    > libreoffice-gtk3-5.4.7.2-3.fc27.x86_64
    > libreoffice-help-en-5.4.7.2-3.fc27.x86_64
    > libreoffice-impress-5.4.7.2-3.fc27.x86_64
    > libreoffice-langpack-en-5.4.7.2-3.fc27.x86_64
    > libreoffice-math-5.4.7.2-3.fc27.x86_64
    > libreoffice-opensymbol-fonts-5.4.7.2-3.fc27.noarch
    > libreoffice-pdfimport-5.4.7.2-3.fc27.x86_64
    > libreoffice-pyuno-5.4.7.2-3.fc27.x86_64
    > libreoffice-ure-5.4.7.2-3.fc27.x86_64
    > libreoffice-ure-common-5.4.7.2-3.fc27.noarch
    > libreoffice-writer-5.4.7.2-3.fc27.x86_64
    > libreoffice-x11-5.4.7.2-3.fc27.x86_64
    > libsemanage-2.7-3.fc27.x86_64
    > libsemanage-python3-2.7-3.fc27.x86_64
    > libsmbclient-4.7.8-0.fc27.x86_64
    > libsolv-0.6.34-3.fc27.x86_64
    > libsoup-2.60.3-2.fc27.x86_64
    > libsss_autofs-1.16.2-1.fc27.x86_64
    > libsss_certmap-1.16.2-1.fc27.x86_64
    > libsss_idmap-1.16.2-1.fc27.x86_64
    > libsss_nss_idmap-1.16.2-1.fc27.x86_64
    > libsss_sudo-1.16.2-1.fc27.x86_64
    > libwbclient-4.7.8-0.fc27.x86_64
    > lirc-libs-0.10.0-7.fc27.x86_64
    > mariadb-10.2.15-2.fc27.x86_64
    > mariadb-backup-10.2.15-2.fc27.x86_64
    > mariadb-common-10.2.15-2.fc27.x86_64
    > mariadb-config-10.2.15-2.fc27.x86_64
    > mariadb-cracklib-password-check-10.2.15-2.fc27.x86_64
    > mariadb-embedded-10.2.15-2.fc27.x86_64
    > mariadb-errmsg-10.2.15-2.fc27.x86_64
    > mariadb-gssapi-server-10.2.15-2.fc27.x86_64
    > mariadb-libs-10.2.15-2.fc27.x86_64
    > mariadb-rocksdb-engine-10.2.15-2.fc27.x86_64
    > mariadb-server-10.2.15-2.fc27.x86_64
    > mariadb-server-utils-10.2.15-2.fc27.x86_64
    > mariadb-tokudb-engine-10.2.15-2.fc27.x86_64
    > NetworkManager-1.8.8-1.fc27.x86_64
    > NetworkManager-adsl-1.8.8-1.fc27.x86_64
    > NetworkManager-bluetooth-1.8.8-1.fc27.x86_64
    > NetworkManager-config-connectivity-fedora-1.8.8-1.fc27.noarch
    > NetworkManager-glib-1.8.8-1.fc27.x86_64
    > NetworkManager-libnm-1.8.8-1.fc27.x86_64
    > NetworkManager-team-1.8.8-1.fc27.x86_64
    > NetworkManager-wifi-1.8.8-1.fc27.x86_64
    > NetworkManager-wwan-1.8.8-1.fc27.x86_64
    > ostree-2018.6-1.fc27.x86_64
    > ostree-libs-2018.6-1.fc27.x86_64
    > pcre2-10.31-5.fc27.x86_64
    > pcre2-utf16-10.31-5.fc27.x86_64
    > perl-Image-ExifTool-11.01-1.fc27.noarch
    > perl-Time-Local-1.280-1.fc27.noarch
    > pipewire-0.1.9-1.fc27.x86_64
    > pipewire-libs-0.1.9-1.fc27.x86_64
    > plasma-integration-5.12.5-1.fc27.1.x86_64
    > ppp-2.4.7-14.fc27.x86_64
    > python3-sssdconfig-1.16.2-1.fc27.noarch
    > qemu-guest-agent-2.10.1-4.fc27.x86_64
    > qt5-qdbusviewer-5.9.6-1.fc27.x86_64
    > qt5-qtbase-5.9.6-3.fc27.x86_64
    > qt5-qtbase-common-5.9.6-3.fc27.noarch
    > qt5-qtbase-gui-5.9.6-3.fc27.x86_64
    > qt5-qtbase-mysql-5.9.6-3.fc27.x86_64
    > qt5-qtdeclarative-5.9.6-1.fc27.x86_64
    > qt5-qtgraphicaleffects-5.9.6-1.fc27.x86_64
    > qt5-qtimageformats-5.9.6-1.fc27.x86_64
    > qt5-qtlocation-5.9.6-1.fc27.x86_64
    > qt5-qtmultimedia-5.9.6-1.fc27.x86_64
    > qt5-qtquickcontrols2-5.9.6-1.fc27.x86_64
    > qt5-qtquickcontrols-5.9.6-1.fc27.x86_64
    > qt5-qtscript-5.9.6-1.fc27.x86_64
    > qt5-qtsensors-5.9.6-1.fc27.x86_64
    > qt5-qtserialport-5.9.6-1.fc27.x86_64
    > qt5-qtspeech-5.9.6-1.fc27.x86_64
    > qt5-qtspeech-speechd-5.9.6-1.fc27.x86_64
    > qt5-qtsvg-5.9.6-1.fc27.x86_64
    > qt5-qttools-5.9.6-1.fc27.x86_64
    > qt5-qttools-common-5.9.6-1.fc27.noarch
    > qt5-qttools-libs-designer-5.9.6-1.fc27.x86_64
    > qt5-qtvirtualkeyboard-5.9.6-1.fc27.x86_64
    > qt5-qtwayland-5.9.6-1.fc27.x86_64
    > qt5-qtwebchannel-5.9.6-1.fc27.x86_64
    > qt5-qtwebengine-5.10.1-4.fc27.1.x86_64
    > qt5-qtwebkit-5.212.0-0.20.alpha2.fc27.1.x86_64
    > qt5-qtx11extras-5.9.6-1.fc27.x86_64
    > qt5-qtxmlpatterns-5.9.6-1.fc27.x86_64
    > samba-client-4.7.8-0.fc27.x86_64
    > samba-client-libs-4.7.8-0.fc27.x86_64
    > samba-common-4.7.8-0.fc27.noarch
    > samba-common-libs-4.7.8-0.fc27.x86_64
    > samba-dc-libs-4.7.8-0.fc27.x86_64
    > samba-libs-4.7.8-0.fc27.x86_64
    > selinux-policy-3.13.1-283.35.fc27.noarch
    > selinux-policy-targeted-3.13.1-283.35.fc27.noarch
    > skypeforlinux-8.25.0.5-1.x86_64
    > sssd-1.16.2-1.fc27.x86_64
    > sssd-ad-1.16.2-1.fc27.x86_64
    > sssd-client-1.16.2-1.fc27.x86_64
    > sssd-common-1.16.2-1.fc27.x86_64
    > sssd-common-pac-1.16.2-1.fc27.x86_64
    > sssd-ipa-1.16.2-1.fc27.x86_64
    > sssd-kcm-1.16.2-1.fc27.x86_64
    > sssd-krb5-1.16.2-1.fc27.x86_64
    > sssd-krb5-common-1.16.2-1.fc27.x86_64
    > sssd-ldap-1.16.2-1.fc27.x86_64
    > sssd-nfs-idmap-1.16.2-1.fc27.x86_64
    > sssd-proxy-1.16.2-1.fc27.x86_64
    > sudo-1.8.23-1.fc27.x86_64
    > unbound-libs-1.7.2-1.fc27.x86_64
    > vim-minimal-8.1.119-2.fc27.x86_64
    > webkitgtk4-2.20.3-1.fc27.x86_64
    > webkitgtk4-jsc-2.20.3-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.20.3-1.fc27.x86_64
    > xdg-desktop-portal-0.11-1.fc27.x86_64
    > xdg-desktop-portal-gtk-0.11-1.fc27.x86_64
    
  • The new 4 packages (from
    [root] .../rpm_history $ diff -y --suppress-common-lines \
                               180620.0251.rpm-qa.After_reg_sw_update \
                               180709.0234.rpm-qa.After_reg_sw_update \
                           | grep -E "<|>"
    
    + a visual inspectiion of the result of
               "diff -y --suppress-common-lines ..." w/o grep ) :
    editorconfig-libs-0.12.2-3.fc27.x86_64
    mariadb-cracklib-password-check-10.2.15-2.fc27.x86_64
    pipewire-0.1.9-1.fc27.x86_64
    pipewire-libs-0.
    

    UPD 02.08.18

  • +181 updates installed via SW Updates (179 modified, 2 new) and 2 packages unistalled.
  • A new full list of installed packages (2493 in total -- did not change since the update of sect.26 - UPD 09.07.18) :
               /opt/root/Install/rpm_history/180802.0109.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added 181 modified/new versions: More... Close
    [root] .../rpm_history $ diff 180709.0234.rpm-qa.After_reg_sw_update \
                                  180802.0109.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > babl-0.1.52-1.fc27.x86_64
    > bind-libs-9.11.4-1.fc27.x86_64
    > bind-libs-lite-9.11.4-1.fc27.x86_64
    > bind-license-9.11.4-1.fc27.noarch
    > bind-utils-9.11.4-1.fc27.x86_64
    > bluedevil-5.12.6-1.fc27.x86_64
    > breeze-cursor-theme-5.12.6-1.fc27.noarch
    > cpp-7.3.1-6.fc27.x86_64
    > dcraw-9.28.0-1.fc27.x86_64
    > dnsmasq-2.79-3.fc27.x86_64
    > ffmpeg-3.3.8-1.fc27.x86_64
    > ffmpeg-libs-3.3.8-1.fc27.x86_64
    > firefox-61.0.1-3.fc27.x86_64
    > flash-plugin-30.0.0.134-release.x86_64
    > flatpak-0.99.3-1.fc27.x86_64
    > flatpak-libs-0.99.3-1.fc27.x86_64
    > gcc-7.3.1-6.fc27.x86_64
    > gcc-c++-7.3.1-6.fc27.x86_64
    > gdisk-1.0.4-1.fc27.x86_64
    > glib2-2.54.3-3.fc27.x86_64
    > gparted-0.31.0-4.fc27.x86_64
    > gstreamer1-plugins-bad-free-1.12.4-2.fc27.x86_64
    > gstreamer1-plugins-bad-free-extras-1.12.4-2.fc27.x86_64
    > gstreamer1-plugins-bad-free-gtk-1.12.4-2.fc27.x86_64
    > gstreamer-plugins-bad-free-0.10.23-42.fc27.x86_64
    > gstreamer-plugins-bad-free-extras-0.10.23-42.fc27.x86_64
    > gutenprint-5.2.14-1.fc27.x86_64
    > gutenprint-cups-5.2.14-1.fc27.x86_64
    > gutenprint-libs-5.2.14-1.fc27.x86_64
    > hwdata-0.313-1.fc27.noarch
    > java-1.8.0-openjdk-headless-1.8.0.181-7.b13.fc27.x86_64
    > java-openjdk-10.0.2.13-1.fc27.x86_64
    > java-openjdk-headless-10.0.2.13-1.fc27.x86_64
    > kactivitymanagerd-5.12.6-1.fc27.x86_64
    > kde-cli-tools-5.12.6-1.fc27.x86_64
    > kdecoration-5.12.6-1.fc27.x86_64
    > kde-gtk-config-5.12.6-1.fc27.x86_64
    > kdeplasma-addons-5.12.6-1.fc27.x86_64
    > kde-style-breeze-5.12.6-1.fc27.x86_64
    > kdesu-5.12.6-1.fc27.x86_64
    > kernel-4.17.9-100.fc27.x86_64
    > kernel-core-4.17.9-100.fc27.x86_64
    > kernel-headers-4.17.9-100.fc27.x86_64
    > kernel-modules-4.17.9-100.fc27.x86_64
    > kernel-modules-extra-4.17.9-100.fc27.x86_64
    > khotkeys-5.12.6-1.fc27.x86_64
    > kinfocenter-5.12.6-1.fc27.x86_64
    > kmenuedit-5.12.6-1.fc27.x86_64
    > konversation-1.7.5-2.fc27.x86_64
    > kscreen-5.12.6-1.fc27.x86_64
    > kscreenlocker-5.12.6-1.fc27.x86_64
    > ksshaskpass-5.12.6-1.fc27.x86_64
    > ksysguard-5.12.6-1.fc27.x86_64
    > ksysguardd-5.12.6-1.fc27.x86_64
    > kwin-5.12.6-1.fc27.x86_64
    > kwin-common-5.12.6-1.fc27.x86_64
    > kwin-libs-5.12.6-1.fc27.x86_64
    > kwrited-5.12.6-1.fc27.x86_64
    > libavdevice-3.3.8-1.fc27.x86_64
    > libgcc-7.3.1-6.fc27.i686
    > libgcc-7.3.1-6.fc27.x86_64
    > libgfortran-7.3.1-6.fc27.x86_64
    > libgit2-0.26.5-1.fc27.x86_64
    > libgomp-7.3.1-6.fc27.x86_64
    > libipa_hbac-1.16.2-4.fc27.x86_64
    > libkscreen-qt5-5.12.6-1.fc27.x86_64
    > libksysguard-5.12.6-1.fc27.x86_64
    > libksysguard-common-5.12.6-1.fc27.x86_64
    > libkworkspace5-5.12.6-1.fc27.x86_64
    > libnice-0.1.14-7.20180504git34d6044.fc27.x86_64
    > libnice-gstreamer1-0.1.14-7.20180504git34d6044.fc27.x86_64
    > libobjc-7.3.1-6.fc27.x86_64
    > libomp-5.0.2-1.fc27.x86_64
    > libquadmath-7.3.1-6.fc27.x86_64
    > LibRaw-0.18.13-1.fc27.x86_64
    > libsss_autofs-1.16.2-4.fc27.x86_64
    > libsss_certmap-1.16.2-4.fc27.x86_64
    > libsss_idmap-1.16.2-4.fc27.x86_64
    > libsss_nss_idmap-1.16.2-4.fc27.x86_64
    > libsss_sudo-1.16.2-4.fc27.x86_64
    > libstdc++-7.3.1-6.fc27.x86_64
    > libstdc++-devel-7.3.1-6.fc27.x86_64
    > libzstd-1.3.5-1.fc27.x86_64
    > mariadb-10.2.16-1.fc27.x86_64
    > mariadb-backup-10.2.16-1.fc27.x86_64
    > mariadb-common-10.2.16-1.fc27.x86_64
    > mariadb-config-10.2.16-1.fc27.x86_64
    > mariadb-cracklib-password-check-10.2.16-1.fc27.x86_64
    > mariadb-embedded-10.2.16-1.fc27.x86_64
    > mariadb-errmsg-10.2.16-1.fc27.x86_64
    > mariadb-gssapi-server-10.2.16-1.fc27.x86_64
    > mariadb-libs-10.2.16-1.fc27.x86_64
    > mariadb-rocksdb-engine-10.2.16-1.fc27.x86_64
    > mariadb-server-10.2.16-1.fc27.x86_64
    > mariadb-server-utils-10.2.16-1.fc27.x86_64
    > mariadb-tokudb-engine-10.2.16-1.fc27.x86_64
    > mesa-dri-drivers-17.3.9-1.fc27.x86_64
    > mesa-filesystem-17.3.9-1.fc27.x86_64
    > mesa-libEGL-17.3.9-1.fc27.x86_64
    > mesa-libgbm-17.3.9-1.fc27.x86_64
    > mesa-libGL-17.3.9-1.fc27.x86_64
    > mesa-libglapi-17.3.9-1.fc27.x86_64
    > mesa-libOpenCL-17.3.9-1.fc27.x86_64
    > mesa-libwayland-egl-17.3.9-1.fc27.x86_64
    > mesa-libxatracker-17.3.9-1.fc27.x86_64
    > mesa-vulkan-drivers-17.3.9-1.fc27.x86_64
    > microcode_ctl-2.1-24.fc27.x86_64
    > NetworkManager-vpnc-1.2.6-1.fc27.x86_64
    > nss-3.38.0-1.0.fc27.x86_64
    > nss-softokn-3.38.0-1.0.fc27.x86_64
    > nss-softokn-freebl-3.38.0-1.0.fc27.x86_64
    > nss-sysinit-3.38.0-1.0.fc27.x86_64
    > nss-tools-3.38.0-1.0.fc27.x86_64
    > nss-util-3.38.0-1.0.fc27.x86_64
    > openblas-0.3.1-1.fc27.x86_64
    > openblas-openmp-0.3.1-1.fc27.x86_64
    > openblas-serial-0.3.1-1.fc27.x86_64
    > openblas-threads-0.3.1-1.fc27.x86_64
    > openblas-threads64_-0.3.1-1.fc27.x86_64
    > open-vm-tools-10.2.5-6.fc27.x86_64
    > open-vm-tools-desktop-10.2.5-6.fc27.x86_64
    > oxygen-sound-theme-5.12.6-1.fc27.noarch
    > pam-kwallet-5.12.6-1.fc27.x86_64
    > pcre2-10.31-7.fc27.x86_64
    > pcre2-utf16-10.31-7.fc27.x86_64
    > pcre-8.42-2.fc27.x86_64
    > perl-File-Temp-0.230.600-1.fc27.noarch
    > plasma-breeze-5.12.6-1.fc27.x86_64
    > plasma-breeze-common-5.12.6-1.fc27.noarch
    > plasma-desktop-5.12.6-1.fc27.x86_64
    > plasma-desktop-doc-5.12.6-1.fc27.noarch
    > plasma-discover-5.12.6-1.fc27.x86_64
    > plasma-discover-flatpak-5.12.6-1.fc27.x86_64
    > plasma-discover-libs-5.12.6-1.fc27.x86_64
    > plasma-drkonqi-5.12.6-1.fc27.x86_64
    > plasma-integration-5.12.6-1.fc27.x86_64
    > plasma-lookandfeel-fedora-5.12.6-1.fc27.noarch
    > plasma-milou-5.12.6-1.fc27.x86_64
    > plasma-pa-5.12.6-1.fc27.x86_64
    > plasma-systemsettings-5.12.6-1.fc27.x86_64
    > plasma-user-manager-5.12.6-1.fc27.x86_64
    > plasma-workspace-5.12.6-1.fc27.x86_64
    > plasma-workspace-common-5.12.6-1.fc27.x86_64
    > plasma-workspace-geolocation-5.12.6-1.fc27.x86_64
    > plasma-workspace-geolocation-libs-5.12.6-1.fc27.x86_64
    > plasma-workspace-libs-5.12.6-1.fc27.x86_64
    > polkit-0.113-16.fc27.x86_64
    > polkit-kde-5.12.6-1.fc27.x86_64
    > polkit-libs-0.113-16.fc27.x86_64
    > powerdevil-5.12.6-1.fc27.x86_64
    > pulseaudio-12.2-1.fc27.x86_64
    > pulseaudio-libs-12.2-1.fc27.x86_64
    > pulseaudio-libs-glib2-12.2-1.fc27.x86_64
    > pulseaudio-module-bluetooth-12.2-1.fc27.x86_64
    > pulseaudio-module-x11-12.2-1.fc27.x86_64
    > pulseaudio-utils-12.2-1.fc27.x86_64
    > python3-3.6.6-1.fc27.x86_64
    > python3-bind-9.11.4-1.fc27.noarch
    > python3-cryptography-2.3-1.fc27.x86_64
    > python3-libs-3.6.6-1.fc27.x86_64
    > python3-sssdconfig-1.16.2-4.fc27.noarch
    > sddm-breeze-5.12.6-1.fc27.noarch
    > sddm-kcm-5.12.6-1.fc27.x86_64
    > skypeforlinux-8.26.0.70-1.x86_64
    > soundtouch-2.0.0-3.fc27.x86_64
    > sssd-1.16.2-4.fc27.x86_64
    > sssd-ad-1.16.2-4.fc27.x86_64
    > sssd-client-1.16.2-4.fc27.x86_64
    > sssd-common-1.16.2-4.fc27.x86_64
    > sssd-common-pac-1.16.2-4.fc27.x86_64
    > sssd-ipa-1.16.2-4.fc27.x86_64
    > sssd-kcm-1.16.2-4.fc27.x86_64
    > sssd-krb5-1.16.2-4.fc27.x86_64
    > sssd-krb5-common-1.16.2-4.fc27.x86_64
    > sssd-ldap-1.16.2-4.fc27.x86_64
    > sssd-nfs-idmap-1.16.2-4.fc27.x86_64
    > sssd-proxy-1.16.2-4.fc27.x86_64
    > unbound-libs-1.7.3-3.fc27.x86_64
    > vim-minimal-8.1.177-1.fc27.x86_64
    > vulkan-loader-1.1.77.0-4.fc27.x86_64
    > xapian-core-libs-1.4.6-1.fc27.x86_64
    

  • From a visual inspection of the result of
    "diff -y --suppress-common-lines ...":
    • the 2 new packages : openblas-serial, vulkan-loader ,
    • the 2 uninstalled packages: vulkan , vulkan-filesystem .

    UPD 26.08.18

  • +255 updates installed via SW Updates (253 modified, 2 new) and 1 package unistalled.
  • A new full list of installed packages (2494 in total vs 2493 after the update of sect.26 - UPD 02.08.18) :
               /opt/root/Install/rpm_history/180826.2333.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added 255 modified/new versions: More... Close
    [root] .../rpm_history $ diff 180802.0109.rpm-qa.After_reg_sw_update \
                                  180826.2333.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > appstream-data-27-12.fc27.noarch
    > avahi-0.7-13.fc27.x86_64
    > avahi-glib-0.7-13.fc27.x86_64
    > avahi-gobject-0.7-13.fc27.x86_64
    > avahi-libs-0.7-13.fc27.x86_64
    > bind-libs-9.11.4-2.P1.fc27.x86_64
    > bind-libs-lite-9.11.4-2.P1.fc27.x86_64
    > bind-license-9.11.4-2.P1.fc27.noarch
    > bind-utils-9.11.4-2.P1.fc27.x86_64
    > boost-1.64.0-7.fc27.x86_64
    > boost-atomic-1.64.0-7.fc27.x86_64
    > boost-chrono-1.64.0-7.fc27.x86_64
    > boost-container-1.64.0-7.fc27.x86_64
    > boost-context-1.64.0-7.fc27.x86_64
    > boost-coroutine-1.64.0-7.fc27.x86_64
    > boost-date-time-1.64.0-7.fc27.x86_64
    > boost-doc-1.64.0-7.fc27.x86_64
    > boost-fiber-1.64.0-7.fc27.x86_64
    > boost-filesystem-1.64.0-7.fc27.x86_64
    > boost-graph-1.64.0-7.fc27.x86_64
    > boost-iostreams-1.64.0-7.fc27.x86_64
    > boost-locale-1.64.0-7.fc27.x86_64
    > boost-log-1.64.0-7.fc27.x86_64
    > boost-math-1.64.0-7.fc27.x86_64
    > boost-numpy-1.64.0-7.fc27.x86_64
    > boost-program-options-1.64.0-7.fc27.x86_64
    > boost-python-1.64.0-7.fc27.x86_64
    > boost-random-1.64.0-7.fc27.x86_64
    > boost-regex-1.64.0-7.fc27.x86_64
    > boost-serialization-1.64.0-7.fc27.x86_64
    > boost-signals-1.64.0-7.fc27.x86_64
    > boost-system-1.64.0-7.fc27.x86_64
    > boost-test-1.64.0-7.fc27.x86_64
    > boost-thread-1.64.0-7.fc27.x86_64
    > boost-timer-1.64.0-7.fc27.x86_64
    > boost-type_erasure-1.64.0-7.fc27.x86_64
    > boost-wave-1.64.0-7.fc27.x86_64
    > breeze-icon-theme-5.48.0-2.fc27.noarch
    > cups-2.2.4-12.fc27.x86_64
    > cups-client-2.2.4-12.fc27.x86_64
    > cups-filesystem-2.2.4-12.fc27.noarch
    > cups-libs-2.2.4-12.fc27.x86_64
    > curl-7.55.1-13.fc27.x86_64
    > exiv2-0.26-12.fc27.x86_64
    > exiv2-libs-0.26-12.fc27.x86_64
    > firefox-61.0.2-1.fc27.x86_64
    > flash-plugin-30.0.0.154-release.x86_64
    > fpaste-0.3.9.2-1.fc27.noarch
    > freerdp-2.0.0-44.rc3.fc27.x86_64
    > freerdp-libs-2.0.0-44.rc3.fc27.x86_64
    > fuse-sshfs-2.10-1.fc27.x86_64
    > goffice-0.10.42-1.fc27.x86_64
    > gstreamer1-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-bad-free-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-bad-free-extras-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-bad-free-gtk-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-base-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-good-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-good-extras-1.12.5-1.fc27.x86_64
    > hwdata-0.314-1.fc27.noarch
    > iwl1000-firmware-39.31.5.1-86.fc27.1.noarch
    > iwl100-firmware-39.31.5.1-86.fc27.1.noarch
    > iwl105-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl135-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl2000-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl2030-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl3160-firmware-25.30.13.0-86.fc27.1.noarch
    > iwl3945-firmware-15.32.2.9-86.fc27.1.noarch
    > iwl4965-firmware-228.61.2.24-86.fc27.1.noarch
    > iwl5000-firmware-8.83.5.1_1-86.fc27.1.noarch
    > iwl5150-firmware-8.24.2.2-86.fc27.1.noarch
    > iwl6000-firmware-9.221.4.1-86.fc27.1.noarch
    > iwl6000g2a-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl6000g2b-firmware-18.168.6.1-86.fc27.1.noarch
    > iwl6050-firmware-41.28.5.1-86.fc27.1.noarch
    > iwl7260-firmware-25.30.13.0-86.fc27.1.noarch
    > javapackages-tools-5.0.0-8.fc27.noarch
    > kernel-4.17.17-100.fc27.x86_64
    > kernel-core-4.17.17-100.fc27.x86_64
    > kernel-headers-4.17.17-1.fc27.x86_64
    > kernel-modules-4.17.17-100.fc27.x86_64
    > kernel-modules-extra-4.17.17-100.fc27.x86_64
    > kf5-attica-5.48.0-2.fc27.x86_64
    > kf5-baloo-5.48.0-1.fc27.x86_64
    > kf5-baloo-file-5.48.0-1.fc27.x86_64
    > kf5-baloo-libs-5.48.0-1.fc27.x86_64
    > kf5-bluez-qt-5.48.0-2.fc27.x86_64
    > kf5-filesystem-5.48.0-3.fc27.x86_64
    > kf5-frameworkintegration-5.48.0-1.fc27.x86_64
    > kf5-frameworkintegration-libs-5.48.0-1.fc27.x86_64
    > kf5-kactivities-5.48.0-3.fc27.x86_64
    > kf5-kactivities-stats-5.48.0-2.fc27.x86_64
    > kf5-karchive-5.48.0-2.fc27.x86_64
    > kf5-kauth-5.48.0-2.fc27.x86_64
    > kf5-kbookmarks-5.48.0-2.fc27.x86_64
    > kf5-kcmutils-5.48.0-1.fc27.x86_64
    > kf5-kcodecs-5.48.0-2.fc27.x86_64
    > kf5-kcompletion-5.48.0-2.fc27.x86_64
    > kf5-kconfig-core-5.48.0-2.fc27.x86_64
    > kf5-kconfig-gui-5.48.0-2.fc27.x86_64
    > kf5-kconfigwidgets-5.48.0-2.fc27.x86_64
    > kf5-kcoreaddons-5.48.0-2.fc27.x86_64
    > kf5-kcrash-5.48.0-2.fc27.x86_64
    > kf5-kdbusaddons-5.48.0-2.fc27.x86_64
    > kf5-kdeclarative-5.48.0-1.fc27.x86_64
    > kf5-kded-5.48.0-1.fc27.x86_64
    > kf5-kdelibs4support-5.48.0-2.fc27.x86_64
    > kf5-kdelibs4support-libs-5.48.0-2.fc27.x86_64
    > kf5-kdesu-5.48.0-2.fc27.x86_64
    > kf5-kdewebkit-5.48.0-1.fc27.x86_64
    > kf5-kdnssd-5.48.0-2.fc27.x86_64
    > kf5-kdoctools-5.48.0-2.fc27.x86_64
    > kf5-kemoticons-5.48.0-2.fc27.x86_64
    > kf5-kfilemetadata-5.48.0-2.fc27.x86_64
    > kf5-kglobalaccel-5.48.0-2.fc27.x86_64
    > kf5-kglobalaccel-libs-5.48.0-2.fc27.x86_64
    > kf5-kguiaddons-5.48.0-2.fc27.x86_64
    > kf5-kholidays-5.48.0-2.fc27.x86_64
    > kf5-khtml-5.48.0-1.fc27.x86_64
    > kf5-ki18n-5.48.0-2.fc27.x86_64
    > kf5-kiconthemes-5.48.0-2.fc27.x86_64
    > kf5-kidletime-5.48.0-2.fc27.x86_64
    > kf5-kimageformats-5.48.0-2.fc27.x86_64
    > kf5-kinit-5.48.0-1.fc27.x86_64
    > kf5-kio-core-5.48.0-1.fc27.x86_64
    > kf5-kio-core-libs-5.48.0-1.fc27.x86_64
    > kf5-kio-doc-5.48.0-1.fc27.noarch
    > kf5-kio-file-widgets-5.48.0-1.fc27.x86_64
    > kf5-kio-gui-5.48.0-1.fc27.x86_64
    > kf5-kio-ntlm-5.48.0-1.fc27.x86_64
    > kf5-kio-widgets-5.48.0-1.fc27.x86_64
    > kf5-kio-widgets-libs-5.48.0-1.fc27.x86_64
    > kf5-kirigami2-5.48.0-2.fc27.x86_64
    > kf5-kitemmodels-5.48.0-2.fc27.x86_64
    > kf5-kitemviews-5.48.0-2.fc27.x86_64
    > kf5-kjobwidgets-5.48.0-2.fc27.x86_64
    > kf5-kjs-5.48.0-2.fc27.x86_64
    > kf5-kjsembed-5.48.0-2.fc27.x86_64
    > kf5-knewstuff-5.48.0-1.fc27.x86_64
    > kf5-knotifications-5.48.0-2.fc27.x86_64
    > kf5-knotifyconfig-5.48.0-1.fc27.x86_64
    > kf5-kpackage-5.48.0-2.fc27.x86_64
    > kf5-kparts-5.48.0-1.fc27.x86_64
    > kf5-kpeople-5.48.0-2.fc27.x86_64
    > kf5-kplotting-5.48.0-2.fc27.x86_64
    > kf5-kpty-5.48.0-2.fc27.x86_64
    > kf5-kross-core-5.48.0-1.fc27.x86_64
    > kf5-kross-ui-5.48.0-1.fc27.x86_64
    > kf5-krunner-5.48.0-2.fc27.x86_64
    > kf5-kservice-5.48.0-2.fc27.x86_64
    > kf5-ktexteditor-5.48.0-1.fc27.x86_64
    > kf5-ktextwidgets-5.48.0-3.fc27.x86_64
    > kf5-kunitconversion-5.48.0-2.fc27.x86_64
    > kf5-kwallet-5.48.0-2.fc27.x86_64
    > kf5-kwallet-libs-5.48.0-2.fc27.x86_64
    > kf5-kwayland-5.48.0-2.fc27.x86_64
    > kf5-kwidgetsaddons-5.48.0-2.fc27.x86_64
    > kf5-kwindowsystem-5.48.0-2.fc27.x86_64
    > kf5-kxmlgui-5.48.0-2.fc27.x86_64
    > kf5-kxmlrpcclient-5.48.0-1.fc27.x86_64
    > kf5-modemmanager-qt-5.48.0-2.fc27.x86_64
    > kf5-networkmanager-qt-5.48.0-2.fc27.x86_64
    > kf5-plasma-5.48.0-2.fc27.x86_64
    > kf5-prison-5.48.0-2.fc27.x86_64
    > kf5-purpose-5.48.0-1.fc27.x86_64
    > kf5-solid-5.48.0-2.fc27.x86_64
    > kf5-sonnet-core-5.48.0-2.fc27.x86_64
    > kf5-sonnet-ui-5.48.0-2.fc27.x86_64
    > kf5-syntax-highlighting-5.48.0-2.fc27.x86_64
    > kf5-threadweaver-5.48.0-2.fc27.x86_64
    > libbytesize-1.4-1.fc27.x86_64
    > libcurl-7.55.1-13.fc27.x86_64
    > libdvdnav-6.0.0-1.fc27.x86_64
    > libdvdread-6.0.0-1.fc27.x86_64
    > libebml-1.3.6-1.fc27.x86_64
    > libertas-usb8388-firmware-20180815-86.gitf1b95fe5.fc27.noarch
    > libfprint-0.8.2-1.fc27.x86_64
    > libgit2-0.26.6-1.fc27.x86_64
    > libmatroska-1.4.9-1.fc27.x86_64
    > libmspack-0.7-0.1.alpha.fc27.x86_64
    > libpcap-1.9.0-1.fc27.x86_64
    > librados2-12.2.7-1.fc27.x86_64
    > libreswan-3.25-3.fc27.x86_64
    > libsmbclient-4.7.9-0.fc27.x86_64
    > libsolv-0.6.35-1.fc27.x86_64
    > libwbclient-4.7.9-0.fc27.x86_64
    > libwinpr-2.0.0-44.rc3.fc27.x86_64
    > libwmf-0.2.8.4-56.fc27.x86_64
    > libwmf-lite-0.2.8.4-56.fc27.x86_64
    > libwps-0.4.10-1.fc27.x86_64
    > libxml2-2.9.8-4.fc27.x86_64
    > link-grammar-5.5.1-4.fc27.x86_64
    > linux-firmware-20180815-86.gitf1b95fe5.fc27.noarch
    > mediawriter-4.1.2-1.fc27.x86_64
    > microcode_ctl-2.1-26.fc27.x86_64
    > netpbm-10.83.01-1.fc27.x86_64
    > netpbm-progs-10.83.01-1.fc27.x86_64
    > openblas-0.3.2-1.fc27.x86_64
    > openblas-openmp-0.3.2-1.fc27.x86_64
    > openblas-serial-0.3.2-1.fc27.x86_64
    > openblas-threads-0.3.2-1.fc27.x86_64
    > openblas-threads64_-0.3.2-1.fc27.x86_64
    > open-vm-tools-10.3.0-4.fc27.x86_64
    > open-vm-tools-desktop-10.3.0-4.fc27.x86_64
    > oxygen-icon-theme-5.48.0-2.fc27.noarch
    > pcre2-10.31-8.fc27.x86_64
    > pcre2-utf16-10.31-8.fc27.x86_64
    > perl-Errno-1.28-407.fc27.x86_64
    > perl-HTTP-Tiny-0.076-1.fc27.noarch
    > perl-interpreter-5.26.2-407.fc27.x86_64
    > perl-IO-1.38-407.fc27.x86_64
    > perl-libs-5.26.2-407.fc27.x86_64
    > perl-macros-5.26.2-407.fc27.x86_64
    > perl-Math-Complex-1.59-407.fc27.noarch
    > perl-open-1.11-407.fc27.noarch
    > perl-SelfLoader-1.23-407.fc27.noarch
    > poppler-0.57.0-10.fc27.x86_64
    > poppler-glib-0.57.0-10.fc27.x86_64
    > poppler-qt5-0.57.0-10.fc27.x86_64
    > poppler-utils-0.57.0-10.fc27.x86_64
    > postgresql-libs-9.6.10-1.fc27.x86_64
    > python2-setuptools-37.0.0-2.fc27.noarch
    > python3-bind-9.11.4-2.P1.fc27.noarch
    > python3-bytesize-1.4-1.fc27.x86_64
    > python3-libxml2-2.9.8-4.fc27.x86_64
    > python3-setuptools-37.0.0-2.fc27.noarch
    > qemu-guest-agent-2.10.2-1.fc27.x86_64
    > rpmfusion-free-appstream-data-27-3.fc27.noarch
    > rpmfusion-nonfree-appstream-data-27-3.fc27.noarch
    > rsyslog-8.37.0-1.fc27.x86_64
    > samba-client-4.7.9-0.fc27.x86_64
    > samba-client-libs-4.7.9-0.fc27.x86_64
    > samba-common-4.7.9-0.fc27.noarch
    > samba-common-libs-4.7.9-0.fc27.x86_64
    > samba-dc-libs-4.7.9-0.fc27.x86_64
    > samba-libs-4.7.9-0.fc27.x86_64
    > seamonkey-2.49.4-1.fc27.x86_64
    > selinux-policy-3.13.1-284.37.fc27.noarch
    > selinux-policy-targeted-3.13.1-284.37.fc27.noarch
    > skypeforlinux-8.28.0.41-1.x86_64
    > soundtouch-2.0.0-6.fc27.x86_64
    > telnet-0.17-72.fc27.x86_64
    > tigervnc-license-1.9.0-2.fc27.noarch
    > tigervnc-server-minimal-1.9.0-2.fc27.x86_64
    > usermode-1.112-3.fc27.x86_64
    > vim-minimal-8.1.279-1.fc27.x86_64
    > webkitgtk4-2.20.5-1.fc27.x86_64
    > webkitgtk4-jsc-2.20.5-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.20.5-1.fc27.x86_64
    > wpa_supplicant-2.6-14.fc27.x86_64
    > xdg-desktop-portal-0.99-1.fc27.x86_64
    > xdg-desktop-portal-gtk-0.99-1.fc27.x86_64
    > xterm-331-1.fc27.x86_64
    > xterm-resize-331-1.fc27.x86_64
    > zbar-0.20.1-1.fc27.x86_64
    

  • From a visual inspection of the result of
    "diff -y --suppress-common-lines ...":
    • the 2 new packages : rpmfusion-free-appstream-data , rpmfusion-nonfree-appstream-data
    • the 1 uninstalled package: kf5-sonnet-ui

    UPD 22.10.18

  • +179 updates installed via SW Updates (179 modified + 0 new)
  • A new full list of installed packages (2494 in total -- did not change since the update of sect.26 - UPD 26.08.18) :
               /opt/root/Install/rpm_history/181022.0132.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added new versions: More... Close
    [root] .../rpm_history $ diff 180826.2333.rpm-qa.After_reg_sw_update \
                                  181022.0132.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > appstream-data-27-14.fc27.noarch
    > armadillo-9.100.5-1.fc27.x86_64
    > babl-0.1.56-2.fc27.x86_64
    > bind-libs-9.11.4-3.P2.fc27.x86_64
    > bind-libs-lite-9.11.4-3.P2.fc27.x86_64
    > bind-license-9.11.4-3.P2.fc27.noarch
    > bind-utils-9.11.4-3.P2.fc27.x86_64
    > btrfs-progs-4.17.1-1.fc27.x86_64
    > ca-certificates-2018.2.26-1.0.fc27.noarch
    > curl-7.55.1-14.fc27.x86_64
    > exfat-utils-1.3.0-1.fc27.x86_64
    > fedora-gpg-keys-27-4.noarch
    > fedora-repos-27-4.noarch
    > firefox-62.0.3-4.fc27.x86_64
    > flash-plugin-31.0.0.122-release.x86_64
    > flatpak-1.0.3-1.fc27.x86_64
    > flatpak-libs-1.0.3-1.fc27.x86_64
    > fuse-exfat-1.3.0-1.fc27.x86_64
    > gd-2.2.5-6.fc27.x86_64
    > gdal-libs-2.1.4-6.1.fc27.x86_64
    > ghostscript-9.22-6.fc27.x86_64
    > ghostscript-core-9.22-6.fc27.x86_64
    > ghostscript-x11-9.22-6.fc27.x86_64
    > glibc-2.26-30.fc27.i686
    > glibc-2.26-30.fc27.x86_64
    > glibc-all-langpacks-2.26-30.fc27.x86_64
    > glibc-common-2.26-30.fc27.x86_64
    > glibc-devel-2.26-30.fc27.x86_64
    > glibc-headers-2.26-30.fc27.x86_64
    > glibc-langpack-en-2.26-30.fc27.x86_64
    > gstreamer1-plugins-ugly-1.12.5-1.fc27.x86_64
    > gstreamer1-plugins-ugly-free-1.12.5-1.fc27.x86_64
    > highlight-3.44-1.fc27.x86_64
    > highlight-gui-3.44-1.fc27.x86_64
    > hwdata-0.316-1.fc27.noarch
    > iwl1000-firmware-39.31.5.1-88.fc27.noarch
    > iwl100-firmware-39.31.5.1-88.fc27.noarch
    > iwl105-firmware-18.168.6.1-88.fc27.noarch
    > iwl135-firmware-18.168.6.1-88.fc27.noarch
    > iwl2000-firmware-18.168.6.1-88.fc27.noarch
    > iwl2030-firmware-18.168.6.1-88.fc27.noarch
    > iwl3160-firmware-25.30.13.0-88.fc27.noarch
    > iwl3945-firmware-15.32.2.9-88.fc27.noarch
    > iwl4965-firmware-228.61.2.24-88.fc27.noarch
    > iwl5000-firmware-8.83.5.1_1-88.fc27.noarch
    > iwl5150-firmware-8.24.2.2-88.fc27.noarch
    > iwl6000-firmware-9.221.4.1-88.fc27.noarch
    > iwl6000g2a-firmware-18.168.6.1-88.fc27.noarch
    > iwl6000g2b-firmware-18.168.6.1-88.fc27.noarch
    > iwl6050-firmware-41.28.5.1-88.fc27.noarch
    > iwl7260-firmware-25.30.13.0-88.fc27.noarch
    > java-1.8.0-openjdk-headless-1.8.0.181.b15-0.fc27.x86_64
    > kernel-4.18.13-100.fc27.x86_64
    > kernel-core-4.18.13-100.fc27.x86_64
    > kernel-headers-4.18.13-100.fc27.x86_64
    > kernel-modules-4.18.13-100.fc27.x86_64
    > kernel-modules-extra-4.18.13-100.fc27.x86_64
    > lcms2-2.8-6.fc27.x86_64
    > libcrypt-nss-2.26-30.fc27.x86_64
    > libcurl-7.55.1-14.fc27.x86_64
    > libertas-usb8388-firmware-20181008-88.gitc6b6265d.fc27.noarch
    > libgit2-0.26.7-1.fc27.x86_64
    > libicu-57.1-10.fc27.x86_64
    > libipa_hbac-1.16.3-2.fc27.x86_64
    > libldb-1.3.2-2.fc27.1.2.3.x86_64
    > libmad-0.15.1b-26.fc27.x86_64
    > librados2-12.2.8-1.fc27.x86_64
    > libsmbclient-4.7.10-1.fc27.x86_64
    > libssh-0.7.6-1.fc27.x86_64
    > libsss_autofs-1.16.3-2.fc27.x86_64
    > libsss_certmap-1.16.3-2.fc27.x86_64
    > libsss_idmap-1.16.3-2.fc27.x86_64
    > libsss_nss_idmap-1.16.3-2.fc27.x86_64
    > libsss_sudo-1.16.3-2.fc27.x86_64
    > libudisks2-2.7.6-2.fc27.x86_64
    > libwbclient-4.7.10-1.fc27.x86_64
    > libxkbcommon-0.8.2-1.fc27.x86_64
    > libxkbcommon-x11-0.8.2-1.fc27.x86_64
    > libzstd-1.3.6-1.fc27.x86_64
    > linux-firmware-20181008-88.gitc6b6265d.fc27.noarch
    > lyx-fonts-2.3.1-1.fc27.noarch
    > mariadb-10.2.18-1.fc27.x86_64
    > mariadb-backup-10.2.18-1.fc27.x86_64
    > mariadb-common-10.2.18-1.fc27.x86_64
    > mariadb-config-10.2.18-1.fc27.x86_64
    > mariadb-cracklib-password-check-10.2.18-1.fc27.x86_64
    > mariadb-embedded-10.2.18-1.fc27.x86_64
    > mariadb-errmsg-10.2.18-1.fc27.x86_64
    > mariadb-gssapi-server-10.2.18-1.fc27.x86_64
    > mariadb-libs-10.2.18-1.fc27.x86_64
    > mariadb-rocksdb-engine-10.2.18-1.fc27.x86_64
    > mariadb-server-10.2.18-1.fc27.x86_64
    > mariadb-server-utils-10.2.18-1.fc27.x86_64
    > mariadb-tokudb-engine-10.2.18-1.fc27.x86_64
    > mjpegtools-libs-2.1.0-13.fc27.x86_64
    > nspr-4.20.0-1.fc27.x86_64
    > nss-3.39.0-1.0.fc27.x86_64
    > nss-softokn-3.39.0-1.0.fc27.x86_64
    > nss-softokn-freebl-3.39.0-1.0.fc27.x86_64
    > nss-sysinit-3.39.0-1.0.fc27.x86_64
    > nss-tools-3.39.0-1.0.fc27.x86_64
    > nss-util-3.39.0-1.0.fc27.x86_64
    > okular-17.12.3-2.fc27.x86_64
    > okular-libs-17.12.3-2.fc27.x86_64
    > okular-part-17.12.3-2.fc27.x86_64
    > openblas-0.3.2-3.fc27.x86_64
    > openblas-openmp-0.3.2-3.fc27.x86_64
    > openblas-serial-0.3.2-3.fc27.x86_64
    > openblas-threads-0.3.2-3.fc27.x86_64
    > openblas-threads64_-0.3.2-3.fc27.x86_64
    > openjpeg2-2.3.0-9.fc27.x86_64
    > openssh-7.6p1-6.fc27.x86_64
    > openssh-clients-7.6p1-6.fc27.x86_64
    > openssh-server-7.6p1-6.fc27.x86_64
    > openssl-1.1.0i-1.fc27.x86_64
    > openssl-libs-1.1.0i-1.fc27.x86_64
    > open-vm-tools-10.3.0-5.fc27.x86_64
    > open-vm-tools-desktop-10.3.0-5.fc27.x86_64
    > ostree-2018.7-1.fc27.x86_64
    > ostree-libs-2018.7-1.fc27.x86_64
    > p11-kit-0.23.14-1.fc27.x86_64
    > p11-kit-trust-0.23.14-1.fc27.x86_64
    > pango-1.40.14-3.fc27.x86_64
    > patch-2.7.6-5.fc27.x86_64
    > pcre2-10.32-3.fc27.x86_64
    > pcre2-utf16-10.32-3.fc27.x86_64
    > pcre-8.42-4.fc27.x86_64
    > perl-File-Path-2.16-1.fc27.noarch
    > perl-Image-ExifTool-11.11-1.fc27.noarch
    > perl-PathTools-3.75-1.fc27.x86_64
    > perl-Storable-3.11-3.fc27.x86_64
    > postgresql-libs-9.6.10-3.fc27.x86_64
    > python2-2.7.15-4.fc27.x86_64
    > python2-libs-2.7.15-4.fc27.x86_64
    > python3-bind-9.11.4-3.P2.fc27.noarch
    > python3-rpm-4.14.2-1.fc27.x86_64
    > python3-sssdconfig-1.16.3-2.fc27.noarch
    > rpm-4.14.2-1.fc27.x86_64
    > rpm-build-libs-4.14.2-1.fc27.x86_64
    > rpm-libs-4.14.2-1.fc27.x86_64
    > rpm-plugin-selinux-4.14.2-1.fc27.x86_64
    > rpm-plugin-systemd-inhibit-4.14.2-1.fc27.x86_64
    > rsyslog-8.38.0-1.fc27.x86_64
    > samba-client-4.7.10-1.fc27.x86_64
    > samba-client-libs-4.7.10-1.fc27.x86_64
    > samba-common-4.7.10-1.fc27.noarch
    > samba-common-libs-4.7.10-1.fc27.x86_64
    > samba-dc-libs-4.7.10-1.fc27.x86_64
    > samba-libs-4.7.10-1.fc27.x86_64
    > shapelib-1.4.1-5.fc27.x86_64
    > skypeforlinux-8.32.0.44-1.x86_64
    > soundtouch-2.1.0-1.fc27.x86_64
    > sssd-1.16.3-2.fc27.x86_64
    > sssd-ad-1.16.3-2.fc27.x86_64
    > sssd-client-1.16.3-2.fc27.x86_64
    > sssd-common-1.16.3-2.fc27.x86_64
    > sssd-common-pac-1.16.3-2.fc27.x86_64
    > sssd-ipa-1.16.3-2.fc27.x86_64
    > sssd-kcm-1.16.3-2.fc27.x86_64
    > sssd-krb5-1.16.3-2.fc27.x86_64
    > sssd-krb5-common-1.16.3-2.fc27.x86_64
    > sssd-ldap-1.16.3-2.fc27.x86_64
    > sssd-nfs-idmap-1.16.3-2.fc27.x86_64
    > sssd-proxy-1.16.3-2.fc27.x86_64
    > tesseract-3.05.02-1.fc27.x86_64
    > udisks2-2.7.6-2.fc27.x86_64
    > unbound-libs-1.7.3-10.fc27.x86_64
    > unrar-5.6.6-1.fc27.x86_64
    > vid.stab-1.1.0-9.20180529git38ecbaf.fc27.x86_64
    > vim-minimal-8.1.450-1.fc27.x86_64
    > vlc-3.0.4-2.fc27.x86_64
    > vlc-core-3.0.4-2.fc27.x86_64
    > volume_key-libs-0.3.12-1.fc27.x86_64
    > webkitgtk4-2.22.2-1.fc27.x86_64
    > webkitgtk4-jsc-2.22.2-1.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.22.2-1.fc27.x86_64
    > zsh-5.4.1-4.fc27.x86_64
    > zsh-html-5.4.1-4.fc27.noarch
    > zziplib-0.13.69-1.fc27.x86_64
    

    UPD 29.11.18

  • +155 updates installed via SW Updates (153 modified, 2 new)
  • A new full list of installed packages (2496 in total vs 2494 after the update of sect.26 - UPD 22.10.18) :
               /opt/root/Install/rpm_history/181129.2139.rpm-qa.After_reg_sw_update
    ( local copy )
  • The added 155 modified/new versions: More... Close
    [root] .../rpm_history $ diff 181022.0132.rpm-qa.After_reg_sw_update \
                                  181129.2139.rpm-qa.After_reg_sw_update \
                             | grep ">"
    > bluedevil-5.12.7-1.fc27.x86_64
    > breeze-cursor-theme-5.12.7-1.fc27.noarch
    > cabextract-1.9-1.fc27.x86_64
    > ffmpeg-3.3.9-1.fc27.x86_64
    > ffmpeg-libs-3.3.9-1.fc27.x86_64
    > firefox-63.0.3-2.fc27.x86_64
    > flash-plugin-31.0.0.153-release.x86_64
    > flatpak-1.0.6-1.fc27.x86_64
    > flatpak-libs-1.0.6-1.fc27.x86_64
    > freerdp-2.0.0-46.20181008git00af869.fc27.x86_64
    > freerdp-libs-2.0.0-46.20181008git00af869.fc27.x86_64
    > gimp-2.8.22-7.fc27.x86_64
    > gimp-libs-2.8.22-7.fc27.x86_64
    > GraphicsMagick-1.3.31-1.fc27.x86_64
    > highlight-3.47-1.fc27.x86_64
    > highlight-gui-3.47-1.fc27.x86_64
    > hwdata-0.317-1.fc27.noarch
    > java-1.8.0-openjdk-headless-1.8.0.191.b12-8.fc27.x86_64
    > julietaula-montserrat-fonts-7.200-5.fc27.noarch
    > kactivitymanagerd-5.12.7-1.fc27.x86_64
    > kde-cli-tools-5.12.7-1.fc27.x86_64
    > kde-connect-1.3.3-1.fc27.x86_64
    > kdeconnectd-1.3.3-1.fc27.x86_64
    > kde-connect-libs-1.3.3-1.fc27.x86_64
    > kdecoration-5.12.7-1.fc27.x86_64
    > kde-gtk-config-5.12.7-1.fc27.x86_64
    > kdeplasma-addons-5.12.7-1.fc27.x86_64
    > kde-style-breeze-5.12.7-1.fc27.x86_64
    > kdesu-5.12.7-1.fc27.x86_64
    > kernel-4.18.19-100.fc27.x86_64
    > kernel-core-4.18.19-100.fc27.x86_64
    > kernel-headers-4.18.19-100.fc27.x86_64
    > kernel-modules-4.18.19-100.fc27.x86_64
    > kernel-modules-extra-4.18.19-100.fc27.x86_64
    > khotkeys-5.12.7-1.fc27.x86_64
    > kinfocenter-5.12.7-1.fc27.x86_64
    > kio-extras-17.12.3-1.fc27.1.x86_64
    > kmenuedit-5.12.7-1.fc27.x86_64
    > kscreen-5.12.7-1.fc27.x86_64
    > kscreenlocker-5.12.7-1.fc27.x86_64
    > ksshaskpass-5.12.7-1.fc27.x86_64
    > ksysguard-5.12.7-1.fc27.x86_64
    > ksysguardd-5.12.7-1.fc27.x86_64
    > kwin-5.12.7-1.fc27.x86_64
    > kwin-common-5.12.7-1.fc27.x86_64
    > kwin-libs-5.12.7-1.fc27.x86_64
    > kwrited-5.12.7-1.fc27.x86_64
    > libaom-1.0.0-4.20180925gitd0076f5.fc27.x86_64
    > libavdevice-3.3.9-1.fc27.x86_64
    > libdnf-0.11.1-2.fc27.x86_64
    > libgit2-0.26.8-1.fc27.x86_64
    > libkscreen-qt5-5.12.7-1.fc27.x86_64
    > libksysguard-5.12.7-1.fc27.x86_64
    > libksysguard-common-5.12.7-1.fc27.x86_64
    > libkworkspace5-5.12.7-1.fc27.x86_64
    > libmspack-0.9.1-0.1.alpha.fc27.x86_64
    > libreswan-3.27-1.fc27.x86_64
    > libssh-0.7.7-1.fc27.x86_64
    > libtiff-4.0.10-1.fc27.x86_64
    > libwinpr-2.0.0-46.20181008git00af869.fc27.x86_64
    > live555-2018.10.17-1.fc27.x86_64
    > lldpad-1.0.1-9.git036e314.fc27.x86_64
    > mariadb-10.2.19-1.fc27.x86_64
    > mariadb-backup-10.2.19-1.fc27.x86_64
    > mariadb-common-10.2.19-1.fc27.x86_64
    > mariadb-config-10.2.19-1.fc27.x86_64
    > mariadb-cracklib-password-check-10.2.19-1.fc27.x86_64
    > mariadb-embedded-10.2.19-1.fc27.x86_64
    > mariadb-errmsg-10.2.19-1.fc27.x86_64
    > mariadb-gssapi-server-10.2.19-1.fc27.x86_64
    > mariadb-libs-10.2.19-1.fc27.x86_64
    > mariadb-rocksdb-engine-10.2.19-1.fc27.x86_64
    > mariadb-server-10.2.19-1.fc27.x86_64
    > mariadb-server-utils-10.2.19-1.fc27.x86_64
    > mariadb-tokudb-engine-10.2.19-1.fc27.x86_64
    > NetworkManager-1.8.8-2.fc27.x86_64
    > NetworkManager-adsl-1.8.8-2.fc27.x86_64
    > NetworkManager-bluetooth-1.8.8-2.fc27.x86_64
    > NetworkManager-config-connectivity-fedora-1.8.8-2.fc27.noarch
    > NetworkManager-glib-1.8.8-2.fc27.x86_64
    > NetworkManager-libnm-1.8.8-2.fc27.x86_64
    > NetworkManager-team-1.8.8-2.fc27.x86_64
    > NetworkManager-wifi-1.8.8-2.fc27.x86_64
    > NetworkManager-wwan-1.8.8-2.fc27.x86_64
    > oxygen-sound-theme-5.12.7-1.fc27.noarch
    > p11-kit-server-0.23.14-1.fc27.x86_64
    > pam-kwallet-5.12.7-1.fc27.x86_64
    > pcre2-10.32-4.fc27.x86_64
    > pcre2-utf16-10.32-4.fc27.x86_64
    > pcre-8.42-5.fc27.x86_64
    > plasma-breeze-5.12.7-1.fc27.x86_64
    > plasma-breeze-common-5.12.7-1.fc27.noarch
    > plasma-desktop-5.12.7-1.fc27.x86_64
    > plasma-desktop-doc-5.12.7-1.fc27.noarch
    > plasma-discover-5.12.7-1.fc27.x86_64
    > plasma-discover-flatpak-5.12.7-1.fc27.x86_64
    > plasma-discover-libs-5.12.7-1.fc27.x86_64
    > plasma-drkonqi-5.12.7-1.fc27.x86_64
    > plasma-integration-5.12.7-1.fc27.x86_64
    > plasma-lookandfeel-fedora-5.12.7-1.fc27.noarch
    > plasma-milou-5.12.7-1.fc27.x86_64
    > plasma-nm-5.12.7-1.fc27.x86_64
    > plasma-nm-l2tp-5.12.7-1.fc27.x86_64
    > plasma-nm-openconnect-5.12.7-1.fc27.x86_64
    > plasma-nm-openswan-5.12.7-1.fc27.x86_64
    > plasma-nm-openvpn-5.12.7-1.fc27.x86_64
    > plasma-nm-pptp-5.12.7-1.fc27.x86_64
    > plasma-nm-vpnc-5.12.7-1.fc27.x86_64
    > plasma-pa-5.12.7-1.fc27.x86_64
    > plasma-systemsettings-5.12.7-1.fc27.x86_64
    > plasma-user-manager-5.12.7-1.fc27.x86_64
    > plasma-workspace-5.12.7-1.fc27.x86_64
    > plasma-workspace-common-5.12.7-1.fc27.x86_64
    > plasma-workspace-geolocation-5.12.7-1.fc27.x86_64
    > plasma-workspace-geolocation-libs-5.12.7-1.fc27.x86_64
    > plasma-workspace-libs-5.12.7-1.fc27.x86_64
    > polkit-kde-5.12.7-1.fc27.x86_64
    > powerdevil-5.12.7-1.fc27.x86_64
    > python2-nose-1.3.7-18.fc27.noarch
    > python3-hawkey-0.11.1-2.fc27.x86_64
    > python3-requests-2.20.0-1.fc27.noarch
    > python3-rpm-4.14.2.1-1.fc27.x86_64
    > python3-urllib3-1.24.1-2.fc27.noarch
    > qt-4.8.7-44.fc27.x86_64
    > qt5-qtbase-5.9.6-4.fc27.x86_64
    > qt5-qtbase-common-5.9.6-4.fc27.noarch
    > qt5-qtbase-gui-5.9.6-4.fc27.x86_64
    > qt5-qtbase-mysql-5.9.6-4.fc27.x86_64
    > qt-common-4.8.7-44.fc27.noarch
    > qt-x11-4.8.7-44.fc27.x86_64
    > rpm-4.14.2.1-1.fc27.x86_64
    > rpm-build-libs-4.14.2.1-1.fc27.x86_64
    > rpm-libs-4.14.2.1-1.fc27.x86_64
    > rpm-plugin-selinux-4.14.2.1-1.fc27.x86_64
    > rpm-plugin-systemd-inhibit-4.14.2.1-1.fc27.x86_64
    > rpmsphere-release-28-1.1.noarch
    > ruby-2.4.5-90.fc27.x86_64
    > rubygem-bigdecimal-1.3.2-90.fc27.x86_64
    > rubygem-did_you_mean-1.1.0-90.fc27.x86_64
    > rubygem-io-console-0.4.6-90.fc27.x86_64
    > rubygem-openssl-2.0.9-90.fc27.x86_64
    > rubygem-psych-2.2.2-90.fc27.x86_64
    > rubygems-2.6.14.3-90.fc27.noarch
    > ruby-irb-2.4.5-90.fc27.noarch
    > ruby-libs-2.4.5-90.fc27.x86_64
    > sddm-breeze-5.12.7-1.fc27.noarch
    > sddm-kcm-5.12.7-1.fc27.x86_64
    > skypeforlinux-8.34.0.78-1.x86_64
    > soundtouch-2.1.1-1.fc27.x86_64
    > vim-minimal-8.1.513-2.fc27.x86_64
    > vlc-3.0.5-4.fc27.x86_64
    > vlc-core-3.0.5-4.fc27.x86_64
    > webkitgtk4-2.22.2-2.fc27.x86_64
    > webkitgtk4-jsc-2.22.2-2.fc27.x86_64
    > webkitgtk4-plugin-process-gtk2-2.22.2-2.fc27.x86_64
    

  • From a visual inspection of the result of
    "diff -y --suppress-common-lines ...":
    • the 2 new packages : libaom , p11-kit-server

  27. (11.04.18) emacsrus script

  • The script in /usr/local/bin is introduced to replace the
               alias  emacsrus='emacs -fn $RUSFONT' in .zshrc .
    The script adds the definition
               LANG=ru_RU.KOI8-R
    prior to an emacs invocation: More... Close
    [root] ~ $ cat /usr/local/bin/emacsrus 
    
    #!/bin/sh
    ###############################################################################
    #
    #  Purpose: Run emacs in a "russian" environment
    #           with font defined with RUSFONT env.variable
    #
    #  Usage:  emacsrus [ parameters ]
    #
    #  Author: A.Fedotov 10.04.18 a version for Fedora 27 @ dom5
    #                               
    ###############################################################################
    
    DEFAULT_FONT=-bitstream-terminal-medium-r-normal--18-180-75-75-c-11-koi8-r
    
                       # LANG=ru_RU seems to have the same functionality
    export LANG=ru_RU.KOI8-R
    
    if [ "$RUSFONT" != "" ]; then
        exec emacs -fn $RUSFONT $* 
    else
        exec emacs -fn $DEFAULT_FONT $* 
    fi
    

  28. (19.04.18) ~fedotov/.Xresources

  • The file (full version: local copy ) is a modified version of
               /x01/legacy/dom3/F18/home/fedotov/.Xresources stored in ~fedotov/.Xresources.F18-dom3 .

  • The modifications consist in new definitions of Emacs and Xterm fonts (note a removal of definitions for font4,font5,font6 ):
    !           Dom5 F27 Xresources for 14-inch 1366 x 768 screen
    !           =================================================
    ...
    !  Modified 19.04.18 : Dom5 F27 Xresources for 14-inch 1366 x 768 screen
    !                      - Xterm fonts:
    !                         - default,1,2,3 defined as
    !                                nice, ru nice, ru medium, ru small
    !                           4,5,6 definitions removed (they are defined in
    !                              in /usr/share/X11/app-defaults/XTerm
    !                              as Medium,Large,Huge)
    !                      - Emacs font is "xterm default" (plus its bold version)
    ...
    Emacs*boldFont: DesyNiceB
    Emacs*font:     DesyNice
    ...
    XEmacs*boldFont: DesyNiceB
    XEmacs*font:     DesyNice
    ...
    XTerm.vt100.boldFont:   DesyNiceB
    XTerm*fontMenu*fontdefault*Label:       Default nice (UTF8: 13sc)
    XTerm*VT100*font:       DesyNice
    XTerm*fontMenu*font1*Label:     Russian nice
    XTerm*VT100*font1:      -bitstream-terminal-medium-r-normal--18-180-75-75-c-11-koi8-r
    XTerm*fontMenu*font2*Label:     Russian medium (UTF8: tiny)
    XTerm*VT100*font2:      -adobe-courier-medium-r-normal--14-140-75-75-m-90-koi8-r
    XTerm*fontMenu*font3*Label:     Russian small (UTF small)
    XTerm*VT100*font3:      -adobe-courier-medium-r-normal--12-120-75-75-m-70-koi8-r
    ...
    

  • The labels for font,font1,font2,font3 become clearer when the above is compared with the "system" definitions of Xterm fonts in /usr/share/X11/app-defaults/XTerm:
    ...
    *fontMenu*fontdefault*Label:    Default
    *fontMenu*font1*Label:  Unreadable
    *VT100.font1:           nil2
    *IconFont:              nil2
    *fontMenu*font2*Label:  Tiny
    *VT100.font2:           5x7
    *fontMenu*font3*Label:  Small
    *VT100.font3:           6x10
    *fontMenu*font4*Label:  Medium
    *VT100.font4:           7x13
    *fontMenu*font5*Label:  Large
    *VT100.font5:           9x15
    *fontMenu*font6*Label:  Huge
    *VT100.font6:           10x20
    ...
    *VT100.utf8Fonts.font2: -misc-fixed-medium-r-normal--8-80-75-75-c-50-iso10646-1
    *VT100.utf8Fonts.font:  -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
    *VT100.utf8Fonts.font3: -misc-fixed-medium-r-normal--14-130-75-75-c-70-iso10646-1
    *VT100.utf8Fonts.font4: -misc-fixed-medium-r-normal--13-120-75-75-c-80-iso10646-1
    *VT100.utf8Fonts.font5: -misc-fixed-medium-r-normal--18-120-100-100-c-90-iso10646-1
    *VT100.utf8Fonts.font6: -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso10646-1
    ...
    

  29. (24.04.18) Browsec VPN 3.19.4 extension for firefox (user fedotov)

  • In an attempt to install firefox addons, we found that firefox addon sites do not work properly. The suspicion was that it was caused by the blockage by the RF government structures of dozens of millions of IP addresses in the fight against the Telegram messenger (for the story, see, e.g., https://www.rbc.ru/society/25/04/2018/5ae075859a7947314b154929) ...

  • Thus it looked like a vicious circle: we needed a VPN to install a VPN.

  • First, we downloaded the "unreachable" page at a comp in Germany with
    • wget "https://addons.cdn.mozilla.net/user-media/addons/603434/browsec_vpn-3.19.4-an+fx.xpi?filehash=sha256%3Ab3d99ef5abc89aaabf8596ef8026946f20eb1951382aa5b083372ed2c825b818"
      producing a strangely named file
    • browsec_vpn-3.19.4-an+fx.xpi?filehash=sha256%3Ab3d99ef5abc89aaabf8596ef8026946f20eb1951382aa5b083372ed2c825b818
  • An FF extension file is expected to be a .xpi file, so we truncated the above name to
               browsec_vpn-3.19.4-an+fx.xpi
  • The file was a zip archive (a good sign!) and the thrown-away part of the name was devoted to just a sha256sum of the file:
    [dom5] ~/tm/browsec $ ll browsec_vpn-3.19.4-an+fx.xpi
    -rw-r--r--. 1 fedotov fedotov 2806141 Feb 21 13:40 browsec_vpn-3.19.4-an+fx.xpi
    
    [dom5] ~/tm/browsec $ file browsec_vpn-3.19.4-an+fx.xpi
    browsec_vpn-3.19.4-an+fx.xpi: Zip archive data, at least v2.0 to extract
    
    [dom5] ~/tm/browsec $ sha256sum browsec_vpn-3.19.4-an+fx.xpi
    b3d99ef5abc89aaabf8596ef8026946f20eb1951382aa5b083372ed2c825b818 \
      browsec_vpn-3.19.4-an+fx.xpi
    

  • The file was successfully installed via
               firefox -> Tools -> Add-ons -> gear icon...

  • And, with the VPN option ON, the firefox addons pages started to work OK.
  • Be cursed once more those hooligans fighting Telegram!

  30. (25.04.18) Yum repository adobe-linux-x86_64 and Adobe Flash Plugin 29.0.0.140

  • Install Adobe YUM Repository RPM package:
    [root] ~ $ rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
    Retrieving http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
    warning: /var/tmp/rpm-tmp.RAGQEh: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
    Preparing...                          ################################# [100%]
    Updating / installing...
       1:adobe-release-x86_64-1.0-1       ################################# [100%]
    

  • Install a gpg-pubkey (whatever it means and is needed for)
    [root] ~ $ rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
    
    The results are:
    • the installed rpm package
                 gpg-pubkey-f6777c67-45e5b1b9
      ( Name: gpg-pubkey, Version: f6777c67, Release: 45e5b1b9, Summary: gpg(Adobe Systems Incorporated (Linux RPM Signing Key) <secure@adobe.com>) )
    • the file mentioned inside the command:
                 /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux

  • Then the instructions suggest the following command:
    # Fedora 28/27/26/25/24 #
    dnf install flash-plugin alsa-plugins-pulseaudio libcurl
    
    The packages alsa-plugins-pulseaudio, libcurl are already available on the system. To install the flash-plugin, we use a different tool: SW Management / dnfdragora.
    dnfdragora -> Files -> Repositories shows a new repo
               adobe-linux-x86_64 , enabled
    dnfdragora, search for flash shows two available Flash Player packages:
    • flash-plugin
      • Summary: Adobe Flash Player NPAPI
      • Description: Adobe Flash Plugin 29.0.0.140
    • flash-player-ppapi
      • Summary: Adobe Flash Player PPAPI 26.0
      • Description: Adobe Flash Player PPAPI 29.0.0.140 Fully Supported: Chromium-based browsers
  • We install the first one which is needed for the firefox.

  • In firefox, the plugin appears after a restart (restart -> add-ons -> plugins) as
               Shockwave flash 29.0.0.140
    We change
               Ask to Activate -> Always Activate

  • A problem appears: the flash videos are played without sound.
    Solved with
    • Taskbar Volume icon -> Right Click -> Audio Volume Settings -> tab Applications -> Plasma: ALSA Playback: -> change 0% to 100% -> OK

  • The full list of installed packages (1760 in total vs 1757 in sect.26/UPD-21.04.18)
               /opt/root/Install/rpm_history/180425.2110.rpm-qa.flash-plugin_installed
    ( local copy )
    The 3 new packages:
    [root] .../rpm_history $ diff 180421.1834.rpm-qa.After_reg_sw_update \
                                  180425.2110.rpm-qa.flash-plugin_installed \
                             | grep ">"
    > adobe-release-x86_64-1.0-1.noarch
    > flash-plugin-29.0.0.140-release.x86_64
    > gpg-pubkey-f6777c67-45e5b1b9
    

  31. (29.04.18) Install RPM Fusion repositories

  • Following the recipy of https://rpmfusion.org/Configuration, an access to both the free and the nonfree repository is enabled with
    [root] ~ $ dnf install \
      https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm \
      https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
    
    The command output: More... Close
    Last metadata expiration check: 0:21:03 ago on Sun 29 Apr 2018 02:45:47 AM MSK.
    rpmfusion-free-release-27.noarch.rpm             52 kB/s |  20 kB     00:00    
    rpmfusion-nonfree-release-27.noarch.rpm          59 kB/s |  20 kB     00:00    
    Dependencies resolved.
    ================================================================================
     Package                        Arch        Version     Repository         Size
    ================================================================================
    Installing:
     rpmfusion-free-release         noarch      27-1        @commandline       20 k
     rpmfusion-nonfree-release      noarch      27-1        @commandline       20 k
    
    Transaction Summary
    ================================================================================
    Install  2 Packages
    
    Total size: 40 k
    Installed size: 18 k
    Is this ok [y/N]: y
    Downloading Packages:
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Transaction test succeeded.
    Running transaction
      Preparing        :                                                        1/1 
      Installing       : rpmfusion-nonfree-release-27-1.noarch                  1/2 
      Installing       : rpmfusion-free-release-27-1.noarch                     2/2 
      Verifying        : rpmfusion-free-release-27-1.noarch                     1/2 
      Verifying        : rpmfusion-nonfree-release-27-1.noarch                  2/2 
    
    Installed:
      rpmfusion-free-release.noarch 27-1    rpmfusion-nonfree-release.noarch 27-1   
    
    Complete!
    

  • Two rpm packages get installed:
    [root] ~ $ rpm -qa |grep rpmfusion
    rpmfusion-nonfree-release-27-1.noarch
    rpmfusion-free-release-27-1.noarch
    

  • Six .repo files appear in /etc/yum.repos.d/:
    [root] ~ $ ll /etc/yum.repos.d/
    ...
    -rw-r--r--. 1 root root 1248 Nov 13 21:17 rpmfusion-free.repo
    -rw-r--r--. 1 root root 1245 Nov 13 21:17 rpmfusion-free-updates.repo
    -rw-r--r--. 1 root root 1305 Nov 13 21:17 rpmfusion-free-updates-testing.repo
    -rw-r--r--. 1 root root 1293 Nov 13 21:21 rpmfusion-nonfree.repo
    -rw-r--r--. 1 root root 1290 Nov 13 21:21 rpmfusion-nonfree-updates.repo
    -rw-r--r--. 1 root root 1350 Nov 13 21:21 rpmfusion-nonfree-updates-testing.repo
    

  • 18 new repos (of which 4 are enabled) are reported by dnf:
    [dom5] ~ $ dnf repolist --all
    ...
    repo id                                     \
          repo name                                               status
    ...
    *rpmfusion-free                             \
          RPM Fusion for Fedora 27 - Free                         enabled:    574
    rpmfusion-free-debuginfo                    \
          RPM Fusion for Fedora 27 - Free - Debug                 disabled
    rpmfusion-free-source                       \
          RPM Fusion for Fedora 27 - Free - Source                disabled
    *rpmfusion-free-updates                     \
          RPM Fusion for Fedora 27 - Free - Updates               enabled:    232
    rpmfusion-free-updates-debuginfo            \
          RPM Fusion for Fedora 27 - Free - Updates Debug         disabled
    rpmfusion-free-updates-source               \
          RPM Fusion for Fedora 27 - Free - Updates Source        disabled
    rpmfusion-free-updates-testing              \
          RPM Fusion for Fedora 27 - Free - Test Updates          disabled
    rpmfusion-free-updates-testing-debuginfo    \
          RPM Fusion for Fedora 27 - Free - Test Updates Debug    disabled
    rpmfusion-free-updates-testing-source       \
          RPM Fusion for Fedora 27 - Free - Test Updates Source   disabled
    *rpmfusion-nonfree                          \
          RPM Fusion for Fedora 27 - Nonfree                      enabled:    205
    rpmfusion-nonfree-debuginfo                 \
          RPM Fusion for Fedora 27 - Nonfree - Debug              disabled
    rpmfusion-nonfree-source                    \
          RPM Fusion for Fedora 27 - Nonfree - Source             disabled
    *rpmfusion-nonfree-updates                  \
          RPM Fusion for Fedora 27 - Nonfree - Updates            enabled:     78
    rpmfusion-nonfree-updates-debuginfo         \
          RPM Fusion for Fedora 27 - Nonfree - Updates Debug      disabled
    rpmfusion-nonfree-updates-source            \
          RPM Fusion for Fedora 27 - Nonfree - Updates Source     disabled
    rpmfusion-nonfree-updates-testing           \
          RPM Fusion for Fedora 27 - Nonfree - Test Updates       disabled
    rpmfusion-nonfree-updates-testing-debuginfo \
          RPM Fusion for Fedora 27 - Nonfree - Test Updates Debug disabled
    rpmfusion-nonfree-updates-testing-source    \
          RPM Fusion for Fedora 27 - Nonfree - Test Updates Sourc disabled
    

  • A new full list of 1762 installed rpm packages :
               /opt/root/Install/rpm_history/180429.0407.rpm-qa.rpmfusion_repos_installed
    ( local copy )

  32. (29.04.18) Audio and video codecs (for firefox and others)

  • Problems with firefox:
    • There are at least 3 things which firefox does not play: * facebook videos * echo.msk.ru mp3 audios * vsefm.com internet radio streams
      (e.g. http://vsefm.com/radio/101-ru-zvuki-prirody/ )
    • A related (?) problem (or was there a problem with youtuve too? -- do not remember...):
      • YouTube HTML5 Video Player page, https://www.youtube.com/html5, which performs a browser test, shows that firefox does not support
        • H.264
        • MSE & H.264

  • Some codecs must be missing.

  • Googling gives, e.g., the following (controversial?) advices, all based on RPM Fusion repos (we installed the repos in the previous sect.31)

# src cmd # command trans-
action
#
[1] How I can install audio codecs like mp3? [closed]
https://ask.fedoraproject.org/en/question/42073/how-i-can-install-audio-codecs-like-mp3/
  yum install gstreamer gstreamer-ffmpeg gstreamer-plugins-bad gstreamer-plugins-bad-free gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly faad2 faac libdca wget compat-libstdc++-33 compat-libstdc++-296  xine-lib-extras-freeworld 9
[2] [Sticky] What plugins do I need to install to watch movies and listen to music?
https://ask.fedoraproject.org/en/question/9111/sticky-what-plugins-do-i-need-to-install-to-watch-movies-and-listen-to-music/
[2.1] dnf install gstreamer1-{ffmpeg,libav,plugins-{good,ugly,bad{,-free,-nonfree}}} --setopt=strict=0 6
[2.2] dnf install xine-lib* k3b-extras-freeworld 7
[2.3] dnf install gstreamer1-{plugin-crystalhd,ffmpeg,plugins-{good,ugly,bad{,-free,-nonfree,-freeworld,-extras}{,-extras}}} libmpg123 lame-libs --setopt=strict=0 8
[2.4] ? (with incomprehensible comments)
dnf remove gstreamer1-plugins-ugly
dnf install gstreamer1-plugin-mpg123 mpg123-libs
 
[3] +15 Things To Do After Installing Fedora 26_
http://www.linuxandubuntu.com/home/15-things-to-do-after-installing-fedora-26
Item 4. Install Multimedia codecs
  dnf install gstreamer1-plugins-base gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-free-extras ffmpeg 10
[4] 22 Things to Do After Fresh Installation of Fedora 27 / Fedora 26
https://www.itzgeek.com/how-tos/linux/fedora-how-tos/22-things-to-do-after-fresh-installation-of-fedora-27-fedora-26.html
Item 6. Install Media Codecs
  dnf -y install gstreamer-plugins-base gstreamer1-plugins-base gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer1-plugins-ugly gstreamer-plugins-good-extras gstreamer1-plugins-good-extras gstreamer1-plugins-bad-freeworld ffmpeg gstreamer-ffmpeg 11
[5] h.264 Videos not working in Firefox [closed]
https://ask.fedoraproject.org/en/question/95637/h264-videos-not-working-in-firefox/
  dnf install ffmpeg-libs  

  • There are already few gstreamer-related packages on the system. Hopefully, they will not interfere with the packages to be installed:
    [root] ... $ rpm -qa |sort | grep gstreamer
    gstreamer1-1.12.4-1.fc27.x86_64
    gstreamer1-plugins-bad-free-1.12.4-1.fc27.x86_64
    gstreamer1-plugins-base-1.12.4-1.fc27.x86_64
    gstreamer1-plugins-good-1.12.4-1.fc27.x86_64
    gstreamer1-plugins-ugly-free-1.12.4-2.fc27.x86_64
    libnice-gstreamer1-0.1.14-1.fc27.x86_64
    PackageKit-gstreamer-plugin-1.1.9-3.fc27.x86_64
    phonon-backend-gstreamer-4.9.0-4.fc27.x86_64
    phonon-qt5-backend-gstreamer-4.9.0-4.fc27.x86_64
    qt5-gstreamer-1.2.0-14.fc27.x86_64
    

  • We will try to execute the found commands from [1]-[5] one by one, hoping that dnf will resolve all the possible interdependences. (Actually, skipped will be [2.4] as unclear, and [5] since the job of [5] is done on the preceeding steps.)

  • Transaction 6: [2.1]

    • dnf install gstreamer1-{ffmpeg,libav,plugins-{good,ugly,bad{,-free,-nonfree}}} --setopt=strict=0
      • stdout: More... Close
        [root] ~ $ dnf install gstreamer1-{ffmpeg,libav,plugins-{good,ugly,bad{,-free,-nonfree}}} --setopt=strict=0
        Last metadata expiration check: 1:31:07 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        No match for argument: gstreamer1-ffmpeg
        Package gstreamer1-plugins-good-1.12.4-1.fc27.x86_64 is already installed, skipping.
        No match for argument: gstreamer1-plugins-bad
        Package gstreamer1-plugins-bad-free-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Dependencies resolved.
        ================================================================================
         Package                 Arch   Version         Repository                 Size
        ================================================================================
        Installing:
         gstreamer1-libav        x86_64 1.12.4-1.fc27   rpmfusion-free-updates    259 k
         gstreamer1-plugins-bad-nonfree
                                 x86_64 1.12.4-1.fc27   rpmfusion-nonfree-updates  58 k
         gstreamer1-plugins-ugly x86_64 1.12.4-3.fc27   rpmfusion-free-updates    194 k
        Installing dependencies:
         clang-libs              x86_64 5.0.1-5.fc27    updates                    13 M
         faac                    x86_64 1.29.9.2-1.fc27 rpmfusion-nonfree-updates  70 k
         fdk-aac                 x86_64 0.1.5-2.fc27    rpmfusion-nonfree         395 k
         ffmpeg-libs             x86_64 3.3.7-1.fc27    rpmfusion-free-updates    6.4 M
         fribidi                 x86_64 0.19.7-5.fc27   fedora                     70 k
         glibc-devel             x86_64 2.26-27.fc27    updates                   989 k
         glibc-headers           x86_64 2.26-27.fc27    updates                   504 k
         hwloc-libs              x86_64 1.11.5-6.fc27   fedora                    1.6 M
         kernel-headers          x86_64 4.16.3-200.fc27 updates                   1.2 M
         libass                  x86_64 0.13.4-4.fc27   fedora                     96 k
         libbluray               x86_64 1.0.2-1.fc27    updates                   166 k
         libclc                  x86_64 0.2.0-9.git1cb3fbf.fc27
                                                        fedora                    7.9 M
         libmfx                  x86_64 1.21-3.fc27     fedora                     33 k
         libmpeg2                x86_64 0.5.1-13.fc27   rpmfusion-free             75 k
         libstdc++-devel         x86_64 7.3.1-5.fc27    updates                   1.9 M
         libva                   x86_64 1.8.3-5.fc27    updates                    90 k
         ocl-icd                 x86_64 2.2.12-1.fc27   updates                    50 k
         opencl-filesystem       noarch 1.0-6.fc27      fedora                    7.1 k
         opencore-amr            x86_64 0.1.5-2.fc27    rpmfusion-free            176 k
         schroedinger            x86_64 1.0.11-13.fc27  fedora                    332 k
         vid.stab                x86_64 1.1-3.20170830gitafc8ea9.fc27
                                                        fedora                     50 k
         vo-amrwbenc             x86_64 0.1.3-3.fc27    rpmfusion-free             76 k
         x264-libs               x86_64 0.148-22.20170521gitaaa9aa8.fc27
                                                        rpmfusion-free            570 k
         x265-libs               x86_64 2.5-1.fc27      rpmfusion-free            1.7 M
         xvidcore                x86_64 1.3.4-4.fc27    rpmfusion-free            264 k
        Installing weak dependencies:
         beignet                 x86_64 1.3.2-2.fc27    updates                   4.8 M
         compiler-rt             x86_64 5.0.1-2.fc27    updates                   1.7 M
         libomp                  x86_64 5.0.1-1.fc27    updates                   259 k
         mesa-libOpenCL          x86_64 17.3.6-1.fc27   updates                   612 k
         pocl                    x86_64 0.15-0.1.20171023git53ef5e8.fc27
                                                        updates                    47 M
        
        Transaction Summary
        ================================================================================
        Install  33 Packages
        
        Total download size: 92 M
        Installed size: 401 M
        Is this ok [y/N]: y
        Downloading Packages:
        ...
        --------------------------------------------------------------------------------
        Total                                           1.8 MB/s |  92 MB     00:51     
        warning: /var/cache/dnf/rpmfusion-free-updates-d6a95764d888d197/packages/gstreamer1-libav-1.12.4-1.fc27.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 7d838377: NOKEY
        Importing GPG key 0x7D838377:
         Userid     : "RPM Fusion free repository for Fedora (27) <rpmfusion-buildsys@lists.rpmfusion.org>"
         Fingerprint: 38FF 4B07 9890 0DAF 5E67 D7D1 1DBD E605 7D83 8377
         From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-27
        Is this ok [y/N]: y
        Key imported successfully
        ...
        Installed:
          gstreamer1-libav.x86_64 1.12.4-1.fc27                                         
          gstreamer1-plugins-bad-nonfree.x86_64 1.12.4-1.fc27                           
          gstreamer1-plugins-ugly.x86_64 1.12.4-3.fc27                                  
          beignet.x86_64 1.3.2-2.fc27                                                   
          compiler-rt.x86_64 5.0.1-2.fc27                                               
          libomp.x86_64 5.0.1-1.fc27                                                    
          mesa-libOpenCL.x86_64 17.3.6-1.fc27                                           
          pocl.x86_64 0.15-0.1.20171023git53ef5e8.fc27                                  
          clang-libs.x86_64 5.0.1-5.fc27                                                
          faac.x86_64 1.29.9.2-1.fc27                                                   
          fdk-aac.x86_64 0.1.5-2.fc27                                                   
          ffmpeg-libs.x86_64 3.3.7-1.fc27                                               
          fribidi.x86_64 0.19.7-5.fc27                                                  
          glibc-devel.x86_64 2.26-27.fc27                                               
          glibc-headers.x86_64 2.26-27.fc27                                             
          hwloc-libs.x86_64 1.11.5-6.fc27                                               
          kernel-headers.x86_64 4.16.3-200.fc27                                         
          libass.x86_64 0.13.4-4.fc27                                                   
          libbluray.x86_64 1.0.2-1.fc27                                                 
          libclc.x86_64 0.2.0-9.git1cb3fbf.fc27                                         
          libmfx.x86_64 1.21-3.fc27                                                     
          libmpeg2.x86_64 0.5.1-13.fc27                                                 
          libstdc++-devel.x86_64 7.3.1-5.fc27                                           
          libva.x86_64 1.8.3-5.fc27                                                     
          ocl-icd.x86_64 2.2.12-1.fc27                                                  
          opencl-filesystem.noarch 1.0-6.fc27                                           
          opencore-amr.x86_64 0.1.5-2.fc27                                              
          schroedinger.x86_64 1.0.11-13.fc27                                            
          vid.stab.x86_64 1.1-3.20170830gitafc8ea9.fc27                                 
          vo-amrwbenc.x86_64 0.1.3-3.fc27                                               
          x264-libs.x86_64 0.148-22.20170521gitaaa9aa8.fc27                             
          x265-libs.x86_64 2.5-1.fc27                                                   
          xvidcore.x86_64 1.3.4-4.fc27                                                  
        
        Complete!
        
    • [root] ~ $ dnf history info 6 : More... Close
      Transaction ID : 6
      Begin time     : Sun 29 Apr 2018 07:59:44 AM MSK
      Begin rpmdb    : 1760:9d3d53ec709845ce76ee27e617be8e642ed05c8e
      End time       : Sun 29 Apr 2018 08:00:22 AM MSK (38 seconds)
      End rpmdb      : 1793:b987eb70556832e3e5cdc243c4d7ce3478e24757
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install gstreamer1-ffmpeg gstreamer1-libav gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad gstreamer1-plugins-bad-free gstreamer1-plugins-bad-nonfree --setopt=strict=0
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install beignet-1.3.2-2.fc27.x86_64                         @updates
          Install clang-libs-5.0.1-5.fc27.x86_64                      @updates
          Install compiler-rt-5.0.1-2.fc27.x86_64                     @updates
          Install faac-1.29.9.2-1.fc27.x86_64                         @rpmfusion-nonfree-updates
          Install fdk-aac-0.1.5-2.fc27.x86_64                         @rpmfusion-nonfree
          Install ffmpeg-libs-3.3.7-1.fc27.x86_64                     @rpmfusion-free-updates
          Install fribidi-0.19.7-5.fc27.x86_64                        @fedora
          Install glibc-devel-2.26-27.fc27.x86_64                     @updates
          Install glibc-headers-2.26-27.fc27.x86_64                   @updates
          Install gstreamer1-libav-1.12.4-1.fc27.x86_64               @rpmfusion-free-updates
          Install gstreamer1-plugins-bad-nonfree-1.12.4-1.fc27.x86_64 @rpmfusion-nonfree-updates
          Install gstreamer1-plugins-ugly-1.12.4-3.fc27.x86_64        @rpmfusion-free-updates
          Install hwloc-libs-1.11.5-6.fc27.x86_64                     @fedora
          Install kernel-headers-4.16.3-200.fc27.x86_64               @updates
          Install libass-0.13.4-4.fc27.x86_64                         @fedora
          Install libbluray-1.0.2-1.fc27.x86_64                       @updates
          Install libclc-0.2.0-9.git1cb3fbf.fc27.x86_64               @fedora
          Install libmfx-1.21-3.fc27.x86_64                           @fedora
          Install libmpeg2-0.5.1-13.fc27.x86_64                       @rpmfusion-free
          Install libomp-5.0.1-1.fc27.x86_64                          @updates
          Install libstdc++-devel-7.3.1-5.fc27.x86_64                 @updates
          Install libva-1.8.3-5.fc27.x86_64                           @updates
          Install mesa-libOpenCL-17.3.6-1.fc27.x86_64                 @updates
          Install ocl-icd-2.2.12-1.fc27.x86_64                        @updates
          Install opencl-filesystem-1.0-6.fc27.noarch                 @fedora
          Install opencore-amr-0.1.5-2.fc27.x86_64                    @rpmfusion-free
          Install pocl-0.15-0.1.20171023git53ef5e8.fc27.x86_64        @updates
          Install schroedinger-1.0.11-13.fc27.x86_64                  @fedora
          Install vid.stab-1.1-3.20170830gitafc8ea9.fc27.x86_64       @fedora
          Install vo-amrwbenc-0.1.3-3.fc27.x86_64                     @rpmfusion-free
          Install x264-libs-0.148-22.20170521gitaaa9aa8.fc27.x86_64   @rpmfusion-free
          Install x265-libs-2.5-1.fc27.x86_64                         @rpmfusion-free
          Install xvidcore-1.3.4-4.fc27.x86_64                        @rpmfusion-free
      Scriptlet output:
         1 Running as unit: run-r25322f94e8434adc8d00fc37a9fdd8b3.service
      

  • Transaction 7: [2.2]

    • dnf install xine-lib* k3b-extras-freeworld
      • stdout: More... Close
        [root] ~ $ dnf install xine-lib* k3b-extras-freeworld
        Last metadata expiration check: 1:45:10 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        Dependencies resolved.
        ================================================================================
         Package              Arch   Version               Repository              Size
        ================================================================================
        Installing:
         k3b-extras-freeworld x86_64 1:17.08.3-1.fc27      rpmfusion-free-updates  24 k
         xine-lib             x86_64 1.2.9-1.fc27          rpmfusion-free-updates 2.5 M
         xine-lib-devel       x86_64 1.2.9-1.fc27          rpmfusion-free-updates 505 k
         xine-lib-extras      x86_64 1.2.9-1.fc27          rpmfusion-free-updates  54 k
        Installing dependencies:
         SDL                  x86_64 1.2.15-29.fc27        fedora                 216 k
         aalib-libs           x86_64 1.4.0-0.32.rc5.fc27   fedora                  70 k
         faad2-libs           x86_64 1:2.8.8-1.fc27        rpmfusion-free-updates 175 k
         freeglut             x86_64 3.0.0-6.fc27          fedora                 189 k
         gpm-libs             x86_64 1.20.7-10.fc26        fedora                  36 k
         jack-audio-connection-kit
                              x86_64 1.9.12-1.fc27         updates                509 k
         libcaca              x86_64 0.99-0.31.beta19.fc26 fedora                 222 k
         libdca               x86_64 0.0.5-11.fc27         rpmfusion-free         106 k
         libffado             x86_64 2.4.0-1.fc27          updates                802 k
         libmodplug           x86_64 1:0.8.9.0-3.fc27      fedora                 169 k
         libxml++             x86_64 2.40.1-5.fc27         fedora                  90 k
         vcdimager            x86_64 0.7.24-12.fc27        rpmfusion-free         322 k
         vcdimager-libs       x86_64 0.7.24-12.fc27        rpmfusion-free         100 k
         zlib-devel           x86_64 1.2.11-4.fc27         fedora                  56 k
        
        Transaction Summary
        ================================================================================
        Install  18 Packages
        
        Total download size: 6.1 M
        Installed size: 16 M
        Is this ok [y/N]: y
        ...
        
        Installed:
          k3b-extras-freeworld.x86_64 1:17.08.3-1.fc27                                  
          xine-lib.x86_64 1.2.9-1.fc27                                                  
          xine-lib-devel.x86_64 1.2.9-1.fc27                                            
          xine-lib-extras.x86_64 1.2.9-1.fc27                                           
          SDL.x86_64 1.2.15-29.fc27                                                     
          aalib-libs.x86_64 1.4.0-0.32.rc5.fc27                                         
          faad2-libs.x86_64 1:2.8.8-1.fc27                                              
          freeglut.x86_64 3.0.0-6.fc27                                                  
          gpm-libs.x86_64 1.20.7-10.fc26                                                
          jack-audio-connection-kit.x86_64 1.9.12-1.fc27                                
          libcaca.x86_64 0.99-0.31.beta19.fc26                                          
          libdca.x86_64 0.0.5-11.fc27                                                   
          libffado.x86_64 2.4.0-1.fc27                                                  
          libmodplug.x86_64 1:0.8.9.0-3.fc27                                            
          libxml++.x86_64 2.40.1-5.fc27                                                 
          vcdimager.x86_64 0.7.24-12.fc27                                               
          vcdimager-libs.x86_64 0.7.24-12.fc27                                          
          zlib-devel.x86_64 1.2.11-4.fc27                                               
        
        Complete!
        
    • [root] ~ $ dnf history info 7 : More... Close
      Transaction ID : 7
      Begin time     : Sun 29 Apr 2018 08:08:24 AM MSK
      Begin rpmdb    : 1793:b987eb70556832e3e5cdc243c4d7ce3478e24757
      End time       : Sun 29 Apr 2018 08:08:39 AM MSK (15 seconds)
      End rpmdb      : 1811:57a67904c115a98d195d2444a06f88d332c66ed6
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install xine-lib* k3b-extras-freeworld
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install SDL-1.2.15-29.fc27.x86_64                      @fedora
          Install aalib-libs-1.4.0-0.32.rc5.fc27.x86_64          @fedora
          Install faad2-libs-1:2.8.8-1.fc27.x86_64               @rpmfusion-free-updates
          Install freeglut-3.0.0-6.fc27.x86_64                   @fedora
          Install gpm-libs-1.20.7-10.fc26.x86_64                 @fedora
          Install jack-audio-connection-kit-1.9.12-1.fc27.x86_64 @updates
          Install k3b-extras-freeworld-1:17.08.3-1.fc27.x86_64   @rpmfusion-free-updates
          Install libcaca-0.99-0.31.beta19.fc26.x86_64           @fedora
          Install libdca-0.0.5-11.fc27.x86_64                    @rpmfusion-free
          Install libffado-2.4.0-1.fc27.x86_64                   @updates
          Install libmodplug-1:0.8.9.0-3.fc27.x86_64             @fedora
          Install libxml++-2.40.1-5.fc27.x86_64                  @fedora
          Install vcdimager-0.7.24-12.fc27.x86_64                @rpmfusion-free
          Install vcdimager-libs-0.7.24-12.fc27.x86_64           @rpmfusion-free
          Install xine-lib-1.2.9-1.fc27.x86_64                   @rpmfusion-free-updates
          Install xine-lib-devel-1.2.9-1.fc27.x86_64             @rpmfusion-free-updates
          Install xine-lib-extras-1.2.9-1.fc27.x86_64            @rpmfusion-free-updates
          Install zlib-devel-1.2.11-4.fc27.x86_64                @fedora
      Scriptlet output:
         1 Running as unit: run-r81f9c70994374262ae7eea81edd93f76.service
      

  • Transaction 8: [2.3]

    • dnf install gstreamer1-{plugin-crystalhd,ffmpeg,plugins-{good,ugly,bad{,-free,-nonfree,-freeworld,-extras}{,-extras}}} libmpg123 lame-libs --setopt=strict=0
      • stdout: More... Close
        [root] ~ $ dnf install gstreamer1-{plugin-crystalhd,ffmpeg,plugins-{good,ugly,bad{,-free,-nonfree,-freeworld,-extras}{,-extras}}} libmpg123 lame-libs --setopt=strict=0
        Last metadata expiration check: 1:52:01 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        No match for argument: gstreamer1-plugin-crystalhd
        No match for argument: gstreamer1-ffmpeg
        Package gstreamer1-plugins-good-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-ugly-1.12.4-3.fc27.x86_64 is already installed, skipping.
        No match for argument: gstreamer1-plugins-bad
        No match for argument: gstreamer1-plugins-bad-extras
        Package gstreamer1-plugins-bad-free-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-bad-nonfree-1.12.4-1.fc27.x86_64 is already installed, skipping.
        No match for argument: gstreamer1-plugins-bad-nonfree-extras
        No match for argument: gstreamer1-plugins-bad-freeworld-extras
        No match for argument: gstreamer1-plugins-bad-extras
        No match for argument: gstreamer1-plugins-bad-extras-extras
        Package mpg123-libs-1.25.6-1.fc27.x86_64 is already installed, skipping.
        Package lame-libs-3.100-1.fc27.x86_64 is already installed, skipping.
        Dependencies resolved.
        ================================================================================
         Package                            Arch   Version        Repository       Size
        ================================================================================
        Installing:
         gstreamer1-plugins-bad-free-extras x86_64 1.12.4-1.fc27  updates         248 k
         gstreamer1-plugins-bad-freeworld   x86_64 1.12.4-1.fc27  rpmfusion-free-updates
                                                                                  196 k
        Installing dependencies:
         GraphicsMagick                     x86_64 1.3.28-1.fc27  updates         1.5 M
         game-music-emu                     x86_64 0.6.1-4.fc27   fedora          155 k
         libbs2b                            x86_64 3.1.0-19.fc27  fedora           29 k
         libchromaprint                     x86_64 1.2-8.fc27     fedora           52 k
         libde265                           x86_64 1.0.2-6.fc27   rpmfusion-free  286 k
         libkate                            x86_64 0.4.1-11.fc27  fedora           57 k
         libmms                             x86_64 0.6.4-5.fc27   rpmfusion-free   53 k
         libofa                             x86_64 0.9.3-31.fc27  fedora           66 k
         librtmp                            x86_64 2.4-9.20160224.gitfa8646d.fc27
                                                                  rpmfusion-free   77 k
         mjpegtools-libs                    x86_64 2.1.0-7.fc27   rpmfusion-free  164 k
         openjpeg-libs                      x86_64 1.5.1-19.fc27  fedora           89 k
         zbar                               x86_64 0.20-4.fc27    fedora          156 k
         zvbi                               x86_64 0.2.35-4.fc27  fedora          420 k
        
        Transaction Summary
        ================================================================================
        Install  15 Packages
        
        Total download size: 3.5 M
        Installed size: 9.9 M
        Is this ok [y/N]: y
        ...
          gstreamer1-plugins-bad-free-extras.x86_64 1.12.4-1.fc27                       
          gstreamer1-plugins-bad-freeworld.x86_64 1.12.4-1.fc27                         
          GraphicsMagick.x86_64 1.3.28-1.fc27                                           
          game-music-emu.x86_64 0.6.1-4.fc27                                            
          libbs2b.x86_64 3.1.0-19.fc27                                                  
          libchromaprint.x86_64 1.2-8.fc27                                              
          libde265.x86_64 1.0.2-6.fc27                                                  
          libkate.x86_64 0.4.1-11.fc27                                                  
          libmms.x86_64 0.6.4-5.fc27                                                    
          libofa.x86_64 0.9.3-31.fc27                                                   
          librtmp.x86_64 2.4-9.20160224.gitfa8646d.fc27                                 
          mjpegtools-libs.x86_64 2.1.0-7.fc27                                           
          openjpeg-libs.x86_64 1.5.1-19.fc27                                            
          zbar.x86_64 0.20-4.fc27                                                       
          zvbi.x86_64 0.2.35-4.fc27                                                     
        
        Complete!
        
    • [root] ~ $ dnf history info 8 : More... Close
      Transaction ID : 8
      Begin time     : Sun 29 Apr 2018 08:15:49 AM MSK
      Begin rpmdb    : 1811:57a67904c115a98d195d2444a06f88d332c66ed6
      End time       : Sun 29 Apr 2018 08:16:03 AM MSK (14 seconds)
      End rpmdb      : 1826:293f99eaa302435fd819c21940baf82cd05e1176
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install gstreamer1-plugin-crystalhd gstreamer1-ffmpeg gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad gstreamer1-plugins-bad-extras gstreamer1-plugins-bad-free gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-nonfree gstreamer1-plugins-bad-nonfree-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-freeworld-extras gstreamer1-plugins-bad-extras gstreamer1-plugins-bad-extras-extras libmpg123 lame-libs --setopt=strict=0
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install GraphicsMagick-1.3.28-1.fc27.x86_64                     @updates
          Install game-music-emu-0.6.1-4.fc27.x86_64                      @fedora
          Install gstreamer1-plugins-bad-free-extras-1.12.4-1.fc27.x86_64 @updates
          Install gstreamer1-plugins-bad-freeworld-1.12.4-1.fc27.x86_64   @rpmfusion-free-updates
          Install libbs2b-3.1.0-19.fc27.x86_64                            @fedora
          Install libchromaprint-1.2-8.fc27.x86_64                        @fedora
          Install libde265-1.0.2-6.fc27.x86_64                            @rpmfusion-free
          Install libkate-0.4.1-11.fc27.x86_64                            @fedora
          Install libmms-0.6.4-5.fc27.x86_64                              @rpmfusion-free
          Install libofa-0.9.3-31.fc27.x86_64                             @fedora
          Install librtmp-2.4-9.20160224.gitfa8646d.fc27.x86_64           @rpmfusion-free
          Install mjpegtools-libs-2.1.0-7.fc27.x86_64                     @rpmfusion-free
          Install openjpeg-libs-1.5.1-19.fc27.x86_64                      @fedora
          Install zbar-0.20-4.fc27.x86_64                                 @fedora
          Install zvbi-0.2.35-4.fc27.x86_64                               @fedora
      Scriptlet output:
         1 Running as unit: run-r89391090dd7841da9d2aa70ce23be8b5.service
      

  • Transaction 9: [1]

    • (replacing yum -> dnf ):
      dnf install gstreamer gstreamer-ffmpeg gstreamer-plugins-bad gstreamer-plugins-bad-free gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly faad2 faac libdca wget compat-libstdc++-33 compat-libstdc++-296  xine-lib-extras-freeworld
      • stdout: More... Close
        r-plugins-bad-free gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly faad2 faac libdca wget compat-libstdc++-33 compat-libstdc++-296  xine-lib-extras-freeworld
        Last metadata expiration check: 1:57:47 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        Package faac-1.29.9.2-1.fc27.x86_64 is already installed, skipping.
        Package libdca-0.0.5-11.fc27.x86_64 is already installed, skipping.
        Package xine-lib-1.2.9-1.fc27.x86_64 is already installed, skipping.
        Dependencies resolved.
        ================================================================================
         Package                      Arch   Version            Repository         Size
        ================================================================================
        Installing:
         compat-libstdc++-296         i686   2.96-146.1         fedora             82 k
         compat-libstdc++-33          x86_64 3.2.3-68.16.fc26.1 fedora            190 k
         faad2                        x86_64 1:2.8.8-1.fc27     rpmfusion-free-updates
                                                                                   45 k
         gstreamer-ffmpeg             x86_64 0.10.13-18.fc27    rpmfusion-free    2.9 M
         gstreamer-plugins-bad        x86_64 0.10.23-9.fc27     rpmfusion-free    178 k
         gstreamer-plugins-bad-free   x86_64 0.10.23-41.fc27    fedora            1.5 M
         gstreamer-plugins-bad-free-extras
                                      x86_64 0.10.23-41.fc27    fedora            250 k
         gstreamer-plugins-bad-nonfree
                                      x86_64 0.10.23-5.fc27     rpmfusion-nonfree  32 k
         gstreamer-plugins-good       x86_64 0.10.31-20.fc27    fedora            1.6 M
         gstreamer-plugins-ugly       x86_64 0.10.19-23.fc27    rpmfusion-free    326 k
         wget                         x86_64 1.19.4-1.fc27      updates           726 k
        Installing dependencies:
         dirac-libs                   x86_64 1.0.2-23.fc27      fedora            258 k
         fluid-soundfont-common       noarch 3.1-17.fc27        fedora             87 k
         fluid-soundfont-lite-patches noarch 3.1-17.fc27        fedora            137 M
         glibc                        i686   2.26-27.fc27       updates           4.3 M
         gstreamer                    x86_64 0.10.36-18.fc27    fedora            998 k
         gstreamer-plugins-base       x86_64 0.10.36-18.fc27    fedora            1.3 M
         gstreamer-tools              x86_64 0.10.36-18.fc27    fedora             33 k
         libcdaudio                   x86_64 0.99.12p2-26.fc27  fedora             53 k
         libdc1394                    x86_64 2.2.2-9.fc27       fedora            124 k
         libgcc                       i686   7.3.1-5.fc27       updates           108 k
         libmimic                     x86_64 1.0.4-10.fc27      rpmfusion-free     33 k
         libtimidity                  x86_64 0.2.5-1.fc27       updates            49 k
         raptor2                      x86_64 2.0.15-10.fc27     fedora            207 k
         rasqal                       x86_64 0.9.33-5.fc27      fedora            286 k
         redland                      x86_64 1.0.17-12.fc27     fedora            172 k
         slv2                         x86_64 0.6.6-22.fc27      fedora             57 k
         wildmidi-libs                x86_64 0.4.2-1.fc27       updates            60 k
         yajl                         x86_64 2.1.0-8.fc27       fedora             38 k
        
        Transaction Summary
        ================================================================================
        Install  29 Packages
        
        Total download size: 153 M
        Installed size: 243 M
        Is this ok [y/N]: y
        ...
        Installed:
          compat-libstdc++-296.i686 2.96-146.1                                          
          compat-libstdc++-33.x86_64 3.2.3-68.16.fc26.1                                 
          faad2.x86_64 1:2.8.8-1.fc27                                                   
          gstreamer-ffmpeg.x86_64 0.10.13-18.fc27                                       
          gstreamer-plugins-bad.x86_64 0.10.23-9.fc27                                   
          gstreamer-plugins-bad-free.x86_64 0.10.23-41.fc27                             
          gstreamer-plugins-bad-free-extras.x86_64 0.10.23-41.fc27                      
          gstreamer-plugins-bad-nonfree.x86_64 0.10.23-5.fc27                           
          gstreamer-plugins-good.x86_64 0.10.31-20.fc27                                 
          gstreamer-plugins-ugly.x86_64 0.10.19-23.fc27                                 
          wget.x86_64 1.19.4-1.fc27                                                     
          dirac-libs.x86_64 1.0.2-23.fc27                                               
          fluid-soundfont-common.noarch 3.1-17.fc27                                     
          fluid-soundfont-lite-patches.noarch 3.1-17.fc27                               
          glibc.i686 2.26-27.fc27                                                       
          gstreamer.x86_64 0.10.36-18.fc27                                              
          gstreamer-plugins-base.x86_64 0.10.36-18.fc27                                 
          gstreamer-tools.x86_64 0.10.36-18.fc27                                        
          libcdaudio.x86_64 0.99.12p2-26.fc27                                           
          libdc1394.x86_64 2.2.2-9.fc27                                                 
          libgcc.i686 7.3.1-5.fc27                                                      
          libmimic.x86_64 1.0.4-10.fc27                                                 
          libtimidity.x86_64 0.2.5-1.fc27                                               
          raptor2.x86_64 2.0.15-10.fc27                                                 
          rasqal.x86_64 0.9.33-5.fc27                                                   
          redland.x86_64 1.0.17-12.fc27                                                 
          slv2.x86_64 0.6.6-22.fc27                                                     
          wildmidi-libs.x86_64 0.4.2-1.fc27                                             
          yajl.x86_64 2.1.0-8.fc27                                                      
        
        Complete!
        
    • [root] ~ $ dnf history info 9 : More... Close
      Transaction ID : 9
      Begin time     : Sun 29 Apr 2018 08:22:34 AM MSK
      Begin rpmdb    : 1826:293f99eaa302435fd819c21940baf82cd05e1176
      End time       : Sun 29 Apr 2018 08:23:15 AM MSK (41 seconds)
      End rpmdb      : 1855:9ac627bf01740edfb5e28603ae9324bbfeb72b29
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install gstreamer gstreamer-ffmpeg gstreamer-plugins-bad gstreamer-plugins-bad-free gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly faad2 faac libdca wget compat-libstdc++-33 compat-libstdc++-296 xine-lib-extras-freeworld
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install compat-libstdc++-296-2.96-146.1.i686                     @fedora
          Install compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64            @fedora
          Install dirac-libs-1.0.2-23.fc27.x86_64                          @fedora
          Install faad2-1:2.8.8-1.fc27.x86_64                              @rpmfusion-free-updates
          Install fluid-soundfont-common-3.1-17.fc27.noarch                @fedora
          Install fluid-soundfont-lite-patches-3.1-17.fc27.noarch          @fedora
          Install glibc-2.26-27.fc27.i686                                  @updates
          Install gstreamer-0.10.36-18.fc27.x86_64                         @fedora
          Install gstreamer-ffmpeg-0.10.13-18.fc27.x86_64                  @rpmfusion-free
          Install gstreamer-plugins-bad-0.10.23-9.fc27.x86_64              @rpmfusion-free
          Install gstreamer-plugins-bad-free-0.10.23-41.fc27.x86_64        @fedora
          Install gstreamer-plugins-bad-free-extras-0.10.23-41.fc27.x86_64 @fedora
          Install gstreamer-plugins-bad-nonfree-0.10.23-5.fc27.x86_64      @rpmfusion-nonfree
          Install gstreamer-plugins-base-0.10.36-18.fc27.x86_64            @fedora
      
          Install gstreamer-plugins-good-0.10.31-20.fc27.x86_64            @fedora
          Install gstreamer-plugins-ugly-0.10.19-23.fc27.x86_64            @rpmfusion-free
          Install gstreamer-tools-0.10.36-18.fc27.x86_64                   @fedora
          Install libcdaudio-0.99.12p2-26.fc27.x86_64                      @fedora
          Install libdc1394-2.2.2-9.fc27.x86_64                            @fedora
          Install libgcc-7.3.1-5.fc27.i686                                 @updates
          Install libmimic-1.0.4-10.fc27.x86_64                            @rpmfusion-free
          Install libtimidity-0.2.5-1.fc27.x86_64                          @updates
          Install raptor2-2.0.15-10.fc27.x86_64                            @fedora
          Install rasqal-0.9.33-5.fc27.x86_64                              @fedora
          Install redland-1.0.17-12.fc27.x86_64                            @fedora
          Install slv2-0.6.6-22.fc27.x86_64                                @fedora
          Install wget-1.19.4-1.fc27.x86_64                                @updates
          Install wildmidi-libs-0.4.2-1.fc27.x86_64                        @updates
          Install yajl-2.1.0-8.fc27.x86_64                                 @fedora
      Scriptlet output:
         1 Running as unit: run-r00bee45ec58d4ae0b4c70b73ae6f656a.service
      

  • Transaction 10: [3]

    • dnf install gstreamer1-plugins-base gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-free-extras ffmpeg
      • stdout : More... Close
        [root] ~ $ dnf install gstreamer1-plugins-base gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-free-extras ffmpeg
        Last metadata expiration check: 2:05:15 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        Package gstreamer1-plugins-base-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-good-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-ugly-1.12.4-3.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-bad-free-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-bad-freeworld-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-bad-free-extras-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Dependencies resolved.
        ================================================================================
         Package           Arch    Version                Repository               Size
        ================================================================================
        Installing:
         ffmpeg            x86_64  3.3.7-1.fc27           rpmfusion-free-updates  1.5 M
        Installing dependencies:
         SDL2              x86_64  2.0.7-2.fc27           updates                 395 k
         libavdevice       x86_64  3.3.7-1.fc27           rpmfusion-free-updates   92 k
         libcdio-paranoia  x86_64  10.2+0.93+1-10.fc27    fedora                   87 k
        
        Transaction Summary
        ================================================================================
        Install  4 Packages
        
        Total download size: 2.1 M
        Installed size: 3.5 M
        Is this ok [y/N]: y
        ...
        Installed:
          ffmpeg.x86_64 3.3.7-1.fc27       SDL2.x86_64 2.0.7-2.fc27                    
          libavdevice.x86_64 3.3.7-1.fc27  libcdio-paranoia.x86_64 10.2+0.93+1-10.fc27 
        
        <Complete!
        
    • [root] ~ $ dnf history info 10 : More... Close
      Transaction ID : 10
      Begin time     : Sun 29 Apr 2018 08:28:21 AM MSK
      Begin rpmdb    : 1855:9ac627bf01740edfb5e28603ae9324bbfeb72b29
      End time       : Sun 29 Apr 2018 08:28:25 AM MSK (4 seconds)
      End rpmdb      : 1859:79b6d8a7c167c337cb32549832e4f6e84cbe542a
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install gstreamer1-plugins-base gstreamer1-plugins-good gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-free-extras ffmpeg
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install SDL2-2.0.7-2.fc27.x86_64                    @updates
          Install ffmpeg-3.3.7-1.fc27.x86_64                  @rpmfusion-free-updates
          Install libavdevice-3.3.7-1.fc27.x86_64             @rpmfusion-free-updates
          Install libcdio-paranoia-10.2+0.93+1-10.fc27.x86_64 @fedora
      Scriptlet output:
         1 Running as unit: run-rf638eae824c74999ba7c468d41a6562e.service
      

  • Transaction 11: [4]

    • (Removing -y option)
      dnf install gstreamer-plugins-base gstreamer1-plugins-base gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer1-plugins-ugly gstreamer-plugins-good-extras gstreamer1-plugins-good-extras gstreamer1-plugins-bad-freeworld ffmpeg gstreamer-ffmpeg
      • stdout: More... Close
        [root] ~ $ dnf install gstreamer-plugins-base gstreamer1-plugins-base gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer1-plugins-ugly gstreamer-plugins-good-extras gstreamer1-plugins-good-extras gstreamer1-plugins-bad-freeworld ffmpeg gstreamer-ffmpeg
        Last metadata expiration check: 2:10:31 ago on Sun 29 Apr 2018 06:22:06 AM MSK.
        Package gstreamer-plugins-base-0.10.36-18.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-base-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer-plugins-bad-0.10.23-9.fc27.x86_64 is already installed, skipping.
        Package gstreamer-plugins-ugly-0.10.19-23.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-ugly-1.12.4-3.fc27.x86_64 is already installed, skipping.
        Package gstreamer1-plugins-bad-freeworld-1.12.4-1.fc27.x86_64 is already installed, skipping.
        Package ffmpeg-3.3.7-1.fc27.x86_64 is already installed, skipping.
        Package gstreamer-ffmpeg-0.10.13-18.fc27.x86_64 is already installed, skipping.
        Dependencies resolved.
        ================================================================================
         Package                          Arch     Version              Repository
                                                                                   Size
        ================================================================================
        Installing:
         gstreamer-plugins-good-extras    x86_64   0.10.31-20.fc27      fedora     39 k
         gstreamer1-plugins-good-extras   x86_64   1.12.4-1.fc27        updates    33 k
        
        Transaction Summary
        ================================================================================
        Install  2 Packages
        
        Total download size: 72 k
        Installed size: 99 k
        Is this ok [y/N]: y
        ...
        Installed:
          gstreamer-plugins-good-extras.x86_64 0.10.31-20.fc27                          
          gstreamer1-plugins-good-extras.x86_64 1.12.4-1.fc27                           
        
        Complete!
        
    • [root] ~ $ dnf history info 11 : More... Close
      Transaction ID : 11
      Begin time     : Sun 29 Apr 2018 08:33:26 AM MSK
      Begin rpmdb    : 1859:79b6d8a7c167c337cb32549832e4f6e84cbe542a
      End time       : Sun 29 Apr 2018 08:33:27 AM MSK (1 seconds)
      End rpmdb      : 1861:ae2534bc15bc102d7d68c6565c836450221847a4
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install gstreamer-plugins-base gstreamer1-plugins-base gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer1-plugins-ugly gstreamer-plugins-good-extras gstreamer1-plugins-good-extras gstreamer1-plugins-bad-freeworld ffmpeg gstreamer-ffmpeg
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install gstreamer-plugins-good-extras-0.10.31-20.fc27.x86_64 @fedora
          Install gstreamer1-plugins-good-extras-1.12.4-1.fc27.x86_64  @updates
      

  • Installed 103 packages.
    The full list of installed packages (1865 in total vs 1762 in sect.31)
               /opt/root/Install/rpm_history/180429.0901.rpm-qa.media_codecs_installed
    ( local copy )
    The 103 new packages: More... Close
    [root] .../rpm_history $ diff 180429.0407.rpm-qa.rpmfusion_repos_installed \
                                  180429.0901.rpm-qa.media_codecs_installed \
                            | grep ">"
    > aalib-libs-1.4.0-0.32.rc5.fc27.x86_64
    > beignet-1.3.2-2.fc27.x86_64
    > clang-libs-5.0.1-5.fc27.x86_64
    > compat-libstdc++-296-2.96-146.1.i686
    > compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64
    > compiler-rt-5.0.1-2.fc27.x86_64
    > dirac-libs-1.0.2-23.fc27.x86_64
    > faac-1.29.9.2-1.fc27.x86_64
    > faad2-2.8.8-1.fc27.x86_64
    > faad2-libs-2.8.8-1.fc27.x86_64
    > fdk-aac-0.1.5-2.fc27.x86_64
    > ffmpeg-3.3.7-1.fc27.x86_64
    > ffmpeg-libs-3.3.7-1.fc27.x86_64
    > fluid-soundfont-common-3.1-17.fc27.noarch
    > fluid-soundfont-lite-patches-3.1-17.fc27.noarch
    > freeglut-3.0.0-6.fc27.x86_64
    > fribidi-0.19.7-5.fc27.x86_64
    > game-music-emu-0.6.1-4.fc27.x86_64
    > glibc-2.26-27.fc27.i686
    > glibc-devel-2.26-27.fc27.x86_64
    > glibc-headers-2.26-27.fc27.x86_64
    > gpg-pubkey-7d838377-582f2494
    > gpg-pubkey-b9c13282-582f265a
    > gpm-libs-1.20.7-10.fc26.x86_64
    > GraphicsMagick-1.3.28-1.fc27.x86_64
    > gstreamer-0.10.36-18.fc27.x86_64
    > gstreamer1-libav-1.12.4-1.fc27.x86_64
    > gstreamer1-plugins-bad-free-extras-1.12.4-1.fc27.x86_64
    > gstreamer1-plugins-bad-freeworld-1.12.4-1.fc27.x86_64
    > gstreamer1-plugins-bad-nonfree-1.12.4-1.fc27.x86_64
    > gstreamer1-plugins-good-extras-1.12.4-1.fc27.x86_64
    > gstreamer1-plugins-ugly-1.12.4-3.fc27.x86_64
    > gstreamer-ffmpeg-0.10.13-18.fc27.x86_64
    > gstreamer-plugins-bad-0.10.23-9.fc27.x86_64
    > gstreamer-plugins-bad-free-0.10.23-41.fc27.x86_64
    > gstreamer-plugins-bad-free-extras-0.10.23-41.fc27.x86_64
    > gstreamer-plugins-bad-nonfree-0.10.23-5.fc27.x86_64
    > gstreamer-plugins-base-0.10.36-18.fc27.x86_64
    > gstreamer-plugins-good-0.10.31-20.fc27.x86_64
    > gstreamer-plugins-good-extras-0.10.31-20.fc27.x86_64
    > gstreamer-plugins-ugly-0.10.19-23.fc27.x86_64
    > gstreamer-tools-0.10.36-18.fc27.x86_64
    > hwloc-libs-1.11.5-6.fc27.x86_64
    > jack-audio-connection-kit-1.9.12-1.fc27.x86_64
    > k3b-extras-freeworld-17.08.3-1.fc27.x86_64
    > kernel-headers-4.16.3-200.fc27.x86_64
    > libass-0.13.4-4.fc27.x86_64
    > libavdevice-3.3.7-1.fc27.x86_64
    > libbluray-1.0.2-1.fc27.x86_64
    > libbs2b-3.1.0-19.fc27.x86_64
    > libcaca-0.99-0.31.beta19.fc26.x86_64
    > libcdaudio-0.99.12p2-26.fc27.x86_64
    > libcdio-paranoia-10.2+0.93+1-10.fc27.x86_64
    > libchromaprint-1.2-8.fc27.x86_64
    > libclc-0.2.0-9.git1cb3fbf.fc27.x86_64
    > libdc1394-2.2.2-9.fc27.x86_64
    > libdca-0.0.5-11.fc27.x86_64
    > libde265-1.0.2-6.fc27.x86_64
    > libffado-2.4.0-1.fc27.x86_64
    > libgcc-7.3.1-5.fc27.i686
    > libkate-0.4.1-11.fc27.x86_64
    > libmfx-1.21-3.fc27.x86_64
    > libmimic-1.0.4-10.fc27.x86_64
    > libmms-0.6.4-5.fc27.x86_64
    > libmodplug-0.8.9.0-3.fc27.x86_64
    > libmpeg2-0.5.1-13.fc27.x86_64
    > libofa-0.9.3-31.fc27.x86_64
    > libomp-5.0.1-1.fc27.x86_64
    > librtmp-2.4-9.20160224.gitfa8646d.fc27.x86_64
    > libstdc++-devel-7.3.1-5.fc27.x86_64
    > libtimidity-0.2.5-1.fc27.x86_64
    > libva-1.8.3-5.fc27.x86_64
    > libxml++-2.40.1-5.fc27.x86_64
    > mesa-libOpenCL-17.3.6-1.fc27.x86_64
    > mjpegtools-libs-2.1.0-7.fc27.x86_64
    > ocl-icd-2.2.12-1.fc27.x86_64
    > opencl-filesystem-1.0-6.fc27.noarch
    > opencore-amr-0.1.5-2.fc27.x86_64
    > openjpeg-libs-1.5.1-19.fc27.x86_64
    > pocl-0.15-0.1.20171023git53ef5e8.fc27.x86_64
    > raptor2-2.0.15-10.fc27.x86_64
    > rasqal-0.9.33-5.fc27.x86_64
    > redland-1.0.17-12.fc27.x86_64
    > schroedinger-1.0.11-13.fc27.x86_64
    > SDL-1.2.15-29.fc27.x86_64
    > SDL2-2.0.7-2.fc27.x86_64
    > slv2-0.6.6-22.fc27.x86_64
    > vcdimager-0.7.24-12.fc27.x86_64
    > vcdimager-libs-0.7.24-12.fc27.x86_64
    > vid.stab-1.1-3.20170830gitafc8ea9.fc27.x86_64
    > vo-amrwbenc-0.1.3-3.fc27.x86_64
    > wget-1.19.4-1.fc27.x86_64
    > wildmidi-libs-0.4.2-1.fc27.x86_64
    > x264-libs-0.148-22.20170521gitaaa9aa8.fc27.x86_64
    > x265-libs-2.5-1.fc27.x86_64
    > xine-lib-1.2.9-1.fc27.x86_64
    > xine-lib-devel-1.2.9-1.fc27.x86_64
    > xine-lib-extras-1.2.9-1.fc27.x86_64
    > xvidcore-1.3.4-4.fc27.x86_64
    > yajl-2.1.0-8.fc27.x86_64
    > zbar-0.20-4.fc27.x86_64
    > zlib-devel-1.2.11-4.fc27.x86_64
    > zvbi-0.2.35-4.fc27.x86_64
    

  • The problems with firefox, mentioned in the beginning of this section, have gone.

  33. (02.05.18) mplayer and mencoder

  • [root] ~ $ dnf install mplayer-gui mplayer-tools mplayer-doc
    • stdout: More... Close
      [root] ~ $ dnf install mplayer-gui mplayer-tools mplayer-doc
      Fedora 27 - x86_64 - Updates                    2.6 MB/s |  23 MB     00:08    
      Last metadata expiration check: 0:00:00 ago on Wed 02 May 2018 01:21:11 AM MSK.
      Dependencies resolved.
      ================================================================================
       Package             Arch        Version              Repository           Size
      ================================================================================
      Installing:
       mplayer-doc         x86_64      1.3.0-11.fc27        rpmfusion-free      1.5 M
       mplayer-gui         x86_64      1.3.0-11.fc27        rpmfusion-free      1.6 M
       mplayer-tools       x86_64      1.3.0-11.fc27        rpmfusion-free       48 k
      Installing dependencies:
       enca                x86_64      1.19-1.fc27          updates             111 k
       lirc-libs           x86_64      0.10.0-6.fc27        updates             135 k
       mencoder            x86_64      1.3.0-11.fc27        rpmfusion-free      866 k
       mplayer             x86_64      1.3.0-11.fc27        rpmfusion-free      1.2 M
       mplayer-common      x86_64      1.3.0-11.fc27        rpmfusion-free      1.2 M
      
      Transaction Summary
      ================================================================================
      Install  8 Packages
      
      Total download size: 6.5 M
      Installed size: 21 M
      Is this ok [y/N]: y
      ...
      Installed:
        mplayer-doc.x86_64 1.3.0-11.fc27       mplayer-gui.x86_64 1.3.0-11.fc27       
        mplayer-tools.x86_64 1.3.0-11.fc27     enca.x86_64 1.19-1.fc27                
        lirc-libs.x86_64 0.10.0-6.fc27         mencoder.x86_64 1.3.0-11.fc27          
        mplayer.x86_64 1.3.0-11.fc27           mplayer-common.x86_64 1.3.0-11.fc27    
      
      Complete!
      
    • transaction info: More... Close
      [root] ~ $ dnf history info 12
      Transaction ID : 12
      Begin time     : Wed 02 May 2018 01:23:45 AM MSK
      Begin rpmdb    : 1861:ae2534bc15bc102d7d68c6565c836450221847a4
      End time       : Wed 02 May 2018 01:23:54 AM MSK (9 seconds)
      End rpmdb      : 1869:964b096c871c68d2300c894794e9a61695cbbb27
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install mplayer-gui mplayer-tools mplayer-doc
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install enca-1.19-1.fc27.x86_64             @updates
          Install lirc-libs-0.10.0-6.fc27.x86_64      @updates
          Install mencoder-1.3.0-11.fc27.x86_64       @rpmfusion-free
          Install mplayer-1.3.0-11.fc27.x86_64        @rpmfusion-free
          Install mplayer-common-1.3.0-11.fc27.x86_64 @rpmfusion-free
          Install mplayer-doc-1.3.0-11.fc27.x86_64    @rpmfusion-free
          Install mplayer-gui-1.3.0-11.fc27.x86_64    @rpmfusion-free
          Install mplayer-tools-1.3.0-11.fc27.x86_64  @rpmfusion-free
      Scriptlet output:
         1 Running as unit: run-r697da31564e74b8393a427ea569b594c.service
      

  • Installed 8 packages. The full list of installed packages (1873 in total vs 1865 in sect.32)
               /opt/root/Install/180502.0129.rpm-qa.mplayer_installed
    ( local copy )
    The 8 new packages:
    [root] .../rpm_history $ diff 180429.0901.rpm-qa.media_codecs_installed \
                                  180502.0129.rpm-qa.mplayer_installed \
                            | grep ">"
    > enca-1.19-1.fc27.x86_64
    > lirc-libs-0.10.0-6.fc27.x86_64
    > mencoder-1.3.0-11.fc27.x86_64
    > mplayer-1.3.0-11.fc27.x86_64
    > mplayer-common-1.3.0-11.fc27.x86_64
    > mplayer-doc-1.3.0-11.fc27.x86_64
    > mplayer-gui-1.3.0-11.fc27.x86_64
    > mplayer-tools-1.3.0-11.fc27.x86_64
    

  • The installed executables (in /usr/bin) :
    package executable(s)
    enca enca enconv
    mencoder mencoder
    mplayer mplayer
    mplayer-gui gmplayer
    mplayer-tools aconvert calcbp  calcbpp countquant
    divx2svcd dvd2divxscript mencvcd
    midentify mpconsole qepdvcd
    subsearch vobshift
  • Manuals:
    man pages: enca, enconv
    mencoder (+ pages in cs, de, es, fr, hu, it, pl, ru, zh_CN)
    mplayer (+ pages in other languages)
    html /usr/share/doc/mplayer-doc/en/index.html (dom5 local link)
    (+ en -> cs,de,es,fr,hu,pl,ru,tech,zh_CN versions)
    txt: /usr/share/doc/mplayer-doc/tech/manpage.txt
    -- "A documentation about MPlayer's man page"

  • Like in the case of F18 @ dom3, running gmplayer on an avi file produced an error message (not exactly the same as in F18 but quite a similar one):
    Failed to open VDPAU backend libvdpau_va_gl.so: \
       cannot open shared object file: No such file or directory
    [vdpau] Error when calling vdp_device_create_x11: 1
    Error opening/initializing the selected video_out (-vo) device.
    
  • And the F18 remedy helped now as well: the following reconfiguration fixed the problem:
    • gmplayer -> icon "settings" (a picture of a wrench on the left) -> tab Video -> change driver `vdpau' to `xv' -> OK
  • Then the avi file could be played

  34. (02.05.18) VLC player

  • [root] ~ $ dnf install vlc
    • stdout: More... Close
      [root] ~ $ dnf install vlc
      Last metadata expiration check: 0:00:00 ago on Wed 02 May 2018 10:06:37 PM MSK.
      Dependencies resolved.
      ================================================================================
       Package             Arch   Version                Repository              Size
      ================================================================================
      Installing:
       vlc                 x86_64 3.0.2-1.fc27           rpmfusion-free-updates 2.0 M
      Installing dependencies:
       fluidsynth-libs     x86_64 1.1.9-1.fc27           updates                215 k
       ftgl                x86_64 2.1.3-0.17.rc5.fc27    fedora                 114 k
       libcddb             x86_64 1.3.2-24.fc27          fedora                  76 k
       libdvbpsi           x86_64 1.3.2-1.fc27           updates                104 k
       libebml             x86_64 1.3.5-1.fc27           fedora                  77 k
       libmatroska         x86_64 1.4.8-1.fc27           fedora                 160 k
       libmicrodns         x86_64 0.0.8-1.fc27           updates                 28 k
       libplacebo          x86_64 0.4.0-1.fc27           updates                123 k
       libprojectM         x86_64 2.1.0-6.fc27           fedora                 480 k
       libtiger            x86_64 0.3.4-14.fc27          fedora                  42 k
       libupnp             x86_64 1.6.25-1.fc27          updates                108 k
       live555             x86_64 2017.07.18-2.fc27      rpmfusion-free         368 k
       lua                 x86_64 5.3.4-7.fc27           updates                190 k
       protobuf-lite       x86_64 3.3.1-2.fc27           fedora                 111 k
       spirv-tools-libs    x86_64 2018.1-0.2.20180205.git9e19fc0.fc27
                                                         updates                573 k
       vlc-core            x86_64 3.0.2-1.fc27           rpmfusion-free-updates  10 M
       vulkan              x86_64 1.1.70.0-1.fc27        updates                1.1 M
       vulkan-filesystem   noarch 1.1.70.0-1.fc27        updates                 12 k
      Installing weak dependencies:
       mesa-vulkan-drivers x86_64 17.3.6-1.fc27          updates                1.6 M
       qt5-qtwayland       x86_64 5.9.4-2.fc27           updates                721 k
      
      Transaction Summary
      ================================================================================
      Install  21 Packages
      
      Total download size: 18 M
      Installed size: 79 M
      Is this ok [y/N]: y
      ...
      Installed:
        vlc.x86_64 3.0.2-1.fc27                                                       
        mesa-vulkan-drivers.x86_64 17.3.6-1.fc27                                      
        qt5-qtwayland.x86_64 5.9.4-2.fc27                                             
        fluidsynth-libs.x86_64 1.1.9-1.fc27                                           
        ftgl.x86_64 2.1.3-0.17.rc5.fc27                                               
        libcddb.x86_64 1.3.2-24.fc27                                                  
        libdvbpsi.x86_64 1.3.2-1.fc27                                                 
        libebml.x86_64 1.3.5-1.fc27                                                   
        libmatroska.x86_64 1.4.8-1.fc27                                               
        libmicrodns.x86_64 0.0.8-1.fc27                                               
        libplacebo.x86_64 0.4.0-1.fc27                                                
        libprojectM.x86_64 2.1.0-6.fc27                                               
        libtiger.x86_64 0.3.4-14.fc27                                                 
        libupnp.x86_64 1.6.25-1.fc27                                                  
        live555.x86_64 2017.07.18-2.fc27                                              
        lua.x86_64 5.3.4-7.fc27                                                       
        protobuf-lite.x86_64 3.3.1-2.fc27                                             
        spirv-tools-libs.x86_64 2018.1-0.2.20180205.git9e19fc0.fc27                   
        vlc-core.x86_64 3.0.2-1.fc27                                                  
        vulkan.x86_64 1.1.70.0-1.fc27                                                 
        vulkan-filesystem.noarch 1.1.70.0-1.fc27                                      
      
      Complete!
      
    • transaction info: More... Close
      [root] ~ $ dnf history info 13
      Transaction ID : 13
      Begin time     : Wed 02 May 2018 10:09:10 PM MSK
      Begin rpmdb    : 1869:964b096c871c68d2300c894794e9a61695cbbb27
      End time       : Wed 02 May 2018 10:09:34 PM MSK (24 seconds)
      End rpmdb      : 1890:bdc1f0a24d6c69bf7a3d11316d08437cf0409e1d
      User           : Alexander Fedotov <fedotov>
      Return-Code    : Success
      Command Line   : install vlc
      Transaction performed with:
          Installed     dnf-2.7.5-2.fc27.noarch  (unknown)
          Installed     rpm-4.14.1-1.fc27.x86_64 (unknown)
      Packages Altered:
          Install fluidsynth-libs-1.1.9-1.fc27.x86_64                         @updates
          Install ftgl-2.1.3-0.17.rc5.fc27.x86_64                             @fedora
          Install libcddb-1.3.2-24.fc27.x86_64                                @fedora
          Install libdvbpsi-1.3.2-1.fc27.x86_64                               @updates
          Install libebml-1.3.5-1.fc27.x86_64                                 @fedora
          Install libmatroska-1.4.8-1.fc27.x86_64                             @fedora
          Install libmicrodns-0.0.8-1.fc27.x86_64                             @updates
          Install libplacebo-0.4.0-1.fc27.x86_64                              @updates
          Install libprojectM-2.1.0-6.fc27.x86_64                             @fedora
          Install libtiger-0.3.4-14.fc27.x86_64                               @fedora
          Install libupnp-1.6.25-1.fc27.x86_64                                @updates
          Install live555-2017.07.18-2.fc27.x86_64                            @rpmfusion-free
          Install lua-5.3.4-7.fc27.x86_64                                     @updates
          Install mesa-vulkan-drivers-17.3.6-1.fc27.x86_64                    @updates
          Install protobuf-lite-3.3.1-2.fc27.x86_64                           @fedora
          Install qt5-qtwayland-5.9.4-2.fc27.x86_64                           @updates
          Install spirv-tools-libs-2018.1-0.2.20180205.git9e19fc0.fc27.x86_64 @updates
          Install vlc-3.0.2-1.fc27.x86_64                                     @rpmfusion-free-updates
          Install vlc-core-3.0.2-1.fc27.x86_64                                @rpmfusion-free-updates
          Install vulkan-1.1.70.0-1.fc27.x86_64                               @updates
          Install vulkan-filesystem-1.1.70.0-1.fc27.noarch                    @updates
      Scriptlet output:
         1 Running as unit: run-re4aba2b585634d88bc967157b4c2f46a.service
      

  • Installed 21 package. The list from the above transaction info:
    fluidsynth-libs-1.1.9-1.fc27.x86_64                         @updates
    ftgl-2.1.3-0.17.rc5.fc27.x86_64                             @fedora
    libcddb-1.3.2-24.fc27.x86_64                                @fedora
    libdvbpsi-1.3.2-1.fc27.x86_64                               @updates
    libebml-1.3.5-1.fc27.x86_64                                 @fedora
    libmatroska-1.4.8-1.fc27.x86_64                             @fedora
    libmicrodns-0.0.8-1.fc27.x86_64                             @updates
    libplacebo-0.4.0-1.fc27.x86_64                              @updates
    libprojectM-2.1.0-6.fc27.x86_64                             @fedora
    libtiger-0.3.4-14.fc27.x86_64                               @fedora
    libupnp-1.6.25-1.fc27.x86_64                                @updates
    live555-2017.07.18-2.fc27.x86_64                            @rpmfusion-free
    lua-5.3.4-7.fc27.x86_64                                     @updates
    mesa-vulkan-drivers-17.3.6-1.fc27.x86_64                    @updates
    protobuf-lite-3.3.1-2.fc27.x86_64                           @fedora
    qt5-qtwayland-5.9.4-2.fc27.x86_64                           @updates
    spirv-tools-libs-2018.1-0.2.20180205.git9e19fc0.fc27.x86_64 @updates
    vlc-3.0.2-1.fc27.x86_64                                     @rpmfusion-free-updates
    vlc-core-3.0.2-1.fc27.x86_64                                @rpmfusion-free-updates
    vulkan-1.1.70.0-1.fc27.x86_64                               @updates
    vulkan-filesystem-1.1.70.0-1.fc27.noarch                    @updates
    

  • The full list of installed packages (1894 in total vs 1873 in sect.33)
               /opt/root/Install/rpm_history/180502.2227.rpm-qa.vlc_installed
    ( local copy )

  • Installed executables (in /usr/bin ):
    package executable(s)
    libcddb cddb_query
    lua lua luac
    vlc qvlc svlc
    vlc-core cvlc nvlc rvlc vlc vlc-wrapper

  • Manuals:
    man pages: lua, luac, vlc-wrapper, vlc
    html: /usr/share/doc/lua/readme.html (dom5 local link)
               -- Welcome to Lua 5.3
    /usr/share/doc/lua/contents.html (dom5 local link)
               -- Lua 5.3 Reference Manual

  35. (03.05.18) directory /products

  • /products has been created as a link to /opt/products :
               [root] ~ $ mkdir /opt/products
               [root] ~ $ ln -s /opt/products /

  36. (04.05.18) Vidyo Desktop 3.6.3-017

  • Still, we give it a try just in case.

  • The downloaded file
               VidyoDesktopInstaller-sl564-TAG_VD_3_6_3_017.rpm is put to the
               /opt/root/Install/RPMS directory .

  • Most of the files from the rpm will go to the /opt/vidyo/ directory
    We redirect them to /opt/products/vidyo/ by
               $ mkdir /products/vidyo
               $ ln -s /opt/products/vidyo/ /opt/

  • Install:
    [root] ~/opt_root_Install/RPMS $ rpm -Uvh VidyoDesktopInstaller-sl564-TAG_VD_3_6_3_017.rpm 
    Preparing...                          ################################# [100%]
    Updating / installing...
       1:VidyoDesktop-3.6.3-017           ################################# [100%]
    Start VidyoDesktop from Application --> Internet --> VidyoDesktop
    VidyoDesktop has been installed in /opt/vidyo/VidyoDesktop
    

  • A package with a different name gets installed:
               VidyoDesktop-3.6.3-017.x86_64
  • The full list of installed packages (1895 in total vs 1894 in sect.34)
               /opt/root/Install/180504.0518.rpm-qa.vidyodesktop_installed
    ( local copy )

  • The executable is
               /usr/bin/VidyoDesktop
    which can also be started from
               Fedora menu --> Application --> Internet --> VidyoDesktop
    Probably, it will autostart due to the presence of the installed file
               /etc/xdg/autostart/VidyoDesktop.desktop

  • Launching it shows a usual login window, where we type
               https://vidyoportal.cern.ch , username, pw
    -> recognised -> a new window with the user "Al... Fe..." opens.

  • Later on, we were able to attend a multi-hour meeting.

  • Everything seems to work properly. We are lucky.

  37. (06.05.18) Enabling sshd service

  • A problem: Trying to connect to local host via ssh (ssh root@dom5 , ssh fedotov@dom5) produces the error
               ssh: connect to host dom5  port 22: Connection refused .
    The reason is that sshd (ssh daemon) service is inactive.

  • So we enable the sshd for future boots with
    [root] ~ $ systemctl enable sshd.service
    Created symlink /etc/systemd/system/multi-user.target.wants/sshd.service -> \
                   /usr/lib/systemd/system/sshd.service.
    
    • Note: the service gets activated at the boot stage, not at a login, and it stays inactive for the current session.

  • NB. One can
    • start/stop a service for the current session with
                 systemctl start     service_name.service
                 systemctl stop      service_name.service
    • check status:
                 systemctl is-active service_name.service (short output)
                 systemctl status    service_name.service (detailed output)
    • display a list of all active services:
                 systemctl list-units --type=service

  38. (07.05.18) Enabling X11 Forwarding for ssh by default

  • We create the file /usr/local/etc/ssh/ssh_config.d/10.ForwardX11_yes.conf
               [root] ~ $ mkdir -p /usr/local/etc/ssh/ssh_config.d
               ... edit /usr/local/etc/ssh/ssh_config.d/10-ForwardX11_yes.conf ...
    with a link in /etc/ssh/ssh_config.d/ :
    [root] ~ $ ll /etc/ssh/ssh_config.d/
    total 4
    -rw-r--r--. 1 root root 690 Feb  1 18:42 05-redhat.conf
    lrwxrwxrwx. 1 root root  54 May  7 00:35 10-ForwardX11_yes.conf -> \
             /usr/local/etc/ssh/ssh_config.d/10-ForwardX11_yes.conf
    
    containing
    [root] ~ $ cat /usr/local/etc/ssh/ssh_config.d/10-ForwardX11_yes.conf
    Host *
      ForwardX11 yes
    

  • All the *.conf files in /etc/ssh/ssh_config.d/ are included into
               /etc/ssh/ssh_config
    via the line
    Include /etc/ssh/ssh_config.d/*.conf
    
    there.

  • Note: The new option
               "ForwardX11 yes" together with the option
               "ForwardX11Trusted yes"
    set already in /etc/ssh/ssh_config.d/05-redhat.conf seem to be equivalent to the "-Y" option of ssh, which invokes a stronger version of X11 Forwarding than the one invoked by the "-X" option of ssh (see man ssh, man ssh_config for details).

  39. (07.05.18) Adding domains desy.de, itep.ru, cern.ch to search list, plus an additional DNS

  • The procedure needs to be applied to every network connection separately.

  • f -> Computer -> System settings (equivalent to the systemsettings5 command) -> Network -> Connections -> Wi-Fi -> X5pro (this one happened to be our current connection) -> IPv4 tab
    • field "Other DNS Servers" -> type 8.8.8.8 (a free Google DNS)
    • field "Search Domains" -> type desy.de,itep.ru,cern.ch (a comma-separated list)
    • press Apply

  • The following lines do appear in
    /etc/sysconfig/network-scripts/ifcfg-X5pro :
    DNS1=8.8.8.8
    DOMAIN="desy.de  itep.ru  cern.ch "
    

  • Restart the NetworkManager (systemctl restart ... could be used?)
    [root] ~ $ systemctl stop  NetworkManager.service
    [root] ~ $ systemctl start NetworkManager.service
    
    • the domains are resolved now
    • file /etc/resolv.conf gets automatically updated:
      [dom5] ~ $ cat /etc/resolv.conf                              
      # Generated by NetworkManager
      search desy.de itep.ru cern.ch
      nameserver 192.168.43.1
      nameserver 8.8.8.8
      

  • Then we repeat the re-configuration for other two available connections:
               Wi-Fi / mgtspon61 and Wired Ethernet / enp3s0

  40. (17.05.18) libreoffice

  • [root] ...$ dnf -y install libreoffice
    stdout: More... Close
    Last metadata expiration check: 0:11:32 ago on Thu 17 May 2018 03:40:53 AM MSK.
    Dependencies resolved.
    ================================================================================
     Package                         Arch   Version                   Repository
                                                                               Size
    ================================================================================
    Installing:
     libreoffice                     x86_64 1:5.4.6.2-6.fc27          updates  78 k
    Installing dependencies:
     apache-commons-logging          noarch 1.2-11.fc27               fedora   86 k
     autocorr-en                     noarch 1:5.4.6.2-6.fc27          updates 207 k
     boost-iostreams                 x86_64 1.64.0-6.fc27             updates  74 k
     clucene-contribs-lib            x86_64 2.3.3.4-29.20130812.e8e3d20git.fc27
                                                                      fedora   94 k
     clucene-core                    x86_64 2.3.3.4-29.20130812.e8e3d20git.fc27
                                                                      fedora  541 k
     copy-jdk-configs                noarch 3.3-9.fc27                updates  25 k
     flute                           noarch 1.3.0-17.OOo31.fc27       fedora   65 k
     google-crosextra-caladea-fonts  noarch 1.002-0.9.20130214.fc27   fedora   96 k
     google-crosextra-carlito-fonts  noarch 1.103-0.7.20130920.fc27   fedora  817 k
     gstreamer1-plugins-bad-free-gtk x86_64 1.12.4-1.fc27             updates  35 k
     hyphen-en                       noarch 2.8.8-8.fc27              fedora   52 k
     java-1.8.0-openjdk-headless     x86_64 1:1.8.0.171-4.b10.fc27    updates  32 M
     java-openjdk                    x86_64 1:10.0.1.10-3.fc27        updates 216 k
     java-openjdk-headless           x86_64 1:10.0.1.10-3.fc27        updates  41 M
     javapackages-tools              noarch 5.0.0-7.fc27              fedora   50 k
     libabw                          x86_64 0.1.2-1.fc27              updates 120 k
     libbase                         noarch 1.1.3-17.fc27             fedora  127 k
     libcdr                          x86_64 0.1.4-1.fc27              fedora  411 k
     libcmis                         x86_64 0.5.1-9.fc27              fedora  522 k
     libe-book                       x86_64 0.1.3-1.fc27              updates 189 k
     libeot                          x86_64 0.01-8.fc27               fedora   35 k
     libexttextcat                   x86_64 3.4.4-7.fc27              fedora  210 k
     libfonts                        noarch 1.1.3-20.fc27             fedora  195 k
     libformula                      noarch 1.1.3-17.fc27             fedora  319 k
     libfreehand                     x86_64 0.1.2-1.fc27              fedora  263 k
     libgltf                         x86_64 0.1.0-7.fc27              fedora  117 k
     liblayout                       noarch 0.2.10-14.fc27            fedora  658 k
     libloader                       noarch 1.1.3-16.fc27             fedora  101 k
     libmspub                        x86_64 0.1.4-1.fc27              updates 166 k
     libmwaw                         x86_64 0.3.14-1.fc27             updates 2.6 M
     liborcus                        x86_64 0.12.1-7.fc27             fedora  378 k
     libpagemaker                    x86_64 0.0.4-1.fc27              updates  78 k
     libreoffice-base                x86_64 1:5.4.6.2-6.fc27          updates 2.2 M
     libreoffice-calc                x86_64 1:5.4.6.2-6.fc27          updates 8.1 M
     libreoffice-core                x86_64 1:5.4.6.2-6.fc27          updates  69 M
     libreoffice-data                noarch 1:5.4.6.2-6.fc27          updates 3.4 M
     libreoffice-draw                x86_64 1:5.4.6.2-6.fc27          updates  91 k
     libreoffice-emailmerge          x86_64 1:5.4.6.2-6.fc27          updates  92 k
     libreoffice-graphicfilter       x86_64 1:5.4.6.2-6.fc27          updates 481 k
     libreoffice-gtk3                x86_64 1:5.4.6.2-6.fc27          updates 323 k
     libreoffice-impress             x86_64 1:5.4.6.2-6.fc27          updates 636 k
     libreoffice-langpack-en         x86_64 1:5.4.6.2-6.fc27          updates 322 k
     libreoffice-math                x86_64 1:5.4.6.2-6.fc27          updates 515 k
     libreoffice-opensymbol-fonts    noarch 1:5.4.6.2-6.fc27          updates 253 k
     libreoffice-pdfimport           x86_64 1:5.4.6.2-6.fc27          updates 289 k
     libreoffice-pyuno               x86_64 1:5.4.6.2-6.fc27          updates 421 k
     libreoffice-ure                 x86_64 1:5.4.6.2-6.fc27          updates 2.2 M
     libreoffice-ure-common          noarch 1:5.4.6.2-6.fc27          updates 514 k
     libreoffice-writer              x86_64 1:5.4.6.2-6.fc27          updates 3.7 M
     libreoffice-x11                 x86_64 1:5.4.6.2-6.fc27          updates 306 k
     librepository                   noarch 1.1.3-16.fc27             fedora   67 k
     libserializer                   noarch 1.1.2-17.fc27             fedora   37 k
     libstaroffice                   x86_64 0.0.6-1.fc27              updates 839 k
     libzmf                          x86_64 0.0.2-1.fc27              fedora   83 k
     lksctp-tools                    x86_64 1.0.16-8.fc27             fedora   95 k
     lpsolve                         x86_64 5.5.2.0-16.fc27           fedora  422 k
     lua-posix                       x86_64 33.3.1-7.fc27             fedora  174 k
     mythes                          x86_64 1.2.4-8.fc27              fedora   18 k
     mythes-en                       noarch 3.0-19.fc27               fedora  3.9 M
     openCOLLADA                     x86_64 0-29.gitcaad49c.fc27      fedora  1.5 M
     pentaho-libxml                  noarch 1.1.3-16.fc27             fedora   86 k
     pentaho-reporting-flow-engine   noarch 1:0.9.4-14.fc27           fedora  287 k
     postgresql-jdbc                 noarch 9.4.1212-4.fc27           fedora  494 k
     sac                             noarch 1.3-26.fc27               fedora   21 k
     ttmkfdir                        x86_64 3.0.9-51.fc27             fedora   55 k
     tzdata-java                     noarch 2018d-1.fc27              updates 184 k
     xml-commons-apis                noarch 1.4.01-23.fc27            fedora  232 k
     xorg-x11-fonts-Type1            noarch 7.5-18.fc27               fedora  521 k
    Installing weak dependencies:
     libreoffice-gtk2                x86_64 1:5.4.6.2-6.fc27          updates 305 k
     libreoffice-help-en             x86_64 1:5.4.6.2-6.fc27          updates 4.9 M
    
    Transaction Summary
    ================================================================================
    Install  71 Packages
    
    Total download size: 189 M
    Installed size: 675 M
    Downloading Packages:
    ...
    
    Installed:
      libreoffice.x86_641:5.4.6.2-6.fc27
      libreoffice-gtk2.x86_641:5.4.6.2-6.fc27
      libreoffice-help-en.x86_641:5.4.6.2-6.fc27
      apache-commons-logging.noarch1.2-11.fc27
      autocorr-en.noarch1:5.4.6.2-6.fc27
      boost-iostreams.x86_641.64.0-6.fc27
      clucene-contribs-lib.x86_642.3.3.4-29.20130812.e8e3d20git.fc27
      clucene-core.x86_642.3.3.4-29.20130812.e8e3d20git.fc27
      copy-jdk-configs.noarch3.3-9.fc27
      flute.noarch1.3.0-17.OOo31.fc27
      google-crosextra-caladea-fonts.noarch1.002-0.9.20130214.fc27
      google-crosextra-carlito-fonts.noarch1.103-0.7.20130920.fc27
      gstreamer1-plugins-bad-free-gtk.x86_641.12.4-1.fc27
      hyphen-en.noarch2.8.8-8.fc27
      java-1.8.0-openjdk-headless.x86_641:1.8.0.171-4.b10.fc27
      java-openjdk.x86_641:10.0.1.10-3.fc27
      java-openjdk-headless.x86_641:10.0.1.10-3.fc27
      javapackages-tools.noarch5.0.0-7.fc27
      libabw.x86_640.1.2-1.fc27
      libbase.noarch1.1.3-17.fc27
      libcdr.x86_640.1.4-1.fc27
      libcmis.x86_640.5.1-9.fc27
      libe-book.x86_640.1.3-1.fc27
      libeot.x86_640.01-8.fc27
      libexttextcat.x86_643.4.4-7.fc27
      libfonts.noarch1.1.3-20.fc27
      libformula.noarch1.1.3-17.fc27
      libfreehand.x86_640.1.2-1.fc27
      libgltf.x86_640.1.0-7.fc27
      liblayout.noarch0.2.10-14.fc27
      libloader.noarch1.1.3-16.fc27
      libmspub.x86_640.1.4-1.fc27
      libmwaw.x86_640.3.14-1.fc27
      liborcus.x86_640.12.1-7.fc27
      libpagemaker.x86_640.0.4-1.fc27
      libreoffice-base.x86_641:5.4.6.2-6.fc27
      libreoffice-calc.x86_641:5.4.6.2-6.fc27
      libreoffice-core.x86_641:5.4.6.2-6.fc27
      libreoffice-data.noarch1:5.4.6.2-6.fc27
      libreoffice-draw.x86_641:5.4.6.2-6.fc27
      libreoffice-emailmerge.x86_641:5.4.6.2-6.fc27
      libreoffice-graphicfilter.x86_641:5.4.6.2-6.fc27
      libreoffice-gtk3.x86_641:5.4.6.2-6.fc27
      libreoffice-impress.x86_641:5.4.6.2-6.fc27
      libreoffice-langpack-en.x86_641:5.4.6.2-6.fc27
      libreoffice-math.x86_641:5.4.6.2-6.fc27
      libreoffice-opensymbol-fonts.noarch1:5.4.6.2-6.fc27
      libreoffice-pdfimport.x86_641:5.4.6.2-6.fc27
      libreoffice-pyuno.x86_641:5.4.6.2-6.fc27
      libreoffice-ure.x86_641:5.4.6.2-6.fc27
      libreoffice-ure-common.noarch1:5.4.6.2-6.fc27
      libreoffice-writer.x86_641:5.4.6.2-6.fc27
      libreoffice-x11.x86_641:5.4.6.2-6.fc27
      librepository.noarch1.1.3-16.fc27
      libserializer.noarch1.1.2-17.fc27
      libstaroffice.x86_640.0.6-1.fc27
      libzmf.x86_640.0.2-1.fc27
      lksctp-tools.x86_641.0.16-8.fc27
      lpsolve.x86_645.5.2.0-16.fc27
      lua-posix.x86_6433.3.1-7.fc27
      mythes.x86_641.2.4-8.fc27
      mythes-en.noarch3.0-19.fc27
      openCOLLADA.x86_640-29.gitcaad49c.fc27
      pentaho-libxml.noarch1.1.3-16.fc27
      pentaho-reporting-flow-engine.noarch1:0.9.4-14.fc27
      postgresql-jdbc.noarch9.4.1212-4.fc27
      sac.noarch1.3-26.fc27
      ttmkfdir.x86_643.0.9-51.fc27
      tzdata-java.noarch2018d-1.fc27
      xml-commons-apis.noarch1.4.01-23.fc27
      xorg-x11-fonts-Type1.noarch7.5-18.fc27
    
    Complete!
    

  • Installed 71 packages.
    The full list of installed packages (1966 in total vs 1895 in sect.26 / UPD 14.05.18)
               /opt/root/Install/rpm_history/180517.0414.rpm-qa.libroffice_installed
    ( local copy )

  • The installed packages: More... Close
    [root] ~/opt_root_Install/rpm_history $ \
              diff 180514.0116.rpm-qa.After_reg_sw_update \
                   180517.0414.rpm-qa.libroffice_installed \
              | grep ">"
    > apache-commons-logging-1.2-11.fc27.noarch
    > autocorr-en-5.4.6.2-6.fc27.noarch
    > boost-iostreams-1.64.0-6.fc27.x86_64
    > clucene-contribs-lib-2.3.3.4-29.20130812.e8e3d20git.fc27.x86_64
    > clucene-core-2.3.3.4-29.20130812.e8e3d20git.fc27.x86_64
    > copy-jdk-configs-3.3-9.fc27.noarch
    > flute-1.3.0-17.OOo31.fc27.noarch
    > google-crosextra-caladea-fonts-1.002-0.9.20130214.fc27.noarch
    > google-crosextra-carlito-fonts-1.103-0.7.20130920.fc27.noarch
    > gstreamer1-plugins-bad-free-gtk-1.12.4-1.fc27.x86_64
    > hyphen-en-2.8.8-8.fc27.noarch
    > java-1.8.0-openjdk-headless-1.8.0.171-4.b10.fc27.x86_64
    > java-openjdk-10.0.1.10-3.fc27.x86_64
    > java-openjdk-headless-10.0.1.10-3.fc27.x86_64
    > javapackages-tools-5.0.0-7.fc27.noarch
    > libabw-0.1.2-1.fc27.x86_64
    > libbase-1.1.3-17.fc27.noarch
    > libcdr-0.1.4-1.fc27.x86_64
    > libcmis-0.5.1-9.fc27.x86_64
    > libe-book-0.1.3-1.fc27.x86_64
    > libeot-0.01-8.fc27.x86_64
    > libexttextcat-3.4.4-7.fc27.x86_64
    > libfonts-1.1.3-20.fc27.noarch
    > libformula-1.1.3-17.fc27.noarch
    > libfreehand-0.1.2-1.fc27.x86_64
    > libgltf-0.1.0-7.fc27.x86_64
    > liblayout-0.2.10-14.fc27.noarch
    > libloader-1.1.3-16.fc27.noarch
    > libmspub-0.1.4-1.fc27.x86_64
    > libmwaw-0.3.14-1.fc27.x86_64
    > liborcus-0.12.1-7.fc27.x86_64
    > libpagemaker-0.0.4-1.fc27.x86_64
    > libreoffice-5.4.6.2-6.fc27.x86_64
    > libreoffice-base-5.4.6.2-6.fc27.x86_64
    > libreoffice-calc-5.4.6.2-6.fc27.x86_64
    > libreoffice-core-5.4.6.2-6.fc27.x86_64
    > libreoffice-data-5.4.6.2-6.fc27.noarch
    > libreoffice-draw-5.4.6.2-6.fc27.x86_64
    > libreoffice-emailmerge-5.4.6.2-6.fc27.x86_64
    > libreoffice-graphicfilter-5.4.6.2-6.fc27.x86_64
    > libreoffice-gtk2-5.4.6.2-6.fc27.x86_64
    > libreoffice-gtk3-5.4.6.2-6.fc27.x86_64
    > libreoffice-help-en-5.4.6.2-6.fc27.x86_64
    > libreoffice-impress-5.4.6.2-6.fc27.x86_64
    > libreoffice-langpack-en-5.4.6.2-6.fc27.x86_64
    > libreoffice-math-5.4.6.2-6.fc27.x86_64
    > libreoffice-opensymbol-fonts-5.4.6.2-6.fc27.noarch
    > libreoffice-pdfimport-5.4.6.2-6.fc27.x86_64
    > libreoffice-pyuno-5.4.6.2-6.fc27.x86_64
    > libreoffice-ure-5.4.6.2-6.fc27.x86_64
    > libreoffice-ure-common-5.4.6.2-6.fc27.noarch
    > libreoffice-writer-5.4.6.2-6.fc27.x86_64
    > libreoffice-x11-5.4.6.2-6.fc27.x86_64
    > librepository-1.1.3-16.fc27.noarch
    > libserializer-1.1.2-17.fc27.noarch
    > libstaroffice-0.0.6-1.fc27.x86_64
    > libzmf-0.0.2-1.fc27.x86_64
    > lksctp-tools-1.0.16-8.fc27.x86_64
    > lpsolve-5.5.2.0-16.fc27.x86_64
    > lua-posix-33.3.1-7.fc27.x86_64
    > mythes-1.2.4-8.fc27.x86_64
    > mythes-en-3.0-19.fc27.noarch
    > openCOLLADA-0-29.gitcaad49c.fc27.x86_64
    > pentaho-libxml-1.1.3-16.fc27.noarch
    > pentaho-reporting-flow-engine-0.9.4-14.fc27.noarch
    > postgresql-jdbc-9.4.1212-4.fc27.noarch
    > sac-1.3-26.fc27.noarch
    > ttmkfdir-3.0.9-51.fc27.x86_64
    > tzdata-java-2018d-1.fc27.noarch
    > xml-commons-apis-1.4.01-23.fc27.noarch
    > xorg-x11-fonts-Type1-7.5-18.fc27.noarch
    

  • The installed executables: More... Close
    package executable(s)
    apache-commons-logging-1.2-11.fc27.noarch  
    autocorr-en-5.4.6.2-6.fc27.noarch  
    boost-iostreams-1.64.0-6.fc27.x86_64  
    clucene-contribs-lib-2.3.3.4-29.20130812.e8e3d20git.fc27.x86_64  
    clucene-core-2.3.3.4-29.20130812.e8e3d20git.fc27.x86_64  
    copy-jdk-configs-3.3-9.fc27.noarch  
    flute-1.3.0-17.OOo31.fc27.noarch  
    google-crosextra-caladea-fonts-1.002-0.9.20130214.fc27.noarch  
    google-crosextra-carlito-fonts-1.103-0.7.20130920.fc27.noarch  
    gstreamer1-plugins-bad-free-gtk-1.12.4-1.fc27.x86_64  
    hyphen-en-2.8.8-8.fc27.noarch  
    java-1.8.0-openjdk-headless-1.8.0.171-4.b10.fc27.x86_64 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/java
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/jjs
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/keytool
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/orbd
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/pack200
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/rmid
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/rmiregistry
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/servertool
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/tnameserv
    /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc27.x86_64/jre/bin/unpack200
    java-openjdk-10.0.1.10-3.fc27.x86_64  
    java-openjdk-headless-10.0.1.10-3.fc27.x86_64 /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/java
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/jjs
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/keytool
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/orbd
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/pack200
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/rmid
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/rmiregistry
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/servertool
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/tnameserv
    /usr/lib/jvm/java-10-openjdk-10.0.1.10-3.fc27.x86_64/bin/unpack200
    javapackages-tools-5.0.0-7.fc27.noarch /usr/bin/build-classpath
    /usr/bin/build-classpath-directory
    /usr/bin/build-jar-repository
    /usr/bin/check-binary-files
    /usr/bin/clean-binary-files
    /usr/bin/create-jar-links
    /usr/bin/diff-jars
    /usr/bin/find-jar
    /usr/bin/rebuild-jar-repository
    /usr/bin/shade-jar
    libabw-0.1.2-1.fc27.x86_64  
    libbase-1.1.3-17.fc27.noarch  
    libcdr-0.1.4-1.fc27.x86_64  
    libcmis-0.5.1-9.fc27.x86_64  
    libe-book-0.1.3-1.fc27.x86_64  
    libeot-0.01-8.fc27.x86_64  
    libexttextcat-3.4.4-7.fc27.x86_64  
    libfonts-1.1.3-20.fc27.noarch  
    libformula-1.1.3-17.fc27.noarch  
    libfreehand-0.1.2-1.fc27.x86_64  
    libgltf-0.1.0-7.fc27.x86_64  
    liblayout-0.2.10-14.fc27.noarch  
    libloader-1.1.3-16.fc27.noarch  
    libmspub-0.1.4-1.fc27.x86_64  
    libmwaw-0.3.14-1.fc27.x86_64  
    liborcus-0.12.1-7.fc27.x86_64  
    libpagemaker-0.0.4-1.fc27.x86_64  
    libreoffice-5.4.6.2-6.fc27.x86_64  
    libreoffice-base-5.4.6.2-6.fc27.x86_64 /usr/bin/oobase
    libreoffice-calc-5.4.6.2-6.fc27.x86_64 /usr/bin/oocalc
    libreoffice-core-5.4.6.2-6.fc27.x86_64 /usr/bin/libreoffice
    /usr/bin/ooffice
    /usr/bin/ooviewdoc
    /usr/bin/openoffice.org
    /usr/bin/soffice
    /usr/bin/unopkg
    libreoffice-data-5.4.6.2-6.fc27.noarch  
    libreoffice-draw-5.4.6.2-6.fc27.x86_64 /usr/bin/oodraw
    libreoffice-emailmerge-5.4.6.2-6.fc27.x86_64  
    libreoffice-graphicfilter-5.4.6.2-6.fc27.x86_64  
    libreoffice-gtk2-5.4.6.2-6.fc27.x86_64  
    libreoffice-gtk3-5.4.6.2-6.fc27.x86_64  
    libreoffice-help-en-5.4.6.2-6.fc27.x86_64  
    libreoffice-impress-5.4.6.2-6.fc27.x86_64 /usr/bin/ooimpress
    libreoffice-langpack-en-5.4.6.2-6.fc27.x86_64  
    libreoffice-math-5.4.6.2-6.fc27.x86_64 /usr/bin/oomath
    libreoffice-opensymbol-fonts-5.4.6.2-6.fc27.noarch  
    libreoffice-pdfimport-5.4.6.2-6.fc27.x86_64  
    libreoffice-pyuno-5.4.6.2-6.fc27.x86_64  
    libreoffice-ure-5.4.6.2-6.fc27.x86_64  
    libreoffice-ure-common-5.4.6.2-6.fc27.noarch  
    libreoffice-writer-5.4.6.2-6.fc27.x86_64 /usr/bin/oowriter
    libreoffice-x11-5.4.6.2-6.fc27.x86_64  
    librepository-1.1.3-16.fc27.noarch  
    libserializer-1.1.2-17.fc27.noarch  
    libstaroffice-0.0.6-1.fc27.x86_64  
    libzmf-0.0.2-1.fc27.x86_64  
    lksctp-tools-1.0.16-8.fc27.x86_64 /usr/bin/checksctp
    /usr/bin/sctp_darn
    /usr/bin/sctp_status
    /usr/bin/sctp_test
    /usr/bin/withsctp
    lpsolve-5.5.2.0-16.fc27.x86_64 /usr/bin/lp_solve
    lua-posix-33.3.1-7.fc27.x86_64  
    mythes-1.2.4-8.fc27.x86_64  
    mythes-en-3.0-19.fc27.noarch  
    openCOLLADA-0-29.gitcaad49c.fc27.x86_64  
    pentaho-libxml-1.1.3-16.fc27.noarch  
    pentaho-reporting-flow-engine-0.9.4-14.fc27.noarch  
    postgresql-jdbc-9.4.1212-4.fc27.noarch  
    sac-1.3-26.fc27.noarch  
    ttmkfdir-3.0.9-51.fc27.x86_64 /usr/bin/ttmkfdir
    tzdata-java-2018d-1.fc27.noarch  
    xml-commons-apis-1.4.01-23.fc27.noarch  
    xorg-x11-fonts-Type1-7.5-18.fc27.noarch  

  • The most important executables seem to be (all in /usr/bin):
    libreoffice
    ooffice
    soffice
    openoffice.org
    ooviewdoc
    oobase
    oocalc
    oodraw
    ooimpress
    oomath
    oowriter
    unopkg

  41. (18.05.18) TEX-related stuff: texlive, texlive-context, texlive-python-doc, latex2html, a2ps (plus ImageMagick by product)

  • The command:
    [root] ... $ dnf -y install texlive texlive-context \
                                texlive-python-doc \
                                latex2html a2ps
    
    stdout: More... Close
    RPM Fusion for Fedora 27 - Free - Updates       238 kB/s | 370 kB     00:01    
    Last metadata expiration check: 0:00:00 ago on Fri 18 May 2018 01:38:04 AM MSK.
    Dependencies resolved.
    ================================================================================
     Package                  Arch   Version                          Repository
                                                                               Size
    ================================================================================
    Installing:
     a2ps                     x86_64 4.14-32.fc27                     fedora  1.1 M
     latex2html               noarch 2017.2-3.fc27                    fedora  834 k
     texlive                  x86_64 6:2016-36.20160520.fc27.5        fedora   34 k
     texlive-context          noarch 6:svn41282-36.fc27.5             fedora  8.6 M
     texlive-python-doc       noarch 6:svn27064.0.21-36.fc27.5        fedora   34 k
    Installing dependencies:
     ImageMagick              x86_64 1:6.9.9.38-1.fc27                updates 186 k
     ImageMagick-perl         x86_64 1:6.9.9.38-1.fc27                updates 169 k
     groff-perl               x86_64 1.22.3-14.fc27                   updates 243 k
     html2ps                  noarch 1.0-0.27.b7.fc27                 fedora   95 k
     libpaper                 x86_64 1.1.24-21.fc27                   updates  43 k
     netpbm                   x86_64 10.81.00-1.fc27                  updates 202 k
     netpbm-progs             x86_64 10.81.00-1.fc27                  updates 2.0 M
     perl-Class-Inspector     noarch 1.32-1.fc27                      fedora   35 k
     perl-Compress-Raw-Bzip2  x86_64 2.074-396.fc27                   fedora   38 k
     perl-Compress-Raw-Zlib   x86_64 2.076-1.fc27                     updates  66 k
     perl-Data-Dump           noarch 1.23-6.fc27                      fedora   35 k
     perl-Digest              noarch 1.17-394.fc27                    fedora   25 k
     perl-Digest-HMAC         noarch 1.03-16.fc27                     fedora   19 k
     perl-Digest-MD5          x86_64 2.55-395.fc27                    fedora   35 k
     perl-Digest-SHA          x86_64 1:6.02-1.fc27                    updates  65 k
     perl-Encode-Locale       noarch 1.05-8.fc27                      fedora   20 k
     perl-File-HomeDir        noarch 1.002-3.fc27                     fedora   60 k
     perl-File-Listing        noarch 6.04-16.fc27                     fedora   17 k
     perl-File-Which          noarch 1.21-5.fc27                      fedora   22 k
     perl-Filter              x86_64 2:1.58-1.fc27                    updates  80 k
     perl-HTML-Parser         x86_64 3.72-9.fc27                      fedora  116 k
     perl-HTML-Tagset         noarch 3.20-31.fc27                     fedora   22 k
     perl-HTTP-Cookies        noarch 6.04-1.fc27                      fedora   38 k
     perl-HTTP-Date           noarch 6.02-17.fc27                     fedora   17 k
     perl-HTTP-Message        noarch 6.16-1.fc27                      updates  96 k
     perl-HTTP-Negotiate      noarch 6.01-18.fc27                     fedora   21 k
     perl-IO-Compress         noarch 2.074-395.fc27                   fedora  256 k
     perl-IO-HTML             noarch 1.001-9.fc27                     fedora   26 k
     perl-LWP-MediaTypes      noarch 6.02-13.fc27                     fedora   27 k
     perl-NTLM                noarch 1.09-16.fc27                     fedora   23 k
     perl-Net-HTTP            noarch 6.17-1.fc27                      fedora   42 k
     perl-SelfLoader          noarch 1.23-404.fc27                    updates  79 k
     perl-Text-Unidecode      noarch 1.30-4.fc27                      fedora  147 k
     perl-TimeDate            noarch 1:2.30-12.fc27                   fedora   51 k
     perl-Tk                  x86_64 804.034-1.fc27                   fedora  2.1 M
     perl-Try-Tiny            noarch 0.28-4.fc27                      fedora   42 k
     perl-Unicode-EastAsianWidth
                              noarch 1.33-11.fc27                     fedora   14 k
     perl-WWW-RobotRules      noarch 6.02-17.fc27                     fedora   21 k
     perl-XML-Parser          x86_64 2.44-9.fc27                      fedora  224 k
     perl-XML-XPath           noarch 1.42-1.fc27                      fedora   86 k
     perl-encoding            x86_64 4:2.19-16.fc27                   updates  66 k
     perl-libintl-perl        x86_64 1.27-1.fc27                      fedora  835 k
     perl-libwww-perl         noarch 6.33-1.fc27                      updates 211 k
     perl-open                noarch 1.11-404.fc27                    updates  74 k
     psutils                  x86_64 1.23-12.fc27                     fedora   61 k
     psutils-perl             noarch 1.23-12.fc27                     fedora   19 k
     ruby                     x86_64 2.4.3-87.fc27                    updates  80 k
     ruby-irb                 noarch 2.4.3-87.fc27                    updates  97 k
     ruby-libs                x86_64 2.4.3-87.fc27                    updates 2.8 M
     rubygem-json             x86_64 2.1.0-102.fc27                   fedora   58 k
     rubygem-psych            x86_64 2.2.2-87.fc27                    updates  90 k
     rubypick                 noarch 1.1.1-7.fc27                     fedora   10 k
     teckit                   x86_64 2.5.1-18.fc27                    fedora  283 k
     texinfo                  x86_64 6.4-6.fc27                       updates 1.2 M
     texinfo-tex              x86_64 6.4-6.fc27                       updates 158 k
     texlive-ae               noarch 6:svn15878.1.4-36.fc27.5         fedora  112 k
     texlive-algorithms       noarch 6:svn38085.0.1-36.fc27.5         fedora   37 k
     texlive-amscls           noarch 6:svn36804.0-36.fc27.5           fedora   69 k
     texlive-amsfonts         noarch 6:svn29208.3.04-36.fc27.5        fedora  3.6 M
     texlive-amsmath          noarch 6:svn41561-36.fc27.5             fedora   66 k
     texlive-anysize          noarch 6:svn15878.0-36.fc27.5           fedora   34 k
     texlive-attachfile       noarch 6:svn38830-36.fc27.5             fedora   38 k
     texlive-auto-pst-pdf     noarch 6:svn23723.0.6-36.fc27.5         fedora   36 k
     texlive-avantgar         noarch 6:svn31835.0-36.fc27.5           fedora  310 k
     texlive-babel            noarch 6:svn40706-36.fc27.5             fedora   68 k
     texlive-babel-english    noarch 6:svn30264.3.3p-36.fc27.5        fedora   36 k
     texlive-babelbib         noarch 6:svn25245.1.31-36.fc27.5        fedora   66 k
     texlive-base             noarch 6:2016-36.20160520.fc27.5        fedora  1.4 M
     texlive-beamer           noarch 6:svn36461.3.36-36.fc27.5        fedora  266 k
     texlive-bera             noarch 6:svn20031.0-36.fc27.5           fedora  364 k
     texlive-beton            noarch 6:svn15878.0-36.fc27.5           fedora   35 k
     texlive-bibtex           noarch 6:svn40768-36.fc27.5             fedora   49 k
     texlive-bibtex-bin       x86_64 6:svn40473-36.20160520.fc27.5    fedora   86 k
     texlive-bookman          noarch 6:svn31835.0-36.fc27.5           fedora  351 k
     texlive-booktabs         noarch 6:svn40846-36.fc27.5             fedora   35 k
     texlive-breakurl         noarch 6:svn29901.1.40-36.fc27.5        fedora   36 k
     texlive-breqn            noarch 6:svn38099.0.98d-36.fc27.5       fedora   60 k
     texlive-caption          noarch 6:svn41409-36.fc27.5             fedora   70 k
     texlive-carlisle         noarch 6:svn18258.0-36.fc27.5           fedora   46 k
     texlive-charter          noarch 6:svn15878.0-36.fc27.5           fedora  218 k
     texlive-chngcntr         noarch 6:svn17157.1.0a-36.fc27.5        fedora   35 k
     texlive-cite             noarch 6:svn36428.5.5-36.fc27.5         fedora   54 k
     texlive-cm               noarch 6:svn32865.0-36.fc27.5           fedora  308 k
     texlive-cm-super         noarch 6:svn15878.0-36.fc27.5           fedora   62 M
     texlive-cmap             noarch 6:svn41168-36.fc27.5             fedora   40 k
     texlive-cmextra          noarch 6:svn32831.0-36.fc27.5           fedora   62 k
     texlive-collection-basic noarch 6:svn41149-36.20160520.fc27.5    fedora   33 k
     texlive-collection-fontsrecommended
                              noarch 6:svn35830.0-36.20160520.fc27.5  fedora   33 k
     texlive-collection-latex noarch 6:svn41011-36.20160520.fc27.5    fedora   33 k
     texlive-collection-latexrecommended
                              noarch 6:svn35765.0-36.20160520.fc27.5  fedora   33 k
     texlive-colortbl         noarch 6:svn29803.v1.0a-36.fc27.5       fedora   36 k
     texlive-context-bin      noarch 6:svn34112.0-36.20160520.fc27.5  fedora   34 k
     texlive-courier          noarch 6:svn35058.0-36.fc27.5           fedora  529 k
     texlive-crop             noarch 6:svn15878.1.5-36.fc27.5         fedora   38 k
     texlive-csquotes         noarch 6:svn39538-36.fc27.5             fedora   52 k
     texlive-ctable           noarch 6:svn38672-36.fc27.5             fedora   37 k
     texlive-currfile         noarch 6:svn40725-36.fc27.5             fedora   37 k
     texlive-dvipdfmx         noarch 6:svn41149-36.fc27.5             fedora   98 k
     texlive-dvipdfmx-bin     x86_64 6:svn40273-36.20160520.fc27.5    fedora   35 k
     texlive-dvipdfmx-def     noarch 6:svn40328-36.fc27.5             fedora   37 k
     texlive-dvips            noarch 6:svn41149-36.fc27.5             fedora  1.1 M
     texlive-dvips-bin        x86_64 6:svn40987-36.20160520.fc27.5    fedora  155 k
     texlive-dvisvgm-def      noarch 6:svn41011-36.fc27.5             fedora   35 k
     texlive-ec               noarch 6:svn25033.1.0-36.fc27.5         fedora  493 k
     texlive-enctex           noarch 6:svn34957.0-36.fc27.5           fedora   64 k
     texlive-enumitem         noarch 6:svn24146.3.5.2-36.fc27.5       fedora   45 k
     texlive-environ          noarch 6:svn33821.0.3-36.fc27.5         fedora   35 k
     texlive-epsf             noarch 6:svn21461.2.7.4-36.fc27.5       fedora   41 k
     texlive-eso-pic          noarch 6:svn37925.2.0g-36.fc27.5        fedora   37 k
     texlive-etex             noarch 6:svn37057.0-36.fc27.5           fedora   50 k
     texlive-etex-pkg         noarch 6:svn39355-36.fc27.5             fedora   38 k
     texlive-etoolbox         noarch 6:svn38031.2.2a-36.fc27.5        fedora   42 k
     texlive-euenc            noarch 6:svn19795.0.1h-36.fc27.5        fedora   38 k
     texlive-euler            noarch 6:svn17261.2.5-36.fc27.5         fedora   36 k
     texlive-euro             noarch 6:svn22191.1.1-36.fc27.5         fedora   36 k
     texlive-eurosym          noarch 6:svn17265.1.4_subrfix-36.fc27.5 fedora  174 k
     texlive-extsizes         noarch 6:svn17263.1.4a-36.fc27.5        fedora   47 k
     texlive-fancybox         noarch 6:svn18304.1.4-36.fc27.5         fedora   41 k
     texlive-fancyhdr         noarch 6:svn15878.3.1-36.fc27.5         fedora   42 k
     texlive-fancyref         noarch 6:svn15878.0.9c-36.fc27.5        fedora   36 k
     texlive-fancyvrb         noarch 6:svn18492.2.8-36.fc27.5         fedora   46 k
     texlive-filecontents     noarch 6:svn24250.1.3-36.fc27.5         fedora   35 k
     texlive-filehook         noarch 6:svn24280.0.5d-36.fc27.5        fedora   38 k
     texlive-finstrut         noarch 6:svn21719.0.5-36.fc27.5         fedora   36 k
     texlive-fix2col          noarch 6:svn38770-36.fc27.5             fedora   36 k
     texlive-float            noarch 6:svn15878.1.3d-36.fc27.5        fedora   36 k
     texlive-fontspec         noarch 6:svn41262-36.fc27.5             fedora   60 k
     texlive-footmisc         noarch 6:svn23330.5.5b-36.fc27.5        fedora   39 k
     texlive-fp               noarch 6:svn15878.0-36.fc27.5           fedora   56 k
     texlive-fpl              noarch 6:svn15878.1.002-36.fc27.5       fedora  392 k
     texlive-geometry         noarch 6:svn19716.5.6-36.fc27.5         fedora   42 k
     texlive-glyphlist        noarch 6:svn28576.0-36.fc27.5           fedora   59 k
     texlive-graphics         noarch 6:svn41015-36.fc27.5             fedora   50 k
     texlive-graphics-cfg     noarch 6:svn40269-36.fc27.5             fedora   35 k
     texlive-graphics-def     noarch 6:svn41879-36.fc27.5             fedora   59 k
     texlive-gsftopk          noarch 6:svn40768-36.fc27.5             fedora   40 k
     texlive-gsftopk-bin      x86_64 6:svn40473-36.20160520.fc27.5    fedora   48 k
     texlive-helvetic         noarch 6:svn31835.0-36.fc27.5           fedora  635 k
     texlive-hyperref         noarch 6:svn41396-36.fc27.5             fedora  156 k
     texlive-hyph-utf8        noarch 6:svn41189-36.fc27.5             fedora   51 k
     texlive-hyphen-base      noarch 6:svn41138-36.fc27.5             fedora   56 k
     texlive-ifetex           noarch 6:svn24853.1.2-36.fc27.5         fedora   35 k
     texlive-ifluatex         noarch 6:svn41346-36.fc27.5             fedora   35 k
     texlive-ifplatform       noarch 6:svn21156.0.4-36.fc27.5         fedora   35 k
     texlive-iftex            noarch 6:svn29654.0.2-36.fc27.5         fedora   34 k
     texlive-ifxetex          noarch 6:svn19685.0.5-36.fc27.5         fedora   34 k
     texlive-index            noarch 6:svn24099.4.1beta-36.fc27.5     fedora   45 k
     texlive-jknapltx         noarch 6:svn19440.0-36.fc27.5           fedora   45 k
     texlive-kastrup          noarch 6:svn15878.0-36.fc27.5           fedora   34 k
     texlive-knuth-lib        noarch 6:svn35820.0-36.fc27.5           fedora   68 k
     texlive-knuth-local      noarch 6:svn38627-36.fc27.5             fedora   61 k
     texlive-koma-script      noarch 6:svn41508-36.fc27.5             fedora  6.5 M
     texlive-kpathsea         noarch 6:svn41139-36.fc27.5             fedora  160 k
     texlive-kpathsea-bin     x86_64 6:svn40473-36.20160520.fc27.5    fedora   59 k
     texlive-kpathsea-doc     noarch 6:svn41139-36.fc27.5             fedora  944 k
     texlive-l3experimental   noarch 6:svn41163-36.fc27.5             fedora   80 k
     texlive-l3kernel         noarch 6:svn41246-36.fc27.5             fedora  149 k
     texlive-l3packages       noarch 6:svn41246-36.fc27.5             fedora   53 k
     texlive-latex            noarch 6:svn40218-36.fc27.5             fedora  233 k
     texlive-latex-bin        noarch 6:svn41438-36.fc27.5             fedora   36 k
     texlive-latex-bin-bin    noarch 6:svn14050.0-36.20160520.fc27.5  fedora   33 k
     texlive-latex-fonts      noarch 6:svn28888.0-36.fc27.5           fedora   59 k
     texlive-latexconfig      noarch 6:svn40274-36.fc27.5             fedora   39 k
     texlive-lib              x86_64 6:2016-36.20160520.fc27.5        fedora  456 k
     texlive-lineno           noarch 6:svn21442.4.41-36.fc27.5        fedora   99 k
     texlive-listings         noarch 6:svn37534.1.6-36.fc27.5         fedora  161 k
     texlive-lm               noarch 6:svn28119.2.004-36.fc27.5       fedora   13 M
     texlive-lm-math          noarch 6:svn36915.1.959-36.fc27.5       fedora  442 k
     texlive-ltabptch         noarch 6:svn17533.1.74d-36.fc27.5       fedora   38 k
     texlive-ltxmisc          noarch 6:svn21927.0-36.fc27.5           fedora   50 k
     texlive-lua-alt-getopt   noarch 6:svn29349.0.7.0-36.fc27.5       fedora   35 k
     texlive-lualatex-math    noarch 6:svn40621-36.fc27.5             fedora   36 k
     texlive-lualibs          noarch 6:svn40370-36.fc27.5             fedora  152 k
     texlive-luaotfload       noarch 6:svn40902-36.fc27.5             fedora  531 k
     texlive-luaotfload-bin   noarch 6:svn34647.0-36.20160520.fc27.5  fedora   33 k
     texlive-luatex           noarch 6:svn40963-36.fc27.5             fedora   54 k
     texlive-luatex-bin       x86_64 6:svn41091-36.20160520.fc27.5    fedora  3.3 M
     texlive-luatexbase       noarch 6:svn38550-36.fc27.5             fedora   38 k
     texlive-makeindex        noarch 6:svn40768-36.fc27.5             fedora   66 k
     texlive-makeindex-bin    x86_64 6:svn40473-36.20160520.fc27.5    fedora   57 k
     texlive-manfnt-font      noarch 6:svn35799.0-36.fc27.5           fedora   59 k
     texlive-marginnote       noarch 6:svn41382-36.fc27.5             fedora   36 k
     texlive-marvosym         noarch 6:svn29349.2.2a-36.fc27.5        fedora  167 k
     texlive-mathpazo         noarch 6:svn15878.1.003-36.fc27.5       fedora  101 k
     texlive-mathtools        noarch 6:svn38833-36.fc27.5             fedora   53 k
     texlive-mdwtools         noarch 6:svn15878.1.05.4-36.fc27.5      fedora   55 k
     texlive-memoir           noarch 6:svn41203-36.fc27.5             fedora  116 k
     texlive-metafont         noarch 6:svn40793-36.fc27.5             fedora  135 k
     texlive-metafont-bin     x86_64 6:svn40987-36.20160520.fc27.5    fedora  223 k
     texlive-metalogo         noarch 6:svn18611.0.12-36.fc27.5        fedora   35 k
     texlive-metapost         noarch 6:svn40768-36.fc27.5             fedora  762 k
     texlive-metapost-bin     x86_64 6:svn40473-36.20160520.fc27.5    fedora  336 k
     texlive-mflogo           noarch 6:svn38628-36.fc27.5             fedora   35 k
     texlive-mflogo-font      noarch 6:svn36898.1.002-36.fc27.5       fedora   53 k
     texlive-mfnfss           noarch 6:svn19410.0-36.fc27.5           fedora   36 k
     texlive-mfware           noarch 6:svn40768-36.fc27.5             fedora   46 k
     texlive-mfware-bin       x86_64 6:svn40473-36.20160520.fc27.5    fedora  110 k
     texlive-microtype        noarch 6:svn41127-36.fc27.5             fedora   86 k
     texlive-mparhack         noarch 6:svn15878.1.4-36.fc27.5         fedora   36 k
     texlive-mptopdf          noarch 6:svn41282-36.fc27.5             fedora   74 k
     texlive-mptopdf-bin      noarch 6:svn18674.0-36.20160520.fc27.5  fedora   33 k
     texlive-ms               noarch 6:svn29849.0-36.fc27.5           fedora   40 k
     texlive-multido          noarch 6:svn18302.1.42-36.fc27.5        fedora   37 k
     texlive-natbib           noarch 6:svn20668.8.31b-36.fc27.5       fedora   51 k
     texlive-ncntrsbk         noarch 6:svn31835.0-36.fc27.5           fedora  357 k
     texlive-ntgclass         noarch 6:svn15878.2.1a-36.fc27.5        fedora   52 k
     texlive-oberdiek         noarch 6:svn41346-36.fc27.5             fedora  327 k
     texlive-palatino         noarch 6:svn31835.0-36.fc27.5           fedora  404 k
     texlive-paralist         noarch 6:svn39247-36.fc27.5             fedora   37 k
     texlive-parallel         noarch 6:svn15878.0-36.fc27.5           fedora   37 k
     texlive-parskip          noarch 6:svn19963.2.0-36.fc27.5         fedora   35 k
     texlive-pdfpages         noarch 6:svn40638-36.fc27.5             fedora   49 k
     texlive-pdftex           noarch 6:svn41149-36.fc27.5             fedora   74 k
     texlive-pdftex-bin       x86_64 6:svn40987-36.20160520.fc27.5    fedora  396 k
     texlive-pdftex-def       noarch 6:svn22653.0.06d-36.fc27.5       fedora   47 k
     texlive-pdftex-doc       noarch 6:svn41149-36.fc27.5             fedora  1.5 M
     texlive-pgf              noarch 6:svn40966-36.fc27.5             fedora  824 k
     texlive-plain            noarch 6:svn40274-36.fc27.5             fedora  495 k
     texlive-powerdot         noarch 6:svn38984-36.fc27.5             fedora   64 k
     texlive-psfrag           noarch 6:svn15878.3.04-36.fc27.5        fedora   38 k
     texlive-pslatex          noarch 6:svn16416.0-36.fc27.5           fedora   41 k
     texlive-psnfss           noarch 6:svn33946.9.2a-36.fc27.5        fedora   61 k
     texlive-pspicture        noarch 6:svn15878.0-36.fc27.5           fedora   35 k
     texlive-pst-3d           noarch 6:svn17257.1.10-36.fc27.5        fedora   37 k
     texlive-pst-blur         noarch 6:svn15878.2.0-36.fc27.5         fedora   36 k
     texlive-pst-coil         noarch 6:svn37377.1.07-36.fc27.5        fedora   38 k
     texlive-pst-eps          noarch 6:svn15878.1.0-36.fc27.5         fedora   36 k
     texlive-pst-fill         noarch 6:svn15878.1.01-36.fc27.5        fedora   37 k
     texlive-pst-grad         noarch 6:svn15878.1.06-36.fc27.5        fedora   37 k
     texlive-pst-math         noarch 6:svn34786.0.63-36.fc27.5        fedora   38 k
     texlive-pst-node         noarch 6:svn40743-36.fc27.5             fedora   60 k
     texlive-pst-ovl          noarch 6:svn40873-36.fc27.5             fedora   35 k
     texlive-pst-pdf          noarch 6:svn31660.1.1v-36.fc27.5        fedora   41 k
     texlive-pst-pdf-bin      noarch 6:svn7838.0-36.20160520.fc27.5   fedora   33 k
     texlive-pst-plot         noarch 6:svn41242-36.fc27.5             fedora   57 k
     texlive-pst-slpe         noarch 6:svn24391.1.31-36.fc27.5        fedora   37 k
     texlive-pst-text         noarch 6:svn15878.1.00-36.fc27.5        fedora   37 k
     texlive-pst-tools        noarch 6:svn34067.0.05-36.fc27.5        fedora   38 k
     texlive-pst-tree         noarch 6:svn24142.1.12-36.fc27.5        fedora   40 k
     texlive-pstricks         noarch 6:svn41321-36.fc27.5             fedora  117 k
     texlive-pstricks-add     noarch 6:svn40744-36.fc27.5             fedora   58 k
     texlive-pxfonts          noarch 6:svn15878.0-36.fc27.5           fedora  515 k
     texlive-qstest           noarch 6:svn15878.0-36.fc27.5           fedora   38 k
     texlive-rcs              noarch 6:svn15878.0-36.fc27.5           fedora   46 k
     texlive-rotating         noarch 6:svn16832.2.16b-36.fc27.5       fedora   36 k
     texlive-rsfs             noarch 6:svn15878.0-36.fc27.5           fedora   92 k
     texlive-sansmath         noarch 6:svn17997.1.1-36.fc27.5         fedora   36 k
     texlive-sansmathaccent   noarch 6:svn30187.0-36.fc27.5           fedora   47 k
     texlive-sauerj           noarch 6:svn15878.0-36.fc27.5           fedora   39 k
     texlive-scheme-basic     noarch 6:svn25923.0-36.20160520.fc27.5  fedora   33 k
     texlive-section          noarch 6:svn20180.0-36.fc27.5           fedora   43 k
     texlive-seminar          noarch 6:svn34011.1.62-36.fc27.5        fedora   67 k
     texlive-sepnum           noarch 6:svn20186.2.0-36.fc27.5         fedora   36 k
     texlive-setspace         noarch 6:svn24881.6.7a-36.fc27.5        fedora   40 k
     texlive-showexpl         noarch 6:svn32737.v0.3l-36.fc27.5       fedora   37 k
     texlive-soul             noarch 6:svn15878.2.4-36.fc27.5         fedora   39 k
     texlive-stmaryrd         noarch 6:svn22027.0-36.fc27.5           fedora  204 k
     texlive-subfig           noarch 6:svn15878.1.3-36.fc27.5         fedora   41 k
     texlive-symbol           noarch 6:svn31835.0-36.fc27.5           fedora   72 k
     texlive-tetex            noarch 6:svn41059-36.fc27.5             fedora  119 k
     texlive-tetex-bin        noarch 6:svn36770.0-36.20160520.fc27.5  fedora   35 k
     texlive-tex              noarch 6:svn40793-36.fc27.5             fedora   40 k
     texlive-tex-bin          x86_64 6:svn40987-36.20160520.fc27.5    fedora  197 k
     texlive-tex-gyre         noarch 6:svn18651.2.004-36.fc27.5       fedora  7.0 M
     texlive-tex-gyre-math    noarch 6:svn41264-36.fc27.5             fedora  1.4 M
     texlive-tex-ini-files    noarch 6:svn40533-36.fc27.5             fedora   37 k
     texlive-texconfig        noarch 6:svn40768-36.fc27.5             fedora   49 k
     texlive-texconfig-bin    noarch 6:svn29741.0-36.20160520.fc27.5  fedora   33 k
     texlive-texlive-common-doc
                              noarch 6:svn40682-36.fc27.5             fedora  232 k
     texlive-texlive-docindex noarch 6:svn41430-36.fc27.5             fedora  166 k
     texlive-texlive-en       noarch 6:svn41185-36.fc27.5             fedora   90 k
     texlive-texlive-msg-translations
                              noarch 6:svn41431-36.fc27.5             fedora  158 k
     texlive-texlive-scripts  noarch 6:svn41433-36.fc27.5             fedora   50 k
     texlive-texlive-scripts-bin
                              noarch 6:svn29741.0-36.20160520.fc27.5  fedora   33 k
     texlive-texlive.infra    noarch 6:svn41280-36.fc27.5             fedora  166 k
     texlive-texlive.infra-bin
                              x86_64 6:svn40312-36.20160520.fc27.5    fedora   33 k
     texlive-textcase         noarch 6:svn15878.0-36.fc27.5           fedora   35 k
     texlive-thumbpdf         noarch 6:svn34621.3.16-36.fc27.5        fedora   54 k
     texlive-thumbpdf-bin     noarch 6:svn6898.0-36.20160520.fc27.5   fedora   33 k
     texlive-times            noarch 6:svn35058.0-36.fc27.5           fedora  358 k
     texlive-tipa             noarch 6:svn29349.1.3-36.fc27.5         fedora  2.8 M
     texlive-tools            noarch 6:svn40934-36.fc27.5             fedora   80 k
     texlive-trimspaces       noarch 6:svn15878.1.1-36.fc27.5         fedora   34 k
     texlive-txfonts          noarch 6:svn15878.0-36.fc27.5           fedora  787 k
     texlive-type1cm          noarch 6:svn21820.0-36.fc27.5           fedora   35 k
     texlive-typehtml         noarch 6:svn17134.0-36.fc27.5           fedora   40 k
     texlive-ucharcat         noarch 6:svn38907-36.fc27.5             fedora   34 k
     texlive-ucs              noarch 6:svn35853.2.2-36.fc27.5         fedora  378 k
     texlive-underscore       noarch 6:svn18261.0-36.fc27.5           fedora   38 k
     texlive-unicode-data     noarch 6:svn39808-36.fc27.5             fedora  285 k
     texlive-unicode-math     noarch 6:svn38462-36.fc27.5             fedora   78 k
     texlive-updmap-map       noarch 6:svn41159-36.fc27.5             fedora  200 k
     texlive-url              noarch 6:svn32528.3.4-36.fc27.5         fedora   39 k
     texlive-utopia           noarch 6:svn15878.0-36.fc27.5           fedora  250 k
     texlive-varwidth         noarch 6:svn24104.0.92-36.fc27.5        fedora   37 k
     texlive-wasy             noarch 6:svn35831.0-36.fc27.5           fedora   58 k
     texlive-wasy2-ps         noarch 6:svn35830.0-36.fc27.5           fedora  248 k
     texlive-wasysym          noarch 6:svn15878.2.0-36.fc27.5         fedora   37 k
     texlive-xcolor           noarch 6:svn41044-36.fc27.5             fedora   52 k
     texlive-xdvi             noarch 6:svn40768-36.fc27.5             fedora   77 k
     texlive-xdvi-bin         x86_64 6:svn40750-36.20160520.fc27.5    fedora  324 k
     texlive-xetex            noarch 6:svn41438-36.fc27.5             fedora  383 k
     texlive-xetex-bin        x86_64 6:svn41091-36.20160520.fc27.5    fedora  629 k
     texlive-xetex-def        noarch 6:svn40327-36.fc27.5             fedora   40 k
     texlive-xetexconfig      noarch 6:svn41133-36.fc27.5             fedora   33 k
     texlive-xkeyval          noarch 6:svn35741.2.7a-36.fc27.5        fedora   50 k
     texlive-xunicode         noarch 6:svn30466.0.981-36.fc27.5       fedora   60 k
     texlive-zapfchan         noarch 6:svn31835.0-36.fc27.5           fedora  120 k
     texlive-zapfding         noarch 6:svn31835.0-36.fc27.5           fedora   82 k
     zziplib                  x86_64 0.13.68-1.fc27                   updates  88 k
    Installing weak dependencies:
     perl-File-ShareDir       noarch 1.104-2.fc27                     fedora   28 k
     rubygem-bigdecimal       x86_64 1.3.0-87.fc27                    updates  91 k
     rubygem-did_you_mean     x86_64 1.1.0-87.fc27                    updates  83 k
     rubygem-io-console       x86_64 0.4.6-87.fc27                    updates  61 k
     rubygem-openssl          x86_64 2.0.5-87.fc27                    updates 181 k
     rubygem-rdoc             noarch 5.1.0-3.fc27                     updates 448 k
     rubygems                 noarch 2.6.14.1-87.fc27                 updates 294 k
    
    Transaction Summary
    ================================================================================
    Install  322 Packages
    
    Total download size: 155 M
    Installed size: 368 M
    
    ...
    
    Installed:
      a2ps.x86_64 4.14-32.fc27                                                      
      latex2html.noarch 2017.2-3.fc27                                               
      texlive.x86_64 6:2016-36.20160520.fc27.5                                      
      texlive-context.noarch 6:svn41282-36.fc27.5                                   
      texlive-python-doc.noarch 6:svn27064.0.21-36.fc27.5                           
      perl-File-ShareDir.noarch 1.104-2.fc27                                        
      rubygem-bigdecimal.x86_64 1.3.0-87.fc27                                       
      rubygem-did_you_mean.x86_64 1.1.0-87.fc27                                     
      rubygem-io-console.x86_64 0.4.6-87.fc27                                       
      rubygem-openssl.x86_64 2.0.5-87.fc27                                          
      rubygem-rdoc.noarch 5.1.0-3.fc27                                              
      rubygems.noarch 2.6.14.1-87.fc27                                              
      ImageMagick.x86_64 1:6.9.9.38-1.fc27                                          
      ImageMagick-perl.x86_64 1:6.9.9.38-1.fc27                                     
      groff-perl.x86_64 1.22.3-14.fc27                                              
      html2ps.noarch 1.0-0.27.b7.fc27                                               
      libpaper.x86_64 1.1.24-21.fc27                                                
      netpbm.x86_64 10.81.00-1.fc27                                                 
      netpbm-progs.x86_64 10.81.00-1.fc27                                           
      perl-Class-Inspector.noarch 1.32-1.fc27                                       
      perl-Compress-Raw-Bzip2.x86_64 2.074-396.fc27                                 
      perl-Compress-Raw-Zlib.x86_64 2.076-1.fc27                                    
      perl-Data-Dump.noarch 1.23-6.fc27                                             
      perl-Digest.noarch 1.17-394.fc27                                              
      perl-Digest-HMAC.noarch 1.03-16.fc27                                          
      perl-Digest-MD5.x86_64 2.55-395.fc27                                          
      perl-Digest-SHA.x86_64 1:6.02-1.fc27                                          
      perl-Encode-Locale.noarch 1.05-8.fc27                                         
      perl-File-HomeDir.noarch 1.002-3.fc27                                         
      perl-File-Listing.noarch 6.04-16.fc27                                         
      perl-File-Which.noarch 1.21-5.fc27                                            
      perl-Filter.x86_64 2:1.58-1.fc27                                              
      perl-HTML-Parser.x86_64 3.72-9.fc27                                           
      perl-HTML-Tagset.noarch 3.20-31.fc27                                          
      perl-HTTP-Cookies.noarch 6.04-1.fc27                                          
      perl-HTTP-Date.noarch 6.02-17.fc27                                            
      perl-HTTP-Message.noarch 6.16-1.fc27                                          
      perl-HTTP-Negotiate.noarch 6.01-18.fc27                                       
      perl-IO-Compress.noarch 2.074-395.fc27                                        
      perl-IO-HTML.noarch 1.001-9.fc27                                              
      perl-LWP-MediaTypes.noarch 6.02-13.fc27                                       
      perl-NTLM.noarch 1.09-16.fc27                                                 
      perl-Net-HTTP.noarch 6.17-1.fc27                                              
      perl-SelfLoader.noarch 1.23-404.fc27                                          
      perl-Text-Unidecode.noarch 1.30-4.fc27                                        
      perl-TimeDate.noarch 1:2.30-12.fc27                                           
      perl-Tk.x86_64 804.034-1.fc27                                                 
      perl-Try-Tiny.noarch 0.28-4.fc27                                              
      perl-Unicode-EastAsianWidth.noarch 1.33-11.fc27                               
      perl-WWW-RobotRules.noarch 6.02-17.fc27                                       
      perl-XML-Parser.x86_64 2.44-9.fc27                                            
      perl-XML-XPath.noarch 1.42-1.fc27                                             
      perl-encoding.x86_64 4:2.19-16.fc27                                           
      perl-libintl-perl.x86_64 1.27-1.fc27                                          
      perl-libwww-perl.noarch 6.33-1.fc27                                           
      perl-open.noarch 1.11-404.fc27                                                
      psutils.x86_64 1.23-12.fc27                                                   
      psutils-perl.noarch 1.23-12.fc27                                              
      ruby.x86_64 2.4.3-87.fc27                                                     
      ruby-irb.noarch 2.4.3-87.fc27                                                 
      ruby-libs.x86_64 2.4.3-87.fc27                                                
      rubygem-json.x86_64 2.1.0-102.fc27                                            
      rubygem-psych.x86_64 2.2.2-87.fc27                                            
      rubypick.noarch 1.1.1-7.fc27                                                  
      teckit.x86_64 2.5.1-18.fc27                                                   
      texinfo.x86_64 6.4-6.fc27                                                     
      texinfo-tex.x86_64 6.4-6.fc27                                                 
      texlive-ae.noarch 6:svn15878.1.4-36.fc27.5                                    
      texlive-algorithms.noarch 6:svn38085.0.1-36.fc27.5                            
      texlive-amscls.noarch 6:svn36804.0-36.fc27.5                                  
      texlive-amsfonts.noarch 6:svn29208.3.04-36.fc27.5                             
      texlive-amsmath.noarch 6:svn41561-36.fc27.5                                   
      texlive-anysize.noarch 6:svn15878.0-36.fc27.5                                 
      texlive-attachfile.noarch 6:svn38830-36.fc27.5                                
      texlive-auto-pst-pdf.noarch 6:svn23723.0.6-36.fc27.5                          
      texlive-avantgar.noarch 6:svn31835.0-36.fc27.5                                
      texlive-babel.noarch 6:svn40706-36.fc27.5                                     
      texlive-babel-english.noarch 6:svn30264.3.3p-36.fc27.5                        
      texlive-babelbib.noarch 6:svn25245.1.31-36.fc27.5                             
      texlive-base.noarch 6:2016-36.20160520.fc27.5                                 
      texlive-beamer.noarch 6:svn36461.3.36-36.fc27.5                               
      texlive-bera.noarch 6:svn20031.0-36.fc27.5                                    
      texlive-beton.noarch 6:svn15878.0-36.fc27.5                                   
      texlive-bibtex.noarch 6:svn40768-36.fc27.5                                    
      texlive-bibtex-bin.x86_64 6:svn40473-36.20160520.fc27.5                       
      texlive-bookman.noarch 6:svn31835.0-36.fc27.5                                 
      texlive-booktabs.noarch 6:svn40846-36.fc27.5                                  
      texlive-breakurl.noarch 6:svn29901.1.40-36.fc27.5                             
      texlive-breqn.noarch 6:svn38099.0.98d-36.fc27.5                               
      texlive-caption.noarch 6:svn41409-36.fc27.5                                   
      texlive-carlisle.noarch 6:svn18258.0-36.fc27.5                                
      texlive-charter.noarch 6:svn15878.0-36.fc27.5                                 
      texlive-chngcntr.noarch 6:svn17157.1.0a-36.fc27.5                             
      texlive-cite.noarch 6:svn36428.5.5-36.fc27.5                                  
      texlive-cm.noarch 6:svn32865.0-36.fc27.5                                      
      texlive-cm-super.noarch 6:svn15878.0-36.fc27.5                                
      texlive-cmap.noarch 6:svn41168-36.fc27.5                                      
      texlive-cmextra.noarch 6:svn32831.0-36.fc27.5                                 
      texlive-collection-basic.noarch 6:svn41149-36.20160520.fc27.5                 
      texlive-collection-fontsrecommended.noarch 6:svn35830.0-36.20160520.fc27.5    
      texlive-collection-latex.noarch 6:svn41011-36.20160520.fc27.5                 
      texlive-collection-latexrecommended.noarch 6:svn35765.0-36.20160520.fc27.5    
      texlive-colortbl.noarch 6:svn29803.v1.0a-36.fc27.5                            
      texlive-context-bin.noarch 6:svn34112.0-36.20160520.fc27.5                    
      texlive-courier.noarch 6:svn35058.0-36.fc27.5                                 
      texlive-crop.noarch 6:svn15878.1.5-36.fc27.5                                  
      texlive-csquotes.noarch 6:svn39538-36.fc27.5                                  
      texlive-ctable.noarch 6:svn38672-36.fc27.5                                    
      texlive-currfile.noarch 6:svn40725-36.fc27.5                                  
      texlive-dvipdfmx.noarch 6:svn41149-36.fc27.5                                  
      texlive-dvipdfmx-bin.x86_64 6:svn40273-36.20160520.fc27.5                     
      texlive-dvipdfmx-def.noarch 6:svn40328-36.fc27.5                              
      texlive-dvips.noarch 6:svn41149-36.fc27.5                                     
      texlive-dvips-bin.x86_64 6:svn40987-36.20160520.fc27.5                        
      texlive-dvisvgm-def.noarch 6:svn41011-36.fc27.5                               
      texlive-ec.noarch 6:svn25033.1.0-36.fc27.5                                    
      texlive-enctex.noarch 6:svn34957.0-36.fc27.5                                  
      texlive-enumitem.noarch 6:svn24146.3.5.2-36.fc27.5                            
      texlive-environ.noarch 6:svn33821.0.3-36.fc27.5                               
      texlive-epsf.noarch 6:svn21461.2.7.4-36.fc27.5                                
      texlive-eso-pic.noarch 6:svn37925.2.0g-36.fc27.5                              
      texlive-etex.noarch 6:svn37057.0-36.fc27.5                                    
      texlive-etex-pkg.noarch 6:svn39355-36.fc27.5                                  
      texlive-etoolbox.noarch 6:svn38031.2.2a-36.fc27.5                             
      texlive-euenc.noarch 6:svn19795.0.1h-36.fc27.5                                
      texlive-euler.noarch 6:svn17261.2.5-36.fc27.5                                 
      texlive-euro.noarch 6:svn22191.1.1-36.fc27.5                                  
      texlive-eurosym.noarch 6:svn17265.1.4_subrfix-36.fc27.5                       
      texlive-extsizes.noarch 6:svn17263.1.4a-36.fc27.5                             
      texlive-fancybox.noarch 6:svn18304.1.4-36.fc27.5                              
      texlive-fancyhdr.noarch 6:svn15878.3.1-36.fc27.5                              
      texlive-fancyref.noarch 6:svn15878.0.9c-36.fc27.5                             
      texlive-fancyvrb.noarch 6:svn18492.2.8-36.fc27.5                              
      texlive-filecontents.noarch 6:svn24250.1.3-36.fc27.5                          
      texlive-filehook.noarch 6:svn24280.0.5d-36.fc27.5                             
      texlive-finstrut.noarch 6:svn21719.0.5-36.fc27.5                              
      texlive-fix2col.noarch 6:svn38770-36.fc27.5                                   
      texlive-float.noarch 6:svn15878.1.3d-36.fc27.5                                
      texlive-fontspec.noarch 6:svn41262-36.fc27.5                                  
      texlive-footmisc.noarch 6:svn23330.5.5b-36.fc27.5                             
      texlive-fp.noarch 6:svn15878.0-36.fc27.5                                      
      texlive-fpl.noarch 6:svn15878.1.002-36.fc27.5                                 
      texlive-geometry.noarch 6:svn19716.5.6-36.fc27.5                              
      texlive-glyphlist.noarch 6:svn28576.0-36.fc27.5                               
      texlive-graphics.noarch 6:svn41015-36.fc27.5                                  
      texlive-graphics-cfg.noarch 6:svn40269-36.fc27.5                              
      texlive-graphics-def.noarch 6:svn41879-36.fc27.5                              
      texlive-gsftopk.noarch 6:svn40768-36.fc27.5                                   
      texlive-gsftopk-bin.x86_64 6:svn40473-36.20160520.fc27.5                      
      texlive-helvetic.noarch 6:svn31835.0-36.fc27.5                                
      texlive-hyperref.noarch 6:svn41396-36.fc27.5                                  
      texlive-hyph-utf8.noarch 6:svn41189-36.fc27.5                                 
      texlive-hyphen-base.noarch 6:svn41138-36.fc27.5                               
      texlive-ifetex.noarch 6:svn24853.1.2-36.fc27.5                                
      texlive-ifluatex.noarch 6:svn41346-36.fc27.5                                  
      texlive-ifplatform.noarch 6:svn21156.0.4-36.fc27.5                            
      texlive-iftex.noarch 6:svn29654.0.2-36.fc27.5                                 
      texlive-ifxetex.noarch 6:svn19685.0.5-36.fc27.5                               
      texlive-index.noarch 6:svn24099.4.1beta-36.fc27.5                             
      texlive-jknapltx.noarch 6:svn19440.0-36.fc27.5                                
      texlive-kastrup.noarch 6:svn15878.0-36.fc27.5                                 
      texlive-knuth-lib.noarch 6:svn35820.0-36.fc27.5                               
      texlive-knuth-local.noarch 6:svn38627-36.fc27.5                               
      texlive-koma-script.noarch 6:svn41508-36.fc27.5                               
      texlive-kpathsea.noarch 6:svn41139-36.fc27.5                                  
      texlive-kpathsea-bin.x86_64 6:svn40473-36.20160520.fc27.5                     
      texlive-kpathsea-doc.noarch 6:svn41139-36.fc27.5                              
      texlive-l3experimental.noarch 6:svn41163-36.fc27.5                            
      texlive-l3kernel.noarch 6:svn41246-36.fc27.5                                  
      texlive-l3packages.noarch 6:svn41246-36.fc27.5                                
      texlive-latex.noarch 6:svn40218-36.fc27.5                                     
      texlive-latex-bin.noarch 6:svn41438-36.fc27.5                                 
      texlive-latex-bin-bin.noarch 6:svn14050.0-36.20160520.fc27.5                  
      texlive-latex-fonts.noarch 6:svn28888.0-36.fc27.5                             
      texlive-latexconfig.noarch 6:svn40274-36.fc27.5                               
      texlive-lib.x86_64 6:2016-36.20160520.fc27.5                                  
      texlive-lineno.noarch 6:svn21442.4.41-36.fc27.5                               
      texlive-listings.noarch 6:svn37534.1.6-36.fc27.5                              
      texlive-lm.noarch 6:svn28119.2.004-36.fc27.5                                  
      texlive-lm-math.noarch 6:svn36915.1.959-36.fc27.5                             
      texlive-ltabptch.noarch 6:svn17533.1.74d-36.fc27.5                            
      texlive-ltxmisc.noarch 6:svn21927.0-36.fc27.5                                 
      texlive-lua-alt-getopt.noarch 6:svn29349.0.7.0-36.fc27.5                      
      texlive-lualatex-math.noarch 6:svn40621-36.fc27.5                             
      texlive-lualibs.noarch 6:svn40370-36.fc27.5                                   
      texlive-luaotfload.noarch 6:svn40902-36.fc27.5                                
      texlive-luaotfload-bin.noarch 6:svn34647.0-36.20160520.fc27.5                 
      texlive-luatex.noarch 6:svn40963-36.fc27.5                                    
      texlive-luatex-bin.x86_64 6:svn41091-36.20160520.fc27.5                       
      texlive-luatexbase.noarch 6:svn38550-36.fc27.5                                
      texlive-makeindex.noarch 6:svn40768-36.fc27.5                                 
      texlive-makeindex-bin.x86_64 6:svn40473-36.20160520.fc27.5                    
      texlive-manfnt-font.noarch 6:svn35799.0-36.fc27.5                             
      texlive-marginnote.noarch 6:svn41382-36.fc27.5                                
      texlive-marvosym.noarch 6:svn29349.2.2a-36.fc27.5                             
      texlive-mathpazo.noarch 6:svn15878.1.003-36.fc27.5                            
      texlive-mathtools.noarch 6:svn38833-36.fc27.5                                 
      texlive-mdwtools.noarch 6:svn15878.1.05.4-36.fc27.5                           
      texlive-memoir.noarch 6:svn41203-36.fc27.5                                    
      texlive-metafont.noarch 6:svn40793-36.fc27.5                                  
      texlive-metafont-bin.x86_64 6:svn40987-36.20160520.fc27.5                     
      texlive-metalogo.noarch 6:svn18611.0.12-36.fc27.5                             
      texlive-metapost.noarch 6:svn40768-36.fc27.5                                  
      texlive-metapost-bin.x86_64 6:svn40473-36.20160520.fc27.5                     
      texlive-mflogo.noarch 6:svn38628-36.fc27.5                                    
      texlive-mflogo-font.noarch 6:svn36898.1.002-36.fc27.5                         
      texlive-mfnfss.noarch 6:svn19410.0-36.fc27.5                                  
      texlive-mfware.noarch 6:svn40768-36.fc27.5                                    
      texlive-mfware-bin.x86_64 6:svn40473-36.20160520.fc27.5                       
      texlive-microtype.noarch 6:svn41127-36.fc27.5                                 
      texlive-mparhack.noarch 6:svn15878.1.4-36.fc27.5                              
      texlive-mptopdf.noarch 6:svn41282-36.fc27.5                                   
      texlive-mptopdf-bin.noarch 6:svn18674.0-36.20160520.fc27.5                    
      texlive-ms.noarch 6:svn29849.0-36.fc27.5                                      
      texlive-multido.noarch 6:svn18302.1.42-36.fc27.5                              
      texlive-natbib.noarch 6:svn20668.8.31b-36.fc27.5                              
      texlive-ncntrsbk.noarch 6:svn31835.0-36.fc27.5                                
      texlive-ntgclass.noarch 6:svn15878.2.1a-36.fc27.5                             
      texlive-oberdiek.noarch 6:svn41346-36.fc27.5                                  
      texlive-palatino.noarch 6:svn31835.0-36.fc27.5                                
      texlive-paralist.noarch 6:svn39247-36.fc27.5                                  
      texlive-parallel.noarch 6:svn15878.0-36.fc27.5                                
      texlive-parskip.noarch 6:svn19963.2.0-36.fc27.5                               
      texlive-pdfpages.noarch 6:svn40638-36.fc27.5                                  
      texlive-pdftex.noarch 6:svn41149-36.fc27.5                                    
      texlive-pdftex-bin.x86_64 6:svn40987-36.20160520.fc27.5                       
      texlive-pdftex-def.noarch 6:svn22653.0.06d-36.fc27.5                          
      texlive-pdftex-doc.noarch 6:svn41149-36.fc27.5                                
      texlive-pgf.noarch 6:svn40966-36.fc27.5                                       
      texlive-plain.noarch 6:svn40274-36.fc27.5                                     
      texlive-powerdot.noarch 6:svn38984-36.fc27.5                                  
      texlive-psfrag.noarch 6:svn15878.3.04-36.fc27.5                               
      texlive-pslatex.noarch 6:svn16416.0-36.fc27.5                                 
      texlive-psnfss.noarch 6:svn33946.9.2a-36.fc27.5                               
      texlive-pspicture.noarch 6:svn15878.0-36.fc27.5                               
      texlive-pst-3d.noarch 6:svn17257.1.10-36.fc27.5                               
      texlive-pst-blur.noarch 6:svn15878.2.0-36.fc27.5                              
      texlive-pst-coil.noarch 6:svn37377.1.07-36.fc27.5                             
      texlive-pst-eps.noarch 6:svn15878.1.0-36.fc27.5                               
      texlive-pst-fill.noarch 6:svn15878.1.01-36.fc27.5                             
      texlive-pst-grad.noarch 6:svn15878.1.06-36.fc27.5                             
      texlive-pst-math.noarch 6:svn34786.0.63-36.fc27.5                             
      texlive-pst-node.noarch 6:svn40743-36.fc27.5                                  
      texlive-pst-ovl.noarch 6:svn40873-36.fc27.5                                   
      texlive-pst-pdf.noarch 6:svn31660.1.1v-36.fc27.5                              
      texlive-pst-pdf-bin.noarch 6:svn7838.0-36.20160520.fc27.5                     
      texlive-pst-plot.noarch 6:svn41242-36.fc27.5                                  
      texlive-pst-slpe.noarch 6:svn24391.1.31-36.fc27.5                             
      texlive-pst-text.noarch 6:svn15878.1.00-36.fc27.5                             
      texlive-pst-tools.noarch 6:svn34067.0.05-36.fc27.5                            
      texlive-pst-tree.noarch 6:svn24142.1.12-36.fc27.5                             
      texlive-pstricks.noarch 6:svn41321-36.fc27.5                                  
      texlive-pstricks-add.noarch 6:svn40744-36.fc27.5                              
      texlive-pxfonts.noarch 6:svn15878.0-36.fc27.5                                 
      texlive-qstest.noarch 6:svn15878.0-36.fc27.5                                  
      texlive-rcs.noarch 6:svn15878.0-36.fc27.5                                     
      texlive-rotating.noarch 6:svn16832.2.16b-36.fc27.5                            
      texlive-rsfs.noarch 6:svn15878.0-36.fc27.5                                    
      texlive-sansmath.noarch 6:svn17997.1.1-36.fc27.5                              
      texlive-sansmathaccent.noarch 6:svn30187.0-36.fc27.5                          
      texlive-sauerj.noarch 6:svn15878.0-36.fc27.5                                  
      texlive-scheme-basic.noarch 6:svn25923.0-36.20160520.fc27.5                   
      texlive-section.noarch 6:svn20180.0-36.fc27.5                                 
      texlive-seminar.noarch 6:svn34011.1.62-36.fc27.5                              
      texlive-sepnum.noarch 6:svn20186.2.0-36.fc27.5                                
      texlive-setspace.noarch 6:svn24881.6.7a-36.fc27.5                             
      texlive-showexpl.noarch 6:svn32737.v0.3l-36.fc27.5                            
      texlive-soul.noarch 6:svn15878.2.4-36.fc27.5                                  
      texlive-stmaryrd.noarch 6:svn22027.0-36.fc27.5                                
      texlive-subfig.noarch 6:svn15878.1.3-36.fc27.5                                
      texlive-symbol.noarch 6:svn31835.0-36.fc27.5                                  
      texlive-tetex.noarch 6:svn41059-36.fc27.5                                     
      texlive-tetex-bin.noarch 6:svn36770.0-36.20160520.fc27.5                      
      texlive-tex.noarch 6:svn40793-36.fc27.5                                       
      texlive-tex-bin.x86_64 6:svn40987-36.20160520.fc27.5                          
      texlive-tex-gyre.noarch 6:svn18651.2.004-36.fc27.5                            
      texlive-tex-gyre-math.noarch 6:svn41264-36.fc27.5                             
      texlive-tex-ini-files.noarch 6:svn40533-36.fc27.5                             
      texlive-texconfig.noarch 6:svn40768-36.fc27.5                                 
      texlive-texconfig-bin.noarch 6:svn29741.0-36.20160520.fc27.5                  
      texlive-texlive-common-doc.noarch 6:svn40682-36.fc27.5                        
      texlive-texlive-docindex.noarch 6:svn41430-36.fc27.5                          
      texlive-texlive-en.noarch 6:svn41185-36.fc27.5                                
      texlive-texlive-msg-translations.noarch 6:svn41431-36.fc27.5                  
      texlive-texlive-scripts.noarch 6:svn41433-36.fc27.5                           
      texlive-texlive-scripts-bin.noarch 6:svn29741.0-36.20160520.fc27.5            
      texlive-texlive.infra.noarch 6:svn41280-36.fc27.5                             
      texlive-texlive.infra-bin.x86_64 6:svn40312-36.20160520.fc27.5                
      texlive-textcase.noarch 6:svn15878.0-36.fc27.5                                
      texlive-thumbpdf.noarch 6:svn34621.3.16-36.fc27.5                             
      texlive-thumbpdf-bin.noarch 6:svn6898.0-36.20160520.fc27.5                    
      texlive-times.noarch 6:svn35058.0-36.fc27.5                                   
      texlive-tipa.noarch 6:svn29349.1.3-36.fc27.5                                  
      texlive-tools.noarch 6:svn40934-36.fc27.5                                     
      texlive-trimspaces.noarch 6:svn15878.1.1-36.fc27.5                            
      texlive-txfonts.noarch 6:svn15878.0-36.fc27.5                                 
      texlive-type1cm.noarch 6:svn21820.0-36.fc27.5                                 
      texlive-typehtml.noarch 6:svn17134.0-36.fc27.5                                
      texlive-ucharcat.noarch 6:svn38907-36.fc27.5                                  
      texlive-ucs.noarch 6:svn35853.2.2-36.fc27.5                                   
      texlive-underscore.noarch 6:svn18261.0-36.fc27.5                              
      texlive-unicode-data.noarch 6:svn39808-36.fc27.5                              
      texlive-unicode-math.noarch 6:svn38462-36.fc27.5                              
      texlive-updmap-map.noarch 6:svn41159-36.fc27.5                                
      texlive-url.noarch 6:svn32528.3.4-36.fc27.5                                   
      texlive-utopia.noarch 6:svn15878.0-36.fc27.5                                  
      texlive-varwidth.noarch 6:svn24104.0.92-36.fc27.5                             
      texlive-wasy.noarch 6:svn35831.0-36.fc27.5                                    
      texlive-wasy2-ps.noarch 6:svn35830.0-36.fc27.5                                
      texlive-wasysym.noarch 6:svn15878.2.0-36.fc27.5                               
      texlive-xcolor.noarch 6:svn41044-36.fc27.5                                    
      texlive-xdvi.noarch 6:svn40768-36.fc27.5                                      
      texlive-xdvi-bin.x86_64 6:svn40750-36.20160520.fc27.5                         
      texlive-xetex.noarch 6:svn41438-36.fc27.5                                     
      texlive-xetex-bin.x86_64 6:svn41091-36.20160520.fc27.5                        
      texlive-xetex-def.noarch 6:svn40327-36.fc27.5                                 
      texlive-xetexconfig.noarch 6:svn41133-36.fc27.5                               
      texlive-xkeyval.noarch 6:svn35741.2.7a-36.fc27.5                              
      texlive-xunicode.noarch 6:svn30466.0.981-36.fc27.5                            
      texlive-zapfchan.noarch 6:svn31835.0-36.fc27.5                                
      texlive-zapfding.noarch 6:svn31835.0-36.fc27.5                                
      zziplib.x86_64 0.13.68-1.fc27                                                 
    
    Complete!
    

  • Installed 322 Packages.
    The full list of installed packages (2288 in total vs 1966 in sect.40)
               /opt/root/Install/rpm_history/180518.0156.rpm-qa.tex_etc_installed
    ( local copy )

  • The installed packages: More... Close
    [root] ~/opt_root_Install/rpm_history $ \
              diff 180517.0414.rpm-qa.libroffice_installed \
                   180518.0156.rpm-qa.tex_etc_installed \
              | grep ">"
    > a2ps-4.14-32.fc27.x86_64
    > groff-perl-1.22.3-14.fc27.x86_64
    > html2ps-1.0-0.27.b7.fc27.noarch
    > ImageMagick-6.9.9.38-1.fc27.x86_64
    > ImageMagick-perl-6.9.9.38-1.fc27.x86_64
    > latex2html-2017.2-3.fc27.noarch
    > libpaper-1.1.24-21.fc27.x86_64
    > netpbm-10.81.00-1.fc27.x86_64
    > netpbm-progs-10.81.00-1.fc27.x86_64
    > perl-Class-Inspector-1.32-1.fc27.noarch
    > perl-Compress-Raw-Bzip2-2.074-396.fc27.x86_64
    > perl-Compress-Raw-Zlib-2.076-1.fc27.x86_64
    > perl-Data-Dump-1.23-6.fc27.noarch
    > perl-Digest-1.17-394.fc27.noarch
    > perl-Digest-HMAC-1.03-16.fc27.noarch
    > perl-Digest-MD5-2.55-395.fc27.x86_64
    > perl-Digest-SHA-6.02-1.fc27.x86_64
    > perl-Encode-Locale-1.05-8.fc27.noarch
    > perl-encoding-2.19-16.fc27.x86_64
    > perl-File-HomeDir-1.002-3.fc27.noarch
    > perl-File-Listing-6.04-16.fc27.noarch
    > perl-File-ShareDir-1.104-2.fc27.noarch
    > perl-File-Which-1.21-5.fc27.noarch
    > perl-Filter-1.58-1.fc27.x86_64
    > perl-HTML-Parser-3.72-9.fc27.x86_64
    > perl-HTML-Tagset-3.20-31.fc27.noarch
    > perl-HTTP-Cookies-6.04-1.fc27.noarch
    > perl-HTTP-Date-6.02-17.fc27.noarch
    > perl-HTTP-Message-6.16-1.fc27.noarch
    > perl-HTTP-Negotiate-6.01-18.fc27.noarch
    > perl-IO-Compress-2.074-395.fc27.noarch
    > perl-IO-HTML-1.001-9.fc27.noarch
    > perl-libintl-perl-1.27-1.fc27.x86_64
    > perl-libwww-perl-6.33-1.fc27.noarch
    > perl-LWP-MediaTypes-6.02-13.fc27.noarch
    > perl-Net-HTTP-6.17-1.fc27.noarch
    > perl-NTLM-1.09-16.fc27.noarch
    > perl-open-1.11-404.fc27.noarch
    > perl-SelfLoader-1.23-404.fc27.noarch
    > perl-Text-Unidecode-1.30-4.fc27.noarch
    > perl-TimeDate-2.30-12.fc27.noarch
    > perl-Tk-804.034-1.fc27.x86_64
    > perl-Try-Tiny-0.28-4.fc27.noarch
    > perl-Unicode-EastAsianWidth-1.33-11.fc27.noarch
    > perl-WWW-RobotRules-6.02-17.fc27.noarch
    > perl-XML-Parser-2.44-9.fc27.x86_64
    > perl-XML-XPath-1.42-1.fc27.noarch
    > psutils-1.23-12.fc27.x86_64
    > psutils-perl-1.23-12.fc27.noarch
    > ruby-2.4.3-87.fc27.x86_64
    > rubygem-bigdecimal-1.3.0-87.fc27.x86_64
    > rubygem-did_you_mean-1.1.0-87.fc27.x86_64
    > rubygem-io-console-0.4.6-87.fc27.x86_64
    > rubygem-json-2.1.0-102.fc27.x86_64
    > rubygem-openssl-2.0.5-87.fc27.x86_64
    > rubygem-psych-2.2.2-87.fc27.x86_64
    > rubygem-rdoc-5.1.0-3.fc27.noarch
    > rubygems-2.6.14.1-87.fc27.noarch
    > ruby-irb-2.4.3-87.fc27.noarch
    > ruby-libs-2.4.3-87.fc27.x86_64
    > rubypick-1.1.1-7.fc27.noarch
    > teckit-2.5.1-18.fc27.x86_64
    > texinfo-6.4-6.fc27.x86_64
    > texinfo-tex-6.4-6.fc27.x86_64
    > texlive-2016-36.20160520.fc27.5.x86_64
    > texlive-ae-svn15878.1.4-36.fc27.5.noarch
    > texlive-algorithms-svn38085.0.1-36.fc27.5.noarch
    > texlive-amscls-svn36804.0-36.fc27.5.noarch
    > texlive-amsfonts-svn29208.3.04-36.fc27.5.noarch
    > texlive-amsmath-svn41561-36.fc27.5.noarch
    > texlive-anysize-svn15878.0-36.fc27.5.noarch
    > texlive-attachfile-svn38830-36.fc27.5.noarch
    > texlive-auto-pst-pdf-svn23723.0.6-36.fc27.5.noarch
    > texlive-avantgar-svn31835.0-36.fc27.5.noarch
    > texlive-babelbib-svn25245.1.31-36.fc27.5.noarch
    > texlive-babel-english-svn30264.3.3p-36.fc27.5.noarch
    > texlive-babel-svn40706-36.fc27.5.noarch
    > texlive-base-2016-36.20160520.fc27.5.noarch
    > texlive-beamer-svn36461.3.36-36.fc27.5.noarch
    > texlive-bera-svn20031.0-36.fc27.5.noarch
    > texlive-beton-svn15878.0-36.fc27.5.noarch
    > texlive-bibtex-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-bibtex-svn40768-36.fc27.5.noarch
    > texlive-bookman-svn31835.0-36.fc27.5.noarch
    > texlive-booktabs-svn40846-36.fc27.5.noarch
    > texlive-breakurl-svn29901.1.40-36.fc27.5.noarch
    > texlive-breqn-svn38099.0.98d-36.fc27.5.noarch
    > texlive-caption-svn41409-36.fc27.5.noarch
    > texlive-carlisle-svn18258.0-36.fc27.5.noarch
    > texlive-charter-svn15878.0-36.fc27.5.noarch
    > texlive-chngcntr-svn17157.1.0a-36.fc27.5.noarch
    > texlive-cite-svn36428.5.5-36.fc27.5.noarch
    > texlive-cmap-svn41168-36.fc27.5.noarch
    > texlive-cmextra-svn32831.0-36.fc27.5.noarch
    > texlive-cm-super-svn15878.0-36.fc27.5.noarch
    > texlive-cm-svn32865.0-36.fc27.5.noarch
    > texlive-collection-basic-svn41149-36.20160520.fc27.5.noarch
    > texlive-collection-fontsrecommended-svn35830.0-36.20160520.fc27.5.noarch
    > texlive-collection-latexrecommended-svn35765.0-36.20160520.fc27.5.noarch
    > texlive-collection-latex-svn41011-36.20160520.fc27.5.noarch
    > texlive-colortbl-svn29803.v1.0a-36.fc27.5.noarch
    > texlive-context-bin-svn34112.0-36.20160520.fc27.5.noarch
    > texlive-context-svn41282-36.fc27.5.noarch
    > texlive-courier-svn35058.0-36.fc27.5.noarch
    > texlive-crop-svn15878.1.5-36.fc27.5.noarch
    > texlive-csquotes-svn39538-36.fc27.5.noarch
    > texlive-ctable-svn38672-36.fc27.5.noarch
    > texlive-currfile-svn40725-36.fc27.5.noarch
    > texlive-dvipdfmx-bin-svn40273-36.20160520.fc27.5.x86_64
    > texlive-dvipdfmx-def-svn40328-36.fc27.5.noarch
    > texlive-dvipdfmx-svn41149-36.fc27.5.noarch
    > texlive-dvips-bin-svn40987-36.20160520.fc27.5.x86_64
    > texlive-dvips-svn41149-36.fc27.5.noarch
    > texlive-dvisvgm-def-svn41011-36.fc27.5.noarch
    > texlive-ec-svn25033.1.0-36.fc27.5.noarch
    > texlive-enctex-svn34957.0-36.fc27.5.noarch
    > texlive-enumitem-svn24146.3.5.2-36.fc27.5.noarch
    > texlive-environ-svn33821.0.3-36.fc27.5.noarch
    > texlive-epsf-svn21461.2.7.4-36.fc27.5.noarch
    > texlive-eso-pic-svn37925.2.0g-36.fc27.5.noarch
    > texlive-etex-pkg-svn39355-36.fc27.5.noarch
    > texlive-etex-svn37057.0-36.fc27.5.noarch
    > texlive-etoolbox-svn38031.2.2a-36.fc27.5.noarch
    > texlive-euenc-svn19795.0.1h-36.fc27.5.noarch
    > texlive-euler-svn17261.2.5-36.fc27.5.noarch
    > texlive-euro-svn22191.1.1-36.fc27.5.noarch
    > texlive-eurosym-svn17265.1.4_subrfix-36.fc27.5.noarch
    > texlive-extsizes-svn17263.1.4a-36.fc27.5.noarch
    > texlive-fancybox-svn18304.1.4-36.fc27.5.noarch
    > texlive-fancyhdr-svn15878.3.1-36.fc27.5.noarch
    > texlive-fancyref-svn15878.0.9c-36.fc27.5.noarch
    > texlive-fancyvrb-svn18492.2.8-36.fc27.5.noarch
    > texlive-filecontents-svn24250.1.3-36.fc27.5.noarch
    > texlive-filehook-svn24280.0.5d-36.fc27.5.noarch
    > texlive-finstrut-svn21719.0.5-36.fc27.5.noarch
    > texlive-fix2col-svn38770-36.fc27.5.noarch
    > texlive-float-svn15878.1.3d-36.fc27.5.noarch
    > texlive-fontspec-svn41262-36.fc27.5.noarch
    > texlive-footmisc-svn23330.5.5b-36.fc27.5.noarch
    > texlive-fpl-svn15878.1.002-36.fc27.5.noarch
    > texlive-fp-svn15878.0-36.fc27.5.noarch
    > texlive-geometry-svn19716.5.6-36.fc27.5.noarch
    > texlive-glyphlist-svn28576.0-36.fc27.5.noarch
    > texlive-graphics-cfg-svn40269-36.fc27.5.noarch
    > texlive-graphics-def-svn41879-36.fc27.5.noarch
    > texlive-graphics-svn41015-36.fc27.5.noarch
    > texlive-gsftopk-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-gsftopk-svn40768-36.fc27.5.noarch
    > texlive-helvetic-svn31835.0-36.fc27.5.noarch
    > texlive-hyperref-svn41396-36.fc27.5.noarch
    > texlive-hyphen-base-svn41138-36.fc27.5.noarch
    > texlive-hyph-utf8-svn41189-36.fc27.5.noarch
    > texlive-ifetex-svn24853.1.2-36.fc27.5.noarch
    > texlive-ifluatex-svn41346-36.fc27.5.noarch
    > texlive-ifplatform-svn21156.0.4-36.fc27.5.noarch
    > texlive-iftex-svn29654.0.2-36.fc27.5.noarch
    > texlive-ifxetex-svn19685.0.5-36.fc27.5.noarch
    > texlive-index-svn24099.4.1beta-36.fc27.5.noarch
    > texlive-jknapltx-svn19440.0-36.fc27.5.noarch
    > texlive-kastrup-svn15878.0-36.fc27.5.noarch
    > texlive-knuth-lib-svn35820.0-36.fc27.5.noarch
    > texlive-knuth-local-svn38627-36.fc27.5.noarch
    > texlive-koma-script-svn41508-36.fc27.5.noarch
    > texlive-kpathsea-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-kpathsea-doc-svn41139-36.fc27.5.noarch
    > texlive-kpathsea-svn41139-36.fc27.5.noarch
    > texlive-l3experimental-svn41163-36.fc27.5.noarch
    > texlive-l3kernel-svn41246-36.fc27.5.noarch
    > texlive-l3packages-svn41246-36.fc27.5.noarch
    > texlive-latex-bin-bin-svn14050.0-36.20160520.fc27.5.noarch
    > texlive-latex-bin-svn41438-36.fc27.5.noarch
    > texlive-latexconfig-svn40274-36.fc27.5.noarch
    > texlive-latex-fonts-svn28888.0-36.fc27.5.noarch
    > texlive-latex-svn40218-36.fc27.5.noarch
    > texlive-lib-2016-36.20160520.fc27.5.x86_64
    > texlive-lineno-svn21442.4.41-36.fc27.5.noarch
    > texlive-listings-svn37534.1.6-36.fc27.5.noarch
    > texlive-lm-math-svn36915.1.959-36.fc27.5.noarch
    > texlive-lm-svn28119.2.004-36.fc27.5.noarch
    > texlive-ltabptch-svn17533.1.74d-36.fc27.5.noarch
    > texlive-ltxmisc-svn21927.0-36.fc27.5.noarch
    > texlive-lua-alt-getopt-svn29349.0.7.0-36.fc27.5.noarch
    > texlive-lualatex-math-svn40621-36.fc27.5.noarch
    > texlive-lualibs-svn40370-36.fc27.5.noarch
    > texlive-luaotfload-bin-svn34647.0-36.20160520.fc27.5.noarch
    > texlive-luaotfload-svn40902-36.fc27.5.noarch
    > texlive-luatexbase-svn38550-36.fc27.5.noarch
    > texlive-luatex-bin-svn41091-36.20160520.fc27.5.x86_64
    > texlive-luatex-svn40963-36.fc27.5.noarch
    > texlive-makeindex-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-makeindex-svn40768-36.fc27.5.noarch
    > texlive-manfnt-font-svn35799.0-36.fc27.5.noarch
    > texlive-marginnote-svn41382-36.fc27.5.noarch
    > texlive-marvosym-svn29349.2.2a-36.fc27.5.noarch
    > texlive-mathpazo-svn15878.1.003-36.fc27.5.noarch
    > texlive-mathtools-svn38833-36.fc27.5.noarch
    > texlive-mdwtools-svn15878.1.05.4-36.fc27.5.noarch
    > texlive-memoir-svn41203-36.fc27.5.noarch
    > texlive-metafont-bin-svn40987-36.20160520.fc27.5.x86_64
    > texlive-metafont-svn40793-36.fc27.5.noarch
    > texlive-metalogo-svn18611.0.12-36.fc27.5.noarch
    > texlive-metapost-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-metapost-svn40768-36.fc27.5.noarch
    > texlive-mflogo-font-svn36898.1.002-36.fc27.5.noarch
    > texlive-mflogo-svn38628-36.fc27.5.noarch
    > texlive-mfnfss-svn19410.0-36.fc27.5.noarch
    > texlive-mfware-bin-svn40473-36.20160520.fc27.5.x86_64
    > texlive-mfware-svn40768-36.fc27.5.noarch
    > texlive-microtype-svn41127-36.fc27.5.noarch
    > texlive-mparhack-svn15878.1.4-36.fc27.5.noarch
    > texlive-mptopdf-bin-svn18674.0-36.20160520.fc27.5.noarch
    > texlive-mptopdf-svn41282-36.fc27.5.noarch
    > texlive-ms-svn29849.0-36.fc27.5.noarch
    > texlive-multido-svn18302.1.42-36.fc27.5.noarch
    > texlive-natbib-svn20668.8.31b-36.fc27.5.noarch
    > texlive-ncntrsbk-svn31835.0-36.fc27.5.noarch
    > texlive-ntgclass-svn15878.2.1a-36.fc27.5.noarch
    > texlive-oberdiek-svn41346-36.fc27.5.noarch
    > texlive-palatino-svn31835.0-36.fc27.5.noarch
    > texlive-paralist-svn39247-36.fc27.5.noarch
    > texlive-parallel-svn15878.0-36.fc27.5.noarch
    > texlive-parskip-svn19963.2.0-36.fc27.5.noarch
    > texlive-pdfpages-svn40638-36.fc27.5.noarch
    > texlive-pdftex-bin-svn40987-36.20160520.fc27.5.x86_64
    > texlive-pdftex-def-svn22653.0.06d-36.fc27.5.noarch
    > texlive-pdftex-doc-svn41149-36.fc27.5.noarch
    > texlive-pdftex-svn41149-36.fc27.5.noarch
    > texlive-pgf-svn40966-36.fc27.5.noarch
    > texlive-plain-svn40274-36.fc27.5.noarch
    > texlive-powerdot-svn38984-36.fc27.5.noarch
    > texlive-psfrag-svn15878.3.04-36.fc27.5.noarch
    > texlive-pslatex-svn16416.0-36.fc27.5.noarch
    > texlive-psnfss-svn33946.9.2a-36.fc27.5.noarch
    > texlive-pspicture-svn15878.0-36.fc27.5.noarch
    > texlive-pst-3d-svn17257.1.10-36.fc27.5.noarch
    > texlive-pst-blur-svn15878.2.0-36.fc27.5.noarch
    > texlive-pst-coil-svn37377.1.07-36.fc27.5.noarch
    > texlive-pst-eps-svn15878.1.0-36.fc27.5.noarch
    > texlive-pst-fill-svn15878.1.01-36.fc27.5.noarch
    > texlive-pst-grad-svn15878.1.06-36.fc27.5.noarch
    > texlive-pst-math-svn34786.0.63-36.fc27.5.noarch
    > texlive-pst-node-svn40743-36.fc27.5.noarch
    > texlive-pst-ovl-svn40873-36.fc27.5.noarch
    > texlive-pst-pdf-bin-svn7838.0-36.20160520.fc27.5.noarch
    > texlive-pst-pdf-svn31660.1.1v-36.fc27.5.noarch
    > texlive-pst-plot-svn41242-36.fc27.5.noarch
    > texlive-pstricks-add-svn40744-36.fc27.5.noarch
    > texlive-pstricks-svn41321-36.fc27.5.noarch
    > texlive-pst-slpe-svn24391.1.31-36.fc27.5.noarch
    > texlive-pst-text-svn15878.1.00-36.fc27.5.noarch
    > texlive-pst-tools-svn34067.0.05-36.fc27.5.noarch
    > texlive-pst-tree-svn24142.1.12-36.fc27.5.noarch
    > texlive-pxfonts-svn15878.0-36.fc27.5.noarch
    > texlive-python-doc-svn27064.0.21-36.fc27.5.noarch
    > texlive-qstest-svn15878.0-36.fc27.5.noarch
    > texlive-rcs-svn15878.0-36.fc27.5.noarch
    > texlive-rotating-svn16832.2.16b-36.fc27.5.noarch
    > texlive-rsfs-svn15878.0-36.fc27.5.noarch
    > texlive-sansmathaccent-svn30187.0-36.fc27.5.noarch
    > texlive-sansmath-svn17997.1.1-36.fc27.5.noarch
    > texlive-sauerj-svn15878.0-36.fc27.5.noarch
    > texlive-scheme-basic-svn25923.0-36.20160520.fc27.5.noarch
    > texlive-section-svn20180.0-36.fc27.5.noarch
    > texlive-seminar-svn34011.1.62-36.fc27.5.noarch
    > texlive-sepnum-svn20186.2.0-36.fc27.5.noarch
    > texlive-setspace-svn24881.6.7a-36.fc27.5.noarch
    > texlive-showexpl-svn32737.v0.3l-36.fc27.5.noarch
    > texlive-soul-svn15878.2.4-36.fc27.5.noarch
    > texlive-stmaryrd-svn22027.0-36.fc27.5.noarch
    > texlive-subfig-svn15878.1.3-36.fc27.5.noarch
    > texlive-symbol-svn31835.0-36.fc27.5.noarch
    > texlive-tetex-bin-svn36770.0-36.20160520.fc27.5.noarch
    > texlive-tetex-svn41059-36.fc27.5.noarch
    > texlive-tex-bin-svn40987-36.20160520.fc27.5.x86_64
    > texlive-texconfig-bin-svn29741.0-36.20160520.fc27.5.noarch
    > texlive-texconfig-svn40768-36.fc27.5.noarch
    > texlive-tex-gyre-math-svn41264-36.fc27.5.noarch
    > texlive-tex-gyre-svn18651.2.004-36.fc27.5.noarch
    > texlive-tex-ini-files-svn40533-36.fc27.5.noarch
    > texlive-texlive-common-doc-svn40682-36.fc27.5.noarch
    > texlive-texlive-docindex-svn41430-36.fc27.5.noarch
    > texlive-texlive-en-svn41185-36.fc27.5.noarch
    > texlive-texlive.infra-bin-svn40312-36.20160520.fc27.5.x86_64
    > texlive-texlive.infra-svn41280-36.fc27.5.noarch
    > texlive-texlive-msg-translations-svn41431-36.fc27.5.noarch
    > texlive-texlive-scripts-bin-svn29741.0-36.20160520.fc27.5.noarch
    > texlive-texlive-scripts-svn41433-36.fc27.5.noarch
    > texlive-tex-svn40793-36.fc27.5.noarch
    > texlive-textcase-svn15878.0-36.fc27.5.noarch
    > texlive-thumbpdf-bin-svn6898.0-36.20160520.fc27.5.noarch
    > texlive-thumbpdf-svn34621.3.16-36.fc27.5.noarch
    > texlive-times-svn35058.0-36.fc27.5.noarch
    > texlive-tipa-svn29349.1.3-36.fc27.5.noarch
    > texlive-tools-svn40934-36.fc27.5.noarch
    > texlive-trimspaces-svn15878.1.1-36.fc27.5.noarch
    > texlive-txfonts-svn15878.0-36.fc27.5.noarch
    > texlive-type1cm-svn21820.0-36.fc27.5.noarch
    > texlive-typehtml-svn17134.0-36.fc27.5.noarch
    > texlive-ucharcat-svn38907-36.fc27.5.noarch
    > texlive-ucs-svn35853.2.2-36.fc27.5.noarch
    > texlive-underscore-svn18261.0-36.fc27.5.noarch
    > texlive-unicode-data-svn39808-36.fc27.5.noarch
    > texlive-unicode-math-svn38462-36.fc27.5.noarch
    > texlive-updmap-map-svn41159-36.fc27.5.noarch
    > texlive-url-svn32528.3.4-36.fc27.5.noarch
    > texlive-utopia-svn15878.0-36.fc27.5.noarch
    > texlive-varwidth-svn24104.0.92-36.fc27.5.noarch
    > texlive-wasy2-ps-svn35830.0-36.fc27.5.noarch
    > texlive-wasy-svn35831.0-36.fc27.5.noarch
    > texlive-wasysym-svn15878.2.0-36.fc27.5.noarch
    > texlive-xcolor-svn41044-36.fc27.5.noarch
    > texlive-xdvi-bin-svn40750-36.20160520.fc27.5.x86_64
    > texlive-xdvi-svn40768-36.fc27.5.noarch
    > texlive-xetex-bin-svn41091-36.20160520.fc27.5.x86_64
    > texlive-xetexconfig-svn41133-36.fc27.5.noarch
    > texlive-xetex-def-svn40327-36.fc27.5.noarch
    > texlive-xetex-svn41438-36.fc27.5.noarch
    > texlive-xkeyval-svn35741.2.7a-36.fc27.5.noarch
    > texlive-xunicode-svn30466.0.981-36.fc27.5.noarch
    > texlive-zapfchan-svn31835.0-36.fc27.5.noarch
    > texlive-zapfding-svn31835.0-36.fc27.5.noarch
    > zziplib-0.13.68-1.fc27.x86_64
    
    • Note: the package ImageMagick whose installation we planned to perform later, got installed by product

  • Installed executables: More... Close
    package executable(s)
    a2ps-4.14-32.fc27.x86_64 /usr/bin/a2ps
    /usr/bin/card
    /usr/bin/composeglyphs
    /usr/bin/fixnt
    /usr/bin/fixps
    /usr/bin/ogonkify
    /usr/bin/pdiff
    /usr/bin/psmandup
    /usr/bin/psset
    /usr/bin/texi2dvi4a2ps
    groff-perl-1.22.3-14.fc27.x86_64 /usr/bin/afmtodit
    /usr/bin/chem
    /usr/bin/glilypond
    /usr/bin/gperl
    /usr/bin/gpinyin
    /usr/bin/groffer
    /usr/bin/grog
    /usr/bin/gropdf
    /usr/bin/mmroff
    /usr/bin/pdfmom
    /usr/bin/roff2dvi
    /usr/bin/roff2html
    /usr/bin/roff2pdf
    /usr/bin/roff2ps
    /usr/bin/roff2text
    /usr/bin/roff2x
    html2ps-1.0-0.27.b7.fc27.noarch /usr/bin/html2ps
    ImageMagick-6.9.9.38-1.fc27.x86_64 /usr/bin/animate
    /usr/bin/compare
    /usr/bin/composite
    /usr/bin/conjure
    /usr/bin/convert
    /usr/bin/display
    /usr/bin/identify
    /usr/bin/import
    /usr/bin/mogrify
    /usr/bin/montage
    /usr/bin/stream
    latex2html-2017.2-3.fc27.noarch /usr/bin/jlatex2html
    /usr/bin/jpstoimg
    /usr/bin/jtexexpand
    /usr/bin/latex2html
    /usr/bin/pstoimg
    /usr/bin/texexpand
    libpaper-1.1.24-21.fc27.x86_64 /usr/bin/paperconf
    /usr/sbin/paperconfig
    netpbm-progs-10.81.00-1.fc27.x86_64 /usr/bin/411toppm
    /usr/bin/anytopnm
    /usr/bin/asciitopgm
    /usr/bin/atktopbm
    /usr/bin/avstopam
    /usr/bin/bioradtopgm
    /usr/bin/bmptopnm
    /usr/bin/bmptoppm
    /usr/bin/brushtopbm
    /usr/bin/cameratopam
    /usr/bin/cistopbm
    /usr/bin/cmuwmtopbm
    /usr/bin/ddbugtopbm
    /usr/bin/escp2topbm
    /usr/bin/eyuvtoppm
    /usr/bin/fiascotopnm
    /usr/bin/fitstopnm
    /usr/bin/fstopgm
    /usr/bin/g3topbm
    /usr/bin/gemtopbm
    /usr/bin/gemtopnm
    /usr/bin/giftopnm
    /usr/bin/gouldtoppm
    /usr/bin/hdifftopam
    /usr/bin/hipstopgm
    /usr/bin/hpcdtoppm
    /usr/bin/icontopbm
    /usr/bin/ilbmtoppm
    /usr/bin/imgtoppm
    /usr/bin/infotopam
    /usr/bin/jbigtopnm
    /usr/bin/jpeg2ktopam
    /usr/bin/jpegtopnm
    /usr/bin/leaftoppm
    /usr/bin/lispmtopgm
    /usr/bin/macptopbm
    /usr/bin/manweb
    /usr/bin/mdatopbm
    /usr/bin/mgrtopbm
    /usr/bin/mrftopbm
    /usr/bin/mtvtoppm
    /usr/bin/neotoppm
    /usr/bin/palmtopnm
    /usr/bin/pamaddnoise
    /usr/bin/pamarith
    /usr/bin/pambackground
    /usr/bin/pambayer
    /usr/bin/pamchannel
    /usr/bin/pamcomp
    /usr/bin/pamcrater
    /usr/bin/pamcut
    /usr/bin/pamdeinterlace
    /usr/bin/pamdepth
    /usr/bin/pamdice
    /usr/bin/pamditherbw
    /usr/bin/pamedge
    /usr/bin/pamendian
    /usr/bin/pamenlarge
    /usr/bin/pamexec
    /usr/bin/pamfile
    /usr/bin/pamfix
    /usr/bin/pamfixtrunc
    /usr/bin/pamflip
    /usr/bin/pamfunc
    /usr/bin/pamgauss
    /usr/bin/pamgradient
    /usr/bin/pamlookup
    /usr/bin/pammasksharpen
    /usr/bin/pammixinterlace
    /usr/bin/pammosaicknit
    /usr/bin/pamoil
    /usr/bin/pampaintspill
    /usr/bin/pamperspective
    /usr/bin/pampick
    /usr/bin/pampop9
    /usr/bin/pamrecolor
    /usr/bin/pamrgbatopng
    /usr/bin/pamrubber
    /usr/bin/pamscale
    /usr/bin/pamseq
    /usr/bin/pamshadedrelief
    /usr/bin/pamsharpmap
    /usr/bin/pamsharpness
    /usr/bin/pamsistoaglyph
    /usr/bin/pamslice
    /usr/bin/pamsplit
    /usr/bin/pamstack
    /usr/bin/pamstereogram
    /usr/bin/pamstretch
    /usr/bin/pamstretch-gen
    /usr/bin/pamsumm
    /usr/bin/pamsummcol
    /usr/bin/pamtable
    /usr/bin/pamthreshold
    /usr/bin/pamtilt
    /usr/bin/pamtoavs
    /usr/bin/pamtodjvurle
    /usr/bin/pamtofits
    /usr/bin/pamtogif
    /usr/bin/pamtohdiff
    /usr/bin/pamtohtmltbl
    /usr/bin/pamtojpeg2k
    /usr/bin/pamtompfont
    /usr/bin/pamtooctaveimg
    /usr/bin/pamtopam
    /usr/bin/pamtopdbimg
    /usr/bin/pamtopfm
    /usr/bin/pamtopng
    /usr/bin/pamtopnm
    /usr/bin/pamtosrf
    /usr/bin/pamtosvg
    /usr/bin/pamtotga
    /usr/bin/pamtotiff
    /usr/bin/pamtouil
    /usr/bin/pamtowinicon
    /usr/bin/pamtoxvmini
    /usr/bin/pamundice
    /usr/bin/pamunlookup
    /usr/bin/pamvalidate
    /usr/bin/pamwipeout
    /usr/bin/pamx
    /usr/bin/pbmclean
    /usr/bin/pbmlife
    /usr/bin/pbmmake
    /usr/bin/pbmmask
    /usr/bin/pbmminkowski
    /usr/bin/pbmpage
    /usr/bin/pbmpscale
    /usr/bin/pbmreduce
    /usr/bin/pbmtext
    /usr/bin/pbmtextps
    /usr/bin/pbmto10x
    /usr/bin/pbmto4425
    /usr/bin/pbmtoascii
    /usr/bin/pbmtoatk
    /usr/bin/pbmtobbnbg
    /usr/bin/pbmtocis
    /usr/bin/pbmtocmuwm
    /usr/bin/pbmtodjvurle
    /usr/bin/pbmtoepsi
    /usr/bin/pbmtoepson
    /usr/bin/pbmtoescp2
    /usr/bin/pbmtog3
    /usr/bin/pbmtogem
    /usr/bin/pbmtogo
    /usr/bin/pbmtoibm23xx
    /usr/bin/pbmtoicon
    /usr/bin/pbmtolj
    /usr/bin/pbmtoln03
    /usr/bin/pbmtolps
    /usr/bin/pbmtomacp
    /usr/bin/pbmtomatrixorbital
    /usr/bin/pbmtomda
    /usr/bin/pbmtomgr
    /usr/bin/pbmtomrf
    /usr/bin/pbmtonokia
    /usr/bin/pbmtopgm
    /usr/bin/pbmtopi3
    /usr/bin/pbmtopk
    /usr/bin/pbmtoplot
    /usr/bin/pbmtoppa
    /usr/bin/pbmtopsg3
    /usr/bin/pbmtoptx
    /usr/bin/pbmtosunicon
    /usr/bin/pbmtowbmp
    /usr/bin/pbmtox10bm
    /usr/bin/pbmtoxbm
    /usr/bin/pbmtoybm
    /usr/bin/pbmtozinc
    /usr/bin/pbmupc
    /usr/bin/pc1toppm
    /usr/bin/pcdovtoppm
    /usr/bin/pcxtoppm
    /usr/bin/pdbimgtopam
    /usr/bin/pfmtopam
    /usr/bin/pgmabel
    /usr/bin/pgmbentley
    /usr/bin/pgmcrater
    /usr/bin/pgmdeshadow
    /usr/bin/pgmedge
    /usr/bin/pgmenhance
    /usr/bin/pgmhist
    /usr/bin/pgmkernel
    /usr/bin/pgmmake
    /usr/bin/pgmmedian
    /usr/bin/pgmminkowski
    /usr/bin/pgmmorphconv
    /usr/bin/pgmnoise
    /usr/bin/pgmnorm
    /usr/bin/pgmoil
    /usr/bin/pgmramp
    /usr/bin/pgmslice
    /usr/bin/pgmtexture
    /usr/bin/pgmtofs
    /usr/bin/pgmtolispm
    /usr/bin/pgmtopbm
    /usr/bin/pgmtopgm
    /usr/bin/pgmtoppm
    /usr/bin/pgmtosbig
    /usr/bin/pgmtost4
    /usr/bin/pi1toppm
    /usr/bin/pi3topbm
    /usr/bin/pjtoppm
    /usr/bin/pktopbm
    /usr/bin/pngtopam
    /usr/bin/pngtopnm
    /usr/bin/pnmalias
    /usr/bin/pnmarith
    /usr/bin/pnmcat
    /usr/bin/pnmcolormap
    /usr/bin/pnmcomp
    /usr/bin/pnmconvol
    /usr/bin/pnmcrop
    /usr/bin/pnmcut
    /usr/bin/pnmdepth
    /usr/bin/pnmenlarge
    /usr/bin/pnmfile
    /usr/bin/pnmflip
    /usr/bin/pnmgamma
    /usr/bin/pnmhisteq
    /usr/bin/pnmhistmap
    /usr/bin/pnmindex
    /usr/bin/pnminterp
    /usr/bin/pnminvert
    /usr/bin/pnmmargin
    /usr/bin/pnmmercator
    /usr/bin/pnmmontage
    /usr/bin/pnmnlfilt
    /usr/bin/pnmnoraw
    /usr/bin/pnmnorm
    /usr/bin/pnmpad
    /usr/bin/pnmpaste
    /usr/bin/pnmpsnr
    /usr/bin/pnmquant
    /usr/bin/pnmquantall
    /usr/bin/pnmremap
    /usr/bin/pnmrotate
    /usr/bin/pnmscale
    /usr/bin/pnmscalefixed
    /usr/bin/pnmshear
    /usr/bin/pnmsmooth
    /usr/bin/pnmsplit
    /usr/bin/pnmstitch
    /usr/bin/pnmtile
    /usr/bin/pnmtoddif
    /usr/bin/pnmtofiasco
    /usr/bin/pnmtofits
    /usr/bin/pnmtojbig
    /usr/bin/pnmtojpeg
    /usr/bin/pnmtopalm
    /usr/bin/pnmtopclxl
    /usr/bin/pnmtoplainpnm
    /usr/bin/pnmtopng
    /usr/bin/pnmtopnm
    /usr/bin/pnmtops
    /usr/bin/pnmtorast
    /usr/bin/pnmtorle
    /usr/bin/pnmtosgi
    /usr/bin/pnmtosir
    /usr/bin/pnmtotiff
    /usr/bin/pnmtotiffcmyk
    /usr/bin/pnmtoxwd
    /usr/bin/ppm3d
    /usr/bin/ppmbrighten
    /usr/bin/ppmchange
    /usr/bin/ppmcie
    /usr/bin/ppmcolormask
    /usr/bin/ppmcolors
    /usr/bin/ppmdcfont
    /usr/bin/ppmddumpfont
    /usr/bin/ppmdim
    /usr/bin/ppmdist
    /usr/bin/ppmdither
    /usr/bin/ppmdmkfont
    /usr/bin/ppmdraw
    /usr/bin/ppmfade
    /usr/bin/ppmflash
    /usr/bin/ppmforge
    /usr/bin/ppmglobe
    /usr/bin/ppmhist
    /usr/bin/ppmlabel
    /usr/bin/ppmmake
    /usr/bin/ppmmix
    /usr/bin/ppmnorm
    /usr/bin/ppmntsc
    /usr/bin/ppmpat
    /usr/bin/ppmquant
    /usr/bin/ppmquantall
    /usr/bin/ppmrainbow
    /usr/bin/ppmrelief
    /usr/bin/ppmrough
    /usr/bin/ppmshadow
    /usr/bin/ppmshift
    /usr/bin/ppmspread
    /usr/bin/ppmtoacad
    /usr/bin/ppmtoapplevol
    /usr/bin/ppmtoarbtxt
    /usr/bin/ppmtoascii
    /usr/bin/ppmtobmp
    /usr/bin/ppmtoeyuv
    /usr/bin/ppmtogif
    /usr/bin/ppmtoicr
    /usr/bin/ppmtoilbm
    /usr/bin/ppmtojpeg
    /usr/bin/ppmtoleaf
    /usr/bin/ppmtolj
    /usr/bin/ppmtomap
    /usr/bin/ppmtomitsu
    /usr/bin/ppmtoneo
    /usr/bin/ppmtopcx
    /usr/bin/ppmtopgm
    /usr/bin/ppmtopi1
    /usr/bin/ppmtopict
    /usr/bin/ppmtopj
    /usr/bin/ppmtopjxl
    /usr/bin/ppmtoppm
    /usr/bin/ppmtopuzz
    /usr/bin/ppmtorgb3
    /usr/bin/ppmtosixel
    /usr/bin/ppmtospu
    /usr/bin/ppmtoterm
    /usr/bin/ppmtotga
    /usr/bin/ppmtouil
    /usr/bin/ppmtowinicon
    /usr/bin/ppmtoxpm
    /usr/bin/ppmtoyuv
    /usr/bin/ppmtoyuvsplit
    /usr/bin/ppmtv
    /usr/bin/ppmwheel
    /usr/bin/psidtopgm
    /usr/bin/pstopnm
    /usr/bin/qrttoppm
    /usr/bin/rasttopnm
    /usr/bin/rawtopgm
    /usr/bin/rawtoppm
    /usr/bin/rgb3toppm
    /usr/bin/rlatopam
    /usr/bin/rletopnm
    /usr/bin/sbigtopgm
    /usr/bin/sgitopnm
    /usr/bin/sirtopnm
    /usr/bin/sldtoppm
    /usr/bin/spctoppm
    /usr/bin/spottopgm
    /usr/bin/sputoppm
    /usr/bin/srftopam
    /usr/bin/st4topgm
    /usr/bin/sunicontopnm
    /usr/bin/svgtopam
    /usr/bin/tgatoppm
    /usr/bin/thinkjettopbm
    /usr/bin/tifftopnm
    /usr/bin/wbmptopbm
    /usr/bin/winicontopam
    /usr/bin/winicontoppm
    /usr/bin/xbmtopbm
    /usr/bin/ximtoppm
    /usr/bin/xpmtoppm
    /usr/bin/xvminitoppm
    /usr/bin/xwdtopnm
    /usr/bin/ybmtopbm
    /usr/bin/yuvsplittoppm
    /usr/bin/yuvtoppm
    /usr/bin/yuy2topam
    /usr/bin/zeisstopnm
    perl-Digest-SHA-6.02-1.fc27.x86_64 /usr/bin/shasum
    perl-IO-Compress-2.074-395.fc27.noarch /usr/bin/zipdetails
    perl-libwww-perl-6.33-1.fc27.noarch /usr/bin/GET
    /usr/bin/HEAD
    /usr/bin/POST
    /usr/bin/lwp-download
    /usr/bin/lwp-dump
    /usr/bin/lwp-mirror
    /usr/bin/lwp-request
    perl-Tk-804.034-1.fc27.x86_64 /usr/bin/ptked
    /usr/bin/ptksh
    /usr/bin/tkjpeg
    perl-XML-XPath-1.42-1.fc27.noarch /usr/bin/xpath
    psutils-1.23-12.fc27.x86_64 /usr/bin/epsffit
    /usr/bin/psbook
    /usr/bin/psnup
    /usr/bin/psresize
    /usr/bin/psselect
    /usr/bin/pstops
    psutils-perl-1.23-12.fc27.noarch /usr/bin/extractres
    /usr/bin/includeres
    /usr/bin/psjoin
    ruby-2.4.3-87.fc27.x86_64 /usr/bin/erb
    /usr/bin/ruby-mri
    rubygem-rdoc-5.1.0-3.fc27.noarch /usr/bin/rdoc
    /usr/bin/ri
    rubygems-2.6.14.1-87.fc27.noarch /usr/bin/gem
    ruby-irb-2.4.3-87.fc27.noarch /usr/bin/irb
    rubypick-1.1.1-7.fc27.noarch /usr/bin/ruby
    teckit-2.5.1-18.fc27.x86_64 /usr/bin/sfconv
    /usr/bin/teckit_compile
    /usr/bin/txtconv
    texinfo-6.4-6.fc27.x86_64 /usr/bin/makeinfo
    /usr/bin/pod2texi
    /usr/bin/texi2any
    texinfo-tex-6.4-6.fc27.x86_64 /usr/bin/pdftexi2dvi
    /usr/bin/texi2dvi
    /usr/bin/texi2pdf
    /usr/bin/texindex
    texlive-bibtex-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/bibtex
    texlive-context-bin-svn34112.0-36.20160520.fc27.5.noarch /usr/bin/context
    /usr/bin/contextjit
    /usr/bin/luatools
    /usr/bin/mtxrun
    /usr/bin/mtxrunjit
    /usr/bin/texexec
    /usr/bin/texmfstart
    texlive-dvipdfmx-bin-svn40273-36.20160520.fc27.5.x86_64 /usr/bin/dvipdfm
    /usr/bin/dvipdfmx
    /usr/bin/dvipdft
    /usr/bin/ebb
    /usr/bin/extractbb
    texlive-dvips-bin-svn40987-36.20160520.fc27.5.x86_64 /usr/bin/afm2tfm
    /usr/bin/dvips
    texlive-gsftopk-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/gsftopk
    texlive-kpathsea-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/kpseaccess
    /usr/bin/kpsereadlink
    /usr/bin/kpsestat
    /usr/bin/kpsewhich
    /usr/bin/mkocp
    /usr/bin/mkofm
    /usr/bin/mktexfmt
    /usr/bin/mktexlsr
    /usr/bin/mktexmf
    /usr/bin/mktexpk
    /usr/bin/mktextfm
    /usr/bin/texhash
    texlive-latex-bin-bin-svn14050.0-36.20160520.fc27.5.noarch /usr/bin/dvilualatex
    /usr/bin/latex
    /usr/bin/lualatex
    /usr/bin/pdflatex
    texlive-luaotfload-bin-svn34647.0-36.20160520.fc27.5.noarch /usr/bin/luaotfload-tool
    texlive-luatex-bin-svn41091-36.20160520.fc27.5.x86_64 /usr/bin/dviluatex
    /usr/bin/luajittex
    /usr/bin/luatex
    /usr/bin/texlua
    /usr/bin/texluac
    /usr/bin/texluajit
    /usr/bin/texluajitc
    texlive-makeindex-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/makeindex
    /usr/bin/mkindex
    texlive-metafont-bin-svn40987-36.20160520.fc27.5.x86_64 /usr/bin/inimf
    /usr/bin/mf
    /usr/bin/mf-nowin
    texlive-metapost-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/dvitomp
    /usr/bin/mfplain
    /usr/bin/mpost
    texlive-mfware-bin-svn40473-36.20160520.fc27.5.x86_64 /usr/bin/gftodvi
    /usr/bin/gftopk
    /usr/bin/gftype
    /usr/bin/mft
    /usr/bin/pktogf
    /usr/bin/pktype
    texlive-mptopdf-bin-svn18674.0-36.20160520.fc27.5.noarch /usr/bin/mptopdf
    texlive-pdftex-bin-svn40987-36.20160520.fc27.5.x86_64 /usr/bin/etex
    /usr/bin/pdfetex
    /usr/bin/pdftex
    /usr/bin/simpdftex
    texlive-pst-pdf-bin-svn7838.0-36.20160520.fc27.5.noarch /usr/bin/ps4pdf
    texlive-tetex-bin-svn36770.0-36.20160520.fc27.5.noarch /usr/bin/allcm
    /usr/bin/allec
    /usr/bin/allneeded
    /usr/bin/dvi2fax
    /usr/bin/dvired
    /usr/bin/fmtutil
    /usr/bin/fmtutil-sys
    /usr/bin/kpsepath
    /usr/bin/kpsetool
    /usr/bin/kpsewhere
    /usr/bin/kpsexpand
    /usr/bin/texconfig-dialog
    /usr/bin/texconfig-sys
    /usr/bin/texlinks
    /usr/bin/updmap
    /usr/bin/updmap-sys
    texlive-tex-bin-svn40987-36.20160520.fc27.5.x86_64 /usr/bin/initex
    /usr/bin/tex
    texlive-texconfig-bin-svn29741.0-36.20160520.fc27.5.noarch /usr/bin/texconfig
    texlive-texlive.infra-bin-svn40312-36.20160520.fc27.5.x86_64  
    texlive-texlive-scripts-bin-svn29741.0-36.20160520.fc27.5.noarch /usr/bin/rungs
    texlive-thumbpdf-bin-svn6898.0-36.20160520.fc27.5.noarch /usr/bin/thumbpdf
    texlive-xdvi-bin-svn40750-36.20160520.fc27.5.x86_64 /usr/bin/xdvi
    /usr/bin/xdvi-xaw
    texlive-xetex-bin-svn41091-36.20160520.fc27.5.x86_64 /usr/bin/xdvipdfmx
    /usr/bin/xelatex
    /usr/bin/xetex

  42. (19.05.18) Installing a bunch of miscellaneous popular programs

  • The command:
    [root] /home/fedotov/tm/dnf $ \
    dnf -y install \
             calc \
             gcc-c++ boost boost-doc \
             recode \
             seamonkey \
             digikam digikam-doc gimp jhead \
             antiword abiword \
             gedit \
             unrar \
             xv xv-doc \
             xfig gnuplot gnuplot-doc \
             fuse-exfat exfat-utils \
             simple-mtpfs \
             gv psutils enscript  \
             xmms \
             aspell aspell-en aspell-ru \
             alpine \
             ncompress \
             xmp \
             evince \
             xpdf qpdf pdfmod pdfshuffler pdfmerge \
             cabextract \
             gparted \
             conky \
             meld \
             colordiff \
             iotop \
             highlight highlight-gui \
    2>&1 | tee dnf.misc_pop
    
    stdout: More... Close
    Last metadata expiration check: 0:21:42 ago on Sat 19 May 2018 02:23:35 AM MSK.
    Package psutils-1.23-12.fc27.x86_64 is already installed, skipping.
    Dependencies resolved.
    ================================================================================
     Package                Arch   Version                            Repository
                                                                               Size
    ================================================================================
    Installing:
     abiword                x86_64 1:3.0.2-8.fc27                     fedora  681 k
     alpine                 x86_64 2.21-4.fc27                        updates 2.4 M
     antiword               x86_64 0.37-22.fc27                       fedora  157 k
     aspell                 x86_64 12:0.60.6.1-18.fc27                fedora  666 k
     aspell-en              x86_64 50:2015.04.24-5.fc27               fedora  1.1 M
     aspell-ru              x86_64 50:0.99f7-19.fc27                  fedora  2.0 M
     boost                  x86_64 1.64.0-6.fc27                      updates  49 k
     boost-doc              x86_64 1.64.0-6.fc27                      updates  34 M
     cabextract             x86_64 1.5-7.fc27                         fedora   48 k
     calc                   x86_64 2.12.6.0-3.fc27                    fedora  366 k
     colordiff              noarch 1.0.18-2.fc27                      fedora   32 k
     conky                  x86_64 1.10.7-1.fc27                      updates 359 k
     digikam                x86_64 5.9.0-1.fc27                       updates  75 M
     digikam-doc            noarch 5.9.0-1.fc27                       updates  22 M
     enscript               x86_64 1.6.6-12.fc27                      fedora  433 k
     evince                 x86_64 3.26.0-2.fc27                      updates 2.2 M
     exfat-utils            x86_64 1.2.8-1.fc27                       rpmfusion-free-updates
                                                                               64 k
     fuse-exfat             x86_64 1.2.8-1.fc27                       rpmfusion-free-updates
                                                                               44 k
     gcc-c++                x86_64 7.3.1-5.fc27                       updates  11 M
     gedit                  x86_64 2:3.22.1-2.fc27                    fedora  2.4 M
     gimp                   x86_64 2:2.8.22-3.fc27                    updates  15 M
     gnuplot                x86_64 5.0.6-5.fc27                       fedora  824 k
     gnuplot-doc            noarch 5.0.6-5.fc27                       fedora  1.4 M
     gparted                x86_64 0.31.0-1.fc27                      updates 2.0 M
     gv                     x86_64 3.7.4-14.fc27                      fedora  242 k
     highlight              x86_64 3.42-1.fc27                        updates 776 k
     highlight-gui          x86_64 3.42-1.fc27                        updates 538 k
     iotop                  noarch 0.6-15.fc27                        fedora   65 k
     jhead                  x86_64 3.00-7.fc27                        updates  63 k
     meld                   noarch 3.18.0-1.fc27                      fedora  774 k
     ncompress              x86_64 4.2.4.4-9.fc27                     fedora   31 k
     pdfmerge               noarch 1.0.6-1.fc27                       updates  21 k
     pdfmod                 x86_64 0.9.1-17.fc27                      fedora  724 k
     pdfshuffler            noarch 0.6.0-11.fc27                      fedora   69 k
     qpdf                   x86_64 7.1.1-5.fc27                       updates  56 k
     recode                 x86_64 3.6-46.fc27                        fedora  723 k
     seamonkey              x86_64 2.49.3-1.fc27                      updates  65 M
     simple-mtpfs           x86_64 0.2-10.fc27                        fedora   70 k
     unrar                  x86_64 5.6.3-1.fc27                       rpmfusion-nonfree-updates
                                                                              156 k
     xfig                   x86_64 3.2.6a-7.fc27                      updates 5.4 M
     xmms                   x86_64 1:1.2.11-32.20071117cvs.fc27       fedora  1.0 M
     xmp                    x86_64 4.1.0-5.fc27                       fedora   69 k
     xpdf                   x86_64 1:4.00-5.fc27                      updates 2.7 M
     xv                     x86_64 3.10a.jumbopatch.20070520-27.fc27  rpmfusion-nonfree-updates
                                                                              588 k
     xv-doc                 noarch 3.10a.jumbopatch.20070520-27.fc27  rpmfusion-nonfree-updates
                                                                              2.1 M
    Installing dependencies:
     ORBit2                 x86_64 2.14.19-18.fc27                    fedora  182 k
     SuperLU                x86_64 5.2.0-4.fc27                       fedora  191 k
     Xaw3d                  x86_64 1.6.2-12.fc27                      fedora  177 k
     aiksaurus              x86_64 1:1.2.1-37.fc27                    fedora  329 k
     armadillo              x86_64 7.900.1-3.fc27                     fedora   29 k
     arpack                 x86_64 3.5.0-4.fc27                       fedora  191 k
     atlas                  x86_64 3.10.3-1.fc27                      fedora  6.4 M
     babl                   x86_64 0.1.46-1.fc27                      updates 308 k
     binutils               x86_64 2.29-13.fc27                       updates 5.9 M
     blas                   x86_64 3.8.0-7.fc27                       updates 427 k
     boost-container        x86_64 1.64.0-6.fc27                      updates  80 k
     boost-context          x86_64 1.64.0-6.fc27                      updates  53 k
     boost-coroutine        x86_64 1.64.0-6.fc27                      updates  65 k
     boost-fiber            x86_64 1.64.0-6.fc27                      updates  76 k
     boost-graph            x86_64 1.64.0-6.fc27                      updates 144 k
     boost-locale           x86_64 1.64.0-6.fc27                      updates 283 k
     boost-log              x86_64 1.64.0-6.fc27                      updates 465 k
     boost-math             x86_64 1.64.0-6.fc27                      updates 301 k
     boost-numpy            x86_64 1.64.0-6.fc27                      updates  62 k
     boost-program-options  x86_64 1.64.0-6.fc27                      updates 172 k
     boost-python           x86_64 1.64.0-6.fc27                      updates 129 k
     boost-random           x86_64 1.64.0-6.fc27                      updates  57 k
     boost-regex            x86_64 1.64.0-6.fc27                      updates 303 k
     boost-serialization    x86_64 1.64.0-6.fc27                      updates 156 k
     boost-signals          x86_64 1.64.0-6.fc27                      updates  75 k
     boost-test             x86_64 1.64.0-6.fc27                      updates 270 k
     boost-timer            x86_64 1.64.0-6.fc27                      updates  56 k
     boost-type_erasure     x86_64 1.64.0-6.fc27                      updates  65 k
     boost-wave             x86_64 1.64.0-6.fc27                      updates 227 k
     calc-libs              x86_64 2.12.6.0-3.fc27                    fedora  421 k
     cfitsio                x86_64 3.370-10.fc27                      fedora  545 k
     cpp                    x86_64 7.3.1-5.fc27                       updates 9.4 M
     dcraw                  x86_64 9.27.0-5.fc27                      fedora  263 k
     digikam-libs           x86_64 5.9.0-1.fc27                       updates 8.0 M
     eosrei-emojione-fonts  noarch 1.0-5.fc27                         fedora  2.5 M
     esmtp                  x86_64 1.2-9.fc27                         updates  57 k
     evince-libs            x86_64 3.26.0-2.fc27                      updates 398 k
     freexl                 x86_64 1.0.5-1.fc27                       updates  37 k
     gcc                    x86_64 7.3.1-5.fc27                       updates  21 M
     gdal-libs              x86_64 2.1.4-5.1.fc27                     updates 5.7 M
     gegl                   x86_64 0.2.0-34.fc27                      fedora  784 k
     geos                   x86_64 3.6.1-4.fc27                       fedora  566 k
     gimp-libs              x86_64 2:2.8.22-3.fc27                    updates 1.4 M
     glib                   x86_64 1:1.2.10-50.fc27                   fedora  147 k
     gnome-desktop3         x86_64 3.26.2-1.fc27                      updates 564 k
     gnome-sharp            x86_64 2.24.2-13.fc26                     fedora  315 k
     gnome-themes-standard  x86_64 3.22.3-5.fc27                      updates 2.7 M
     gnome-vfs2             x86_64 2.24.4-25.fc27                     fedora  394 k
     gnome-vfs2-common      noarch 2.24.4-25.fc27                     fedora  419 k
     gnuplot-common         x86_64 5.0.6-5.fc27                       fedora  643 k
     goffice                x86_64 0.10.39-1.fc27                     updates 1.9 M
     gspell                 x86_64 1.6.1-1.fc27                       updates  95 k
     gtk+                   x86_64 1:1.2.10-85.fc27                   fedora  874 k
     gtk-sharp2             x86_64 2.12.45-3.fc27                     fedora  708 k
     gtkmathview            x86_64 0.8.0-19.fc23                      fedora  648 k
     gtksourceview3         x86_64 3.24.6-1.fc27                      updates 854 k
     gvfs                   x86_64 1.34.2.1-1.fc27                    updates 375 k
     gvfs-client            x86_64 1.34.2.1-1.fc27                    updates 805 k
     hyena                  x86_64 0.5-17.fc27                        fedora  354 k
     imlib2                 x86_64 1.4.9-4.fc27                       fedora  218 k
     isl                    x86_64 0.16.1-3.fc27                      fedora  835 k
     lapack                 x86_64 3.8.0-7.fc27                       updates 8.6 M
     lasem                  x86_64 0.4.3-7.fc27                       fedora  224 k
     lensfun                x86_64 0.3.2-11.fc27                      fedora  248 k
     leptonica              x86_64 1.74.4-5.fc27                      updates 1.0 M
     libIDL                 x86_64 0.8.14-14.fc27                     fedora   90 k
     libabiword             x86_64 1:3.0.2-8.fc27                     fedora  5.3 M
     libart_lgpl            x86_64 2.3.21-18.fc27                     fedora   73 k
     libbonobo              x86_64 2.32.1-13.fc27                     fedora  446 k
     libbonoboui            x86_64 2.24.5-13.fc27                     fedora  348 k
     libcanberra-gtk2       x86_64 0.30-15.fc27                       fedora   31 k
     libcanberra-gtk3       x86_64 0.30-15.fc27                       fedora   37 k
     libdap                 x86_64 3.18.3-4.fc27                      fedora  613 k
     libesmtp               x86_64 1.0.6-13.fc27                      fedora   66 k
     libgdiplus             x86_64 5.6-1.fc27                         updates 182 k
     libgeotiff             x86_64 1.4.0-11.fc27                      fedora  715 k
     libglade2              x86_64 2.6.4-17.fc27                      fedora   68 k
     libgnome               x86_64 2.32.1-15.fc27                     fedora  747 k
     libgnome-keyring       x86_64 3.12.0-10.fc27                     fedora  114 k
     libgnomecanvas         x86_64 2.30.3-14.fc27                     fedora  233 k
     libgnomeui             x86_64 2.24.5-16.fc27                     fedora  798 k
     libgsf                 x86_64 1.14.41-4.fc27                     fedora  245 k
     libgta                 x86_64 1.0.7-6.fc27                       fedora   38 k
     libgxps                x86_64 0.3.0-4.fc27                       updates  75 k
     libjpeg-turbo-utils    x86_64 1.5.3-1.fc27                       updates  88 k
     libkml                 x86_64 1.3.0-8.fc27                       fedora  333 k
     liblqr-1               x86_64 0.4.2-9.fc27                       fedora   50 k
     libmikmod              x86_64 3.3.11.1-1.fc27                    updates 152 k
     libmpc                 x86_64 1.0.2-8.fc27                       fedora   56 k
     libopenraw             x86_64 0.1.2-3.fc27                       fedora  185 k
     libpeas                x86_64 1.22.0-1.fc27                      fedora  119 k
     libpeas-gtk            x86_64 1.22.0-1.fc27                      fedora   35 k
     libpeas-loader-python3 x86_64 1.22.0-1.fc27                      fedora   26 k
     libspatialite          x86_64 4.3.0a-6.fc27                      fedora  2.6 M
     libspiro               x86_64 20150131-6.fc27                    fedora   38 k
     libucil                x86_64 0.9.10-15.fc27                     fedora   75 k
     libunicap              x86_64 0.9.12-20.fc27                     fedora  125 k
     libwmf                 x86_64 0.2.8.4-53.fc27                    fedora  144 k
     libxmp                 x86_64 4.4.1-4.fc27                       fedora  285 k
     link-grammar           x86_64 5.5.0-1.fc27                       updates 2.1 M
     minisat2-libs          x86_64 2.2.1-4.fc27                       fedora   47 k
     mono-core              x86_64 4.8.0-12.fc27                      fedora   18 M
     mono-data              x86_64 4.8.0-12.fc27                      fedora  4.4 M
     mono-data-sqlite       x86_64 4.8.0-12.fc27                      fedora  103 k
     mono-extras            x86_64 4.8.0-12.fc27                      fedora  465 k
     mono-mvc               x86_64 4.8.0-12.fc27                      fedora  484 k
     mono-wcf               x86_64 4.8.0-12.fc27                      fedora  946 k
     mono-web               x86_64 4.8.0-12.fc27                      fedora  2.5 M
     mono-winforms          x86_64 4.8.0-12.fc27                      fedora  1.6 M
     netcdf                 x86_64 4.4.1.1-6.fc27                     fedora  744 k
     nunit                  x86_64 3.7.1-3.fc27                       fedora  396 k
     ogdi                   x86_64 3.2.0-3.fc27                       fedora  273 k
     openblas               x86_64 0.2.20-10.fc27                     updates 4.4 M
     openblas-openmp        x86_64 0.2.20-10.fc27                     updates 4.5 M
     openblas-threads       x86_64 0.2.20-10.fc27                     updates 4.5 M
     openblas-threads64_    x86_64 0.2.20-10.fc27                     updates 4.4 M
     opencv-contrib         x86_64 3.2.0-15.fc27                      updates 2.1 M
     opencv-core            x86_64 3.2.0-15.fc27                      updates 3.6 M
     openni                 x86_64 1.5.7.10-11.fc27                   fedora  390 k
     ots-libs               x86_64 0.5.0-15.fc27                      fedora   50 k
     pangox-compat          x86_64 0.0.2-10.fc27                      fedora   61 k
     patch                  x86_64 2.7.6-4.fc27                       updates 133 k
     poppler-glib           x86_64 0.57.0-8.fc27                      updates 149 k
     poppler-sharp          x86_64 0.0.3-16.fc27                      fedora   34 k
     postgresql-libs        x86_64 9.6.8-1.fc27                       updates 257 k
     pyPdf                  noarch 1.13-14.fc27                       fedora   73 k
     pygobject2             x86_64 2.28.6-19.fc27                     fedora  232 k
     pygtk2                 x86_64 2.24.0-18.fc27                     fedora  919 k
     pypoppler              x86_64 0.12.2-7.fc27                      fedora   32 k
     python2-nose           noarch 1.3.7-15.fc27                      fedora  267 k
     python2-numpy          x86_64 1:1.13.3-4.fc27                    updates 3.5 M
     sqlite                 x86_64 3.20.1-2.fc27                      updates 588 k
     suitesparse            x86_64 4.4.6-10.fc27                      fedora  1.0 M
     t1lib                  x86_64 5.1.2-21.fc27                      fedora  173 k
     tbb                    x86_64 2017.7-3.fc27                      fedora  138 k
     tesseract              x86_64 3.05.01-3.fc27                     fedora   11 M
     tinyxml                x86_64 2.6.2-14.fc27                      fedora   54 k
     tolua++                x86_64 1.0.93-21.fc27                     fedora   79 k
     unixODBC               x86_64 2.3.5-2.fc27                       updates 447 k
     uriparser              x86_64 0.8.5-1.fc27                       updates  57 k
     wv                     x86_64 1.2.9-16.fc27                      fedora  267 k
     xmms-libs              x86_64 1:1.2.11-32.20071117cvs.fc27       fedora  307 k
     xorg-x11-fonts-100dpi  noarch 7.5-18.fc27                        fedora  3.1 M
     xorg-x11-fonts-ISO8859-1-100dpi
                            noarch 7.5-18.fc27                        fedora  1.1 M
    Installing weak dependencies:
     calc-stdrc             x86_64 2.12.6.0-3.fc27                    fedora  213 k
     evince-djvu            x86_64 3.26.0-2.fc27                      updates  57 k
    
    Transaction Summary
    ================================================================================
    Install  191 Packages
    
    Total download size: 441 M
    Installed size: 1.3 G
    Downloading Packages:
    
    ...
    
    Total                                           1.3 MB/s | 441 MB     05:36     
    
    ...
    
    Installed:
      abiword.x86_64 1:3.0.2-8.fc27                                                 
      alpine.x86_64 2.21-4.fc27                                                     
      antiword.x86_64 0.37-22.fc27                                                  
      aspell.x86_64 12:0.60.6.1-18.fc27                                             
      aspell-en.x86_64 50:2015.04.24-5.fc27                                         
      aspell-ru.x86_64 50:0.99f7-19.fc27                                            
      boost.x86_64 1.64.0-6.fc27                                                    
      boost-doc.x86_64 1.64.0-6.fc27                                                
      cabextract.x86_64 1.5-7.fc27                                                  
      calc.x86_64 2.12.6.0-3.fc27                                                   
      colordiff.noarch 1.0.18-2.fc27                                                
      conky.x86_64 1.10.7-1.fc27                                                    
      digikam.x86_64 5.9.0-1.fc27                                                   
      digikam-doc.noarch 5.9.0-1.fc27                                               
      enscript.x86_64 1.6.6-12.fc27                                                 
      evince.x86_64 3.26.0-2.fc27                                                   
      exfat-utils.x86_64 1.2.8-1.fc27                                               
      fuse-exfat.x86_64 1.2.8-1.fc27                                                
      gcc-c++.x86_64 7.3.1-5.fc27                                                   
      gedit.x86_64 2:3.22.1-2.fc27                                                  
      gimp.x86_64 2:2.8.22-3.fc27                                                   
      gnuplot.x86_64 5.0.6-5.fc27                                                   
      gnuplot-doc.noarch 5.0.6-5.fc27                                               
      gparted.x86_64 0.31.0-1.fc27                                                  
      gv.x86_64 3.7.4-14.fc27                                                       
      highlight.x86_64 3.42-1.fc27                                                  
      highlight-gui.x86_64 3.42-1.fc27                                              
      iotop.noarch 0.6-15.fc27                                                      
      jhead.x86_64 3.00-7.fc27                                                      
      meld.noarch 3.18.0-1.fc27                                                     
      ncompress.x86_64 4.2.4.4-9.fc27                                               
      pdfmerge.noarch 1.0.6-1.fc27                                                  
      pdfmod.x86_64 0.9.1-17.fc27                                                   
      pdfshuffler.noarch 0.6.0-11.fc27                                              
      qpdf.x86_64 7.1.1-5.fc27                                                      
      recode.x86_64 3.6-46.fc27                                                     
      seamonkey.x86_64 2.49.3-1.fc27                                                
      simple-mtpfs.x86_64 0.2-10.fc27                                               
      unrar.x86_64 5.6.3-1.fc27                                                     
      xfig.x86_64 3.2.6a-7.fc27                                                     
      xmms.x86_64 1:1.2.11-32.20071117cvs.fc27                                      
      xmp.x86_64 4.1.0-5.fc27                                                       
      xpdf.x86_64 1:4.00-5.fc27                                                     
      xv.x86_64 3.10a.jumbopatch.20070520-27.fc27                                   
      xv-doc.noarch 3.10a.jumbopatch.20070520-27.fc27                               
      calc-stdrc.x86_64 2.12.6.0-3.fc27                                             
      evince-djvu.x86_64 3.26.0-2.fc27                                              
      ORBit2.x86_64 2.14.19-18.fc27                                                 
      SuperLU.x86_64 5.2.0-4.fc27                                                   
      Xaw3d.x86_64 1.6.2-12.fc27                                                    
      aiksaurus.x86_64 1:1.2.1-37.fc27                                              
      armadillo.x86_64 7.900.1-3.fc27                                               
      arpack.x86_64 3.5.0-4.fc27                                                    
      atlas.x86_64 3.10.3-1.fc27                                                    
      babl.x86_64 0.1.46-1.fc27                                                     
      binutils.x86_64 2.29-13.fc27                                                  
      blas.x86_64 3.8.0-7.fc27                                                      
      boost-container.x86_64 1.64.0-6.fc27                                          
      boost-context.x86_64 1.64.0-6.fc27                                            
      boost-coroutine.x86_64 1.64.0-6.fc27                                          
      boost-fiber.x86_64 1.64.0-6.fc27                                              
      boost-graph.x86_64 1.64.0-6.fc27                                              
      boost-locale.x86_64 1.64.0-6.fc27                                             
      boost-log.x86_64 1.64.0-6.fc27                                                
      boost-math.x86_64 1.64.0-6.fc27                                               
      boost-numpy.x86_64 1.64.0-6.fc27                                              
      boost-program-options.x86_64 1.64.0-6.fc27                                    
      boost-python.x86_64 1.64.0-6.fc27                                             
      boost-random.x86_64 1.64.0-6.fc27                                             
      boost-regex.x86_64 1.64.0-6.fc27                                              
      boost-serialization.x86_64 1.64.0-6.fc27                                      
      boost-signals.x86_64 1.64.0-6.fc27                                            
      boost-test.x86_64 1.64.0-6.fc27                                               
      boost-timer.x86_64 1.64.0-6.fc27                                              
      boost-type_erasure.x86_64 1.64.0-6.fc27                                       
      boost-wave.x86_64 1.64.0-6.fc27                                               
      calc-libs.x86_64 2.12.6.0-3.fc27                                              
      cfitsio.x86_64 3.370-10.fc27                                                  
      cpp.x86_64 7.3.1-5.fc27                                                       
      dcraw.x86_64 9.27.0-5.fc27                                                    
      digikam-libs.x86_64 5.9.0-1.fc27                                              
      eosrei-emojione-fonts.noarch 1.0-5.fc27                                       
      esmtp.x86_64 1.2-9.fc27                                                       
      evince-libs.x86_64 3.26.0-2.fc27                                              
      freexl.x86_64 1.0.5-1.fc27                                                    
      gcc.x86_64 7.3.1-5.fc27                                                       
      gdal-libs.x86_64 2.1.4-5.1.fc27                                               
      gegl.x86_64 0.2.0-34.fc27                                                     
      geos.x86_64 3.6.1-4.fc27                                                      
      gimp-libs.x86_64 2:2.8.22-3.fc27                                              
      glib.x86_64 1:1.2.10-50.fc27                                                  
      gnome-desktop3.x86_64 3.26.2-1.fc27                                           
      gnome-sharp.x86_64 2.24.2-13.fc26                                             
      gnome-themes-standard.x86_64 3.22.3-5.fc27                                    
      gnome-vfs2.x86_64 2.24.4-25.fc27                                              
      gnome-vfs2-common.noarch 2.24.4-25.fc27                                       
      gnuplot-common.x86_64 5.0.6-5.fc27                                            
      goffice.x86_64 0.10.39-1.fc27                                                 
      gspell.x86_64 1.6.1-1.fc27                                                    
      gtk+.x86_64 1:1.2.10-85.fc27                                                  
      gtk-sharp2.x86_64 2.12.45-3.fc27                                              
      gtkmathview.x86_64 0.8.0-19.fc23                                              
      gtksourceview3.x86_64 3.24.6-1.fc27                                           
      gvfs.x86_64 1.34.2.1-1.fc27                                                   
      gvfs-client.x86_64 1.34.2.1-1.fc27                                            
      hyena.x86_64 0.5-17.fc27                                                      
      imlib2.x86_64 1.4.9-4.fc27                                                    
      isl.x86_64 0.16.1-3.fc27                                                      
      lapack.x86_64 3.8.0-7.fc27                                                    
      lasem.x86_64 0.4.3-7.fc27                                                     
      lensfun.x86_64 0.3.2-11.fc27                                                  
      leptonica.x86_64 1.74.4-5.fc27                                                
      libIDL.x86_64 0.8.14-14.fc27                                                  
      libabiword.x86_64 1:3.0.2-8.fc27                                              
      libart_lgpl.x86_64 2.3.21-18.fc27                                             
      libbonobo.x86_64 2.32.1-13.fc27                                               
      libbonoboui.x86_64 2.24.5-13.fc27                                             
      libcanberra-gtk2.x86_64 0.30-15.fc27                                          
      libcanberra-gtk3.x86_64 0.30-15.fc27                                          
      libdap.x86_64 3.18.3-4.fc27                                                   
      libesmtp.x86_64 1.0.6-13.fc27                                                 
      libgdiplus.x86_64 5.6-1.fc27                                                  
      libgeotiff.x86_64 1.4.0-11.fc27                                               
      libglade2.x86_64 2.6.4-17.fc27                                                
      libgnome.x86_64 2.32.1-15.fc27                                                
      libgnome-keyring.x86_64 3.12.0-10.fc27                                        
      libgnomecanvas.x86_64 2.30.3-14.fc27                                          
      libgnomeui.x86_64 2.24.5-16.fc27                                              
      libgsf.x86_64 1.14.41-4.fc27                                                  
      libgta.x86_64 1.0.7-6.fc27                                                    
      libgxps.x86_64 0.3.0-4.fc27                                                   
      libjpeg-turbo-utils.x86_64 1.5.3-1.fc27                                       
      libkml.x86_64 1.3.0-8.fc27                                                    
      liblqr-1.x86_64 0.4.2-9.fc27                                                  
      libmikmod.x86_64 3.3.11.1-1.fc27                                              
      libmpc.x86_64 1.0.2-8.fc27                                                    
      libopenraw.x86_64 0.1.2-3.fc27                                                
      libpeas.x86_64 1.22.0-1.fc27                                                  
      libpeas-gtk.x86_64 1.22.0-1.fc27                                              
      libpeas-loader-python3.x86_64 1.22.0-1.fc27                                   
      libspatialite.x86_64 4.3.0a-6.fc27                                            
      libspiro.x86_64 20150131-6.fc27                                               
      libucil.x86_64 0.9.10-15.fc27                                                 
      libunicap.x86_64 0.9.12-20.fc27                                               
      libwmf.x86_64 0.2.8.4-53.fc27                                                 
      libxmp.x86_64 4.4.1-4.fc27                                                    
      link-grammar.x86_64 5.5.0-1.fc27                                              
      minisat2-libs.x86_64 2.2.1-4.fc27                                             
      mono-core.x86_64 4.8.0-12.fc27                                                
      mono-data.x86_64 4.8.0-12.fc27                                                
      mono-data-sqlite.x86_64 4.8.0-12.fc27                                         
      mono-extras.x86_64 4.8.0-12.fc27                                              
      mono-mvc.x86_64 4.8.0-12.fc27                                                 
      mono-wcf.x86_64 4.8.0-12.fc27                                                 
      mono-web.x86_64 4.8.0-12.fc27                                                 
      mono-winforms.x86_64 4.8.0-12.fc27                                            
      netcdf.x86_64 4.4.1.1-6.fc27                                                  
      nunit.x86_64 3.7.1-3.fc27                                                     
      ogdi.x86_64 3.2.0-3.fc27                                                      
      openblas.x86_64 0.2.20-10.fc27                                                
      openblas-openmp.x86_64 0.2.20-10.fc27                                         
      openblas-threads.x86_64 0.2.20-10.fc27                                        
      openblas-threads64_.x86_64 0.2.20-10.fc27                                     
      opencv-contrib.x86_64 3.2.0-15.fc27                                           
      opencv-core.x86_64 3.2.0-15.fc27                                              
      openni.x86_64 1.5.7.10-11.fc27                                                
      ots-libs.x86_64 0.5.0-15.fc27                                                 
      pangox-compat.x86_64 0.0.2-10.fc27                                            
      patch.x86_64 2.7.6-4.fc27                                                     
      poppler-glib.x86_64 0.57.0-8.fc27                                             
      poppler-sharp.x86_64 0.0.3-16.fc27                                            
      postgresql-libs.x86_64 9.6.8-1.fc27                                           
      pyPdf.noarch 1.13-14.fc27                                                     
      pygobject2.x86_64 2.28.6-19.fc27                                              
      pygtk2.x86_64 2.24.0-18.fc27                                                  
      pypoppler.x86_64 0.12.2-7.fc27                                                
      python2-nose.noarch 1.3.7-15.fc27                                             
      python2-numpy.x86_64 1:1.13.3-4.fc27                                          
      sqlite.x86_64 3.20.1-2.fc27                                                   
      suitesparse.x86_64 4.4.6-10.fc27                                              
      t1lib.x86_64 5.1.2-21.fc27                                                    
      tbb.x86_64 2017.7-3.fc27                                                      
      tesseract.x86_64 3.05.01-3.fc27                                               
      tinyxml.x86_64 2.6.2-14.fc27                                                  
      tolua++.x86_64 1.0.93-21.fc27                                                 
      unixODBC.x86_64 2.3.5-2.fc27                                                  
      uriparser.x86_64 0.8.5-1.fc27                                                 
      wv.x86_64 1.2.9-16.fc27                                                       
      xmms-libs.x86_64 1:1.2.11-32.20071117cvs.fc27                                 
      xorg-x11-fonts-100dpi.noarch 7.5-18.fc27                                      
      xorg-x11-fonts-ISO8859-1-100dpi.noarch 7.5-18.fc27                            
    
    Complete!
    

  • 191 package installed.
    The full list of installed packages (2479 in total vs 2288 in sect.41)
               /opt/root/Install/rpm_history/180519.0300.rpm-qa.misc_installed
    ( local copy )

  • The installed packages: More... Close
    [root] ~/opt_root_Install/rpm_history $ \
              diff 180518.0156.rpm-qa.tex_etc_installed \
                   180519.0300.rpm-qa.misc_installed \
              | grep ">"
    > abiword-3.0.2-8.fc27.x86_64
    > aiksaurus-1.2.1-37.fc27.x86_64
    > alpine-2.21-4.fc27.x86_64
    > antiword-0.37-22.fc27.x86_64
    > armadillo-7.900.1-3.fc27.x86_64
    > arpack-3.5.0-4.fc27.x86_64
    > aspell-0.60.6.1-18.fc27.x86_64
    > aspell-en-2015.04.24-5.fc27.x86_64
    > aspell-ru-0.99f7-19.fc27.x86_64
    > atlas-3.10.3-1.fc27.x86_64
    > babl-0.1.46-1.fc27.x86_64
    > binutils-2.29-13.fc27.x86_64
    > blas-3.8.0-7.fc27.x86_64
    > boost-1.64.0-6.fc27.x86_64
    > boost-container-1.64.0-6.fc27.x86_64
    > boost-context-1.64.0-6.fc27.x86_64
    > boost-coroutine-1.64.0-6.fc27.x86_64
    > boost-doc-1.64.0-6.fc27.x86_64
    > boost-fiber-1.64.0-6.fc27.x86_64
    > boost-graph-1.64.0-6.fc27.x86_64
    > boost-locale-1.64.0-6.fc27.x86_64
    > boost-log-1.64.0-6.fc27.x86_64
    > boost-math-1.64.0-6.fc27.x86_64
    > boost-numpy-1.64.0-6.fc27.x86_64
    > boost-program-options-1.64.0-6.fc27.x86_64
    > boost-python-1.64.0-6.fc27.x86_64
    > boost-random-1.64.0-6.fc27.x86_64
    > boost-regex-1.64.0-6.fc27.x86_64
    > boost-serialization-1.64.0-6.fc27.x86_64
    > boost-signals-1.64.0-6.fc27.x86_64
    > boost-test-1.64.0-6.fc27.x86_64
    > boost-timer-1.64.0-6.fc27.x86_64
    > boost-type_erasure-1.64.0-6.fc27.x86_64
    > boost-wave-1.64.0-6.fc27.x86_64
    > cabextract-1.5-7.fc27.x86_64
    > calc-2.12.6.0-3.fc27.x86_64
    > calc-libs-2.12.6.0-3.fc27.x86_64
    > calc-stdrc-2.12.6.0-3.fc27.x86_64
    > cfitsio-3.370-10.fc27.x86_64
    > colordiff-1.0.18-2.fc27.noarch
    > conky-1.10.7-1.fc27.x86_64
    > cpp-7.3.1-5.fc27.x86_64
    > dcraw-9.27.0-5.fc27.x86_64
    > digikam-5.9.0-1.fc27.x86_64
    > digikam-doc-5.9.0-1.fc27.noarch
    > digikam-libs-5.9.0-1.fc27.x86_64
    > enscript-1.6.6-12.fc27.x86_64
    > eosrei-emojione-fonts-1.0-5.fc27.noarch
    > esmtp-1.2-9.fc27.x86_64
    > evince-3.26.0-2.fc27.x86_64
    > evince-djvu-3.26.0-2.fc27.x86_64
    > evince-libs-3.26.0-2.fc27.x86_64
    > exfat-utils-1.2.8-1.fc27.x86_64
    > freexl-1.0.5-1.fc27.x86_64
    > fuse-exfat-1.2.8-1.fc27.x86_64
    > gcc-7.3.1-5.fc27.x86_64
    > gcc-c++-7.3.1-5.fc27.x86_64
    > gdal-libs-2.1.4-5.1.fc27.x86_64
    > gedit-3.22.1-2.fc27.x86_64
    > gegl-0.2.0-34.fc27.x86_64
    > geos-3.6.1-4.fc27.x86_64
    > gimp-2.8.22-3.fc27.x86_64
    > gimp-libs-2.8.22-3.fc27.x86_64
    > glib-1.2.10-50.fc27.x86_64
    > gnome-desktop3-3.26.2-1.fc27.x86_64
    > gnome-sharp-2.24.2-13.fc26.x86_64
    > gnome-themes-standard-3.22.3-5.fc27.x86_64
    > gnome-vfs2-2.24.4-25.fc27.x86_64
    > gnome-vfs2-common-2.24.4-25.fc27.noarch
    > gnuplot-5.0.6-5.fc27.x86_64
    > gnuplot-common-5.0.6-5.fc27.x86_64
    > gnuplot-doc-5.0.6-5.fc27.noarch
    > goffice-0.10.39-1.fc27.x86_64
    > gparted-0.31.0-1.fc27.x86_64
    > gspell-1.6.1-1.fc27.x86_64
    > gtk+-1.2.10-85.fc27.x86_64
    > gtkmathview-0.8.0-19.fc23.x86_64
    > gtk-sharp2-2.12.45-3.fc27.x86_64
    > gtksourceview3-3.24.6-1.fc27.x86_64
    > gv-3.7.4-14.fc27.x86_64
    > gvfs-1.34.2.1-1.fc27.x86_64
    > gvfs-client-1.34.2.1-1.fc27.x86_64
    > highlight-3.42-1.fc27.x86_64
    > highlight-gui-3.42-1.fc27.x86_64
    > hyena-0.5-17.fc27.x86_64
    > imlib2-1.4.9-4.fc27.x86_64
    > iotop-0.6-15.fc27.noarch
    > isl-0.16.1-3.fc27.x86_64
    > jhead-3.00-7.fc27.x86_64
    > lapack-3.8.0-7.fc27.x86_64
    > lasem-0.4.3-7.fc27.x86_64
    > lensfun-0.3.2-11.fc27.x86_64
    > leptonica-1.74.4-5.fc27.x86_64
    > libabiword-3.0.2-8.fc27.x86_64
    > libart_lgpl-2.3.21-18.fc27.x86_64
    > libbonobo-2.32.1-13.fc27.x86_64
    > libbonoboui-2.24.5-13.fc27.x86_64
    > libcanberra-gtk2-0.30-15.fc27.x86_64
    > libcanberra-gtk3-0.30-15.fc27.x86_64
    > libdap-3.18.3-4.fc27.x86_64
    > libesmtp-1.0.6-13.fc27.x86_64
    > libgdiplus-5.6-1.fc27.x86_64
    > libgeotiff-1.4.0-11.fc27.x86_64
    > libglade2-2.6.4-17.fc27.x86_64
    > libgnome-2.32.1-15.fc27.x86_64
    > libgnomecanvas-2.30.3-14.fc27.x86_64
    > libgnome-keyring-3.12.0-10.fc27.x86_64
    > libgnomeui-2.24.5-16.fc27.x86_64
    > libgsf-1.14.41-4.fc27.x86_64
    > libgta-1.0.7-6.fc27.x86_64
    > libgxps-0.3.0-4.fc27.x86_64
    > libIDL-0.8.14-14.fc27.x86_64
    > libjpeg-turbo-utils-1.5.3-1.fc27.x86_64
    > libkml-1.3.0-8.fc27.x86_64
    > liblqr-1-0.4.2-9.fc27.x86_64
    > libmikmod-3.3.11.1-1.fc27.x86_64
    > libmpc-1.0.2-8.fc27.x86_64
    > libopenraw-0.1.2-3.fc27.x86_64
    > libpeas-1.22.0-1.fc27.x86_64
    > libpeas-gtk-1.22.0-1.fc27.x86_64
    > libpeas-loader-python3-1.22.0-1.fc27.x86_64
    > libspatialite-4.3.0a-6.fc27.x86_64
    > libspiro-20150131-6.fc27.x86_64
    > libucil-0.9.10-15.fc27.x86_64
    > libunicap-0.9.12-20.fc27.x86_64
    > libwmf-0.2.8.4-53.fc27.x86_64
    > libxmp-4.4.1-4.fc27.x86_64
    > link-grammar-5.5.0-1.fc27.x86_64
    > meld-3.18.0-1.fc27.noarch
    > minisat2-libs-2.2.1-4.fc27.x86_64
    > mono-core-4.8.0-12.fc27.x86_64
    > mono-data-4.8.0-12.fc27.x86_64
    > mono-data-sqlite-4.8.0-12.fc27.x86_64
    > mono-extras-4.8.0-12.fc27.x86_64
    > mono-mvc-4.8.0-12.fc27.x86_64
    > mono-wcf-4.8.0-12.fc27.x86_64
    > mono-web-4.8.0-12.fc27.x86_64
    > mono-winforms-4.8.0-12.fc27.x86_64
    > ncompress-4.2.4.4-9.fc27.x86_64
    > netcdf-4.4.1.1-6.fc27.x86_64
    > nunit-3.7.1-3.fc27.x86_64
    > ogdi-3.2.0-3.fc27.x86_64
    > openblas-0.2.20-10.fc27.x86_64
    > openblas-openmp-0.2.20-10.fc27.x86_64
    > openblas-threads-0.2.20-10.fc27.x86_64
    > openblas-threads64_-0.2.20-10.fc27.x86_64
    > opencv-contrib-3.2.0-15.fc27.x86_64
    > opencv-core-3.2.0-15.fc27.x86_64
    > openni-1.5.7.10-11.fc27.x86_64
    > ORBit2-2.14.19-18.fc27.x86_64
    > ots-libs-0.5.0-15.fc27.x86_64
    > pangox-compat-0.0.2-10.fc27.x86_64
    > patch-2.7.6-4.fc27.x86_64
    > pdfmerge-1.0.6-1.fc27.noarch
    > pdfmod-0.9.1-17.fc27.x86_64
    > pdfshuffler-0.6.0-11.fc27.noarch
    > poppler-glib-0.57.0-8.fc27.x86_64
    > poppler-sharp-0.0.3-16.fc27.x86_64
    > postgresql-libs-9.6.8-1.fc27.x86_64
    > pygobject2-2.28.6-19.fc27.x86_64
    > pygtk2-2.24.0-18.fc27.x86_64
    > pyPdf-1.13-14.fc27.noarch
    > pypoppler-0.12.2-7.fc27.x86_64
    > python2-nose-1.3.7-15.fc27.noarch
    > python2-numpy-1.13.3-4.fc27.x86_64
    > qpdf-7.1.1-5.fc27.x86_64
    > recode-3.6-46.fc27.x86_64
    > seamonkey-2.49.3-1.fc27.x86_64
    > simple-mtpfs-0.2-10.fc27.x86_64
    > sqlite-3.20.1-2.fc27.x86_64
    > suitesparse-4.4.6-10.fc27.x86_64
    > SuperLU-5.2.0-4.fc27.x86_64
    > t1lib-5.1.2-21.fc27.x86_64
    > tbb-2017.7-3.fc27.x86_64
    > tesseract-3.05.01-3.fc27.x86_64
    > tinyxml-2.6.2-14.fc27.x86_64
    > tolua++-1.0.93-21.fc27.x86_64
    > unixODBC-2.3.5-2.fc27.x86_64
    > unrar-5.6.3-1.fc27.x86_64
    > uriparser-0.8.5-1.fc27.x86_64
    > wv-1.2.9-16.fc27.x86_64
    > Xaw3d-1.6.2-12.fc27.x86_64
    > xfig-3.2.6a-7.fc27.x86_64
    > xmms-1.2.11-32.20071117cvs.fc27.x86_64
    > xmms-libs-1.2.11-32.20071117cvs.fc27.x86_64
    > xmp-4.1.0-5.fc27.x86_64
    > xorg-x11-fonts-100dpi-7.5-18.fc27.noarch
    > xorg-x11-fonts-ISO8859-1-100dpi-7.5-18.fc27.noarch
    > xpdf-4.00-5.fc27.x86_64
    > xv-3.10a.jumbopatch.20070520-27.fc27.x86_64
    > xv-doc-3.10a.jumbopatch.20070520-27.fc27.noarch
    

  • Installed executables: More... Close
    package executable(s)
    abiword-3.0.2-8.fc27.x86_64 /usr/bin/abiword
    aiksaurus-1.2.1-37.fc27.x86_64 /usr/bin/aiksaurus
    /usr/bin/caiksaurus
    alpine-2.21-4.fc27.x86_64 /usr/bin/alpine
    /usr/bin/pico
    /usr/bin/pilot
    /usr/bin/rpdump
    /usr/bin/rpload
    antiword-0.37-22.fc27.x86_64 /usr/bin/antiword
    /usr/bin/antiword.bin
    aspell-0.60.6.1-18.fc27.x86_64 /usr/bin/aspell
    /usr/bin/ispell
    /usr/bin/precat
    /usr/bin/preunzip
    /usr/bin/prezip
    /usr/bin/prezip-bin
    /usr/bin/run-with-aspell
    /usr/bin/spell
    /usr/bin/word-list-compress
    binutils-2.29-13.fc27.x86_64 /usr/bin/addr2line
    /usr/bin/ar
    /usr/bin/as
    /usr/bin/c++filt
    /usr/bin/dwp
    /usr/bin/elfedit
    /usr/bin/gprof
    /usr/bin/ld
    /usr/bin/ld.bfd
    /usr/bin/ld.gold
    /usr/bin/nm
    /usr/bin/objcopy
    /usr/bin/objdump
    /usr/bin/ranlib
    /usr/bin/readelf
    /usr/bin/size
    /usr/bin/strings
    /usr/bin/strip
    cabextract-1.5-7.fc27.x86_64 /usr/bin/cabextract
    calc-2.12.6.0-3.fc27.x86_64 /usr/bin/calc
    colordiff-1.0.18-2.fc27.noarch /usr/bin/cdiff
    /usr/bin/colordiff
    conky-1.10.7-1.fc27.x86_64 /usr/bin/conky
    cpp-7.3.1-5.fc27.x86_64 /usr/bin/cpp
    dcraw-9.27.0-5.fc27.x86_64 /usr/bin/dcraw
    digikam-5.9.0-1.fc27.x86_64 /usr/bin/cleanup_digikamdb
    /usr/bin/digikam
    /usr/bin/digitaglinktree
    /usr/bin/showfoto
    enscript-1.6.6-12.fc27.x86_64 /usr/bin/diffpp
    /usr/bin/enscript
    /usr/bin/mkafmmap
    /usr/bin/nenscript
    /usr/bin/over
    /usr/bin/sliceprint
    /usr/bin/states
    esmtp-1.2-9.fc27.x86_64 /usr/bin/esmtp
    /usr/bin/esmtp-wrapper
    /usr/bin/mailq
    /usr/sbin/sendmail
    evince-3.26.0-2.fc27.x86_64 /usr/bin/evince
    /usr/bin/evince-previewer
    /usr/bin/evince-thumbnailer
    exfat-utils-1.2.8-1.fc27.x86_64 /usr/sbin/dumpexfat
    /usr/sbin/exfatfsck
    /usr/sbin/exfatlabel
    /usr/sbin/fsck.exfat
    /usr/sbin/mkexfatfs
    /usr/sbin/mkfs.exfat
    fuse-exfat-1.2.8-1.fc27.x86_64 /usr/sbin/mount.exfat
    /usr/sbin/mount.exfat-fuse
    gcc-7.3.1-5.fc27.x86_64 /usr/bin/c89
    /usr/bin/c99
    /usr/bin/cc
    /usr/bin/gcc
    /usr/bin/gcc-ar
    /usr/bin/gcc-nm
    /usr/bin/gcc-ranlib
    /usr/bin/gcov
    /usr/bin/gcov-tool
    /usr/bin/x86_64-redhat-linux-gcc
    /usr/bin/x86_64-redhat-linux-gcc-7
    gcc-c++-7.3.1-5.fc27.x86_64 /usr/bin/c++
    /usr/bin/g++
    /usr/bin/x86_64-redhat-linux-c++
    /usr/bin/x86_64-redhat-linux-g++
    gedit-3.22.1-2.fc27.x86_64 /usr/bin/gedit
    /usr/bin/gnome-text-editor
    gegl-0.2.0-34.fc27.x86_64 /usr/bin/gegl
    gimp-2.8.22-3.fc27.x86_64 /usr/bin/gimp
    /usr/bin/gimp-2.8
    /usr/bin/gimp-console
    /usr/bin/gimp-console-2.8
    gnome-sharp-2.24.2-13.fc26.x86_64 /usr/bin/gconfsharp2-schemagen
    gnome-vfs2-2.24.4-25.fc27.x86_64 /usr/bin/gnomevfs-cat
    /usr/bin/gnomevfs-copy
    /usr/bin/gnomevfs-df
    /usr/bin/gnomevfs-info
    /usr/bin/gnomevfs-ls
    /usr/bin/gnomevfs-mkdir
    /usr/bin/gnomevfs-monitor
    /usr/bin/gnomevfs-mv
    /usr/bin/gnomevfs-rm
    gnuplot-5.0.6-5.fc27.x86_64 /usr/bin/gnuplot
    /usr/bin/gnuplot-qt
    gparted-0.31.0-1.fc27.x86_64 /usr/bin/gparted
    /usr/sbin/gpartedbin
    gtkmathview-0.8.0-19.fc23.x86_64 /usr/bin/mathmlps
    /usr/bin/mathmlsvg
    gv-3.7.4-14.fc27.x86_64 /usr/bin/ghostview
    /usr/bin/gv
    /usr/bin/gv-update-userconfig
    gvfs-client-1.34.2.1-1.fc27.x86_64 /usr/bin/gvfs-cat
    /usr/bin/gvfs-copy
    /usr/bin/gvfs-info
    /usr/bin/gvfs-less
    /usr/bin/gvfs-ls
    /usr/bin/gvfs-mime
    /usr/bin/gvfs-mkdir
    /usr/bin/gvfs-monitor-dir
    /usr/bin/gvfs-monitor-file
    /usr/bin/gvfs-mount
    /usr/bin/gvfs-move
    /usr/bin/gvfs-open
    /usr/bin/gvfs-rename
    /usr/bin/gvfs-rm
    /usr/bin/gvfs-save
    /usr/bin/gvfs-set-attribute
    /usr/bin/gvfs-trash
    /usr/bin/gvfs-tree
    highlight-3.42-1.fc27.x86_64 /usr/bin/highlight
    highlight-gui-3.42-1.fc27.x86_64 /usr/bin/highlight-gui
    iotop-0.6-15.fc27.noarch /usr/sbin/iotop
    jhead-3.00-7.fc27.x86_64 /usr/bin/jhead
    libbonobo-2.32.1-13.fc27.x86_64 /usr/bin/activation-client
    /usr/bin/bonobo-activation-run-query
    /usr/sbin/bonobo-activation-sysconf
    libcanberra-gtk3-0.30-15.fc27.x86_64 /usr/bin/canberra-gtk-play
    libdap-3.18.3-4.fc27.x86_64 /usr/bin/getdap
    /usr/bin/getdap4
    libgeotiff-1.4.0-11.fc27.x86_64 /usr/bin/applygeo
    /usr/bin/geotifcp
    /usr/bin/listgeo
    /usr/bin/makegeo
    libgnome-2.32.1-15.fc27.x86_64 /usr/bin/gnome-open
    libgsf-1.14.41-4.fc27.x86_64 /usr/bin/gsf-office-thumbnailer
    libjpeg-turbo-utils-1.5.3-1.fc27.x86_64 /usr/bin/cjpeg
    /usr/bin/djpeg
    /usr/bin/jpegtran
    /usr/bin/rdjpgcom
    /usr/bin/wrjpgcom
    libwmf-0.2.8.4-53.fc27.x86_64 /usr/bin/libwmf-fontmap
    /usr/bin/wmf2eps
    /usr/bin/wmf2fig
    /usr/bin/wmf2gd
    /usr/bin/wmf2svg
    /usr/bin/wmf2x
    link-grammar-5.5.0-1.fc27.x86_64 /usr/bin/link-parser
    meld-3.18.0-1.fc27.noarch /usr/bin/meld
    mono-core-4.8.0-12.fc27.x86_64 /usr/bin/ccrewrite
    /usr/bin/cert-sync
    /usr/bin/chktrust
    /usr/bin/csharp
    /usr/bin/gacutil
    /usr/bin/gacutil2
    /usr/bin/ikdasm
    /usr/bin/lc
    /usr/bin/mcs
    /usr/bin/mono
    /usr/bin/mono-boehm
    /usr/bin/mono-heapviz
    /usr/bin/mono-package-runtime
    /usr/bin/mono-service2
    /usr/bin/mono-sgen
    /usr/bin/mono-sgen-gdb.py
    /usr/bin/mono-test-install
    /usr/bin/monograph
    /usr/bin/mozroots
    /usr/bin/mprof-report
    /usr/bin/pdb2mdb
    /usr/bin/setreg
    /usr/bin/sgen-grep-binprot
    /usr/bin/sn
    /usr/share/gdb/auto-load/usr/bin/mono-gdb.py
    mono-data-4.8.0-12.fc27.x86_64 /usr/bin/sqlmetal
    /usr/bin/sqlsharp
    mono-extras-4.8.0-12.fc27.x86_64 /usr/bin/mono-service
    mono-web-4.8.0-12.fc27.x86_64 /usr/bin/disco
    /usr/bin/httpcfg
    /usr/bin/mconfig
    /usr/bin/soapsuds
    /usr/bin/svcutil
    /usr/bin/wsdl
    /usr/bin/wsdl2
    /usr/bin/xsd
    ncompress-4.2.4.4-9.fc27.x86_64 /usr/bin/compress
    /usr/bin/uncompress
    netcdf-4.4.1.1-6.fc27.x86_64 /usr/bin/nccopy
    /usr/bin/ncdump
    /usr/bin/ncgen
    /usr/bin/ncgen3
    nunit-3.7.1-3.fc27.x86_64 /usr/bin/nunitlite-runner
    ogdi-3.2.0-3.fc27.x86_64 /usr/bin/gltpd
    /usr/bin/ogdi_import
    /usr/bin/ogdi_info
    openni-1.5.7.10-11.fc27.x86_64 /usr/bin/niLicense
    /usr/bin/niReg
    patch-2.7.6-4.fc27.x86_64 /usr/bin/patch
    pdfmerge-1.0.6-1.fc27.noarch /usr/bin/pdfmerge
    pdfmod-0.9.1-17.fc27.x86_64 /usr/bin/pdfmod
    pdfshuffler-0.6.0-11.fc27.noarch /usr/bin/pdfshuffler
    pygtk2-2.24.0-18.fc27.x86_64 /usr/bin/pygtk-demo
    python2-nose-1.3.7-15.fc27.noarch /usr/bin/nosetests
    /usr/bin/nosetests-2
    /usr/bin/nosetests-2.7
    qpdf-7.1.1-5.fc27.x86_64 /usr/bin/fix-qdf
    /usr/bin/qpdf
    /usr/bin/zlib-flate
    recode-3.6-46.fc27.x86_64 /usr/bin/recode
    seamonkey-2.49.3-1.fc27.x86_64 /usr/bin/seamonkey
    simple-mtpfs-0.2-10.fc27.x86_64 /usr/bin/simple-mtpfs
    sqlite-3.20.1-2.fc27.x86_64 /usr/bin/sqlite3
    t1lib-5.1.2-21.fc27.x86_64 /usr/sbin/t1libconfig
    tesseract-3.05.01-3.fc27.x86_64 /usr/bin/ambiguous_words
    /usr/bin/classifier_tester
    /usr/bin/cntraining
    /usr/bin/combine_tessdata
    /usr/bin/dawg2wordlist
    /usr/bin/mftraining
    /usr/bin/set_unicharset_properties
    /usr/bin/shapeclustering
    /usr/bin/tesseract
    /usr/bin/text2image
    /usr/bin/unicharset_extractor
    /usr/bin/wordlist2dawg
    unixODBC-2.3.5-2.fc27.x86_64 /usr/bin/dltest
    /usr/bin/isql
    /usr/bin/iusql
    /usr/bin/odbc_config
    /usr/bin/odbcinst
    /usr/bin/slencheck
    unrar-5.6.3-1.fc27.x86_64 /usr/bin/unrar
    /usr/bin/unrar-nonfree
    uriparser-0.8.5-1.fc27.x86_64 /usr/bin/uriparse
    wv-1.2.9-16.fc27.x86_64 /usr/bin/wvAbw
    /usr/bin/wvCleanLatex
    /usr/bin/wvConvert
    /usr/bin/wvDVI
    /usr/bin/wvDocBook
    /usr/bin/wvHtml
    /usr/bin/wvLatex
    /usr/bin/wvMime
    /usr/bin/wvPDF
    /usr/bin/wvPS
    /usr/bin/wvRTF
    /usr/bin/wvSummary
    /usr/bin/wvText
    /usr/bin/wvVersion
    /usr/bin/wvWare
    /usr/bin/wvWml
    xfig-3.2.6a-7.fc27.x86_64 /usr/bin/xfig
    xmms-1.2.11-32.20071117cvs.fc27.x86_64 /usr/bin/wmxmms
    /usr/bin/xmms
    xmp-4.1.0-5.fc27.x86_64 /usr/bin/xmp
    xpdf-4.00-5.fc27.x86_64 /usr/bin/pdftopng
    /usr/bin/xpdf
    xv-3.10a.jumbopatch.20070520-27.fc27.x86_64 /usr/bin/bggen
    /usr/bin/vdcomp
    /usr/bin/xcmap
    /usr/bin/xv
    /usr/bin/xvpictoppm

  43. (20.05.18) Skype

  • In browser: https://www.skype.com/en/ -> press Download Skype -> press Get Skype for Linux RPM -> an rpm file gets downloaded.

  • The file
               skypeforlinux-64.rpm
    is put into /opt/root/Install/RPMS .

  • Install:
               [root] ~/opt_root_Install/RPMS $ dnf install -y skypeforlinux-64.rpm
    ...
    ================================================================================
     Package              Arch          Version           Repository           Size
    ================================================================================
    Installing:
     skypeforlinux        x86_64        8.20.0.9-1        @commandline        110 M
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total size: 110 M
    Installed size: 272 M
    ...
    

  • The installed package (from rpm -q skypeforlinux ):
               skypeforlinux-8.20.0.9-1.x86_64

  • The executable:
    • /usr/bin/skypeforlinux
      -- a script which is an interface to /usr/share/skypeforlinux/skypeforlinux
    • also: f -> Applications -> Internet -> Skype Internet Telephony

  • A full list of installed packages (2480 in total vs 2479 in sect.26 / UPD 19.05.18) :
               /opt/root/Install/rpm_history/180520.0254.rpm-qa.skype_installed=
    ( local copy )

  44. (21.05.18) dir_ret, dir_rem in /usr/local/bin

  • The scripts have been copied from /afs/desy.de/user/f/fedotov/binc .
  • They are required for commands dret , drem defined in ~fedotov/.zshrc and /root/.bashrc   .

  45. (21.05.18) rrecode

  • rrecode performs a recoding from/to 4 russian encodings.

  • We follow the installation procedure described for F10 @ dom2 in sect.22 of /x01/legacy/dom2/F10/opt/root/Install/Installed_SW .

  • The directory
               /products/rrecode
    is created as a copy of
               /afs/desy.de/user/f/fedotov/public/rrecode_SLD4
    (done via
               [root] /products $ scp -rp fedotov@naf-hone01:public/rrecode_SLD4 rrecode
    )

  • Compile:
    [root] /products/rrecode $ gcc recode.c 2>&1 \
                             | tee Compilation_at_F27-dom5_180521.log
    
    A lot of warnings:
               cat > Compilation_at_F27-dom5_180521.log : More... Close
    recode.c: In function 'main':
    recode.c:141:5: warning: implicit declaration of function 'strcmp' [-Wimplicit-function-declaration]
     if(!strcmp(argv[1], "-ai"))
         ^~~~~~
    recode.c:188:7: warning: implicit declaration of function 'exit' [-Wimplicit-function-declaration]
           exit(1);
           ^~~~
    recode.c:188:7: warning: incompatible implicit declaration of built-in function 'exit'
    recode.c:188:7: note: include '<stdlib.h>' or provide a declaration of 'exit'
    recode.c:193:10: warning: implicit declaration of function 'strcpy' [-Wimplicit-function-declaration]
              strcpy(temp, (char *) tmpnam(NULL));
              ^~~~~~
    recode.c:193:10: warning: incompatible implicit declaration of built-in function 'strcpy'
    recode.c:193:10: note: include '<string.h>' or provide a declaration of 'strcpy'
    recode.c:195:3: warning: incompatible implicit declaration of built-in function 'strcpy'
       strcpy(temp, argv[3]);
       ^~~~~~
    recode.c:195:3: note: include '<string.h>' or provide a declaration of 'strcpy'
    recode.c:202:10: warning: incompatible implicit declaration of built-in function 'exit'
              exit(1);
              ^~~~
    recode.c:202:10: note: include '<stdlib.h>' or provide a declaration of 'exit'
    recode.c:209:4: warning: incompatible implicit declaration of built-in function 'exit'
        exit(1);
        ^~~~
    recode.c:209:4: note: include '<stdlib.h>' or provide a declaration of 'exit'
    recode.c:215:4: warning: incompatible implicit declaration of built-in function 'exit'
        exit(1);
        ^~~~
    recode.c:215:4: note: include '<stdlib.h>' or provide a declaration of 'exit'
    recode.c:228:4: warning: implicit declaration of function 'unlink'; did you mean 'unix'? [-Wimplicit-function-declaration]
        unlink(argv[2]);
        ^~~~~~
        unix
    recode.c:232:4: warning: implicit declaration of function 'link'; did you mean 'linux'? [-Wimplicit-function-declaration]
        link(temp, argv[2]);
        ^~~~
        linux
    recode.c: In function 'usage':
    recode.c:260:1: warning: incompatible implicit declaration of built-in function 'exit'
     exit(1);
     ^~~~
    recode.c:260:1: note: include '<stdlib.h>' or provide a declaration of 'exit'
    /tmp/ccyuCQAc.o: In function `main':
    recode.c:(.text+0x39d): warning: the use of `tmpnam' is dangerous, better use `mkstemp'
    

    However, the executable a.out is produced. We rename it to
               recode .

  • The interface script rrecode is modified: the variable `_executable' is set to the new address of the recode executable /products/rrecode/recode.

  • Help is provided by invoking rrecode w/o parameters:
    [root] /products/rrecode $ ./rrecode 
    Usage: /products/rrecode/recode -{ai|ak|aw|ia|ik|iw|ka|ki|kw|wa|wi|wk} [input_file [output_file]]
           Parameters are:
           -ai         - from Alternative to ISO,
           -ak         - from Alternative to Koi8,
           -aw         - from Alternative to Windows,
           -ia         - from ISO to Alternative,
           -ik         - from ISO to Koi8,
           -iw         - from ISO to Windows,
           -ka         - from Koi8 to Alternative,
           -ki         - from Koi8 to ISO,
           -kw         - from Koi8 to Windows,
           -wa         - from Windows to Alternative,
           -wi         - from Windows to ISO;
           -wk         - from Windows to Koi8;
           input_file  - name of input file, may be "-" as standard input;
           output_file - name of output file, may be "-" as standard output.
    

  • A link to rrecode is set in /usr/local/bin/:
               [root] ... $ ln -s /products/rrecode/rrecode /usr/local/bin/

  46. (22.05.18) Installing an "RPM Sphere all" (rpmsphere) repository

  • Try to install the repo with
    • [root] /home/fedotov/tm/dnf $ dnf -y install http://ftp.gwdg.de/pub/opensuse/repositories/home:/zhonghuaren/Fedora_27/noarch/rpmsphere-release-27-1.1.noarch.rpm 2>&1 |tee dnf.rpmsphere-release
    • [root] /home/fedotov/tm/dnf $ cat dnf.rpmsphere-release : More... Close
      Last metadata expiration check: 0:03:26 ago on Tue 22 May 2018 03:33:41 AM MSK.
      rpmsphere-release-27-1.1.noarch.rpm              35 kB/s | 7.1 kB     00:00    
      Dependencies resolved.
      ================================================================================
       Package                  Arch          Version       Repository           Size
      ================================================================================
      Installing:
       rpmsphere-release        noarch        27-1.1        @commandline        7.1 k
      
      Transaction Summary
      ================================================================================
      Install  1 Package
      
      Total size: 7.1 k
      Installed size: 291  
      Downloading Packages:
      Running transaction check
      Transaction check succeeded.
      Running transaction test
      Transaction test succeeded.
      Running transaction
        Preparing        :                                                        1/1 
        Installing       : rpmsphere-release-27-1.1.noarch                        1/1 
        Verifying        : rpmsphere-release-27-1.1.noarch                        1/1 
      
      Installed:
        rpmsphere-release.noarch 27-1.1                                               
      
      Complete!
      

  • Package rpmsphere-release-27-1.1.noarch installed:
    [root] ... $ rpm -q rpmsphere-release       
    rpmsphere-release-27-1.1.noarch
    

  • Installed is a single file:
    [root] /home/fedotov/tm/dnf $ rpm -ql rpmsphere-release
    /etc/yum.repos.d/rpmsphere.repo
    
    The file contents:
    [root] ... $ cat /etc/yum.repos.d/rpmsphere.repo : More... Close
    [rpmsphere]
    name=RPM Sphere
    baseurl=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_$releasever/
    gpgkey=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_$releasever/repodata/repomd.xml.key
    skip_if_unavailable=True
    gpgcheck=1
    enabled=1
    metadata_expire=6h
    

  • a new repo is reported by dnf:
    [root] /home/fedotov/tm/dnf $ dnf repolist --all |grep sphere 
    rpmsphere                                   RPM Sphere           enabled: 10,741
    
  • The repo is also seen by the Software Management / dnfdragora tool, and the latter is able to find the tkdiff package in the rpmsphere repo.

  • A full list of installed packages (2481 in total vs 2480 in sect.43) :
               /opt/root/Install/rpm_history/180522.0357.rpm-qa.rpmsphere_repo_installed
    ( local copy )

  47. (22.05.18) tkdiff

  • Install tkdiff from the rpmsphere repo (installed in the prev. sect.46):
               [root] /home/fedotov/tm/dnf $ dnf -y install tkdiff 2>&1 |tee dnf.tkdiff
    • [root] /home/fedotov/tm/dnf $ cat dnf.tkdiff : More... Close
      Last metadata expiration check: 1:04:39 ago on Tue 22 May 2018 03:46:07 AM MSK.
      Dependencies resolved.
      ================================================================================
       Package        Arch           Version                  Repository         Size
      ================================================================================
      Installing:
       tkdiff         noarch         4.2-8.1                  rpmsphere          84 k
      Installing dependencies:
       tcl            x86_64         1:8.6.8-1.fc27           updates           1.1 M
       tk             x86_64         1:8.6.8-1.fc27           updates           1.6 M
      
      Transaction Summary
      ================================================================================
      Install  3 Packages
      
      Total download size: 2.8 M
      Installed size: 8.0 M
      Downloading Packages:
      (1/3): tk-8.6.8-1.fc27.x86_64.rpm               1.3 MB/s | 1.6 MB     00:01    
      (2/3): tkdiff-4.2-8.1.noarch.rpm                 42 kB/s |  84 kB     00:02    
      (3/3): tcl-8.6.8-1.fc27.x86_64.rpm              399 kB/s | 1.1 MB     00:02    
      --------------------------------------------------------------------------------
      Total                                           687 kB/s | 2.8 MB     00:04     
      warning: /var/cache/dnf/rpmsphere-90d4b62b32edacc1/packages/tkdiff-4.2-8.1.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID e06f8c93: NOKEY
      Importing GPG key 0xE06F8C93:
       Userid     : "home:zhonghuaren OBS Project <home:zhonghuaren@build.opensuse.org>"
       Fingerprint: B125 1F65 95B8 AA05 366D 3138 51F2 F00C E06F 8C93
       From       : http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_27/repodata/repomd.xml.key
      Key imported successfully
      Running transaction check
      Transaction check succeeded.
      Running transaction test
      Transaction test succeeded.
      Running transaction
        Preparing        :                                                        1/1 
        Installing       : tcl-1:8.6.8-1.fc27.x86_64                              1/3 
        Running scriptlet: tcl-1:8.6.8-1.fc27.x86_64                              1/3 
        Running scriptlet: tk-1:8.6.8-1.fc27.x86_64                               2/3 
        Installing       : tk-1:8.6.8-1.fc27.x86_64                               2/3 
        Running scriptlet: tk-1:8.6.8-1.fc27.x86_64                               2/3 
        Installing       : tkdiff-4.2-8.1.noarch                                  3/3 
        Running scriptlet: tkdiff-4.2-8.1.noarch                                  3/3 
      Running as unit: run-rc7faa4033dcd40e39e837b005f88bb0e.service
        Verifying        : tkdiff-4.2-8.1.noarch                                  1/3 
        Verifying        : tk-1:8.6.8-1.fc27.x86_64                               2/3 
        Verifying        : tcl-1:8.6.8-1.fc27.x86_64                              3/3 
      
      Installed:
        tkdiff.noarch 4.2-8.1   tcl.x86_64 1:8.6.8-1.fc27   tk.x86_64 1:8.6.8-1.fc27  
      
      Complete!
      

  • executable (a shell script):
               /usr/bin/tkdiff
  • help (a txt file):
               /usr/share/doc/tkdiff/README.SuSE

  • A full list of installed packages (2485 in total vs 2481 in sect.46) :
               /opt/root/Install/rpm_history/180522.0500.rpm-qa.tkdiff_installed
    ( local copy )

  • The 4 new packages are:
    [root] ~/opt_root_Install/rpm_history $ \
            diff 180522.0357.rpm-qa.rpmsphere_repo_installed \
                 180522.0500.rpm-qa.tkdiff_installed \
            | grep ">"
    > gpg-pubkey-e06f8c93-59a055dd
    > tcl-8.6.8-1.fc27.x86_64
    > tk-8.6.8-1.fc27.x86_64
    > tkdiff-4.2-8.1.noarch
    
    • Note: The package gpg-pubkey-e06f8c93-59a055dd contains no files ...

  • The executables in the two auxiliary packages:
    package executable(s)
    tcl-8.6.8-1.fc27.x86_64 /usr/bin/tclsh
    /usr/bin/tclsh8.6
    tk-8.6.8-1.fc27.x86_64 /usr/bin/wish
    /usr/bin/wish8.6

  48. (23.05.18) rpm-qa script

  • The script /usr/local/bin/rpm-qa produces a specially named file with the sorted list of installed rpm packages.
  • To be used by root for bookkeeping inside the /opt/root/Install/rpm_history directory.

  49. (23.05.18) coolreader3 (cr3)

  • Installed from the rpmsphere repository:
               [root] /home/fedotov/tm/dnf $ dnf -y install coolreader3 2>&1 | tee dnf.cr3
               More... Close
    ...
    ================================================================================
     Package             Arch           Version             Repository         Size
    ================================================================================
    Installing:
     coolreader3         x86_64         3.0.56-19.1         rpmsphere         1.4 M
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total download size: 1.4 M
    Installed size: 4.3 M
    Downloading Packages:
    coolreader3-3.0.56-19.1.x86_64.rpm              451 kB/s | 1.4 MB     00:03    
    ...
    Installed:
      coolreader3.x86_64 3.0.56-19.1                                                
    
    Complete!
    

  • Installed one package:
               coolreader3-3.0.56-19.1.x86_64

  • Description from rpm -qi coolreader3 :
    • CoolReader is fast and small cross-platform XML/CSS based E-Book reader for desktops and handheld devices. Supported formats: FB2, TXT, RTF, DOC, TCR, HTML, EPUB, CHM, PDB ...

  • Executable:
               /usr/bin/cr3
    Also:
               f -> Application -> Office -> E-book reader / CoolReader3

  • Help :
               man cr3

  • A full list of installed packages (2486 in total vs 2485 in sect.47) :
               /opt/root/Install/rpm_history/180523.0352.rpm-qa.coolreader3_installed
               ( local copy )

  • Executing cr3 leads to a lot of errors and a crash in the end: More... Close
    [dom5] ~/tm/fb2 $ cr3&
    [1] 2353
    [dom5] ~/tm/fb2 $ 2018/05/23 04:03:00.8123 WARN Changing log level from 3 to 1
    411 fonts loaded.
    2018/05/23 04:03:00.8650 ERROR Canot load translation file cr3_en_US from dir /usr/share/cr3/i18n/
    2018/05/23 04:03:00.8910 ERROR Error opening file /home/fedotov/.cr3/cr3.ini for reading
    2018/05/23 04:03:00.8911 ERROR Cannot load settings from file /home/fedotov/.cr3/cr3.ini
    2018/05/23 04:03:00.8940 ERROR Error opening file /usr/share/cr3/cr3.ini for reading
    2018/05/23 04:03:00.8940 ERROR Cannot load settings from file /usr/share/cr3/cr3.ini
    2018/05/23 04:03:00.8947 ERROR Error opening file /usr/share/cr3/cr3hist.bmk for reading
    2018/05/23 04:03:00.8947 ERROR Error opening file /home/fedotov/.cr3/cr3hist.bmk for reading
    2018/05/23 04:03:00.8947 ERROR Error opening file /home/fedotov/.cr3/fb2.css for reading
    
    [1]  + segmentation fault (core dumped)  cr3
    

  • NB. The `okular' program can read ebooks in at least FB2 format.

  • UPD 03.06.18
    Copy Win7 version of cr3.ini from F18 @ dom3:
    [dom5] ~/.cr3 $ scp -p 192.168.100.102:.cr3/cr3.ini.win7 .
    [dom5] ~/.cr3 $ cp -p cr3.ini.win7 cr3.ini
    
    This does not help. When started, cr3 continues to crash with a segmentation fault (core dumped into /var/lib/systemd/coredump/core.cr3.*)

  50. (23.05.18) Installing the "CERT Forensics Tools" repository ( forensics + 3 more)

  • The repo is installed in order to get a rar rpm-package from there.

  • [root] /home/fedotov/tm/dnf $ dnf -y install https://forensics.cert.org/fedora/cert/27/x86_64//cert-forensics-tools-release-27-13.noarch.rpm 2>&1 |tee dnf.cert-forensics-tools
    More... Close
    ...
    ================================================================================
     Package                          Arch       Version     Repository        Size
    ================================================================================
    Installing:
     cert-forensics-tools-release     noarch     27-13       @commandline      16 k
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total size: 16 k
    Installed size: 11 k
    ...
    Installed:
      cert-forensics-tools-release.noarch 27-13                                     
    
    Complete!
    

  • Installed is one package:
    [dom5] ~/tm/dnf $ rpm -q cert-forensics-tools-release
    cert-forensics-tools-release-27-13.noarch
    

  • A full list of installed packages (2487 in total vs 2486 in sect.49) :
               /opt/root/Install/rpm_history/180524.0337.rpm-qa.cert-forensics-tools_repo_installed
               ( local copy )

  • 4 new repos are reported by dnf, of which 2 are enabled:
    [root] ... $ dnf repolist --all |grep -i forens
    forensics                                   CERT Forensics Tools enabled:    947
    forensics-sip                               CERT Forensics Tools disabled
    forensics-splunk                            CERT Forensics Tools enabled:      1
    forensics-test                              CERT Forensics Tools disabled
    
  • We disable the unneeded forensics-splunk with
               [root] ... $ dnf config-manager --set-disabled forensics-splunk

  • UPD:
    Having installed a rar package from the repo forensics in the next sect 51, we disable the repo forensics too.

  51. (23.05.18) rar

  • Install rar from the repository forensics (installed in the prev. sect.50):
               [root] /home/fedotov/tm/dnf $ dnf -y install rar 2>&1 |tee dnf.rar
               More... Close
    ...
    ================================================================================
     Package      Arch            Version                  Repository          Size
    ================================================================================
    Installing:
     rar          x86_64          5.4.0-1.fc27             forensics          273 k
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total download size: 273 k
    Installed size: 654 k
    Downloading Packages:
    ...
    warning: /var/cache/dnf/forensics-ccbcc1f3f59bb672/packages/rar-5.4.0-1.fc27.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 87e360b8: NOKEY
    Importing GPG key 0x87E360B8:
     Userid     : "CERT Forensics Operations and Investivations Team <forensics@cert.org>"
     Fingerprint: 26A0 829D 5C01 FC51 C304 9037 E97F 3E0A 87E3 60B8
     From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-cert-forensics-2018-04-07
    Key imported successfully
    ...
    Installed:
      rar.x86_64 5.4.0-1.fc27                                                       
    
    Complete!
    

  • A full list of installed packages (2489 in total vs 2487 in sect.50) :
               /opt/root/Install/rpm_history/180524.0422.rpm-qa.rar_installed
               ( local copy )

  • Two packages got installed (the gpg-pubkey... w/o any files):
    [root] ~/opt_root_Install/rpm_history $ \
            diff 180524.0337.rpm-qa.cert-forensics-tools_repo_installed \
                 180524.0422.rpm-qa.rar_installed \
            |grep ">"
    > gpg-pubkey-87e360b8-56c463fe
    > rar-5.4.0-1.fc27.x86_64
    

  • The executable:
               /usr/bin/rar
  • The User's Manual "RAR 5.40 console version":
               /usr/share/doc/rar/rar.txt
  • A short help: run rar w/o parameters

  52. (23.12.18) pavucontrol

  • The package pavucontrol-3.0-10.fc27.x86_64 :
    • installed via SW Management (dnfdragora). Total number of installed packages is now 2497 -- +1 to the number after the update sect.26 - UPD 29.11.18
    • a description from `rpm -qi pavucontrolv' :
      • "PulseAudio Volume Control (pavucontrol) is a simple GTK based volume control tool ("mixer") for the PulseAudio sound server. In contrast to classic mixer tools this one allows you to control both the volume of hardware devices and of each playback stream separately. "
  • Motivation: to be able to change the audio capture device
               from the default "Built-in Audio Analog Stereo" (micrpohone)
               to "Monitor of Built-in Audio Analog Stereo" (speakers/headset)
    for a sound recording program ( SRP ).

    The procedure is described in "How to Record System Sound with Pulse Audio and Audacity in Linux" https://www.maketecheasier.com/record-system-sound-linux/ for the SRP Audacity:
    • Start pavucontrol. The "Recording" tab is blank.
    • Start recording with an SRP . Now the "Recording" shows (if you are lucky) the default "Built-in Audio Analog Stereo"
    • Press the "Built-in..." bar and switch to the "Monitor..." option.
      From this moment the SRP gets its input from "speakers"
      (here you may want to restart the recording to have a clean beginning of the output file).
    • Having the recording finished, switch to initial setting in pavucontrol while the SRP still working (either in the last second(s) of the main recording, or in a new SRP run with a dummy output file).

    • For Fedora 27:
      • this does not work with SRP = vlc
      • this works fine with SRP = ffmpeg run as follows:
                   ffmpeg -f alsa -i pulse -c:a libmp3lame -b:a 128k an_output_file.mp3
      • it seems to work also for SRP = arecord

Tips

  Tutorials on the dual and triple boot for windows 10 + linux

Topic attachments
I Attachment History Action Size Date Who Comment
Texttxt 180304.0439.Xorg.0.log.Soon_after_initial_installation.txt r1 manage 35.8 K 2018-03-11 - 00:59 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-001.png r1 manage 160.1 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-002.png r1 manage 123.5 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-003.png r1 manage 66.7 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-004.png r1 manage 77.3 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-005.png r1 manage 69.0 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-006.png r1 manage 79.1 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-007.png r1 manage 69.8 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-008.png r1 manage 80.7 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-009.png r1 manage 69.7 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-010.png r1 manage 127.1 K 2018-03-11 - 00:50 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-011.png r1 manage 248.9 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-012.png r1 manage 250.2 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-013.png r1 manage 156.0 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-014.png r1 manage 126.7 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-015.png r1 manage 62.0 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-016.png r1 manage 61.7 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-017.png r1 manage 125.2 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-018.png r1 manage 100.2 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-019.png r1 manage 97.5 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-020.png r1 manage 81.8 K 2018-03-11 - 00:52 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-021.png r1 manage 119.4 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-022.png r1 manage 118.6 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-023.png r1 manage 119.3 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-024.png r1 manage 119.4 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-025.png r1 manage 119.2 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-026.png r1 manage 81.5 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-027.png r1 manage 74.4 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-028.png r1 manage 75.6 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-029.png r1 manage 99.5 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-030.png r1 manage 101.6 K 2018-03-11 - 00:53 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-031.png r1 manage 90.0 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-032.png r1 manage 89.5 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-033.png r1 manage 99.5 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-034.png r1 manage 99.4 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-035.png r1 manage 87.3 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-036.png r1 manage 102.6 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-037.png r1 manage 104.0 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-038.png r1 manage 90.7 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-039.png r1 manage 105.2 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-040.png r1 manage 106.0 K 2018-03-11 - 00:54 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-041.png r1 manage 91.8 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-042.png r1 manage 108.5 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-043.png r1 manage 109.5 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-044.png r1 manage 118.3 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-045.png r1 manage 117.9 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-046.png r1 manage 118.0 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-047.png r1 manage 119.0 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-048.png r1 manage 122.4 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-049.png r1 manage 163.2 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-050.png r1 manage 173.5 K 2018-03-11 - 00:55 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-051.png r1 manage 58.0 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-052.png r1 manage 112.2 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-053.png r1 manage 66.0 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-054.png r1 manage 67.1 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-055.png r1 manage 71.0 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-056.png r1 manage 112.6 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-057.png r1 manage 111.9 K 2018-03-11 - 00:56 AlexanderFedotov  
PNGpng 180304.anaconda_screenshot-058.png r1 manage 107.1 K 2018-03-11 - 00:56 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_cfg.anaconda-ks.cfg.txt r1 manage 2.1 K 2018-03-11 - 00:47 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_cfginitial-setup-ks.cfg.txt r1 manage 2.1 K 2018-03-11 - 00:47 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.anaconda.log.txt r1 manage 86.3 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.ifcfg.log.txt r1 manage 2.5 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.lvm.log.txt r1 manage 385.0 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.packaging.log.txt r1 manage 0.1 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.program.log.txt r1 manage 69.3 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180304.initial_installation.anaconda_logs.storage.log.txt r1 manage 425.0 K 2018-03-11 - 00:48 AlexanderFedotov  
Texttxt 180419.0247.fedotov.Xresources.txt r1 manage 6.0 K 2018-04-19 - 02:49 AlexanderFedotov  
Texttxt rpm_history.180305.1935.rpm-qa.Initially_installed.txt r1 manage 58.1 K 2018-03-11 - 00:59 AlexanderFedotov  
Texttxt rpm_history.180312.0426.rpm-qa.After_first_sw_update.txt r1 manage 58.7 K 2018-03-12 - 02:42 AlexanderFedotov  
Texttxt rpm_history.180316.0201.After_sw_update_No2.txt r1 manage 58.9 K 2018-03-16 - 00:36 AlexanderFedotov  
Texttxt rpm_history.180316.0318.zsh_emacs_xterm_installed.txt r1 manage 59.3 K 2018-03-16 - 02:37 AlexanderFedotov  
Texttxt rpm_history.180317.2243.rpm-qa.After_reg_sw_update_No3.txt r1 manage 59.3 K 2018-03-17 - 21:53 AlexanderFedotov  
Texttxt rpm_history.180324.0024.rpm-qa.After_reg_sw_update_No4.txt r1 manage 59.3 K 2018-03-23 - 23:04 AlexanderFedotov  
Texttxt rpm_history.180326.1720.rpm-qa.After_reg_sw_update.txt r1 manage 59.3 K 2018-03-26 - 16:35 AlexanderFedotov  
Texttxt rpm_history.180331.2123.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-03-31 - 21:25 AlexanderFedotov  
Texttxt rpm_history.180403.2251.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-03 - 21:15 AlexanderFedotov  
Texttxt rpm_history.180409.2038.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-09 - 20:00 AlexanderFedotov  
Texttxt rpm_history.180410.2337.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-10 - 23:00 AlexanderFedotov  
Texttxt rpm_history.180413.2153.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-13 - 21:11 AlexanderFedotov  
Texttxt rpm_history.180418.2327.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-18 - 22:41 AlexanderFedotov  
Texttxt rpm_history.180421.1834.rpm-qa.After_reg_sw_update.txt r1 manage 59.4 K 2018-04-21 - 17:50 AlexanderFedotov  
Texttxt rpm_history.180425.2110.rpm-qa.flash-plugin_installed.txt r1 manage 59.5 K 2018-04-26 - 01:25 AlexanderFedotov  
Texttxt rpm_history.180429.0220.rpm-qa.After_reg_sw_update.txt r1 manage 59.5 K 2018-04-29 - 01:43 AlexanderFedotov  
Texttxt rpm_history.180429.0407.rpm-qa.rpmfusion_repos_installed.txt r1 manage 59.6 K 2018-04-29 - 03:22 AlexanderFedotov  
Texttxt rpm_history.180429.0901.rpm-qa.media_codecs_installed.txt r1 manage 63.1 K 2018-05-01 - 03:01 AlexanderFedotov  
Texttxt rpm_history.180502.0129.rpm-qa.mplayer_installed.txt r1 manage 63.4 K 2018-05-02 - 02:07 AlexanderFedotov  
Texttxt rpm_history.180502.2227.rpm-qa.vlc_installed.txt r2 r1 manage 64.0 K 2018-05-05 - 00:32 AlexanderFedotov  
Texttxt rpm_history.180504.0518.rpm-qa.vidyodesktop_installed.txt r1 manage 64.1 K 2018-05-05 - 00:32 AlexanderFedotov  
Texttxt rpm_history.180514.0116.rpm-qa.After_reg_sw_update.txt r1 manage 64.1 K 2018-05-14 - 00:35 AlexanderFedotov  
Texttxt rpm_history.180517.0414.rpm-qa.libroffice_installed.txt r1 manage 66.7 K 2018-05-17 - 23:27 AlexanderFedotov  
Texttxt rpm_history.180518.0156.rpm-qa.tex_etc_installed.txt r1 manage 80.6 K 2018-05-18 - 02:03 AlexanderFedotov  
Texttxt rpm_history.180519.0300.rpm-qa.misc_installed.txt r1 manage 86.4 K 2018-05-19 - 03:09 AlexanderFedotov  
Texttxt rpm_history.180519.2050.rpm-qa.After_reg_sw_update.txt r1 manage 86.4 K 2018-05-19 - 20:09 AlexanderFedotov  
Texttxt rpm_history.180520.0254.rpm-qa.skype_installed.txt r1 manage 86.5 K 2018-05-20 - 04:22 AlexanderFedotov  
Texttxt rpm_history.180522.0357.rpm-qa.rpmsphere_repo_installed.txt r1 manage 86.5 K 2018-05-22 - 03:35 AlexanderFedotov  
Texttxt rpm_history.180522.0500.rpm-qa.tkdiff_installed.txt r1 manage 86.6 K 2018-05-22 - 04:19 AlexanderFedotov  
Texttxt rpm_history.180523.0352.rpm-qa.coolreader3_installed.txt r1 manage 86.6 K 2018-05-23 - 04:18 AlexanderFedotov  
Texttxt rpm_history.180524.0337.rpm-qa.cert-forensics-tools_repo_installed.txt r1 manage 86.7 K 2018-05-24 - 05:10 AlexanderFedotov  
Texttxt rpm_history.180524.0422.rpm-qa.rar_installed.txt r1 manage 86.7 K 2018-05-24 - 05:10 AlexanderFedotov  
Texttxt rpm_history.180604.0230.rpm-qa.After_reg_sw_update.txt r1 manage 86.7 K 2018-06-04 - 02:38 AlexanderFedotov  
Texttxt rpm_history.180620.0251.rpm-qa.After_reg_sw_update.txt r1 manage 86.8 K 2018-06-20 - 02:12 AlexanderFedotov  
Texttxt rpm_history.180709.0234.rpm-qa.After_reg_sw_update.txt r1 manage 86.9 K 2018-07-09 - 02:27 AlexanderFedotov  
Texttxt rpm_history.180802.0109.rpm-qa.After_reg_sw_update.txt r1 manage 87.0 K 2018-08-02 - 01:10 AlexanderFedotov  
Texttxt rpm_history.180826.2333.rpm-qa.After_reg_sw_update.txt r1 manage 87.0 K 2018-08-26 - 23:15 AlexanderFedotov  
Texttxt rpm_history.181022.0132.rpm-qa.After_reg_sw_update.txt r1 manage 87.0 K 2018-10-22 - 01:23 AlexanderFedotov  
Texttxt rpm_history.181129.2139.rpm-qa.After_reg_sw_update.txt r1 manage 87.1 K 2018-11-29 - 20:25 AlexanderFedotov  
Edit | Attach | Watch | Print version | History: r61 < r60 < r59 < r58 < r57 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r61 - 2018-12-27 - AlexanderFedotov
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    Main All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback