-- AmolWakanakar - 31-Jan-2011 Graphtool has a dependency on numpy and python-numpy but there is a Conflict between the latest version versions of python-numpy and numpy. The issue could be resolved by installing followind versions: numpy-1.2.1-1.el4.art.x86_64 and python-numpy-1.2.0-1.1.x86_64

Following are the steps to install graphtool: # Graphtool requires: Python-imaging, python-matplotlib and python-numpy

# First Install python-imaging: download rpm for python-imaging-1.1.6-14.el5.art.x86_64.rpm

rpm -iv python-imaging-1.1.6-14.el5.art.x86_64.rpm

# Install matplotlib as follows yum install python-dateutil

yum install pytz

rpm -iv refblas3-3.0-11.1.x86_64.rpm

rpm -iv lapack3-3.0-19.1.x86_64.rpm

yum install python-nose

yum remove numpy # the version of numpy already installed in slc-5 is not compatible with python-numpy version required for graphtool

rpm -iv numpy-1.2.1-1.el4.art.x86_64.rpm

rpm -iv python-matplotlib-0.99.1.2-1.el5.x86_64.rpm

# Now install python-numpy

rpm -iv python-numpy-1.2.0-1.1.x86_64.rpm

# Finally install the graphtool

rpm -iv graphtool-0.6.6-2.noarch.rpm


This topic: Main > TWikiUsers > AmolWakanakar > ProblemInstallingGraphtTool
Topic revision: r2 - 2011-04-05 - unknown
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback