https://twiki.cern.ch/twiki/bin/view/CMSPublic/SWGuideLcgAccessLeftBar?redirectedfrom=CMS.SWGuideLcgAccessLeftBar&topic=SWGuideLcgAccess

https://twiki.cern.ch/twiki/bin/view/CMSPublic/WorkBookRunningGrid

Add to your .bash_profile to:

source /afs/cern.ch/cms/LCG/LCG-2/UI/cms_ui_env.sh 
cd ../CMSSW_X_Y_Z/src
cmsenv
source /afs/cern.ch/cms/ccs/wm/scripts/Crab/crab.sh

Log out, log back in. Run

grid-proxy-init -debug -verify
voms-proxy-init -voms cms

Final step:

Follow important note near start of https://twiki.cern.ch/twiki/bin/view/CMS/SiteDBForCRAB. You have to link your Hypernews account.

PROBLEMS

ERROR : Unable to ship the project to the server

crab:  Credential successfully delegated to the server.

crab:  Starting sending the project to the storage vocms83.cern.ch...

crab: ERROR : Unable to ship the project to the server "Error copying: \n ['/afs/cern.ch/user/r/raggleto/scratch0/CMSSW_5_3_5/src/Configuration/PowhegBox4/python/Crab_HiggsVBF_5000/job/CMSSW.sh'] \nto: \n ['/data01/CSstoragePath/raggleto_Crab_HiggsVBF_5000_l62w4p/CMSSW.sh']"
Project raggleto_Crab_HiggsVBF_5000_l62w4p not Submitted

SOLUTION: In your crab config file, try using

scheduler=remoteGlidein
use_server=0

instead of the now unsupported

scheduler = glite
use_server=1

You might also want to try deleting your proxies... https://twiki.cern.ch/twiki/bin/view/CMSPublic/SWGuideCrabFaq?redirectedfrom=CMS.SWGuideCrabFaq#How_do_I_clean_all_my_proxies

then

myproxy-init -s myproxy.cern.ch -d -n -c <HH:MM>

although I din't have any luck with this. Perhaps it was CRAB just having a mare? Either way, I lost most of an afternoon trying to solve this.

426 Connection timed out

Trying to do a srmcp and you get:

org.globus.ftp.exception.ServerException: Server refused performing the request. Custom message: Server reported transfer failure (error code 1) [Nested exception message:  Custom message: Unexpected reply: 426 Connection timed out].  Nested exception is org.globus.ftp.exception.UnexpectedReplyCodeException:  Custom message: Unexpected reply: 426 Connection timed out

SOLUTION:

Then use the flag

-streams_num=1

when doing srmcp. This is due to small file sizes. Source: www.lofar.org/wiki/doku.php?id=public:grid:troubleshooting

Yay! Another afternoon lost

SRMClientV1 : Method 'ns1:get' not implemented: method name or namespace not recognized

Trying to do a srmcp and you get:

SRMClientV1 : Method 'ns1:get' not implemented: method name or namespace not recognized
SRMClientV1 : get : try # 0 failed with error
SRMClientV1 : Method 'ns1:get' not implemented: method name or namespace not recognized
srm copy of at least one file failed or not completed

SOLUTION:

This is because SRM on your machine is using version 1 of the protocol, and you probably need version 2 (note for examplethe v2 in

srm://dcache-se-cms.desy.de:8443/srm/managerv2?SFN= 

). Use the flag

-srm_protocol_version=2
Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r6 - 2013-12-16 - RobinAggleton
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    Main All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2021 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
or Ideas, requests, problems regarding TWiki? use Discourse or Send feedback