Frequently Asked Questions

Plain password authenticaion in COOL 1.2.6

There's a bug in COOL 1.2.6 preventing the use of the plain password authentication, i.e. passing the password in the connect string. You'll have to use the (better) authentication via authentication.xml (see below).

Authentication via authentication.xml

Add the following to your authentication.xml:

<connection name="oracle://ATLAS_COOLPROD;schema=ATLAS_COOL_SCT;user=ATLAS_COOL_SCT;dbname=TBMCPROD" >
  <parameter name="user" value="ATLAS_COOL_SCT" />
  <parameter name="password" value="xxx" />
</connection>

and use the connect string

"oracle://ATLAS_COOLPROD;schema=ATLAS_COOL_SCT;user=ATLAS_COOL_SCT;dbname=TBMCPROD"

You can specify the location of authentication.xml by setting the following value in your seal configuration file:

Persistency/Services/XMLAuthenticationService.AuthenticationFile="$HOME/cool_extras/authentication.xml";

(or POOL/Services/... if you're using RAL)

-- SvenASchmidt - 12 Jan 2006

Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r6 - 2013-10-02 - AndreaValassi
 
    • Cern Search Icon Cern Search
    • TWiki Search Icon TWiki Search
    • Google Search Icon Google Search

    Persistency All webs login

This site is powered by the TWiki collaboration platform Powered by PerlCopyright & 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback